Release notes/1.1

From Inkscape Wiki
Jump to navigation Jump to search
This page contains changes which are not marked for translation.


Warning symbol.png These Release Notes are in Draft Status.

Important Links:



Warning symbol.png Notes:

For changes made even before the 1.0 release that aren't in 1.0, try to find out if the checked and not stroked ones here: https://gitlab.com/inkscape/inkscape/-/issues/1030 have really not been cherrypicked


Warning symbol.png Pending questions:


Release highlights

Definitely not released yet.

Inkscape 1.1 is the latest major Inkscape release that brings users many fresh new features and new functionality. The most notable changes include:

  • A Welcome dialog, where the theme can be selected, and some choices for the new document's size or file to open are available
  • A Commands palette that opens when the ? key is pressed and that allows to search and use many functions without having to use a keyboard shortcut or going through the menus
  • It is now possible to copy, cut and paste parts of paths with the Node tool
  • The dialog docking system has been rewritten, which resolves many issues with Inkscape's docked dialogs and allows you to dock dialogs on either side of the screen
  • New Outline Overlay mode that displays object outlines while also showing their real colors
  • Preferences options are now easier to find by using the new search field
  • It is no longer necessary to remember to click on 'Export' in the PNG Export dialog, as the exporting will already happen after the click on 'Save' in the file selection dialog.
  • Export as JPG, TIFF, optimized PNG and WebP directly from Inkscape

Important changes

For packagers

  • Inkscape no longer depends on GtkSpell and ASpell but on GSpell for spell checking.
  • lib2geom has been moved into its own git submodule (like the extensions), a new release is available.
  • Inkscape now ships a /share/themes folder with two custom themes that are only suitable for use with Inkscape (as a git submodule)

General user interface

Command palette

  • Pressing ? will open the new Command palette.
  • In the little overlay, a type-forward search allows you to find any available command to execute on the whole drawing or selection. The list of available commands is currently restricted to those commands that have already been converted to 'actions', as part of an ongoing effort. Additionally, it includes the option to import or open files from Inkscape's document usage history.
    • Some commands allow you to indicate parameters. A little keyboard icon will show you when the program expects a parameter (such as an angle for rotation, or a fraction for scaling). Note that the unit that is used for parameters is usually 'px', not the display unit. Some parameters require a specific format (like a comma-separated list of values for moving). The format is often indicated in the description of the command, e.g. to align selected objects to the last selected one's left side, find the 'align objects' command, then type 'left last'.
    • Some commands do nothing visible in the user interface (yet), as either
      • they only work in conjunction with other commands, such as commands that change how a file is exported, or commands that export the file. These need to be entered in order, e.g. export type ⯈ type 'png' ⯈ press Enter ⯈ press ?export file name ⯈ type a file name ⯈ press Enter ⯈ press ?export do ⯈ press Enter; export do in this example can also be used repeatedly to export the updated image to the same file name) or
      • they produce output on the command line (like commands asking for coordinates of objects), which you will only see if you have started Inkscape from the command line.
  • Press Enter to execute any command.
  • By pressing the (upwards arrow key), you enter the history mode, where you can choose between commands that you have already used.
  • To close the palette, if not using any of the commands offered, you can press ? again, or just click on the canvas.

If a keyboard shortcut is available for the selected command, it will show up in the command palette (in the form that it is saved in the keyboard shortcut file). In the settings, at Edit → Preferences → Interface: Command palette, you can select some of the info you would like the palette to display. In addition to the translated action name, it can also show the English names of the commands and the corresponding command line argument name.

This feature was added by Google Summer of Code Student Abhay Raj Singh in 2020. You can learn more about the feature's development on GitLab or in Abhay's blog entry. (UX issue #31, MR #2072)

Paste on top of selection

When pasting an object from the clipboard onto the canvas, Inkscape will now by default paste it right above the currently selected object. This feature can be disabled in Edit → Preferences → Behavior → Selecting: Paste on top of selection instead of layer-top (MR #2476, Usability test #65).

Canvas

New Display mode

  • 'Outline Overlay' display mode: In this mode, a toned down view of the drawing (not click-sensitive) is shown behind the (click-sensitive) object outlines. The opacity of the original drawing in this view mode can be set in Edit → Preferences → Rendering: Outline overlay opacity.

Handles

  • Inkscape now uses vector-based handles, which are currently hardcoded (not SVG) (MR #2334)
  • The maximum handle size has been increased, so users with HiDPI displays will be able to enlarge them to a more comfortable size from Edit → Preferences → Interface: Handle size
  • Rotation center handles have been made more visible

Handels.png

Tools

Calligraphy Tool

  • The tool now supports units for the width, with a much increased precision (up to three digits after the decimal separator, e.g. 0.005). The old, zoom-dependent width behavior is accessible with the unit '%'.
  • The entry field for 'Mass' has been moved towards left (for LTR languages) on the tool's tool controls bar, emphasizing its importance (MR #2816)

Connector tool

  • Connection lines now update in real time while objects are moved

Node tool

The node tool now allows to copy, cut and paste a selection of nodes. These nodes can be inserted into the original path, into a different path or they can be pasted as a completely new path.

Selector Tool

  • A new selection mode for the lasso/rubber-band selection was added, which can now select every object that is either within the box or that touches its boundaries. The mode can be activated by pressing the corresponding button in the Selector tool's tool controls bar. On canvas, the mode is visualized by changing the color of the selection box to dashed red line while dragging (MR #2520).

Touch rect.gif

Text Tool

  • Text-in-a-shape can now make use of justified text alignment.
  • Highlight all shapes: When editing text-in-shape or text-on-path, all shapes are highlighted, not only the first (MR #2468) and the orientation / position of the shapes is shown correctly (e.g. display rotated rectangle as being rotated).

Dialogs

General

  • Arrows on color sliders now have better visibility

Docking

Dialogs can now be docked on the left of the Inkscape window. They're now displayed as tabs, with optional label and icon. The dialog tabs can be combined to new floating docks. Tabs can be closed by middle mouse click, right-click and selecting to close, or by clicking on the x icon.

The work for this big code refactoring was undertaken by Google Summer of Code Student Valentin Ionita in 2020. You can learn more about his work on GitLab (technical documentation).

Docking demo.gif

Preferences dialog

  • The preferences dialog now features a search bar, which performs a recursive search over all the nested categories of settings:
    • press F3 or Ctrl + G for next result
    • press Shift + F3 or Ctrl + Shift+G for previous result
  • In Edit → Preferences → Imported images: Import, there is a new option that allows you to disable relative paths to linked files ("Store absolute file path for linked images", deactivated by default).
  • In Edit → Preferences → Rendering, there is a new option to Redraw while editing, which improves performance of redrawing with some faster CPUs ("Responsive", active by default, or "Conservative").
  • In Edit → Preferences → Behavior → Scrolling, the setting Mouse wheel zooms by default has been removed. This setting can now be set by disabling the modifier 'Ctrl' for Canvas zoom, and enabling it for Vertical pan instead (see section about 'Customization' below for more information).
  • The Zoom correction factor in Edit → Preferences → Interface now works correctly for other units than mm and remembers values below 100%.
  • There is an option now to adjust the number shown in the Zoom field in the bottom right corner to match the real world scale. The new option is active by default, so that, after adjusting the factor for your monitor, at 100% zoom, your document page is as large on the screen as it is in reality.

'About Inkscape' dialog

The Help → About Inkscape dialog has been rebuilt from scratch with a larger window (and image) and a tabbed interface.

  • The user-contributed About Screen artwork is now displayed much larger, as it should be!
  • Authors and translators are now featured on separate tabs.
  • A new license tab offers a brief explanation of Inkscape licensing.
  • All the tabs include calls to action or links to the official website for more information.
  • The current version of Inkscape is displayed on a button. When clicked, the full version information is copied to the clipboard, so it can be used in bug reports, for example.
  • In the bottom right corner, there is an additional small button with a little beetle on it. Clicking that button will copy extensive information about available software library versions, in addition to operating system and Inkscape version information.

Fill and Stroke

  • The stroke's width can now be set to Hairline in the dialog at Object → Fill and stroke → Stroke Style (as a unit). This type of stroke is always 1px wide, independent of the zoom level. The feature will hopefully one day be useful for laser cutting and plotting (MR #846)
    • Hairline strokes can be exported to file formats with native hairline support (PDF/PS), but this requires a code change in the Cairo software library, which has not been accepted (yet), so the PS/PDF hairline export feature will not yet be available in any official packages. If unavailable, a very thin line width will be used instead (1px at the "1:1 zoom" level of the output).
    • In other SVG renderers, hairlines will be handled via non-scaling stroke with a stroke width of 1px.
    • Export to PNG and rendering on canvas will use a line width of 1px.
  • The Miter maximum has been increased to 100000 (Commit 69dc16)
  • Stock markers use SVG 2.0 context-stroke to automatically take on the stroke color of the object (MR #2009). If SVG 1.1 compatibility is needed, the setting for marker colors in Edit → Preferences → Input/Output → SVG export can be activated and SVG 1.1 compatibility can be activated in the 'Save as' dialog.

InkscapeHairlines.gif

Gradient Editor dialog (removed)

  • The legacy gradient editor (a dialog that could previously be enabled in the preferences for the gradient tool) has been removed.

Text and Font dialog

'Welcome' dialog

A new welcome and onboarding screen was added. You can set up the look of Inkscape on a first run and select from presets of document settings. This dialog can be turned off.

Filters

  • A new "Fast Crop" filter can be found at Filters → Fill and transparency → Fast Crop (MR #2767)

Live path effects

Automatic fill preservation for path effects

LPEs which render strokes as fills (Join Type, Power Stroke, and Taper Stroke) have been modified to automatically preserve the previous fill by creating a linked clone with the original fill color when applied to an object.

"Boolean Operations" LPE

  • The path effect is no longer marked as experimental.
  • Operands can now easily be selected and moved with the mouse.
  • Improved stability

"Taper Stroke" LPE

The Taper stroke LPE has been updated to include taper direction options (allowing the taper to run to one side of the path, instead of to the middle) and smoothing options for both ends of the path, allowing more interesting paths to be made in the effect. In addition, Shift+clicking on the on-canvas handles allows quickly alternating between the different possible taper shapes.

"Fill between many" LPE

A new item Fill between Paths has been added under the Path menu to automatically create a linked fill path using the Fill between many path effect. The effect is created beneath the selected paths and automatically selected to faciliate moving the path into the correct z-order and styling it as intended. For greater efficiency, a shortcut can also be assigned, using the Preferences dialog.

This is especially useful for filling variable-width paths created with the PowerStroke option (or other live path effects that use the fill to emulate a stroke).

"Offset" LPE

  • The Offset LPE's performance was improved for more complex shapes.
  • Open paths can now have an offset that is not automatically closed [Known issue: when they don't self-intersect].

"Slice" LPE (new)

This new path effect allows you to split an object into two (or more by stacking multiple LPEs), without destroying the original. It works with groups, shapes, and paths. If you want to use it on Text, you need to use the 'Clone' LPE and apply the 'Slice' LPE on this clone. It also allows to change styles for the resulting parts, because each part is a separate object (MR #2372)

Slice LPE 1.gif

Import / Export

  • Inkscape can now recognize layers in SVG files exported from CorelDraw (MR !2046)
  • The Export PNG Image dialog now exports the PNG as soon as the button Export as has been clicked and a file name was selected for the file. It's no longer necessary to explicitly click on Export after choosing a file name. Clicking on Export will still be available to export to the file name that is currently set in the dialog.
  • Use the file name extensions '.jpg', '.webp' or '.tiff' in the PNG export dialog to open the corresponding export options and export to the selected file format. In the file chooser that opens after clicking on 'Export as', there is also a dropdown menu available to choose the file format. 'Optimized PNG' is available there as an additional option (as it uses the same file name extension, it's not possible to auto-detect). The export functionality is implemented using a Python extension of the new 'Raster Output' type.

Customization

Cursors

A set of SVG-based, themeable mouse cursors with HiDPI support were added. These new cursors are coupled with the icon themes. The default set (hicolor theme) is stored in ~inkscape\share\inkscape\icons\hicolor\cursors.

More information can be found on the SVG Cursors page.

Shortcuts

  • In Edit → Preferences → Interface → Keyboard, in the new Modifiers tab, you can customize keyboard shortcut modifiers for on-canvas mouse actions (for example holding Ctrl for scaling while keeping the object's aspect ratio can be changed to Shift) [Known issue: doesn't survive a restart]
  • Keyboard shortcut files for Inkscape can now inherit from other keyboard shortcut files by using XInclude (MR !1150)
  • Illustrator keyboard shortcut map has been updated to ... Fill me in

Themes

  • A contrast slider was added for finer control over any theme look at Preferences → Interface → Themeing → Contrast 906
  • A more compact Minwaita theme has been added
  • The win32 theme has been improved by adding some custom adjustments
Contrast slider.gif

macOS-specific Changes

  • New Inkscape icon (commit ee589650)
  • Visio files can be imported (issue #2094)
  • No longer bundle Ghostscript, effectively removing out of the box support for EPS and PS (MR #2608), information about workarounds can be found at https://gitlab.com/inkscape/inbox/-/issues/4321
  • This is the last release to support OS X El Capitan 10.11. Future releases will require at least macOS High Sierra 10.13 as oldest supported operating system. A few hours ago I got feedback on the upstream issue which is the deciding factor here. There's hope now, so let's not make an announcement like this just yet.

Extensions

Command line

  • The options x y z have been added back in to preserve compatibility with legacy Inkscape command line scripts (and ImageMagick's SVG conversion)
  • Added actions for aligning and distributing objects (MR #2472)
  • Shell mode: a history of commands is now remembered and can be accessed with the up and down arrow keys. [Tab ... autocompletion?]

Behind the curtains

Inkscape developers have also worked on improving and evolving parts of Inkscape which are not directly visible to the users. Indirectly, these changes will also benefit the users, as they make it easier for developers to work with the project, and help them make fewer mistakes.

  • Documentation for developers was updated and improved continuously, helping developers better understand other people's code
  • Outdated code was updated continuously, making it easier to handle the code moving forwards. This includes a continued effort to convert old C code to modern C++, removing dead code and rewriting parts of the code in a more modern way.
  • Code formatting was improved continuously, improving readability of the code
  • Continuous integration was updated and improved continuously, ensuring that each code change will be tested automatically and can be reviewed by bug reporters before it is included into the main line code, also keeping up with changes in GitLab, AppVeyor and other infrastructure that is used by Inkscape
  • Improvements were made to the build system, so Inkscape can be built on more Linux, Windows and macOS versions, keeping up with changes in software libraries that Inkscape depends upon
  • Many tests were added and improved, reducing the risk of accidental loss of functionality
  • Running test versions on Windows was simplified by adding shortcuts to the top level folder: Run Inkscape !.bat, Run Inkscape and create debug trace.bat, Run Inkscape with GTK Inspector.bat (MR #2884)

Notable bugfixes

Crash fixes

Fix a crash …

  • … when ... (#number)
  • when deleting the d attribute in the XML editor (MR #2722)

Other bug fixes

  • @import statements in CSS sheets are now processed in the correct order, so their styles are no longer overwritten unintentionally.
  • The color selector's color wheel looks better now on HiDPI screens (MR #2416)
  • Color slider handles look better now on HiDPI screens (MR #2733)
  • The color indicator field in the bottom left corner of the window now uses a constant width and has been cleaned up a bit (MR #2400)
  • The size of the double-arrow handles in the color sliders has been increased (MR #2427)
  • Fix of multiple regressions and bugs with Stroke to path (MR #2410)
  • Fix of feColorMatrix filter primitive default rendering (MR #2424)
  • You can now just click in the color wheel to select a color (MR #2428)
  • Reverse order of z-order buttons to achieve more consistency (MR #2556)
  • Fix reversed buttons in Arrange / Polar Coordinates (MR 2561)
  • Multiple Fixes for Selectors and CSS dialog (MR #1681)
  • Multiple fixes for command: Stroke to path (MR #2410)
  • Fixed rendering of antialiasing on clipping path (MR #2401)
  • Fix z-order rendering issue after ungrouping (MR #2452)
  • Fix copying mesh gradients to new document (MR #2362)
  • "X-Ray" mode no longer disables automatically when the cursor reaches the edge of the canvas (MR #2346)
  • Fix Ctrl+click "Pop selected object out of group" MR #2729)
  • Wording and spelling improvements
  • Improved colors selection of icons - This fixes multiple bugs for different Gtk themes and icon themes 2845

Even more bug fixes

There were even more issues fixed than those listed above, but these probably only affect a small portion of users, or are relevant for development and packaging only.

For a complete list, visit our GitLab issue tracker and see the commit history (all changes since DATE until release date).

Extensions

  • Element selections API has been improved, the API in 10? of using self.svg.selected is deprecated in favour of the new self.svg.selection interface. The previous API will continue to work for the time being but should be updated to the new API. Selection is now a type of ElementList which provides filtering, ordering and other generalised functionality, if you need an element list for example to make a bounding box, this is the way to do it.

Translations

The following UI translations received updates [2021-03-03]:

  • Basque
  • Brazilian Portuguese
  • Bulgarian
  • Catalan
  • Croatian
  • Czech
  • Danish
  • Dutch
  • French
  • German
  • Hungarian
  • Icelandic
  • Italian
  • Korean
  • Latvian
  • Polish
  • Simplified Chinese
  • Spanish
  • Traditional Chinese
  • Turkish
  • Ukrainian

The Windows installer translation was updated for [2021-03-03]:

  • Czech

The following documentation translations received updates:

  • Language

Additionally, time has been spent on improving translatability and adding hints for translators in various places.

Contributing to interface translations

Want to help with translations? Learn how to help!

Documentation

  • Some missing options were added to the man page (command line help)
  • Some missing keyboard shortcuts were added to the keyboard shortcut reference

Contributing to documentation and documentation translation

Contributions to the documentation translations, as well as improvements to its contents, are welcome at the inkscape-docs repository.

Known issues

Previous releases