Difference between revisions of "Release notes/1.1"

From Inkscape Wiki
Jump to navigation Jump to search
Line 144: Line 144:
 
* In <code>Edit → Preferences → Rendering</code>, there is a new option to <code>Redraw while editing</code>, which improves performance of redrawing with some faster CPUs ("Responsive", active by default).
 
* In <code>Edit → Preferences → Rendering</code>, there is a new option to <code>Redraw while editing</code>, which improves performance of redrawing with some faster CPUs ("Responsive", active by default).
 
* In <code>Edit → Preferences → Interface → Keyboard</code>, in the new '''Modifiers''' tab, you can customize keyboard shortcut modifiers for on-canvas mouse actions (for example holding <kbd>Ctrl</kbd> for scaling while keeping the object's aspect ratio can be changed to Shift) [Known issue: doesn't survive a restart]
 
* In <code>Edit → Preferences → Interface → Keyboard</code>, in the new '''Modifiers''' tab, you can customize keyboard shortcut modifiers for on-canvas mouse actions (for example holding <kbd>Ctrl</kbd> for scaling while keeping the object's aspect ratio can be changed to Shift) [Known issue: doesn't survive a restart]
 +
* In <code>Edit → Preferences → Behaviour → Scrolling</code>, The setting '''Mouse wheel zooms by default''' has been removed, this setting can now be set by changing the Modifier setting '''Canvas zoom''' to remove the Ctrl modifier (see above).
 
* The Zoom correction factor in <code>Edit → Preferences → Interface</code> now works correctly for other units than mm and remembers values below 100%.
 
* The Zoom correction factor in <code>Edit → Preferences → Interface</code> now works correctly for other units than mm and remembers values below 100%.
  

Revision as of 15:22, 24 January 2021


Warning symbol.png These Release Notes are in Draft Status.

Important Links:



Warning symbol.png Notes:

For changes made even before the 1.0 release that aren't in 1.0, try to find out if the checked and not stroked ones here: https://gitlab.com/inkscape/inkscape/-/issues/1030 have really not been cherrypicked


Warning symbol.png Pending questions:


Release highlights

Definitely not released yet.

Inkscape 1.1 is the latest major Inkscape release that brings users many fresh new features and new functionality. The most notable changes include:

  • A Welcome dialog, where the theme and the new document's size or file to open can be selected
  • A Commands palette that opens when the ? key is pressed and that allows to search and use many functions without having to use a keyboard shortcut or going through the menus
  • It is now possible to copy, cut and paste parts of paths with the Node tool
  • The dialog docking system has been rewritten, which resolves many issues with Inkscape's docked dialogs and allows you to dock dialogs on either side of the screen
  • New Outline overlay mode that displays object outlines while also showing their real colors
  • Preferences options are now easier to find by using the new search field
  • It is no longer necessary to remember to click on 'Export' in the PNG Export dialog, as the exporting will already happen after the click on 'Save' in the file selection dialog.

Important changes

For packagers

  • Inkscape no longer depends on GtkSpell and ASpell but on GSpell for spell checking.
  • lib2geom has been moved into its own git submodule (like the extensions), a new release is available.

Improvements

  • XInclude support (see !1150) TODO: Move to a "technical" or "advanced" section?
  • Shell mode: a history of commands is now remembered and can be accessed with the up and down arrow keys. [Tab ... autocompletion?]
  • Recognize layers in SVG files exported from CorelDraw (see !2046)
  • @import statements in CSS sheets are now processed in the correct order, so their styles are no longer overwritten unintentionally.

General user interface

Commands palette

This feature was added by Google Summer of Code Student Abhay Raj Singh in 2020. Learn more about the feature's development on GitLab. UX issue 31 MR 2072


Canvas

'Outline Overlay' display mode

In this mode, a toned down view of the drawing (not click-sensitive) is shown behind the (click-sensitive) object outlines. The opacity of the original drawing in this view mode can be set in Edit → Preferences → Rendering: Outline overlay opacity.

Outline Overlay Preview.png

'Gray scale' display mode

In this mode, all colors are displayed in grayscale, making this a useful feature for checking contrast. Can be activated in View → Gray Scale

Handles

New vector-based handels. The maximal handle size has been increased, so users with HiDPI displays will be able to enlarge them to a more comfortable size. Edit → Preferences → Interface: Handle size


2334 2344

Handels.png

Tools

Calligraphy Tool

  • The tool now supports units for the width, with a much increased precision (up to three digits after the decimal separator, e.g. 0.005). The old, zoom-dependent width behavior is accessible with the unit '%'.

Connector tool

  • Connection lines now update in real time while objects are moved
  • New sub-point connections for clones and groups, allowing users to use Inkscape to connect diagrams together like in other drafting tools:

Node tool

The node tool now allows to copy, cut and paste a selection of nodes. These nodes can be inserted into the original path, into a different path or they can be pasted as a completely new path.

Selector Tool

A new selection mode for the lasso/rubber-band selection was added, which can now select every object that is either within the box or that touches its boundaries. The mode can be activated by pressing the corresponding button in the Selector tool's tool controls bar. On canvas, the mode is visualized by changing the color of the selection box to dashed red line while dragging.

TODO: record with new dashed line indicator instead of red 2520

Touch rect.gif

Text Tool

  • Text-in-a-shape can now make use of justified text alignment.
  • Highlight all shapes: When editing text-in-shape or text-on-path, highlight all shapes,

not only the first rectangle. 2468

  • Also apply correct transformation (e.g. display rotated rectangle).
  • removed the close button from this dialog 2523

Dialogs

Docking

The docking feature has been refactored by Google Summer of Code Student Valentin Ionita in 2020. You can learn more about his work on GitLab (technical documentation).

Preferences dialog

  • Added new search bar in the preferences dialogue that performs a recursive search over all the nested categories of settings
    • press F3 or Ctrl+G for next result
    • press Shift+F3 or Ctrl+Shift+G for previous result
  • In Edit → Preferences → Imported images: Import, there is a new option that allows you to disable relative paths to linked files ("Store absolute file path for linked images", active by default).
  • In Edit → Preferences → Rendering, there is a new option to Redraw while editing, which improves performance of redrawing with some faster CPUs ("Responsive", active by default).
  • In Edit → Preferences → Interface → Keyboard, in the new Modifiers tab, you can customize keyboard shortcut modifiers for on-canvas mouse actions (for example holding Ctrl for scaling while keeping the object's aspect ratio can be changed to Shift) [Known issue: doesn't survive a restart]
  • In Edit → Preferences → Behaviour → Scrolling, The setting Mouse wheel zooms by default has been removed, this setting can now be set by changing the Modifier setting Canvas zoom to remove the Ctrl modifier (see above).
  • The Zoom correction factor in Edit → Preferences → Interface now works correctly for other units than mm and remembers values below 100%.

'About Inkscape' dialog

The Help > About Inkscape dialog has been rebuilt from scratch with a larger window (and image) and a tabbed interface.

  • The user-contributed About Screen artwork is now displayed much larger, as it should be!
  • Authors and translators are now featured on separate tabs.
  • A new license tab offers a brief explanation of Inkscape licensing.
  • All the tabs include calls to action or links to the official website for more information.
  • The current version of Inkscape is displayed on a button. When clicked, the full version information is copied to the clipboard, so it can be used in bug reports, for example.

Fill and Stroke

Object → Fill and stroke → Stroke Style

  • Hairline stroke style can now be set in the dialog. This type of stroke is always 1px wide, independent of the zoom level. This feature is useful for laser cutters and plotters.
    • Supports exporting hairlines to file formats with native hairline support (pdf/ps).
    • Exporting hairlines to output devices or native file formats requires a patch to Cairo. If unavailable, a very thin line width will be used instead.
    • In other SVG renderers, these will be handled via non-scaling stroke with a stroke width of 1px.
    • Export to PNG and rendering on canvas will use a line width of 1px.

MR 846

InkscapeHairlines.gif

  • Miter maximum increased to 100000 commit
  • Markers use SVG 2.0 context-stroke 2009

Gradients

  • The legacy gradient editor (a dialog that could previously be enabled in the preferences for the gradient tool) has been removed.

'Welcome' dialog

A new welcome and onboarding screen was added. You can set up the look of Inkscape on a first run and select from presets of document settings. This dialog can be turned off.

Live path effects

Automatic fill preservation for path effects

LPEs which render strokes as fills (Join Type, Power Stroke, and Taper Stroke) have been modified to automatically preserve the previous fill by creating a linked path when applied to an object.

"Taper Stroke" LPE

The Taper stroke LPE has been updated to include taper direction options (allowing the taper to run to one side of the path, instead of to the middle) and smoothing options for both ends of the path, allowing more interesting paths to be made in the effect. In addition, using the keybind Shift+click on the on-canvas knots allows quickly alternating between the different possible taper shapes.

"Fill between many" LPE

A new shortcut has been added under the Path menu to automatically create a linked fill path using the Fill between many path effect. The effect is created beneath the selected paths and automatically selected to faciliate moving the path into the correct z-order and styling it as intended. For greater efficiency, the shortcut can also be bound to a hotkey using the Preferences dialog.

"Offset" LPE

Offset calculation works faster now. Open paths can now have an offset that is not automatically closed [Known issue: when they don't self-intersect].

"Slice" LPE (new)

This new path effect allows you to split an object into two without destroying the original (or more by stacking multiple LPEs). It works with groups, shapes, and paths. If you want to use it on Text, you need to use the 'Clone' LPE and apply the 'Slice' LPE on this clone. It also allow change styles to any part because each part is a separated object only linked by original shape and maybe original transforms

Slice LPE 1.gif

Other LPE improvemts

  • Mirror symmetry alow open and closed paths 2366

Export

  • The Export PNG Image dialog now exports the PNG as soon as the button Export as has been clicked and a file name was selected for the file. It's no longer necessary to explicitly click on Export after choosing a file name.

Customization

Cursors

A set of SVG-based, themeable mouse cursors with HiDPI support were added. These new cursors are coupled with the icon themes. The default set (hicolor theme) is stored in ~inkscape\share\inkscape\icons\hicolor\cursors.

More information can be found on the SVG Cursors page.

Shortcuts

  • Illustrator keyboard shortcut map has been updated to ... Fill me in

Themes

  • A contrast slider was added for finer control over the theme look at Preferences → Interface → Themeing → Contrast 906
  • A more compact Minwaita theme has been added
  • The win32 theme has been improved by adding some custom adjustments
Contrast slider.gif

macOS-specific changes

  • New Inkscape icon (commit ee589650)
  • Visio files can be imported (issue #2094)
  • No longer bundle Ghostscript, effectively removing out of the box support for EPS and PS (MR #2608), information about workarounds can be found at https://gitlab.com/inkscape/inbox/-/issues/4321
  • This is the last release to support OS X El Capitan 10.11. Future releases will require at least macOS High Sierra 10.13 as oldest supported operating system. A few hours ago I got feedback on the upstream issue which is the deciding factor here. There's hope now, so let's not make an announcement like this just yet.

Extensions

Command line

  • The options x y z have been added back in to preserve compatibility with legacy Inkscape command line scripts (and ImageMagick's SVG conversion)
  • Added actions for aligning and distributing objects 2472

Notable bugfixes

Crash fixes

Fix a crash …

Other bug fixes

  • The color selector's color wheel looks better now on HiDPI screens MR #2416
  • The color indicator field in the bottom left corner of the window now uses a constant width and has been cleaned up a bit MR #2400
  • The size of the double-arrow handles in the color sliders has been increased MR #2427
  • Fix of multiple regressions and bugs with Stroke to path MR #2410
  • Fix of feColorMatrix filter primitive default rendering MR #2424
  • You can now just click in the color wheel to select a color MR #2428
  • Reverse order of z-order buttons to achieve more consistency MR #2556
  • Fix reversed buttons in Arrange/Polar Coordinates MR 2561
  • Multiple Fixes for Selectors and CSS dialog 1681
  • Multiple fixes for command: Stroke to path 2410
  • Fixed rendering of antialiasing on clipping path 2401
  • Fix z-order rendering issue after ungrouping 2452
  • Fix copying mesh gradients to new document. 2362
  • "X-Ray" mode auto disable when cursor reaches edge of canvas. 2346

Even more bug fixes

There were even more issues fixed than those listed above, but these probably only affect a small portion of users, or are relevant for development and packaging only.

For a complete list, visit our GitLab issue tracker and see the commit history (all changes since DATE until release date).

Breaking changes / Action required

Extensions

Element selections API has been improved, the API in 10? of using self.svg.selected is deprecated in favour of the new self.svg.selection interface. The previous API will continue to work for the time being but should be updated to the new API. Selection is now a type of ElementList which provides filtering, ordering and other generalised functionality, if you need an element list for example to make a bounding box, this is the way to do it.

Translations

The following UI translations received updates:

  • Language

The following documentation translations received updates:

  • Language

Contributing to interface translations

Want to help with translations? Learn how to help!

Documentation

  • Some missing options were added to the man page (command line help)
  • Some missing keyboard shortcuts were added to the keyboard shortcut reference

Contributing to documentation and documentation translation

Contributions to the documentation translations, as well as improvements to its contents, are welcome at the inkscape-docs repository.

Known issues

Previous releases