Difference between revisions of "Tracking Dependencies"

From Inkscape Wiki
Jump to navigation Jump to search
Line 41: Line 41:
| 2.7.1* (Required for Variable fonts)
| 2.9* (Required for Variable fonts)

Revision as of 08:48, 21 December 2020


We need help getting our basic lib dependencies listed out and kept up to date. Also we need to track which versions of which distros have the needed dependencies.

To get glib and GTK+ dependencies figured out, people can go through the API documentation and look for the 'since' entries saying when calls were added. Then look for those calls in our source. Voila! we'll have base minimum dependencies figured out.


Version 1.0 requires a C++11 compiler. Version 1.1 requires a C++17 compiler.

See c++11 and c++17.


C++ bindings are not included, since their required versions match those of the C counterparts.

Library v 0.92 v 1.0 master
Boehm-GC 7.2 7.2
Cairo 1.14 1.14 (1.15.4 required for PDF links) 1.16*
double-conversion [1]
(lib2geom dependency)
(not required) any
FreeType 2.9* (Required for Variable fonts)
3.4 Not Used
Glib 2.28 2.48 2.56 or 2.62*
GTK+ 2.24
3.22 3.24*
GNU Scientific Library ? ?
HarfBuzz ? ? 2.2*
libsigc++ 2.0.12* 2.0.12* 2.10*
libSoup (not required) (any)
libpotrace (not required) (any)
libxml 2.6.11* 2.6.11*
libxslt 1.0.15* 1.0.15*
lcms 1.13 2.2 2.2 (2.9*)
Pango 1.24 1.24 (1.41.1 required for variable fonts) 1.42*
Poppler 0.20.0 0.20.0 0.29 (0.71*)
N/A 2.0.8 (macOS only)

* Tentative dependency

  • Pango 1.42.2 requires Harfbuzz 1.4.2
  • Pango 1.44.0 requires Glib 2.59.2 and Harfbuzz 2.0
  • Pango 1.45.1 requires Glib 2.60


Note: This table is not relevant to (non-fink) MacOS X, where we ship the desired version with Inkscape.

"Inkscape" column is default or distro version / oldest that builds - latest that builds. If no latest is given then that means trunk is expected to build on the given platform.

e.g. for a distro that ships with 0.48 but should support building of trunk you might get:

0.48 / 0.47-

General rules:

  • Support last Debian Stable
  • Support last Ubuntu LTS
  • Support last CentOS/Redhat (as best effort).
  • Support last two Fedora releases.
  • Don't break point releases.
Distro Inkscape gcc clang cairo cairomm freetype glib glibmm gtk+ gtkmm harfbuzz pango poppler gdl lcms2 libsigc++ libgc libsoup
Windows MSYS2 (2018-11-08)
(mingw-w64 packages from MSYS2 project)
- 8.2.0 (7.0.0) 1.16.0 1.12.2 2.10.4 (2020-12) 2.58.1 2.58.0 2.24.32
2.7.2 (2020-12) 1.42.4 0.69.0 3.28.0 1.19
2.10.1 7.6.8 2.64.2
Debian 10 (Buster, stable) EOL 2024-06 0.92.4 8.3.0 7.0 1.16 1.12.2 2.9.1 2.58.3 2.58.0 2.24.32
2.3.1 1.42.4 0.71.0 3.28.0 2.9 2.10.1 7.6.4 2.64.2
(RHEL) / CentOS 8.1 EOFS 2024-05
Based on Centros 8.1 package list
0.92.3 8.3.1 8.0.1 1.15.12 1.12.0 2.8.14 2.56.4 2.56.0 2.24.32
1.7.5 1.42.4 0.66.0 ? 2.9 2.10.0 7.6.4 2.62.3
Ubuntu 18.04 LTS (Bionic) EOL 2023-04 0.92.3 7.3 6.0 1.15.10 1.12.2 2.8.1 2.56.1 2.56.0 2.24.32
1.7.2 1.40.14 0.62.0 3.28.0 2.9 2.10.0 7.4.2 2.62.1
Ubuntu 20.04 LTS (Focal Fossa) EOL 2025-04 0.92.5 10 10 1.16 1.12.2 2.10.1 2.64.1 2.64.2 2.24.32
2.6.4 1.44.7 0.86.1 3.34.0 2.9.4 2.10.2 10 2.70.0
Inkscape 1.0.x unsupported
GTK+ 3 builds unsupported
  • Agreed to at Saarbrücken hackfest.

Getting and Installing Source packages

If your distro does not have some packages available (like many don't, ie, Fedora Core 2), you must often download source packages and build and install them yourself. Actually this is not that hard, and is similar to doing a Gentoo 'emerge.'

  • Usually you download a file with a name like somepackage-1.0.tar.gz. Unpack it with
   $ tar zxf somepackage-1.0.tar.gz
   $ tar jxf somepackage-1.0.tar.bz2
  • Then 'cd' into the new directory.
  • Configure it with the command:
   $ ./configure
  • Build it with:
   $ make
  • As the 'root' user, install it with:
   # make install


Website: http://www.hboehm.info/gc/

GitHub Project: https://github.com/ivmai/bdwgc

Binaries: If searching for a package for GC, the name of it is sometimes:

  • gc
  • libgc
  • gc-devel
  • libgc-devel
  • boehm-gc (on Gentoo)
  • debian/ubuntu: sudo apt-get install libgc-dev


Source: http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/libsigc++-2.2.3.tar.bz2

With this file, and for GlibMM and GtkMM below, it is usually desirable for us developers to build this C++ library statically. This removes a dependency that might be difficult for an end-user during installation. Configure it with:

   ./configure --enable-static --disable-shared


Try to match your Glib2 version with GlibMM's version. For example, if your Glib2 is 2.16.6, download glibmm-2.16.4.tar.bz2.

Latest source: http://ftp.gnome.org/pub/GNOME/sources/glibmm/


Usually you can try the latest version of GtkMM, but if you get version mismatch errors, try older releases.

Source: http://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.12/gtkmm-2.12.7.tar.bz2


if you got prompted about cairomm, try first solve your cairo version, so you can grab there a compatible version.


Many users have reported when building from source that after installing the above dependencies, the configure script still requires a "boost" package. It can be found below, but even after installing, you will need to create a symlink to allow the configure script to find it:

   ln -s /usr/local/include/boost_1_xx_x/boost /usr/local/include/boost

Source: http://www.boost.org/users/download/


Boost filesystem is a temporary dependency we discussed in September 2020 because compilers we wanted to support (in particular gcc-8 and some macos compilers) do not yet support std::filesystem.

Once all compilers we support get std::filesystem, we will drop this dep


Source: http://poppler.freedesktop.org/

Poppler is required for PDF import. There are several potential issues:

  • Some Linux distributions do not ship the Xpdf headers required by Inkscape. In such cases, you need to recompile Poppler, passing --enable-xpdf-headers on the configure line or install the libpoppler-private-dev package. See this wishlist bug. This typically manifests in error messages like this:
In file included from extension/internal/pdfinput/svg-builder.cpp:19:
extension/internal/pdfinput/svg-builder.h:32:23: error: CharTypes.h: No such file or directory
make[2]: *** [extension/internal/pdfinput/svg-builder.o] Error 1
make[2]: Leaving directory `/tmp/build/inkscape-0.46/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/build/inkscape-0.46'
make: *** [all] Error 2
  • Inkscape 0.47 does not compile with Poppler >= 0.12.2. If you need to compile Inkscape on such systems, use the development version from Bazaar, where this bug is fixed. See the bug report for details and a minimal patch.
  • Inkscape compiled with Poppler <= 0.12.1 will run on systems with Poppler >= 0.12.2, but the PDF import function will crash instantly. This problem does not concern Windows users, since the correct Poppler version is contained in the Windows installer package. This cannot be fixed on Inkscape's side: those two versions of Poppler are not ABI compatible, yet share the same soname. See this bug for more details.
  • Poppler's Xpdf headers are not guaranteed to be API-compatible between releases. It's likely that future Poppler versions will break PDF import in some way. PDF import works at least up to 0.12.4 but might not work with later versions.

Optional Dependencies

Inkscape will still compile without these, but some features may be missing if they are absent during compilation:

Library Needed for Default
aspell Dictionaries for spell checking On
libcdr Open Corel Draw files On
gettext/msgformat Translation support On
gtest/gmock Automatted testing Off
gspell Spell checking On
imagemagick Bitmap editing extensions, bitmap import resolution On
jpeg jpeg import? On
OpenMP Multi-threaded filter rendering On
scour Save as Optimized SVG (not needed during compiling, Python)
libvisio Open Visio Files, use Visio stencils On
libwpg Open WordPerfect Graphics On