Release notes/0.91/ja

From Inkscape Wiki
Revision as of 06:26, 1 December 2012 by Hashimo (talk | contribs) (Based on en 2012-11-30T08:06:17)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

Other languages: العربية Català Česky Deutsch English Español Français Italiano 日本語 한국어 Português Português do Brasil Русский Slovenčina 中文

Inkscape 0.49

(not released yet - AnnouncePlanning049)

Release highlights

Released on d month year.

  • Cairo rendering for display and PNG export
  • OpenMP multithreading for all filters

レンダリングとパフォーマンス

Inkscape 0.49 は Cairo ライブラリベースの新しいレンダラーを搭載しました。この作業は Google Summer of Code 2010 および 2011 の中で行われました。

  • パフォーマンスの向上 この新しいレンダラーにより、ほとんどの描画において性能が著しく向上しました。編集中の反応性を向上させるため、複雑なオブジェクトの描画のほとんどが自動的にキャッシュされます。
  • OpenMP によるフィルターのマルチスレッド処理 フィルターはその計算時に利用可能なすべてのプロセッサーコアを使用します。マルチコアシステム上で大きなフィルターオブジェクトを含む描画を編集する時に大きな性能向上が期待できます。
  • メモリ消費量の大幅な減少 複雑な描画を開いた時のメモリ消費量が減少し、より大きなファイルを開けるようになりました。一部のケースでは Inkscape 0.48 の時の 25% しか消費しません。
  • 反応性の向上 SVG のレンダリングがキャッシュされるようになりました。これにより、パスのハイライト表示、オブジェクトの選択/選択解除、および遅延更新モードにおけるパス編集時の反応性が大きく向上しました。
  • レンダリングにおけるバグの修正 バグトラッカーに報告されているレンダリングに関する問題のほとんどが Inkscape 0.49 で修正されました。以下のような描画も正常に行われます:
    • パターンフィル (変形を行ってもタイル間に隙間ができることはありません)
    • パターン内での変形されたオブジェクトのストローク
    • クリップされたオブジェクトを含むパターン
    • ネストしたクリッピングパス
    • アウトライン表示時の、大きいマスク/クリッピングパスでマスクまたはクリップされたオブジェクト
    • 幅が広いストロークおよび長い結合部のパス
    • フォント

ツール

ノードツール

ノードツールのツールバーに、新しく選択したパスセグメントの極値点にノードを追加するボタンが追加されました。ノードの挿入ボタンの隣にある矢印をクリックしてください。

ものさしツール

新機能です。

テキストツール

  • テキストサイズのデフォルトの単位はポイント (pt) になり、さらにカスタマイズ可能 (px,pt,pc,mm,cm,in,em) になりました。
  • テキストツールのツールバーではフォントのスタイルも表示・選択できるようになりました。
  • テキストの単位が em であるファイルも正しく読み込めるようになりました。
  • 代替フォントへの置き換え時に警告ダイアログを表示できるようになりました。

グラデーション

  • グラデーションツールバーを強化し、色フェーズの選択と修正、反転、繰り返し、およびグラデーションのリンクが設定できるようになりました。
  • キャンバス上でのグラデーションの編集が修正されました ― ダブルクリックで色フェーズを作成し、正しく選択します。
  • 「フィル/ストローク」ダイアログで、色、名前、および利用数によるグラデーションの並び替えが行えるようになりました。
  • 「フィル/ストローク」ダイアログで、グラデーションの名前の変更ができるようになりました。

ダイアログ、その他

整列と配置

  • 新しく 3 種類の「選択オブジェクトの位置を入れ替える」機能が追加されました (「整列と配置」ダイアログの「再配置」グループ)。これらは選択オブジェクトの位置を、1. 選択順、2. Z 軸順、および 3. 時計回り に入れ替えます。
  • 整列操作のキーボードショートカットが追加されました (Ctrl+Alt+テンキー)。

検索/選択

  • Z 軸上で最前面にないアイテムの選択が容易になりました。Alt+マウスホイールで、マウスポインタの位置にある重なったアイテムを順番に選択していきます (Shift+Alt+マウスホイールで選択範囲に追加します)。現在のところ、グループ設定は考慮されず、グループ内のアイテムが個別に選択されます。
  • 新しい検索/置換ダイアログでは、テキストやあらゆる属性に対して操作できるようになりました。
  • 「同じオブジェクトを選択」では、色/スタイル/タイプが同じオブジェクトを選択できるようになりました。

レイヤー

  • ドラッグアンドドロップでレイヤーの順序変更やサブレイヤーの作成が行えるようになりました。
  • コンテキストメニューに「全レイヤーを表示/非表示」オプションが追加されました。

シンボル

  • シンボルを管理するダイアログを用意しました。

変形

  • オブジェクトの回転で時計回りまたは反時計回りを指定できるようになりました。

マーカー

  • マーカーにオブジェクトの色を使用するようになりました。

ビットマップのトレース

  • ビットマップのトレースでライブプレビューとが行えるようになり、サイズも変更されるようになりました。

ライブパスエフェクト

オブジェクトのライブパスエフェクトは、 An object's Live Path Effects are now forked upon object duplication.

PowerStroke

Here a list of the current state. Note that this is very much work in progress and anything can change. I think this is the most efficient place of keeping track how the powerstroke LPE works.

  • stroke knots are purple diamonds
  • when first applied, 3 stroke knots are added one at start, one at end, one somewhere in the middle along the path.
  • adding nodes: Ctrl+click purple knot
  • deleting nodes: Ctrl+Alt+click purple knot
  • "sort points" reorders the stroke knots according to where they lie along the path (where they are closest to the path), instead of keeping them in original order.
  • start and end caps can be specified. The SVG cap types are available, as well as an extra type, "Zero width", that is identical to adding a width control knot at the start/end of the path with zero width.
  • join type can be specified. In addition to the SVG join types, there are two new types:
    • Extrapolated: this extrapolates the contour of the stroked path to obtain a more natural looking miter join.
    • Extrapolated arc: Mathematical explanation.
    • Spiro: rounds the join using a spiro curve (the rounded type rounds the curve using an elliptical arc).

example screenshot

Clone original

The Clone original LPE ignores the path data of the path it has been applied to; instead, it copies the original-d path data, i.e. the path data before LPE calculation, from the path linked to by the Linked path parameter.

The Clone original LPE is made to be used in conjunction with powerstroke. Powerstroke creates a path with a variable stroke, but this path can then not be filled (because the fill is used as the stroke). To fill a powerstroked path, one must create a second path (dummy path), apply the Clone original LPE and link it to the powerstroked path. Because this second path clones the original path data before the Powerstroke LPE, it can be used to fill the powerstroked path. To quickly create a dummy path and apply this effect, one can select the path to 'clone' and click the menu item Edit > Clone > Clone original path (LPE).

Like for normal clones, pressing Shift+D, when the selected path has the Clone original LPE applied, selects the path referred to by the LPE.

Another very useful ability of the Clone original LPE is to create a clone with a different style than its referred path. To facilitate this, the LPE dialog will add the Clone original LPE when a clone is selected and the "+" button is pressed.

フィルター

新しいカスタム定義済みフィルターでは、カスタムパラメーターで定義済みフィルターを作成できるようになりました。SpecCustomPredefinedFilters を参照してください。

インポート/エクスポート

  • Flash XML Graphics (FXG) 形式へのエクスポートをサポートしました。
  • Synfig Animation Studio (SIF) 形式へのエクスポートをサポートしました。
  • Visio (VSD) 形式のインポートをサポートしました。
  • XAML へのエクスポートが強化されました。
  • SVG メディア付き圧縮が強化されました。新しく ZIP ファイル内に画像を格納するディレクトリを指定できるようになり、SVG ドキュメント上で使用されているフォントのリストをテキストファイルで格納できるようになりました。
  • ビットマップ画像のインポート時に、画像を常にリンクさせるか、常に埋め込むか、あるいは毎回尋ねるかを設定できるようになりました。
  • SVG の入力および/またはエクスポート時に、不正または無用な要素、属性、あるいはプロパティのチェックができるようになりました。それらアイテムがあった時に、警告を出力する (コマンドラインからの起動時) か、削除するかを設定できます。
  • プレーン SVG へのエクスポートでもオプション --export-text-to-path が動作するようになりました。

Gimp XCF サポートの強化

  • 「背景色を保存」オプションで、ページの背景色を各 Gimp レイヤーの背景にできるようになりました。
  • エクスポートされたレイヤーに label 属性が設定されていればその値を、無ければ id 属性の値を使用するようになりました。
  • ヘルプタブを用意しました。
  • いくつかのバグと警告を修正しました。

PDF

  • 「裁ち落とし/マージン」オプションが追加されました。エクスポートする境界枠を拡張するマージン幅を指定できます。これは PDF にエクスポートする際に描画の周囲に小さな余白を付けたり、ページの外側に数 mm の裁ち落とし幅をつける場合などに役立ちます。

PDF/EPS/PS + LaTeX

  • Added the possibility of scaling the image. The 'calc' package must be included in the preamble. Then the image can be scaled by defining '\svgscale' instead of '\svgwidth'.
  • The font shape is now also exported. '\textit{}' for italic text, '\textbf{}' for bold text, and '\textsl{}' (slanted) for oblique text. It is important to note that Arial has an oblique font shape and not italic, so the result in LaTeX will be slanted instead of italic. It is better to use another font in Inkscape when you want true italics.

エクステンション

新しく追加されたもの

  • 「ギロチン」: 描画をスライスし PNG にエクスポートします。スライスはキャンバス内に設定された水平および垂直ガイドに沿って行われます。キャンバスの境界枠はスライスされる領域の全体のサイズとして使用されます。
  • G-code tools」: パスを (円形補間を使用した) G コードに変換し、オフセットパスを作成し、コーンカッターを使用したシャープコーナーを彫り込みます。(日本語化されません)
  • QR コード
  • 「アイソメトリックグリッド」
  • ビットマップの「切り落とし」
  • テキストの「抽出」: ドキュメント内の text 要素を選択順に出力します。
  • 「HSL 調整」
  • 「フォントの置換」
  • 「N-up レイアウト」
  • 「ヴォロノイ図」: 選択オブジェクトの重心を基準に、ヴォロノイ図およびドロネー三角形分割を作成します。
  • New Interpolate Attribute in a group extension.
  • 「タイポグラフィ」エクステンションメニュー

強化されたもの

  • 「パスの番号付け」: 開始ドット番号および 2 つのノード間のステップ数を指定できるようになりました。
  • 「マーカーの色をストロークに合わせる」エクステンション: マーカーはオブジェクトからフィル、ストローク、およびアルファチャンネルを継承するか、または色のカスタム指定が行えるようになり、名称も単に「マーカーの色」になりました。
  • Optional sliders added on float and int extension parameters (full and minimal modes).
  • Extension parameters values (except attributes!) can now be contextualized for translation (with msgctxt).
  • 「レンダリング」メニューにおいて、バーコード、グリッド、およびレイアウトエクステンションがサブメニューにまとめられました。

ユーザーインターフェイス

全般

  • キャンバスの背景をエクスポート以外でも設定できるようになりました (背景の透明度はエクスポート時のみ使用され、キャンバスには使用されませんでした)。
  • ガイドの表示/非表示をルーラーのクリックで切り換えることができるようになりました。

メニュー/アクセス

  • キーボードショートカットエディターを用意しました。
  • より多くのダイアログで、インターフェイスの要素に、キーボードから Alt+キーでアクセスできるようになりました。
  • テキストオブジェクトのコンテキストメニュー (右クリック) に「テキストとフォント」、「フィル/ストローク」、および「スペルチェック」ダイアログが追加されました。
  • メニューアイテムの名前を変更および移動しました ― 「編集」>「設定」、「編集」>「入力デバイス」、「ファイル」>「ドキュメントのクリーンアップ」
  • 「表示」メニューのグリッド/ガイド/スナップ/カラーマネジメントがそれぞれの状態を表示するチェックボックスになりました。
  • コンテキストメニューからグループ化/グループ解除が行えるようになりました。

ダイアログ

  • Dialog status and position is remembered between sessions
  • Most dialogs now dockable (including "Object properties", "Object attributes", "Text and Font", "Check spelling", "Export bitmap", "XML editor", "Find", and "Tiled clones")
  • New preference to allow Windows users to choose between native and Gtk open/save dialog
  • Preferences dialog cleanup
  • Document Metadata dialog merged into Document Properties

Simple calculations in spinboxes

In most spinboxes (a spinbox is an entry field with up and down "spinbuttons" next to it) you can now write simple calculations. For example: "2 * 3", "50 + 100", or "((12 + 34) * (5 + 5) - 2) / 2". Moreover, you can use units in entering values, like "2 + 2 cm". The result will be converted to the selected unit for the particular entry.

Configurable Control Handles

New preferences have been added to allow for the size of the on-canvas controls to be increased or decreased. The "Input Devices" section has been updated to control this.

Translations

  • The Keyboard and mouse reference (inkscape-docs project) and color palettes' labels are now translatable.
  • New UI translation in Latvian.
  • New tutorial translations in Galician and Greek.
  • New man pages in Chinese (zh_TW) Greek (el), Japanese (ja) and Slovak (sk), and updated French translation. [Galician (gl) and Polish (pl) in progress]
  • Man pages now use PO files for translation (inkscape-docs project).
  • The tutorial generation system now fully supports RTL languages.

SVG Support

  • The clip-rule property is now supported. No UI to set it exists at the moment, other than the XML editor.

Snapping

  • The snapping preferences and the snap toolbar have been reworked, both in the underlying code as well as in the GUI. This should make the snapping preferences easier to understand, easier to maintain, and make it easier to find and fix any remaining snapping bugs
  • Inkscape now also snaps perpendicularly and tangentialy to paths, when creating paths in the pen tool, when dragging nodes, or when manipulating guides. Newly created guides (dragged off the ruler) will snap perpendicularly or tangentialy to any curve that is being snapped to. Two checkboxes have been added to the document properties dialog (on the snapping tab). Please note that snapping perpendicularly or tangetialy will not work in the selector tool when transforming an object or a selection of objects.
  • Intersections of paths and guides can now be snapped to too
  • Snapping has been implemented fully for transforming selections of multiple nodes in the node tool
  • Snapping to text anchors and baselines has been implemented properly
  • If one has chosen for only snapping the snap source closest to the mouse pointer, then the tab key can be used to cycle to the next closest snap source

Notable bug fixes

Notable bug fixes since last bug fix release (0.48.3):

  • Relative image paths are no longer stored as absolute (regression introduced with 0.47).
  • Many rendering glitches were fixed.
  • The rendering of the stroke on transformed objects now matches the SVG specification.
  • Values entered in the numeric input boxes for the selector tool (X/Y/width/height) are much more accurately applied.

Known issues

  • The Cairo library used in the new renderer does not implement downscaling, which causes large bitmaps to be pixelated on export. [1]

Previous releases