Difference between revisions of "Tricks and tips"

From Inkscape Wiki
Jump to navigation Jump to search
(→‎New Tips and Tricks Scratchpad: Added section on PDF/EPS bounding boxes, based on 3 Dec 2007 #inkscape IRC conversation with ScislaC)
Line 16: Line 16:
 
Install [http://sourceforge.net/projects/pdfcreator/ PDF Creator].
 
Install [http://sourceforge.net/projects/pdfcreator/ PDF Creator].
 
Print to the PDFCreator device.
 
Print to the PDFCreator device.
 +
 +
=== PDF/EPS bounding boxes ===
 +
 +
As of version 0.45:  when you export an object to PDF or EPS, the figure's bounding box is the canvas (probably the page) rather than a tight box around the object.  If you want a tight box, select your object (with the rubber band selector) and use "Fit Page to Selection" in the "Document Properties" dialog to crop the canvas tightly around the object.  Then, you can export to PDF or EPS and get the bounding box you want.  There isn't really a way to automate this process by using Inkscape's command-line options.
  
 
== changing languages ==
 
== changing languages ==

Revision as of 00:18, 4 December 2007

Generic tricks and tips

The tips and tricks are collected to share/tutorials/tipsandtricks.svg and made apart of the release. If you want to contribute further, please add your tips and tricks to the SVN copy of the aforementioned. Also, you can add them below and they will be collected from time to time as a part of that tutorial.


New Tips and Tricks Scratchpad

Please enter your new tips and tricks here...

Export to PDF Workaround

As of version 0.45 saving as pdf results in unclipped images.

The following is a good workaround (On Windows):

Install PDF Creator. Print to the PDFCreator device.

PDF/EPS bounding boxes

As of version 0.45: when you export an object to PDF or EPS, the figure's bounding box is the canvas (probably the page) rather than a tight box around the object. If you want a tight box, select your object (with the rubber band selector) and use "Fit Page to Selection" in the "Document Properties" dialog to crop the canvas tightly around the object. Then, you can export to PDF or EPS and get the bounding box you want. There isn't really a way to automate this process by using Inkscape's command-line options.

changing languages

Remember when you first installed inkscape, and there were a bunch of language options? To switch to Espanol, select ...

Adjusting the Canvas Size to Fit Your Image

So, you've done a bunch of drawing, and now the canvas is too big/small.

  • File->Document Preferences
  • Check "Show canvas border" if not already checked, just to get some feedback.
  • Set Canvas size to "Custom".
  • Back in the Document window drop-down select box to the right of the height/width boxes, set the units to the same units as shown in the Document Preferences window.
  • Edit->Select All in All Layers
  • Copy the Width and Height now shown in the Document window into the Width and Height of the Document Preferences window. Press the enter key after changing each number.
  • Back in the Document window change the X and Y coordinates, both, to 0. Again, press the enter key after changing each number.
  • Clean up after yourself:
  • Edit->Deselect
  • Close Document Preferences window

Note: Starting with version 0.44, you can use instead the button "Fit Page to Selection" under File>Document Properties. If nothing is selected then the page is adjusted to the whole drawing.

Position guides

Position a guide roughly, then double click it to bring up a dialog box in which you can enter the desired position. --Pbhj 13:00, 1 July 2006 (PDT)

  • AFAIK you can't do this any other way ... I've been using Inkscape since not long after the split from sodipodi and I just today (1st July 06) found this out! Super! This was in the AI users tips.

Adding fill to Shapes drawn with the Calligraphic Pen tool

Quick tut on how to add fill to shapes you've drawn with the calligraphic pen. Please reupload tut on this topic --GigaClon 20:42, 19 June 2006 (PDT)

Printing or Producing PDFs in ISO A4 rather than US Specific Letter Paper

I've been messing with this for ages, and as it turns out it's got a very simple solution (much easier than emailing your SVG to a friend with Illustrator ;-).

With Inkscape 0.42, if you create an A4 canvas and print it, it will quite happily print properly on an A4 printer. It'll even produce suitable PostScript too. However, if you produce a PDF (either by Save As... or by using the command line ps2pdf or by using Adobe Acrobat) you'll always get a US Letter PDF. I think this is because the PostScript doesn't mandate A4 or suggests Letter, after all, most .ps files will convert perfectly like this. However, you can force ps2pdf to use A4, although sadly not in Inkscape. Do it on the command line after printing PostScript to a file:

ps2pdf -sPAPERSIZE=a4 myfile.ps

(it'll produce myfile.pdf, which should be an A4 PDF rather than the default Letter).

Hopefully one day, Inkscape will have a dialogue asking you what paper size you'd like when it produced PDFs (much like saving .eps asks you a couple of things). After all, Inkscape just uses ps2pdf to produce PDFs anyway, so it ought to be able to pass in the paper size specification when it does so.

...Coofer Cat

Mirror modelling

Inkscape is a drawing application, not CAD, so maybe the word "modelling" is not appropriate.

http://khiraly.4242.hu/tmp/mirrorModellingDone.png

If you want to play with the image, the inkscape source available here.

How to make an edge

http://khiraly.4242.hu/tmp/joinTwoNodes.png

Source is here.

Comment :

  1. This doesn't explain anything to me. HOW do you break apart a node? HOW do you join two nodes? I see steps I through III, but those little graphics don't explain how to do it.
  2. I think this is trying to explain how to [apparently] join something to a closed loop; I'd like to see n-way nodes for this (is that in the spec?). What they are doing is taking a node on that loop and making it in to two nodes in the same place using -0-0- (that's my ASCII art for the node duplicate icon! it's on the menu bar when you are using the node edit tool on a path). Then we split using -0 0-. Then join one of the coincidental nodes to the other shape. It now looks like you have a spur off from your closed loop. But you don't. Is that it, do I get a cookie?? --Pbhj 15:08, 7 July 2006 (PDT)

How to rotate and duplicate

Need more appropriate name, like: how to make a swatch.

Not finished yet.

Khiraly - Feel free to comment on tips, if its not clear. Any comment are useful.