We need help getting our basic lib dependencies listed out and kept up to date. Also we need to track which versions of which distros have the needed dependencies.
To get glib and GTK+ dependencies figured out, people can go through the API documentation and look for the 'since' entries saying when calls were added. Then look for those calls in our source. Voila! we'll have base minimum dependencies figured out.
C++ bindings are not included, since their required versions match those of the C counterparts.
|Library||v 0.47||v 0.48.x||trunk|
|GNU Scientific Library||?||?||?|
* Tentative dependency
1Inkscape has an internal fork of GDL that we will eventually remove. GDL 3.4 will contain all the new functionality that was introduced in our fork. However, this will also introduce a dependency upon GTK+ 3.
2We can't actually build against GDL 3.4 until we are able to support GTK+ 3.
Note: This table is not relevant to (non-fink) MacOS X, where we ship the desired version with Inkscape.
|Debian 6.0 (Squeeze, stable) EOL ~2014?||1.8.10||2.24.2||2.24.2||2.20.1||2.20.3||1.28.3||2.30.1||1.18||220.127.116.11||6.8|
|Fedora 15 EOL 2012-06||1.10.2||2.28.6||2.28.6||2.24.4
|Open SuSE 11.4 EOL 2012-09-15||1.10.2||2.28.0||2.25.5||2.22.1||2.22.0||1.28.3||2.30.1||1.19
|Open SuSE 12.1 EOL 2013-05-15||1.10.2||2.30.1||2.30.0||2.24.7
|Ubuntu 10.04 LTS (Lucid) EOL 2013-04 (Desktop)||1.8.10||2.24.0||2.24.1||2.20.0||2.20.2||1.28.0||2.30.0||1.18||18.104.22.168||6.8|
|Ubuntu 11.04 (Natty) EOL 2012-10||1.10.2||2.28.6||2.28.0||2.24.4
|Ubuntu 11.10 (Oneiric) EOL 2013-04||1.10.2||2.30.0||2.30.0||2.24.6
|Ubuntu 12.04 (Precise) EOL 2017-04 (as of 2012-03-08)||1.10.2||2.32.0||2.32.0||2.24.10
|Inkscape 0.48 unsupported|
|Inkscape trunk unsupported|
Getting and Installing Source packages
If your distro does not have some packages available (like many don't, ie, Fedora Core 2), you must often download source packages and build and install them yourself. Actually this is not that hard, and is similar to doing a Gentoo 'emerge.'
- Usually you download a file with a name like somepackage-1.0.tar.gz. Unpack it with
$ tar zxf somepackage-1.0.tar.gz or $ tar jxf somepackage-1.0.tar.bz2
- Then 'cd' into the new directory.
- Configure it with the command:
- Build it with:
- As the 'root' user, install it with:
# make install
- Download this file:
- Unpack it
- tar zxf gc6.8.tar.gz
- Configure and build it
- cd gc6.8
- ./configure --disable-shared --enable-static
- Install it
- su (or however else you become root)
- make install
Binaries: If searching for a package for GC, the name of it is sometimes:
- boehm-gc (on Gentoo)
- debian/ubuntu: sudo apt-get install libgc-dev
With this file, and for GlibMM and GtkMM below, it is usually desirable for us developers to build this C++ library statically. This removes a dependency that might be difficult for an end-user during installation. Configure it with:
./configure --enable-static --disable-shared
Try to match your Glib2 version with GlibMM's version. For example, if your Glib2 is 2.16.6, download glibmm-2.16.4.tar.bz2.
Latest source: http://ftp.gnome.org/pub/GNOME/sources/glibmm/
Usually you can try the latest version of GtkMM, but if you get version mismatch errors, try older releases.
if you got prompted about cairomm, try first solve your cairo version, so you can grab there a compatible version.
Many users have reported when building from source that after installing the above dependencies, the configure script still requires a "boost" package. It can be found below, but even after installing, you will need to create a symlink to allow the configure script to find it:
ln -s /usr/local/include/boost_1_xx_x/boost /usr/local/include/boost
Poppler is required for PDF import. There are several potential issues:
- Some Linux distributions do not ship the Xpdf headers required by Inkscape. In such cases, you need to recompile Poppler, passing --enable-xpdf-headers on the configure line. See this wishlist bug. This typically manifests in error messages like this:
In file included from extension/internal/pdfinput/svg-builder.cpp:19: extension/internal/pdfinput/svg-builder.h:32:23: error: CharTypes.h: No such file or directory ... make: *** [extension/internal/pdfinput/svg-builder.o] Error 1 make: Leaving directory `/tmp/build/inkscape-0.46/src' make: *** [all-recursive] Error 1 make: Leaving directory `/tmp/build/inkscape-0.46' make: *** [all] Error 2
- Inkscape 0.47 does not compile with Poppler >= 0.12.2. If you need to compile Inkscape on such systems, use the development version from Bazaar, where this bug is fixed. See the bug report for details and a minimal patch.
- Inkscape compiled with Poppler <= 0.12.1 will run on systems with Poppler >= 0.12.2, but the PDF import function will crash instantly. This problem does not concern Windows users, since the correct Poppler version is contained in the Windows installer package. This cannot be fixed on Inkscape's side: those two versions of Poppler are not ABI compatible, yet share the same soname. See this bug for more details.
- Poppler's Xpdf headers are not guaranteed to be API-compatible between releases. It's likely that future Poppler versions will break PDF import in some way. PDF import works at least up to 0.12.4 but might not work with later versions.