We need help getting our basic lib dependencies listed out and kept up to date. Also we need to track which versions of which distros have the needed dependencies.
To get glib and GTK+ dependencies figured out, people can go through the API documentation and look for the 'since' entries saying when calls were added. Then look for those calls in our source. Voila! we'll have base minimum dependencies figured out.
For C++11 features, see C++11
C++ bindings are not included, since their required versions match those of the C counterparts.
|Library||v 0.91||trunk||trunk (GTK+ 3.0 build)|
|GNU Scientific Library||?||?||?|
* Tentative dependency
Note: This table is not relevant to (non-fink) MacOS X, where we ship the desired version with Inkscape.
"Inkscape" column is default or distro version / oldest that builds - latest that builds. If no latest is given then that means trunk is expected to build on the given platform.
e.g. for a distro that ships with 0.48 but should support building of trunk you might get:
0.48 / 0.47-
|Windows Devlibs (32bit)  (r53)||1.11.2||1.10.0||2.28.8||2.28.2||2.24.10||2.24.2||1.28.3||0.39.0||(none)||1.17
|Windows Devlibs Gtk+ 3 branch  (r34)||1.10.2||1.10.0||2.38.0||2.36.0||2.24.18
|Windows Devlibs 64bit  (r17)||1.14.1||1.11.2||2.40.0||2.40.0||2.24.23
|Debian 8.2.0 (Jessie, stable)||0.48.5||4.9.2||3.5||1.14.0||1.10.0||2.42.1||2.42.0||2.24.25
|RHEL / CentOS / Scientific Linux 7.x||0.48||4.8.3||X||1.12.14||1.10.0||2.40.0||2.36.2||2.24.22
|Ubuntu 12.04 LTS (Precise) EOL 2017-04||0.48.3||4.6.3||(U 3.4)||1.10.2||1.10.0||2.32.4||2.32.0||2.24.10
|Ubuntu 14.04 (Trusty) EOL 2019-04||0.48.4||4.8.2||(U 3.5)||1.13.0||1.10.0||2.40.2||2.39.93||2.24.23
|Ubuntu 15.04 (Vivid) EOL 2016-01||0.91.0||4.9.2||3.6||1.14.2||1.11.2||2.44.1||2.42.0||2.24.27
|Ubuntu 15.10 (Wiley) EOL 2016-07||0.91.0||5.2.1||3.6||1.14.2||1.11.2||2.46.1||2.45.41||2.24.28
|Ubuntu 16.04 (Xenial) (As of 2016-01-02)||0.91.0||5.2.1||3.6||1.14.4||1.12.0||2.47.3||2.46.3||2.24.29
|Inkscape stable unsupported|
|Inkscape trunk unsupported|
|GTK+ 3 builds unsupported|
Getting and Installing Source packages
If your distro does not have some packages available (like many don't, ie, Fedora Core 2), you must often download source packages and build and install them yourself. Actually this is not that hard, and is similar to doing a Gentoo 'emerge.'
- Usually you download a file with a name like somepackage-1.0.tar.gz. Unpack it with
$ tar zxf somepackage-1.0.tar.gz or $ tar jxf somepackage-1.0.tar.bz2
- Then 'cd' into the new directory.
- Configure it with the command:
- Build it with:
- As the 'root' user, install it with:
# make install
- Download this file:
- Unpack it
- tar zxf gc6.8.tar.gz
- Configure and build it
- cd gc6.8
- ./configure --disable-shared --enable-static
- Install it
- su (or however else you become root)
- make install
Binaries: If searching for a package for GC, the name of it is sometimes:
- boehm-gc (on Gentoo)
- debian/ubuntu: sudo apt-get install libgc-dev
With this file, and for GlibMM and GtkMM below, it is usually desirable for us developers to build this C++ library statically. This removes a dependency that might be difficult for an end-user during installation. Configure it with:
./configure --enable-static --disable-shared
Try to match your Glib2 version with GlibMM's version. For example, if your Glib2 is 2.16.6, download glibmm-2.16.4.tar.bz2.
Latest source: http://ftp.gnome.org/pub/GNOME/sources/glibmm/
Usually you can try the latest version of GtkMM, but if you get version mismatch errors, try older releases.
if you got prompted about cairomm, try first solve your cairo version, so you can grab there a compatible version.
Many users have reported when building from source that after installing the above dependencies, the configure script still requires a "boost" package. It can be found below, but even after installing, you will need to create a symlink to allow the configure script to find it:
ln -s /usr/local/include/boost_1_xx_x/boost /usr/local/include/boost
Poppler is required for PDF import. There are several potential issues:
- Some Linux distributions do not ship the Xpdf headers required by Inkscape. In such cases, you need to recompile Poppler, passing --enable-xpdf-headers on the configure line or install the libpoppler-private-dev package. See this wishlist bug. This typically manifests in error messages like this:
In file included from extension/internal/pdfinput/svg-builder.cpp:19: extension/internal/pdfinput/svg-builder.h:32:23: error: CharTypes.h: No such file or directory ... make: *** [extension/internal/pdfinput/svg-builder.o] Error 1 make: Leaving directory `/tmp/build/inkscape-0.46/src' make: *** [all-recursive] Error 1 make: Leaving directory `/tmp/build/inkscape-0.46' make: *** [all] Error 2
- Inkscape 0.47 does not compile with Poppler >= 0.12.2. If you need to compile Inkscape on such systems, use the development version from Bazaar, where this bug is fixed. See the bug report for details and a minimal patch.
- Inkscape compiled with Poppler <= 0.12.1 will run on systems with Poppler >= 0.12.2, but the PDF import function will crash instantly. This problem does not concern Windows users, since the correct Poppler version is contained in the Windows installer package. This cannot be fixed on Inkscape's side: those two versions of Poppler are not ABI compatible, yet share the same soname. See this bug for more details.
- Poppler's Xpdf headers are not guaranteed to be API-compatible between releases. It's likely that future Poppler versions will break PDF import in some way. PDF import works at least up to 0.12.4 but might not work with later versions.