Tracking Dependencies

From Inkscape Wiki
Jump to navigation Jump to search


We need help getting our basic lib dependencies listed out and kept up to date. Also we need to track which versions of which distros have the needed dependencies.

To get glib and GTK+ dependencies figured out, people can go through the API documentation and look for the 'since' entries saying when calls were added. Then look for those calls in our source. Voila! we'll have base minimum dependencies figured out.


For C++11 features, see C++11




C++ bindings are not included, since their required versions match those of the C counterparts. Versions in parentheses refer to the dependencies for experimental Gtk+ 3 builds.

Library v 0.92 trunk
Boehm-GC 7.2 7.2
Cairo 1.10 1.10 (1.15.4 required for PDF links)
double-conversion [1]
(lib2geom dependency)
(not required) ?
Glib 2.28 2.48
GTK+ 2.24
GNU Scientific Library ? ?
libsigc++ 2.0.12* 2.0.12*
libSoup (not required) (any)
libxml 2.6.11* 2.6.11*
libxslt 1.0.15* 1.0.15*
LittleCMS 1.13 1.13
Pango 1.24 1.24 (1.41.1 required for variable fonts)
Poppler 0.20.0 0.20.0
N/A 2.0.8 (macOS only)

* Tentative dependency


Note: This table is not relevant to (non-fink) MacOS X, where we ship the desired version with Inkscape.

"Inkscape" column is default or distro version / oldest that builds - latest that builds. If no latest is given then that means trunk is expected to build on the given platform.

e.g. for a distro that ships with 0.48 but should support building of trunk you might get:

0.48 / 0.47-

General rules:

  • Support Debian Stable
  • Support Ubuntu LTS
  • Support last CentOS/Redhat (as best effort).
  • Support last two Fedora releases.
  • Don't break point releases.
Distro Inkscape gcc clang cairo cairomm glib glibmm gtk+ gtkmm pango poppler gdl lcms libsigc++ libgc libsoup
Windows MSYS2 (2018-11-08)
(mingw-w64 packages from MSYS2 project)
- 8.2.0 (7.0.0) 1.16.0 1.12.2 2.58.1 2.58.0 2.24.32
1.42.4 0.69.0 3.28.0 1.19
2.10.1 7.6.8 2.64.2
Debian 9 (Stretch, old stable) EOL 2022-06 0.92.1 6.3.0 3.8 1.14.8 1.12.0 2.50.3 2.50.0 2.24.31
1.40.5 0.48.0 3.22.0 2.8 2.10.0 7.4.2 2.56.0
Debian 10 (Buster, stable) EOL 2024-06 0.92.4 8.3.0 7.0 1.16 1.12.2 2.58.3 2.58.0 2.24.32
1.42.4 0.71.0 3.28.0 2.9 2.10.1 7.6.4 2.64.2
RHEL / CentOS 7.4 0.48 4.8.3 X 1.12.14 1.10.0 2.40.0 2.36.2 2.24.22
1.34.1 0.22.5 X 2.5.4 2.3.1 7.2d
Ubuntu 16.04 LTS (Xenial) EOL 2021-04 0.91.0 5.3.1 3.8 1.14.6 1.12.0 2.48.0 2.46.3 2.24.30
1.38.1 0.41.0 3.18.0 2.6 2.6.2 7.4.2 2.52.2
Ubuntu 18.04 LTS (Bionic) EOL 2023-04 - 7.3 6.0 1.15.10 1.12.2 2.56.1 2.56.0 2.24.32
1.40.14 0.62.0 3.26.0? 2.9 2.10.0 7.4.2 2.62.1
Ubuntu 18.10 (Cosmic) EOL 2019-07 - 8.2 6.0? 1.15.12 1.12.2 2.58.1 2.56.0 2.24.31
1.42.4 0.68.0 3.26.0? 2.9 2.10.0 7.6.4 2.64.1
Ubuntu 19.04 (Disco) EOL 2020-01
Inkscape stable unsupported
Inkscape trunk unsupported
GTK+ 3 builds unsupported
  • Agreed to at Saarbrücken hackfest.

Getting and Installing Source packages

If your distro does not have some packages available (like many don't, ie, Fedora Core 2), you must often download source packages and build and install them yourself. Actually this is not that hard, and is similar to doing a Gentoo 'emerge.'

  • Usually you download a file with a name like somepackage-1.0.tar.gz. Unpack it with
   $ tar zxf somepackage-1.0.tar.gz
   $ tar jxf somepackage-1.0.tar.bz2
  • Then 'cd' into the new directory.
  • Configure it with the command:
   $ ./configure
  • Build it with:
   $ make
  • As the 'root' user, install it with:
   # make install



GitHub Project:

Binaries: If searching for a package for GC, the name of it is sometimes:

  • gc
  • libgc
  • gc-devel
  • libgc-devel
  • boehm-gc (on Gentoo)
  • debian/ubuntu: sudo apt-get install libgc-dev



With this file, and for GlibMM and GtkMM below, it is usually desirable for us developers to build this C++ library statically. This removes a dependency that might be difficult for an end-user during installation. Configure it with:

   ./configure --enable-static --disable-shared


Try to match your Glib2 version with GlibMM's version. For example, if your Glib2 is 2.16.6, download glibmm-2.16.4.tar.bz2.

Latest source:


Usually you can try the latest version of GtkMM, but if you get version mismatch errors, try older releases.



if you got prompted about cairomm, try first solve your cairo version, so you can grab there a compatible version.


Many users have reported when building from source that after installing the above dependencies, the configure script still requires a "boost" package. It can be found below, but even after installing, you will need to create a symlink to allow the configure script to find it:

   ln -s /usr/local/include/boost_1_xx_x/boost /usr/local/include/boost




Poppler is required for PDF import. There are several potential issues:

  • Some Linux distributions do not ship the Xpdf headers required by Inkscape. In such cases, you need to recompile Poppler, passing --enable-xpdf-headers on the configure line or install the libpoppler-private-dev package. See this wishlist bug. This typically manifests in error messages like this:
In file included from extension/internal/pdfinput/svg-builder.cpp:19:
extension/internal/pdfinput/svg-builder.h:32:23: error: CharTypes.h: No such file or directory
make[2]: *** [extension/internal/pdfinput/svg-builder.o] Error 1
make[2]: Leaving directory `/tmp/build/inkscape-0.46/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/build/inkscape-0.46'
make: *** [all] Error 2
  • Inkscape 0.47 does not compile with Poppler >= 0.12.2. If you need to compile Inkscape on such systems, use the development version from Bazaar, where this bug is fixed. See the bug report for details and a minimal patch.
  • Inkscape compiled with Poppler <= 0.12.1 will run on systems with Poppler >= 0.12.2, but the PDF import function will crash instantly. This problem does not concern Windows users, since the correct Poppler version is contained in the Windows installer package. This cannot be fixed on Inkscape's side: those two versions of Poppler are not ABI compatible, yet share the same soname. See this bug for more details.
  • Poppler's Xpdf headers are not guaranteed to be API-compatible between releases. It's likely that future Poppler versions will break PDF import in some way. PDF import works at least up to 0.12.4 but might not work with later versions.

Optional Dependencies

Inkscape will still compile without these, but some features may be missing if they are absent during compilation:

Library Needed for Default
aspell Dictionaries for spell checking On
libcdr Open Corel Draw files On
gettext/msgformat Translation support On
gtest/gmock Automatted testing Off
gtkspell Spell checking On
imagemagick Bitmap editing extensions, bitmap import resolution On
jpeg jpeg import? On
lcms Color management On
OpenMP Multi-threaded filter rendering On
libpotrace Bucket fill, Trace bitmap On
scour Save as Optimized SVG (not needed during compiling, Python)
libvisio Open Visio Files, use Visio stencils On
libwpg Open WordPerfect Graphics On
libyaml xverbs command line options On