Difference between revisions of "Tracking Dependencies"
|Line 275:||Line 275:|
| Ubuntu 20.04 LTS (Focal Fossa) <small>EOL 2025-04</small>
| Ubuntu 20.04 LTS (Focal Fossa) <small>EOL 2025-04</small>
Revision as of 07:30, 14 April 2021
We need help getting our basic lib dependencies listed out and kept up to date. Also we need to track which versions of which distros have the needed dependencies.
To get glib and GTK+ dependencies figured out, people can go through the API documentation and look for the 'since' entries saying when calls were added. Then look for those calls in our source. Voila! we'll have base minimum dependencies figured out.
Version 1.0 requires a C++11 compiler. Version 1.1 requires a C++17 compiler.
C++ bindings are not included, since their required versions match those of the C counterparts.
|Library||v 0.92||v 1.0||v 1.1||v 1.2||master|
|Cairo||1.14||1.14 (1.15.4 required for PDF links)||1.16*||1.16||1.16|
|FreeType||2.9* (Required for Variable fonts)||2.9||2.9|
|3.4||Not Used||Not Used|
|Glib||2.28||2.48||2.56 or 2.62*||2.64||2.64|
|GNU Scientific Library||?||?|
|Pango||1.24||1.24 (1.41.1 required for variable fonts)||1.42*||1.44||1.44 (HarfBuzz shaping)|
|Poppler||0.20.0||0.20.0||0.29 (0.71*)||0.29 (0.71*)||0.71*|
|N/A||2.0.8 (macOS only)|
* Tentative dependency
- Pango 1.42.2 requires Harfbuzz 1.4.2
- Pango 1.44.0 requires Glib 2.59.2 and Harfbuzz 2.0. 1.44 exposes hb_font directly.
- Pango 1.45.1 requires Glib 2.60
- Pango 1.48.4 has vertical upright marks fix.
Note: This table is not relevant to (non-fink) MacOS X, where we ship the desired version with Inkscape.
"Inkscape" column is default or distro version / oldest that builds - latest that builds. If no latest is given then that means trunk is expected to build on the given platform.
e.g. for a distro that ships with 0.48 but should support building of trunk you might get:
0.48 / 0.47-
- Support last Debian Stable
- Support last Ubuntu LTS Ubuntu packages
- Support last CentOS/Redhat (as best effort).
- Support last two Fedora releases.
- Don't break point releases.
|Windows MSYS2 (2021-04-14)
(mingw-w64 packages from MSYS2 project)
|Debian 10 (Buster, stable) EOL 2024-06||0.92.4 (1.0.2)||8.3.0||7.0||1.16||1.12.2||2.9.1||2.58.3||2.58.0||2.24.32
|Debian 11 (Bullseye, testing) EOL ?
|(RHEL) / CentOS 8.1 EOFS 2024-05
Based on Centros 8.1 package list
|Ubuntu 20.04 LTS (Focal Fossa) EOL 2025-04||0.92.5||10||10||1.16||1.12.2||2.10.1||2.64.1||2.64.2||2.24.32
|Inkscape 1.0.x unsupported|
|GTK+ 3 builds unsupported|
- Agreed to at Saarbrücken hackfest.
Getting and Installing Source packages
If your distro does not have some packages available (like many don't, ie, Fedora Core 2), you must often download source packages and build and install them yourself. Actually this is not that hard, and is similar to doing a Gentoo 'emerge.'
- Usually you download a file with a name like somepackage-1.0.tar.gz. Unpack it with
$ tar zxf somepackage-1.0.tar.gz or $ tar jxf somepackage-1.0.tar.bz2
- Then 'cd' into the new directory.
- Configure it with the command:
- Build it with:
- As the 'root' user, install it with:
# make install
GitHub Project: https://github.com/ivmai/bdwgc
Binaries: If searching for a package for GC, the name of it is sometimes:
- boehm-gc (on Gentoo)
- debian/ubuntu: sudo apt-get install libgc-dev
With this file, and for GlibMM and GtkMM below, it is usually desirable for us developers to build this C++ library statically. This removes a dependency that might be difficult for an end-user during installation. Configure it with:
./configure --enable-static --disable-shared
Try to match your Glib2 version with GlibMM's version. For example, if your Glib2 is 2.16.6, download glibmm-2.16.4.tar.bz2.
Latest source: http://ftp.gnome.org/pub/GNOME/sources/glibmm/
Usually you can try the latest version of GtkMM, but if you get version mismatch errors, try older releases.
if you got prompted about cairomm, try first solve your cairo version, so you can grab there a compatible version.
Many users have reported when building from source that after installing the above dependencies, the configure script still requires a "boost" package. It can be found below, but even after installing, you will need to create a symlink to allow the configure script to find it:
ln -s /usr/local/include/boost_1_xx_x/boost /usr/local/include/boost
Boost filesystem is a temporary dependency we discussed in September 2020 because compilers we wanted to support (in particular gcc-8 and some macos compilers) do not yet support std::filesystem.
Once all compilers we support get std::filesystem, we will drop this dep
Poppler is required for PDF import. There are several potential issues:
- Some Linux distributions do not ship the Xpdf headers required by Inkscape. In such cases, you need to recompile Poppler, passing --enable-xpdf-headers on the configure line or install the libpoppler-private-dev package. See this wishlist bug. This typically manifests in error messages like this:
In file included from extension/internal/pdfinput/svg-builder.cpp:19: extension/internal/pdfinput/svg-builder.h:32:23: error: CharTypes.h: No such file or directory ... make: *** [extension/internal/pdfinput/svg-builder.o] Error 1 make: Leaving directory `/tmp/build/inkscape-0.46/src' make: *** [all-recursive] Error 1 make: Leaving directory `/tmp/build/inkscape-0.46' make: *** [all] Error 2
- Inkscape 0.47 does not compile with Poppler >= 0.12.2. If you need to compile Inkscape on such systems, use the development version from Bazaar, where this bug is fixed. See the bug report for details and a minimal patch.
- Inkscape compiled with Poppler <= 0.12.1 will run on systems with Poppler >= 0.12.2, but the PDF import function will crash instantly. This problem does not concern Windows users, since the correct Poppler version is contained in the Windows installer package. This cannot be fixed on Inkscape's side: those two versions of Poppler are not ABI compatible, yet share the same soname. See this bug for more details.
- Poppler's Xpdf headers are not guaranteed to be API-compatible between releases. It's likely that future Poppler versions will break PDF import in some way. PDF import works at least up to 0.12.4 but might not work with later versions.
Inkscape will still compile without these, but some features may be missing if they are absent during compilation:
|aspell||Dictionaries for spell checking||On|
|libcdr||Open Corel Draw files||On|
|imagemagick||Bitmap editing extensions, bitmap import resolution||On|
|OpenMP||Multi-threaded filter rendering||On|
|scour||Save as Optimized SVG||(not needed during compiling, Python)|
|libvisio||Open Visio Files, use Visio stencils||On|
|libwpg||Open WordPerfect Graphics||On|