Difference between revisions of "Tracking Dependencies"

From Inkscape Wiki
Jump to navigation Jump to search
 
(253 intermediate revisions by 16 users not shown)
Line 1: Line 1:
(stub contents in need of filling out)
== Compilers ==


== Overview ==
Version 1.0 requires a C++11 compiler.
Version 1.1 requires a C++17 compiler.


We need help getting our basic lib dependencies listed out and kept up to date. Also we need to track which versions of which distros have the needed dependencies.
See [[c++11]] and [[c++17]].
 
To get glib and GTK+ dependencies figured out, people can go through the API documentation and look for the 'since' entries saying when calls were added. Then look for those calls in our source. Voila! we'll have base minimum dependencies figured out.


== Libs ==
== Libs ==
Line 11: Line 10:
C++ bindings are not included, since their required versions match those of the C counterparts.
C++ bindings are not included, since their required versions match those of the C counterparts.


{| class="wikitable" border="1"
{| class="wikitable"
|-
|-
! Library
! Library
! v 0.47
! v 0.92
! v 0.48.x
! v 1.0
! trunk
! v 1.1
! v 1.2
! master
|-
|-
| Boehm-GC
| Boehm-GC
| ?
| 7.2
| 6.4
| 7.2
| 6.4
| 7.2
|
|
|-
|-
| Cairo
| Cairo
| ?
| 1.14
| ?
| 1.14 (1.15.4 required for PDF links)
| 1.10
| 1.16*
| 1.16
| 1.16
|-
| double-conversion [https://github.com/google/double-conversion]<br/>''(lib2geom dependency)''
| ''(not required)''
| any
|
|
|
|-
| FreeType
|
|
| 2.9* (Required for Variable fonts)
| 2.9
| 2.9
|-
|-
| GDK
| GDL
| ?
| N/A<br />(3.4)
| ?
| 3.4
| ?
| Not Used
| Not Used
|-
|-
| Glib
| Glib
| ''2.16*''
| 2.28
| ''2.16*''
| 2.48
| 2.24
| 2.56 or 2.62*
| 2.64
| 2.64
|-
|-
| GTK+
| GTK+
| ''2.12*''
| 2.24<br />(3.8)
| ''2.12*''
| 3.22
| 2.20
| 3.24*
| 3.24
| 3.24
|-
|-
| GNU Scientific Library
| GNU Scientific Library
| ?
| ?
| ?
| ?
|
|
|
|-
| HarfBuzz
| ?
| ?
| ?
| 2.2*
| 2.6
| 2.6
|-
| libsigc++
| ''2.0.12*''
| ''2.0.12*''
| ''2.0.12*''
|
|-
|-
| LittleCMS
| libSoup
| 1.13
| ''(not required)''
| 1.13
| (any)
| 1.13
|
|
|
|-
| libpotrace
| ''(not required)''
| (any)
|
|
|
|-
|-
| libxml
| libxml
| ''2.6.11*''
| ''2.6.11*''
| ''2.6.11*''
| ''2.6.11*''
| ''2.6.11*''
|
|
|
|-
|-
| libxslt
| libxslt
| ''1.0.15*''
| ''1.0.15*''
| ''1.0.15*''
| ''1.0.15*''
| ''1.0.15*''
|
|
|
|-
| lcms
| 1.13
| 2.2
| 2.2 (2.9*)
| 2.9*
| 2.9*
|-
|-
| Pango
| Pango
| ?
| 1.24
| ?
| 1.24 (1.41.1 required for variable fonts)
| ?
| 1.42*
| 1.44
| 1.44 (HarfBuzz shaping)
|-
|-
| Poppler
| Poppler
| ''0.5.9*''
| 0.20.0
| ''0.5.9*''
| 0.20.0
| ''0.5.9*''
| 0.29 (0.71*)
| 0.29 (0.71*)
| 0.71*
|-
|-
| libsigc++
| [https://formulae.brew.sh/formula/gtk-mac-integration gtk-mac-integration]<br>[https://www.macports.org/ports.php?by=library&substr=gtk-osx-application-gtk3 gtk-osx-application-gtk3]
| ''2.0.12*''
| N/A
| ''2.0.12*''
| 2.0.8 ([[CompilingMacOsX|macOS only]])
| ''2.0.12*''
|
|
|
|}
|}


''* Tentative dependency''
''* Tentative dependency''


== Functions Used ==
* Pango 1.42.2 requires Harfbuzz 1.4.2
 
* Pango 1.44.0 requires Glib 2.59.2 and Harfbuzz 2.0. 1.44 exposes hb_font directly.
{| class="wikitable" border="1"
* Pango 1.45.1 requires Glib 2.60
|-
* Pango 1.48.4 has vertical upright marks fix.
! Function
! Lib
! Since
! Required
|-
| g_timeout_add_seconds
| Glib
| 2.14
| ?
|}


== Distros ==
== Distros ==
Line 100: Line 155:
Note: This table is not relevant to (non-fink) MacOS X, where we ship the desired version with Inkscape.
Note: This table is not relevant to (non-fink) MacOS X, where we ship the desired version with Inkscape.


{| class="wikitable" border="1"
"Inkscape" column is default or distro version / oldest that builds - latest that builds. If no latest is given then that means trunk is expected to build on the given platform.
 
e.g. for a distro that ships with 0.48 but should support building of trunk you might get:
0.48 / 0.47-
 
'''General rules:'''
* Support last Debian Stable
* Support last Ubuntu LTS [https://packages.ubuntu.com/ Ubuntu packages]
* Support last CentOS/Redhat (as best effort).
* Support last two Fedora releases.
* Don't break ''point'' releases.
 
{| class="wikitable"
|-
|-
! Distro
! Distro
! Inkscape
! gcc
! clang
! cairo
! cairo
! cairomm
! freetype
! glib
! glib
! glibmm
! glibmm
! gtk+
! gtk+
! gtkmm
! gtkmm
! harfbuzz
! pango
! pango
! poppler
! gdl
! gdl
! lcms
! lcms2
! libsigc++
! libgc <!-- Fedora rpm: gc -->
! libsoup
|-
| Windows MSYS2 (2021-04-14)<br/>([https://github.com/Alexpux/MINGW-packages mingw-w64 packages] from MSYS2 project)
  <!-- see http://quodlibet.duckdns.org/msys2/base for list of latest package versions -->
| 1.0.2
| 10.2.0
| 11.0.0
| 1.17.4
| 1.12.2
| 2.10.4
| 2.68.1
| 2.66.0
| 3.24.27
| 3.24.3
| 2.8.0
| 1.48.4
| 20.12.1
| 3.34.0
| 2.12
| 2.10.6
| 8.0.4 <!-- mingw-w64-gc -->
| 2.72.0
|-
| Debian 10 (Buster, <i>oldstable</i>) <small>EOL 2024-06</small>
| 0.92.4 (1.0.2)
| 8.3.0
| 7.0
| 1.16
| 1.12.2
| 2.9.1
| 2.58.3
| 2.58.0
| 2.24.32<br />3.24.5
| 2.24.5<br />3.24.0
| 2.3.1
| 1.42.4
| 0.71.0
| 3.28.0
| 2.9
| 2.10.1
| 7.6.4
| 2.64.2
|-
| Debian 11 (Bullseye, stable) <small>EOL 2026</small>
| 1.0.2
| 10.2.1
| 11.0
| 1.16
| 1.12.2
| 2.10.4
| 2.66.8
| 2.64.2
| 3.24.24
| 3.24.2
| 2.7.4
| 1.46.2
| 20.09.0
| 3.34.0
| 2.12
| 2.10.4
| 8.0.4
| 2.72.0
|-
|-
|Windows Devlibs
| style="background:Violet;"|(RHEL) / CentOS 8.1 <small>EOFS 2024-05</small><br/>Based on Centros 8.1 package list
| 1.10.2
| 0.92.3
| 2.26.1
| 8.3.1
| 2.26.0
| 8.0.1
| 2.22.1<br />(none)
| 1.15.12
| 2.22.0
| 1.12.0
| 1.28.3
| 2.8.14
| (none)
| 2.56.4
| ?
| 2.56.0
| 2.24.32<br />3.22.30
| 2.24.5<br />3.22.2
| 1.7.5
| 1.42.4
| 0.66.0
| style="background:Violet;"|?
| 2.9
| 2.10.0
| 7.6.4
| 2.62.3
|-
| Ubuntu 20.04 LTS (Focal Fossa) <small>EOL 2025-04</small>
| 0.92.5
| 10
| 10
| 1.16
| 1.12.2
| 2.10.1
| 2.64.1
| 2.64.2
| 2.24.32<br />3.24.17
| 2.24.5<br />3.24.2
| 2.6.4
| 1.44.7
| 0.86.1
| 3.34.0
| 2.9.4
| 2.10.2
| 10
| 2.70.0
|}
 
{| class="wikitable"
|-
! Legend
|-
|-
| style="background:Orange;"| Debian 5.0 (Lenny, <i>oldstable</i>) <small>EOL 2012-02-07</small>
| style="background:Orange;"| Inkscape 1.0.x unsupported
| style="background:Orange;"| 1.6.4
| style="background:Orange;"| 2.16.6
| 2.16.4
| style="background:Orange;"| 2.12.12 <br /> (none)
| 2.12.7
| 1.20.5
| 0.7.11
| ?
|-
|-
| style="background:Orange;"| Debian 6.0 (Squeeze, <i>stable</i>) <small>EOL ~2014?</small>
| style="background:Violet;"| GTK+ 3 builds unsupported
| style="background:Orange;"| 1.8.10
|}
| 2.24.2
 
| 2.24.2
* Agreed to at Saarbrücken hackfest.
| 2.20.1 <br /> (none)
 
| 2.20.3
== Getting and Installing Source packages ==
| 1.28.3
 
| 2.30.1
See [https://inkscape.org/develop/getting-started/ Getting Started]
| ?
 
== Optional Dependencies ==
 
Inkscape will still compile without these, but some features may be missing if they are absent during compilation:
 
{| class="wikitable"
|-
|-
| Fedora 15 <small>EOL 2012-06</small>
! scope="col"| Library
| 1.10.2
! scope="col"| Needed for
| 2.28.6
! scope="col"| Default
| 2.28.6
| 2.24.4 <br /> 3.0.9
| 2.24.0
| 1.28.4
| 3.0.0
| ?
|-
|-
| Fedora 16
|aspell
| 1.10.2
|Dictionaries for spell checking
| 2.30.1
|On
| 2.30.0
| 2.24.8 <br /> 3.2.1
| 2.24.2<br />3.2.0
| 1.29.4
| 3.2.0
| ?
|-
|-
| style="background:Orange;"| Open SuSE 11.3 <small>EOL 2012-01-15</small>
|libcdr
| style="background:Orange;"| 1.8.10
|Open Corel Draw files
| 2.24.1
|On
| 2.24.2
| 2.20.1 <br /> (none)
| 2.20.3
| 1.28.0
| 2.30.1
| ?
|-
|-
| Open SuSE 11.4 <small>EOL 2012-09-15</small>
|gettext/msgformat
| 1.10.2
|Translation support
| 2.28.0
|On
| 2.25.5
| 2.22.1 <br /> (none)
| 2.22.0
| 1.28.3
| 2.30.1
| ?
|-
|-
| Open SuSE 12.1 <small>EOL 2013-05-15</small>
|gtest/gmock
| 1.10.2
|Automatted testing
| 2.30.1
|Off
| 2.30.0
| 2.24.7 <br /> 3.2.1
| 2.24.2<br />3.2.0
| 1.29.4
| 3.2.0
| ?
|-
|-
| style="background:Orange;"| Ubuntu 10.04 LTS (Lucid) <small>EOL 2013-04 (Desktop)</small>
|gspell
| style="background:Orange;"| 1.8.10
|Spell checking
| 2.24.0
|On
| 2.24.1
| 2.20.0 <br /> (none)
| 2.20.2
| 1.28.0
| 2.30.0
| ?
|-
|-
| Ubuntu 10.10 (Maverick) <small>EOL 2012-04</small>
|imagemagick
| 1.10.0
|Bitmap editing extensions, bitmap import resolution
| 2.26.1
|On
| 2.25.2
| 2.22.0 <br /> (none)
| 2.20.3
| 1.28.2
| 2.30.0
| 1.18
|-
|-
| Ubuntu 11.04 (Natty) <small>EOL 2012-10</small>
|jpeg
| 1.10.2
|jpeg import?
| 2.28.6
|On
| 2.28.0
| 2.24.4 <br /> 3.0.8
| 2.24.0
| 1.28.4
| 2.30.1
| 1.18
|-
|-
| Ubuntu 11.10 (Oneiric) <small>EOL 2013-04</small>
|OpenMP
| 1.10.2
|Multi-threaded filter rendering
| 2.30.0
|On
| 2.30.0
| 2.24.6 <br /> 3.2.0
| 2.24.2<br />3.2.0
| 1.29.3
| 3.1.5
| 1.19
|-
|-
| Ubuntu 11.10 (Precise) <small>EOL ?</small>
|scour
| ?
|Save as Optimized SVG
| ?
|(not needed during compiling, Python)
| ?
| ?
| ?
| ?
| ?
| 2.x
|}
 
{| class="wikitable"
|-
|-
! Legend
|libvisio
|Open Visio Files, use Visio stencils
|On
|-
|-
| style="background:Red;"| Inkscape 0.48 unsupported
|libwpg
|Open WordPerfect Graphics
|On
|-
|-
| style="background:Orange;"| Inkscape trunk unsupported
|}
|}
[[Category:About Inkscape]]
[[Category:Developer Documentation]]

Latest revision as of 15:45, 16 August 2021

Compilers

Version 1.0 requires a C++11 compiler. Version 1.1 requires a C++17 compiler.

See c++11 and c++17.

Libs

C++ bindings are not included, since their required versions match those of the C counterparts.

Library v 0.92 v 1.0 v 1.1 v 1.2 master
Boehm-GC 7.2 7.2 7.2
Cairo 1.14 1.14 (1.15.4 required for PDF links) 1.16* 1.16 1.16
double-conversion [1]
(lib2geom dependency)
(not required) any
FreeType 2.9* (Required for Variable fonts) 2.9 2.9
GDL N/A
(3.4)
3.4 Not Used Not Used
Glib 2.28 2.48 2.56 or 2.62* 2.64 2.64
GTK+ 2.24
(3.8)
3.22 3.24* 3.24 3.24
GNU Scientific Library ? ?
HarfBuzz ? ? 2.2* 2.6 2.6
libsigc++ 2.0.12* 2.0.12* 2.0.12*
libSoup (not required) (any)
libpotrace (not required) (any)
libxml 2.6.11* 2.6.11*
libxslt 1.0.15* 1.0.15*
lcms 1.13 2.2 2.2 (2.9*) 2.9* 2.9*
Pango 1.24 1.24 (1.41.1 required for variable fonts) 1.42* 1.44 1.44 (HarfBuzz shaping)
Poppler 0.20.0 0.20.0 0.29 (0.71*) 0.29 (0.71*) 0.71*
gtk-mac-integration
gtk-osx-application-gtk3
N/A 2.0.8 (macOS only)

* Tentative dependency

  • Pango 1.42.2 requires Harfbuzz 1.4.2
  • Pango 1.44.0 requires Glib 2.59.2 and Harfbuzz 2.0. 1.44 exposes hb_font directly.
  • Pango 1.45.1 requires Glib 2.60
  • Pango 1.48.4 has vertical upright marks fix.

Distros

Note: This table is not relevant to (non-fink) MacOS X, where we ship the desired version with Inkscape.

"Inkscape" column is default or distro version / oldest that builds - latest that builds. If no latest is given then that means trunk is expected to build on the given platform.

e.g. for a distro that ships with 0.48 but should support building of trunk you might get:

0.48 / 0.47-

General rules:

  • Support last Debian Stable
  • Support last Ubuntu LTS Ubuntu packages
  • Support last CentOS/Redhat (as best effort).
  • Support last two Fedora releases.
  • Don't break point releases.
Distro Inkscape gcc clang cairo cairomm freetype glib glibmm gtk+ gtkmm harfbuzz pango poppler gdl lcms2 libsigc++ libgc libsoup
Windows MSYS2 (2021-04-14)
(mingw-w64 packages from MSYS2 project)
1.0.2 10.2.0 11.0.0 1.17.4 1.12.2 2.10.4 2.68.1 2.66.0 3.24.27 3.24.3 2.8.0 1.48.4 20.12.1 3.34.0 2.12 2.10.6 8.0.4 2.72.0
Debian 10 (Buster, oldstable) EOL 2024-06 0.92.4 (1.0.2) 8.3.0 7.0 1.16 1.12.2 2.9.1 2.58.3 2.58.0 2.24.32
3.24.5
2.24.5
3.24.0
2.3.1 1.42.4 0.71.0 3.28.0 2.9 2.10.1 7.6.4 2.64.2
Debian 11 (Bullseye, stable) EOL 2026 1.0.2 10.2.1 11.0 1.16 1.12.2 2.10.4 2.66.8 2.64.2 3.24.24 3.24.2 2.7.4 1.46.2 20.09.0 3.34.0 2.12 2.10.4 8.0.4 2.72.0
(RHEL) / CentOS 8.1 EOFS 2024-05
Based on Centros 8.1 package list
0.92.3 8.3.1 8.0.1 1.15.12 1.12.0 2.8.14 2.56.4 2.56.0 2.24.32
3.22.30
2.24.5
3.22.2
1.7.5 1.42.4 0.66.0 ? 2.9 2.10.0 7.6.4 2.62.3
Ubuntu 20.04 LTS (Focal Fossa) EOL 2025-04 0.92.5 10 10 1.16 1.12.2 2.10.1 2.64.1 2.64.2 2.24.32
3.24.17
2.24.5
3.24.2
2.6.4 1.44.7 0.86.1 3.34.0 2.9.4 2.10.2 10 2.70.0
Legend
Inkscape 1.0.x unsupported
GTK+ 3 builds unsupported
  • Agreed to at Saarbrücken hackfest.

Getting and Installing Source packages

See Getting Started

Optional Dependencies

Inkscape will still compile without these, but some features may be missing if they are absent during compilation:

Library Needed for Default
aspell Dictionaries for spell checking On
libcdr Open Corel Draw files On
gettext/msgformat Translation support On
gtest/gmock Automatted testing Off
gspell Spell checking On
imagemagick Bitmap editing extensions, bitmap import resolution On
jpeg jpeg import? On
OpenMP Multi-threaded filter rendering On
scour Save as Optimized SVG (not needed during compiling, Python)
libvisio Open Visio Files, use Visio stencils On
libwpg Open WordPerfect Graphics On