Difference between revisions of "Tracking Dependencies"

From Inkscape Wiki
Jump to navigation Jump to search
(→‎Distros: Minor: Correct wording for other operating systems)
Line 98: Line 98:
 
== Distros ==
 
== Distros ==
  
Note: this table is only relevant for Linux distributions. For other systems (Mac OS X, Windows) the GTK+ runtime is not provided by the system, so we can ship the desired version with Inkscape.
+
Note: This table is not relevant to Windows and (non-fink) MacOS X, where we ship the desired version with Inkscape.
  
 
{| class="wikitable" border="1"
 
{| class="wikitable" border="1"

Revision as of 06:08, 17 December 2008

(stub contents in need of filling out)

Overview

We need help getting our basic lib dependencies listed out and kept up to date. Also we need to track which versions of which distros have the needed dependencies.


To get glib and GTK+ dependencies figured out, people can go through the API documentation and look for the 'since' entries saying when calls were added. Then look for those calls in our source. Voila! we'll have base minimum dependencies figured out.


Libs

C++ bindings are not included, since their required versions match those of the C counterparts.

Library v 0.45 v 0.46 v 0.47
Boehm-GC ? ? ?
Cairo ? ? ?
GDK ? ? ?
Glib ? ? 2.16
GTK+ 2.8 2.10 2.12
GNU Scientific Library X X ?
LittleCMS ? ? 1.13
libxml ? ? 2.6.11
libxslt ? ? 1.0.15
Pango ? ? ?
Poppler ? ? 0.5.9
libsigc++ ? ? 2.0.12

Functions Used

Function Lib Since Required
g_timeout_add_seconds Glib 2.14 ?

Distros

Note: This table is not relevant to Windows and (non-fink) MacOS X, where we ship the desired version with Inkscape.

Distro cairo glib gtk+ pango
Fedora 7 ? 2.12 2.10.14 ?
Fedora 8 ? 2.14 2.12.8 ?
Fedora 9 ? 2.16 2.12.10 ?
Open SuSE 10.3 1.4.14 2.14.1 2.12.0 1.18.2
Open SuSE 11.0 ? ? 2.12.9 ?
Ubuntu 7.10 (Gutsy) 1.4.10 2.14.1 2.12.0 1.18.3
Ubuntu 8.04 LTS (Hardy) 1.6.0 2.16.6 2.12.9 1.20.5
Ubuntu 8.10 (Intrepid) 1.8.0 2.18.2 2.14.4 1.22.1
Xandros 1.2.4 2.12.4 2.8.20 1.14.8