Difference between revisions of "Tracking Dependencies"

From Inkscape Wiki
Jump to navigation Jump to search
Line 14: Line 14:
 
|-
 
|-
 
! Library
 
! Library
! Inkscape 0.45
+
! v 0.45
! Inkscape 0.46
+
! v 0.46
! Inkscape 0.47
+
! v 0.47
 
|-
 
|-
 
| boehmgc
 
| boehmgc
Line 41: Line 41:
 
| ?
 
| ?
 
| ?
 
| ?
| ?
+
| 2.4
 
|-
 
|-
 
| glib
 
| glib
Line 51: Line 51:
 
| ?
 
| ?
 
| ?
 
| ?
| ?
+
| 2.4
 
|-
 
|-
| gtk+
+
| gtk+2.0
 
| ?
 
| ?
 
| ?
 
| ?
Line 61: Line 61:
 
| ?
 
| ?
 
| ?
 
| ?
 +
| 2.10.0
 +
|-
 +
| gsl
 +
| X
 +
| X
 
| ?
 
| ?
 
|-
 
|-
Line 66: Line 71:
 
| ?
 
| ?
 
| ?
 
| ?
| ?
+
| 1.13
 
|-
 
|-
 
| libxml2
 
| libxml2
 
| ?
 
| ?
 
| ?
 
| ?
| ?
+
| 2.6.11
 
|-
 
|-
 
| libxslt
 
| libxslt
 
| ?
 
| ?
 
| ?
 
| ?
| ?
+
| 1.0.15
 
|-
 
|-
 
| pango
 
| pango
Line 90: Line 95:
 
| poppler
 
| poppler
 
| ?
 
| ?
 +
| ?
 +
| 0.5.9
 +
|-
 +
| sigc++
 
| ?
 
| ?
 
| ?
 
| ?
 +
| 2.0.12
 
|}
 
|}

Revision as of 05:33, 25 June 2008

(stub contents in need of filling out)

Overview

We need help getting our basic lib dependencies listed out and kept up to date. Also we need to track which versions of which distros have the needed dependencies.


To get glib and GTK+ dependencies figured out, people can go through the API documentation and look for the 'since' entries saying when calls were added. Then look for those calls in our source. Voila! we'll have base minimum dependencies figured out.


Libs

Library v 0.45 v 0.46 v 0.47
boehmgc ? ? ?
cairo ? ? ?
cairomm ? ? ?
gdk ? ? ?
gdkmm ? ? 2.4
glib ? ? ?
glibmm ? ? 2.4
gtk+2.0 ? ? ?
gtkmm ? ? 2.10.0
gsl X X ?
lcms ? ? 1.13
libxml2 ? ? 2.6.11
libxslt ? ? 1.0.15
pango ? ? ?
pangomm ? ? ?
poppler ? ? 0.5.9
sigc++ ? ? 2.0.12