Difference between revisions of "Release notes/0.92/fr"

From Inkscape Wiki
Jump to navigation Jump to search
(Translated the very last small sections)
m (→‎Versions précédentes: le lien vers la page en français quand existante)
Line 394: Line 394:
 
== Versions précédentes ==
 
== Versions précédentes ==
  
* [[Release notes/0.91]]
+
* [[Release notes/0.91/fr]]
 
* [[Release notes/0.48]] ([[Release notes/0.48.1 |0.48.1]], [[Release notes/0.48.2 | 0.48.2]], [[Release notes/0.48.3 | 0.48.3]], [[Release notes/0.48.4 | 0.48.4]], [[Release notes/0.48.5 | 0.48.5]])
 
* [[Release notes/0.48]] ([[Release notes/0.48.1 |0.48.1]], [[Release notes/0.48.2 | 0.48.2]], [[Release notes/0.48.3 | 0.48.3]], [[Release notes/0.48.4 | 0.48.4]], [[Release notes/0.48.5 | 0.48.5]])
 
* [[Release notes/0.47]]
 
* [[Release notes/0.47]]
 
* [[Release notes/0.46]]
 
* [[Release notes/0.46]]
* [[Release notes/0.45]]
+
* [[Release notes/0.45/fr]]
* [[Release notes/0.44]]
+
* [[Release notes/0.44/fr]]
* [[Release notes/0.43]]
+
* [[Release notes/0.43/fr]]
* [[Release notes/0.42]]
+
* [[Release notes/0.42/fr]]
* [[Release notes/0.41]]
+
* [[Release notes/0.41/fr]]
* [[Release notes/0.40]]
+
* [[Release notes/0.40/fr]]
* [[Release notes/0.39]]
+
* [[Release notes/0.39/fr]]
* [[Release notes/0.38]]
+
* [[Release notes/0.38/fr]]
* [[Release notes/0.37]]
+
* [[Release notes/0.37/fr]]
* [[Release notes/0.36]]
+
* [[Release notes/0.36/fr]]
* [[Release notes/0.35]]
+
* [[Release notes/0.35/fr]]

Revision as of 07:44, 28 October 2016

Other languages: العربية Català Česky Deutsch English Español Français Italiano 日本語 한국어 Polski Português Português do Brasil Русский Slovenčina 中文

Inkscape 0.92

(Non encore livré — AnnouncePlanning092)

Nouveautés en lumière

Sorti le « YYYY-MM-DD ».

  • La nouvelle boîte de dialogue Objet permet de sélectionner, étiqueter, masquer et verrouiller tout objet du dessin depuis une liste
  • Les ensembles de sélection permettent de « grouper » des objets indépendamment de la structure du document
  • Les guides peuvent à présent être verrouillés afin d’éviter d’être déplacés involontairement
  • Plusieurs nouveaux effets de chemin ont été ajoutés, parmi lesquels Enveloppe/Perspective, Déformation par grille, Copies en miroir et tournées
  • Il y a plusieurs nouvelles extensions (par ex. une extension de motif sans couture) et un nouveau filtre (simulation de couleurs pour daltoniens) inclus dans la version ; de nombreuses anciennes extensions ont été mises à jour et ont obtenu de nouvelles fonctionnalités
  • De nombreuses propriétés SVG 2 et CSS 3 sont à présent supportées pour le rendu (par ex. paint-order, mix-blend-mode)
  • Les outils Aérographe et Mesurer ont acquis un lot de nouvelles fonctionnalités très pratiques
  • Les lignes créées avec l’outil Crayon sont lissées interactivement
  • Les B-splines (et plus) sont disponibles avec l’outil Stylo
  • Un arrière-plan en damier peut être utilisé pour déterminer plus aisément les objets transparents

Manipulation d’objets

Boîte de dialogue Objet

Nouvelle boîte de dialogue pour manipuler l’arborescence d’objets.

  • Glisser-déposer pour ordonner les objets.
  • Verrouiller et masquer un ou plusieurs éléments.
  • Utiliser Ctrl+F pour rechercher un élément.
  • Sélectionner un ou plusieurs objets du dessin.
  • Afficher des objets individuels comme des calques.
  • Possibilité de changer la couleur de surbrillance des objets.
  • Possibilité de définir le mode de mélange pour chaque objet.

Importé depuis Ponyscape.

Boîte de dialogue Ensembles de sélection

Nouvelle boîte de dialogue qui permet de créer des ensembles de sélection qui ne sont pas affectés par la structure du document.

Utilisation :

  • Ouvrir la boîte de dialogue avec Objet > Ensembles de sélection
  • Pour créer un nouvel ensemble de sélection :
  1. Cliquer sur le bouton « + » en bas du panneau pour créer un nouvel ensemble de sélection (double-cliquer sur son libellé pour le modifier)
  • Pour ajouter des objets à un ensemble de sélection :
  1. Sélectionner les objets sur le canevas
  2. Dans le panneau « Ensembles de sélection », cliquer sur l’icône « + » avant l’ensemble de sélection dans la liste
  • Pour sélectionner tous les objets d’un ensemble de sélection :
  1. Tout désélectionner puis cliquer sur l’ensemble de sélection dans la liste
  • Pour retirer un objet d’un ensemble de sélection :
  1. Sélectionner l’ensemble de sélection dans le panneau
  2. Cliquer sur « Éléments » pour afficher tous les objets de l’ensemble
  3. Sélectionner un objet sur le canevas ou la liste d’éléments dans le panneau
  4. Cliquer sur l’icône « Supprimer » (poubelle) à côté de l’objet dans la liste
  • Pour supprimer un ensemble de sélection, le sélectionner dans la liste et cliquer sur le bouton « − » en bas du panneau

Text

Font Features

It is now possible to take advantage of OpenType tables to select alternative glyphs from a font. Note that browser support is still limited. Inkscape must also be linked with a recent version of the Pango library.

Vertical Text

Support for vertical text layout has been improved.

  • The default behavior for Latin bases glyphs has been changed. They are now rotated sideways as required by the SVG 1.1 standard.
  • Support for the CSS 3 'text-orientation' property has been added. (Note that this property is not yet fully supported by browsers.)
  • The CSS 3 values for the 'writing-mode' property are supported in rendering. Saving still uses the deprecated SVG 1.1 values.

Accessibility

Converting text to a path will save the text in the 'aria-label' attribute. This is useful for accessibility and could eventually be used by Inkscape to reconstruct the text.

Other

Line height setting now allows you to select a unit.

Live Path Effects

  • Now some suitable LPEs can be applied to clips and masks.
  • Helper lines come again to life.
  • The option to add a bend path directly was added to the pen/pencil shape combo box.

Spiro Live


Extended video: <https://www.youtube.com/watch?v=bFakiI5f0-Y>

Based upon Spiro Live Path Effect, now shows the result while drawing.

  • Cusp nodes can be created by holding down the Shift key.
  • When you append a path in cusp and Spiro mode, the helper preview path will be displayed.

Spirolive.gif

BSpline


Extended video https://www.youtube.com/watch?v=vwV0DHvA-OE

Pen & Node mode

Uses the BSpline Live Path Effect while creating and editing paths.

  • Works with Pen and Pencil tool directly.
  • Create cusp nodes by holding down the Shift key (Pen/Bézier tool only).
  • When a path is appended, a preview helper path will also be shown.
  • Hold down Shift key and drag on a handle to change the weight of a bspline in node tool.
  • Custom weight steps are applied by holding CTRL down and dragging on a handle with the node tool (no Shift key required).
  • Double-click on a handle resets weight to default

Bspline.gif Bspline2.gif

Live Path Effect mode
Bspline3.gif

The options in the Live Path Effect dialog give you full control over bspline paths.

  • Option to set to Default weight (0.3333 times curve segment)
  • Option to make nodes cusp
  • Numeric input for weight
  • Option to set number of Steps with CTRL to quickly snap the weight in node/handle editing
  • Apply changes if weight ... applies changes in the widgets to all nodes with weight == 0 or weight > 0 or both, for example, retains cusp nodes when you change the weight and have unselected "Apply changes if weight == 0".
  • Change only selected nodes applies to all other widgets changes.
  • Shows a helper path with the final shape and the generated new nodes.

Roughen


Roughen.png

Extended video: https://www.youtube.com/watch?v=130Dbt0juvY

This path effect is a semi-clone of two extensions, ("add nodes" and "jitter nodes") and handles units.

The parameters are similar to both extensions and adds a global randomizer.

  • Can be applied to paths, shapes and groups.
  • Can be applied to clips and masks, if they are vector objects.

Roughen.gif

Simplify


Simplify.png

Extended video: https://www.youtube.com/watch?v=gaWujN_iTSk

Simplifies a vector element using a non-destructive live path effect.

  • Can be used on paths, shapes and groups of these.
  • Can be applied to clips and masks, if they are vector objects
  • The effect's threshold can be modified in the preferences dialog, by setting a numeric parameter.
  • Apply Simplify multiple times in the same LPE.

Simplify.gif

This path effect can optionally be applied directly via the pencil/freehand drawing tool's tool bar when creating a new path. It then replaces the normal smoothing (which would be a destructive operation).

Perspective/Envelope


Perspective-envelope.png

Extended video: https://www.youtube.com/watch?v=CjKGatyxTZ8

Both deformations can be applied by specifying 4 points.

  • Two modes, perspective and envelope
  • Can be used on paths, shapes and groups.
  • Also works with vector clips and masks.

Perspective-envelope.gif

Lattice Deformation 2


Latice2.png

Extended video: https://www.youtube.com/watch?v=YlK9L88_tWE
Symmetry video: https://www.youtube.com/watch?v=jhuVjqFA6ig

  • Deforms an object by 25 handles arranged in a mesh
  • Optionally deforms symmetrically along vertical or horizontal axis or both.
  • Can be applied to paths, shapes and groups.
  • Also works on vector clips and masks.

Latice2.gif

Show Handles


ShowHandles.png

Extended video: https://www.youtube.com/watch?v=h9ul_PR9XYo

An LPE version of the Show Handles extension.

  • Works on paths, shapes and groups.
  • Works on clones.
  • Node and Handle shapes are resizeable
  • If not applied to a clone, this is a destructive LPE, it does not save styles, better work on a copy!

ShowHandles.gif

Transform by two points

TransformByTwoKnots.png

Extended video: https://www.youtube.com/watch?v=ZLmYdWoXXIw
Extended video (Elastic rubber): https://www.youtube.com/watch?v=lOWTeZC_LjM

Transforms an element by two control points (e.g. moving, skewing, resizing and rotation). You can position the control points on the bounding box edge midpoints or by the index of the nodes of the original path. Thanks to Ivan Louette for the idea for this effect!

  • Works on paths, shapes. With groups you have limited features constrained to bounding box.
  • Allows snapping of both control points.
  • Allows to fix angle or distance.
  • Elastic mode to simulate a rubber band path.
  • Two bounding box edge midpoints can be used as control points if 'From original width' is active.

TransformByTwoKnots.gif

Rotate copies

Extended video (partial fuse path): https://www.youtube.com/watch?v=UpI8gRbkTu4
Extended video (live editing): https://www.youtube.com/watch?v=fBQpvfgT4mE
Extended video (kaleidoscope): https://www.youtube.com/watch?v=LfMixSKy3Eo

Arranges identical elements dynamically on an arc or circle.

  • Works on paths, shapes and groups of paths.
  • Allows to fuse the result to create kaleidoscope-like effects
  • Allows to arrange the copies on an arc when the 360° copies checkbox is not checked.
  • Live editing.

Mirror Symmetry

Extended video: https://www.youtube.com/watch?v=m1sj4AeU3Yo
Mirrors an item dynamically.

  • Works on paths, shapes and groups.
  • Allows to fuse the result.
  • Different mirror lines: Free, bounding box center X, bounding box center Y, Document center X, Document center Y.

Spray tool

Extended video 1 (No overlap): https://www.youtube.com/watch?v=uehj4ATOWos
Extended video 2 (No overlap multiple items): https://www.youtube.com/watch?v=1eTG2U3qlb4
Extended video 3 (Over visible, pick color): https://www.youtube.com/watch?v=aTdKu7mAZE8
Extended video 4 (Pressure): https://www.youtube.com/watch?v=kWdQnxd_z30
Extended video 5 (Trace -clones- dialog): https://www.youtube.com/watch?v=Zn3vzf-yA_w

  • New eraser mode
  • More pressure toggles added
  • "No overlap" option with optional multiple elements
  • "No overlap" option between different background colors
  • Configurable offset for overlaps
  • Color picker from center or average area
  • Apply picked color to fill
  • Apply picked color to stroke
  • Invert picked colors
  • Spray over transparent background areas
  • Spray over non-transparent background areas
  • Makes use of "Trace the drawing" options from Tiled Clones dialog

Measure tool

Extended video: https://www.youtube.com/watch?v=OE0cVDGCzbM

  • Measure is kept until a new one is made (only visible when using measure tool)
  • Repositioning of origin/end
  • Convert to object
  • Convert to guides
  • Add just the distance measurement, consisting of editable text and a line indicating start and end
  • Display a 'phantom measurement' temporarily to be able to compare two measurements
  • Reverse origin/end
  • Measure global
  • Measure only current layer
  • Change precision

Align and Distribute

  • NEW: drop-down chooser with options to align nodes relative to each other in node editing mode.

Import / Export

Export PDF / EPS / PS

  • The default PostScript level for exporting from the command line changes from 2 to 3 (consistent with the user interface PS exporter which defaults to level 3). Level 3 is required for gradient support.

Export Optimized SVG

  • Completely redesigned settings dialog
  • Starting with version 0.92, Inkscape uses the Scour version installed on the system (e.g. via "pip install scour") instead of a bundled version so you can always profit from the latest improvements
  • A lot of new features and fixes in the Scour module itself, check out the release notes (Scour 0.26 from 2011-05-09 was the version that has been bundled with Inkscape 0.91)

Extensions

New

  • Render > Seamless Pattern (Screencast)
  • Images > Set Image Attributes (Bug #1357808, can be used to fix the scaling problem of raster images in SVGs created with previous Inkscape versions)
  • Render > NiceCharts (github repo, not maintained)
  • Arrange > Deep Ungroup (Bug #171117)

Plotter Driver

Multiple Pens

The Plotter driver (Extensions -> Export -> Plot) can now handle multiple pens to create colorful drawings on Pen Plotters:

  • Create a layer for every pen to use and move the corresponding drawings into it
  • Name the layer with a title like "Pen 1" or "MyLayerName Pen 1", where the number corresponds to the pen number the plotter should use
  • The layer name always overrides the standard pen setting in the plot menu

Serial Connection

The connection settings now allow you to specify rarely used serial connection settings like byte size, stop bits and parity. Most plotters use the default settings, so only change these if you know what you are doing.

HPGL Export

The HPGL export (File -> Save as -> HP Grafics Language file) has now the same multiple pens feature as the #Plotter Driver.

HPGL Import

The HPGL import (File -> Open -> Select .hpgl file) can now import multiple pens into corresponding layers, see #Plotter Driver for more information.

PDF Import

The image 'interpolate' value is now used to determine how to display bitmaps (interpolated or blocky).

Miscellaneous Improvements

  • Arrange > Restack has new options to reverse and shuffle the z-order of selected objects.
  • Render > Random Tree has new option to omit redundant segments.
  • Visualize Path > Measure Path has additional text layout options.
  • Render > Barcode was updated with new EAN2 code and extended EAN13 with automatic EAN2 and EAN5 additions
  • Color > Randomize now allows to set the range for randomization, and (with some limits) can now also randomize opacity

Extension Development

  • It is now possible for an extension to retrieve a list of selected nodes (Bug #171287).

Filters

New

  • Color > Color Blindness filter allows to simulate different color blindness conditions.

Other dialogs

Document Properties: Licences

All selectable licences have been updated to most current version.

Filter Editor

Filter list now displays how often a filter is used.

Menus

  • 'Resize page to selection' added to Edit menu, shortcut: Shift+Ctrl+R

Other user interface

Node Snapping

Snapping in the node tool has been improved:

  • When double clicking to insert new nodes, the position of these new nodes will snap to for example path intersections and to path-guide intersections
  • When grabbing a segment of a path and dragging it to deform it, the pointer will now snap

Checkerboard Background

It is now possible to use a checkerboard background when editing. This allows one to clearly see the transparency of objects.

View Box

One can now set the SVG 'viewBox' attribute from the GUI. This attribute sets the scale of the drawing by determining the real-world value of the SVG user unit (pixel size).

Lock Guides

Now guides can be locked and unlocked globally or individually.

SVG and CSS

  • The 'marker-orientation' property now recognizes units ('deg', 'rad', 'grad' and 'turn').
  • The new SVG 2 'context-fill' and 'context-stroke' properties are implemented which allows the auto-matching of arrowhead fill color to path stroke color.
  • The new SVG 2 marker orientation attribute value 'auto-start-reverse' is implemented. This allows one arrow marker to be used for both ends of a path.
  • The new CSS 3 'mix-blend-mode' and 'isolation' properties are implemented, allowing setting the blend mode between objects without using filters.
  • The new SVG 2 'paint-order' property is now supported. This allows setting the order in which the fill, stroke, and markers are drawn (buttons will be available in the Fill and Stroke dialog).
  • The new SVG 2 'mesh' paint server is supported, including bicubic auto-smoothing. A primitive GUI is available.
  • The SVG 1.1 'text-decoration' property is now rendered (underlines, strike through, etc.). CSS 3 'text-decoration' properties are also rendered.
  • The new SVG 2 'hatch' paint server is now supported.
  • The CSS 'white-space' property is now supported. Use of this property was added in SVG 2 to replace the now deprecated 'xml;space' attribute.
  • The SVG 1.1 'textLength" and 'textAdjust' attributes are implemented, however, there is no GUI for these attributes.
  • Rendering of the Component Transfer filter primitive has been corrected.
  • Units are now recognized in the text and tspan 'x', 'y', 'dx', and 'dy' attributes.
  • Percentage values are now interpreted correctly for shapes.

New SVG 2 and CSS 3 features are generally not enabled in the GUI until widespread support in browsers.

New dependencies

  • The Paintbucket and Trace Bitmap tools now use an external copy of the Potrace library, which is available in many Linux distributions or can be obtained from http://potrace.sourceforge.net
  • Export to Optimized SVG now depends upon an external copy of the Scour python module, which can be obtained via pip (pip install scour), package management (version may be outdated) or from the scour project github site. For Windows versions, the module is included.

Translations

New UI translations for Assamese, Bodo, Dogri, Gujarati, Hindi, Kannada, Kashmiri (Perso-Arabic and Devanagari), Konkani (Latin and Devanagari scripts), Maithili, Malayalam, Manipuri (Meetei Mayek and Bengali scripts), Marathi, Odia, Santali (Devanagari and Ol-Chiki scripts), Sanskrit, Sindhi, Tamil, Urdu (Perso-Arabic and Devanagari scripts).

Correctifs notables

  • RÉSOLU : Problèmes de performance sévères sous Ms Windows (paquetages 64 bits) sur les installations utilisant des cartes graphiques Intel (masquer les règles permettait de contourner le problème sous Inkscape 0.91) (bogue #1351597)
  • RÉSOLU : Sous Ms Windows (paquetages 64 bits), l’impression pouvait donner des pages presque noires lorsque de l’opacité partielle est utilisée dans le document (bogue #1418865)

Problèmes connus

  • Les polices de caractères chargées par les logiciels de gestion de polices sous Windows ne peuvent pas être sélectionnés sous Inkscape (bogue #1416674)

Versions précédentes