Release notes/0.91/ja

From Inkscape Wiki
Jump to navigation Jump to search

Other languages: العربية Català Česky Deutsch English Español Français Italiano 日本語 한국어 Português Português do Brasil Русский Slovenčina 中文

Inkscape 0.91

(not released yet - AnnouncePlanning091)

リリースハイライト

リリース: YYYY月MM月DD日

  • 表示と PNG エクスポートにおける Cairo レンダリング
  • すべてのフィルターにおける OpenMP マルチスレッド処理
  • C++ へのコードの移行(完了?)
  • テキストツールの全面的な改良、「タイポグラフィ」エクステンション
  • 「ものさし」ツール
  • タイプデザイン機能
  • シンボルライブラリと Visio ステンシルのサポート
  • クロスプラットフォームでの WMF/EMF のインポートおよびエクスポート
  • Corel DRAW ドキュメントおよび Visio インポートサポートの改善
  • 実世界でのドキュメントおよびページサイズ単位 (mm など) のサポート
  • 数々の使い勝手の向上
  • ネイティブ Windows 64-bit でのビルド Partha
  • ネイティブ Mac OS X でのビルド? (Valerio Aimale?) Mailing List discussion
  • その他重要なバグの修正

レンダリングとパフォーマンス

Inkscape 0.49 は Cairo ライブラリベースの新しいレンダラーを搭載しました。この作業は主に Google Summer of Code 2010 および 2011 の中で行われました。

  • パフォーマンスの向上 この新しいレンダラーにより、ほとんどの描画性能が著しく向上しました。編集中の反応性を向上させるため、複雑なオブジェクトの描画のほとんどが自動的にキャッシュされます。
  • OpenMP によるフィルターのマルチスレッド処理 フィルターはその計算時に利用可能なすべてのプロセッサーコアを使用できます。マルチコアシステム上で大きなフィルターオブジェクトを含む描画を編集する際に大きな性能向上が期待できます。
  • メモリ消費量の大幅な減少 複雑な描画を開いた時のメモリ消費量が減少し、より大きなファイルを開けるようになりました。一部のケースでは Inkscape 0.48 の時の 25% しか消費しません。
  • 反応性の向上 SVG のレンダリングがキャッシュされるようになりました。これにより、パスのハイライト表示、オブジェクトの選択/選択解除、および遅延更新モード(?)におけるパス編集時の反応性が大きく向上しました。
  • レンダリングにおけるバグの修正 バグトラッカーに報告されているレンダリングに関する問題のほとんどが Inkscape 0.49 で修正されました。以下のような描画も正常に行われます:
    • パターンフィル (変形を行ってもタイル間に隙間ができることはありません)
    • パターン内での変形されたオブジェクトのストローク
    • クリップされたオブジェクトを含むパターン
    • ネストしたクリッピングパス
    • アウトライン表示時の、大きいマスク/クリッピングパスでマスクまたはクリップされたオブジェクト
    • 幅が広いストロークおよび長い結合部のパス
    • フォント

色表示モード

描画の色表示モードに グレースケール が追加されました。Shift+テンキー(キーパッド)5 で通常の色表示と切り替えます。

ツール

ノードツール

ノードツールのツールバーに、選択したパスセグメントの極値点にノードを追加するボタンが追加されました。ノードの挿入ボタンの隣にある矢印をクリックしてください。

ものさしツール

新機能です。

テキストツール

  • テキストサイズのデフォルトの単位はポイント (pt) になり、さらにカスタマイズ可能 (px,pt,pc,mm,cm,in,em) になりました。
  • テキストツールのツールバーではフォントのスタイルも表示・選択できるようになりました。
  • テキストの単位が em であるファイルも正しく読み込めるようになりました。
  • 代替フォントへの置き換え時に警告ダイアログを表示できるようになりました。

グラデーション

  • グラデーションツールバーを強化し、色フェーズの選択と修正、反転、繰り返し、およびグラデーションのリンクが設定できるようになりました。
  • キャンバス上でのグラデーションの編集が修正されました ― ダブルクリックで色フェーズを作成し、正しく選択します。
  • 「フィル/ストローク」ダイアログで、色、名前、および利用数によるグラデーションの並び替えが行えるようになりました。
  • 「フィル/ストローク」ダイアログで、グラデーションの名前を変更できるようになりました。

ダイアログ、その他

整列と配置

  • 新しく 3 種類の "選択オブジェクトの位置を入れ替える" 機能が追加されました (「整列と配置」ダイアログの「再配置」グループ)。これらは選択オブジェクトの位置を、1. 選択順、2. Z 軸順、および 3. 時計回り に入れ替えます。
  • 整列操作のキーボードショートカットが追加されました (Ctrl+Alt+テンキー)。

検索/選択

  • Z 軸上で最前面にないアイテムの選択が容易になりました。Alt+マウスホイールで、マウスポインターの位置にある重なったアイテムを順番に選択していきます (Shift+Alt+マウスホイールで選択範囲に追加します)。現在のところ、グループ設定は考慮されず、グループ内のアイテムが個別に選択されます。
  • 新しい検索/置換ダイアログでは、テキストやあらゆる属性に対して操作できるようになりました。
  • "同じオブジェクトを選択" では、色/スタイル/タイプが同じオブジェクトを選択できるようになりました。

フィル/ストローク

  • グラデーションリストでのグラデーション、名前、および利用数の表示
  • よりコンパクトなマーカーセレクター

レイヤー

  • ドラッグアンドドロップでレイヤーの順序変更やサブレイヤーの作成が行えるようになりました。
  • コンテキストメニューに「全レイヤーを表示/非表示」オプションが追加されました。

シンボル

シンボルライブラリからシンボルを表示する「シンボル」ダイアログを新しく用意しました。Inkscape 0.49 では、論理回路シンボルと AIGA/DOT ピクトグラムの 2 つのサンプルライブラリが含まれています。このダイアログでは Inkscape 描画上にあるすべてのシンボルから擬似ライブラリを作成することもできます (シンボルは SVG <symbol> 要素によって定義されます)。シンボルの Inkscape キャンバスへの追加はダイアログからのドラッグで行います。

シンボルを含むあらゆるドキュメントはシンボルライブラリとして利用できます。ライブラリへ追加するには、Inkscape 構成ディレクトリ内のsymbols ディレクトリ (通常 share/inkscape) へコピーします。適切に処理されれば、シンボルは (ユーザー定義された) デフォルトのフィルおよびストロークで提供されます。

同様に、Visio ステンシルファイル (.vss) も、同じ symbols ディレクトリに置くことで使用できます。ただし SVG シンボルライブラリとしては満足のいくものではないかもしれません。

詳細は Symbols Dialog Wiki ページを参照してください。

変形

  • オブジェクトの回転で時計回りおよび反時計回りを指定できるようになりました。

マーカー

  • マーカーにオブジェクトの色を使用できるようになりました。

ビットマップのトレース

  • ビットマップのトレースでライブプレビューが行えるようになり、サイズも変更されるようになりました。

ライブパスエフェクト

オブジェクトのライブパスエフェクトは、オブジェクトの複製にフォークされるようになりました(?)。

パワーストローク

Here a list of the current state. Note that this is very much work in progress and anything can change. I think this is the most efficient place of keeping track how the powerstroke LPE works.

  • ストロークノットは紫色の菱形で表示されます。
  • 最初の適用時、3 個のストロークノットが、パスの始点、終点、および中間点に追加されます。
  • ノットの追加: ストロークノット上で Ctrl+click
  • ノットの削除: ストロークノット上で Ctrl+Alt+click
  • "ポイントの並び替え" では、ストロークノットを、パス上の位置によって並び替えます。
  • 始点および終点の形状を指定できます。SVG における両端の形状は外部タイプ(?)と同様可変であり、"ゼロ幅" はパスの両端に、幅ゼロのコントロールノット(?)を追加するのと同じです。
  • 角のタイプを指定できます。SVG での結合方式の他、2 つの方式が加えられています:
    • 外挿: ストロークされたパスの輪郭がより自然になるよう結合部 (角) の形状を外挿 (推定) します。
    • (未実装) 外挿・弧状: こちらの数学的説明を参照してください。
    • スピロ: スピロ曲線を使用して結合部を丸めます (丸形方式は曲線に楕円弧を使用します)。

サンプルのスクリーンショット

クローンオリジナル

クローンオリジナル LPE は、適用されたパスのパスデータを無視します。代わりに、オリジナル-d パスデータのコピー、すなわち、リンクパスパラメータでリンクされたパスから、LPE 演算前のパスデータをコピーを作成します。

クローンオリジナル LPE は、パワーストロークとともに開発されました。パワーストロークは可変的なストロークを作成しますが、このパスにフィルを設定することができません (フィルはストロークとして使用されます)。パワーストロークのパスにフィルを設定するには、第 2 パス (ダミーパス) を作成し、クローンオリジナル LPE を適用し、パワーストロークのパスへリンクします(?)。この第 2 パスはパワーストローク LPE の前にオリジナルパスのクローンを作成するため、パワーストロークのパスにフィルを使用することができます。速やかにダミーパスを作成しこのエフェクトを適用するには、クローンを作成するパスを選択し、編集 > クローン > クローンオリジナルパス (LPE) を選択します。

通常のクローンと同様に、クローンオリジナル LPE が適用されているパスを選択して Shift+D を押すと、LPE によって参照されているパスを選択します。

その他のクローンオリジナル LPE の便利な使い方としては、参照するパスとは異なるスタイルのクローンの作成があります。クローンを選択し LPE ダイアログの "+" を押すとクローンオリジナル LPE が追加されます。

フィルター

新しいカスタム定義済みフィルターでは、カスタムパラメーターで定義済みフィルターを作成できるようになりました。SpecCustomPredefinedFilters を参照してください。

ピクセルアートのトレース (libdepixelize)

ピクセルアート (ドット絵) に特化したラスター画像のベクター化ライブラリ libdepixelize を使用した、「ピクセルアートのトレース」が追加されました。古き良き「ビットマップのトレース」もこれまで通り使用できます。このアルゴリズムでどのように処理されるかのプレビュー画像をアルゴリズムの作者による説明で確認できます。

ユーザーインターフェイス

全般

  • キャンバスの背景をエクスポート以外でも設定できるようになりました (これまで背景の透明度はエクスポート時のみ使用され、キャンバスには使用されませんでした)。
  • ガイドの表示/非表示をルーラーのクリックで切り換えることができるようになりました。

メニュー/アクセス

  • キーボードショートカットエディターを用意しました。
  • より多くのダイアログで、インターフェイスの要素に、キーボードから Alt+キーでアクセスできるようになりました。
  • テキストオブジェクトのコンテキストメニュー (右クリック) に、「テキストとフォント」、「フィル/ストローク」、および「スペルチェック」が追加されました。
  • メニューアイテムの名前を変更および移動しました:
    • 「ファイル」>「Inkscape の設定」→「編集」>「Inkscape の設定」
    • 「ファイル」>「入力デバイス」→「編集」>「入力デバイス」
    • 「ファイル」>「<Def> のバキューム」→「ファイル」>「ドキュメントのクリーンアップ」
  • 「表示」メニューのグリッド/ガイド/スナップ/カラーマネジメントがそれぞれの状態を表示するチェックボックスになりました。
  • コンテキストメニューからグループ化/グループ解除が行えるようになりました。

ダイアログ

  • ダイアログの位置と状態をセッション間で記憶するようになりました。
  • ほとんどのダイアログ (「オブジェクトのプロパティ」、「オブジェクトの属性」、「テキストとフォント」、「スペルチェック」、「PNG 画像にエクスポート」、「XML エディター」、「検索/置換」、および「タイルクローン」を含む) がドック可能になりました。
  • Windows において、ファイルを開く/保存のダイアログに Windows ネイティブを使用するか Gtk を使用するか選べるようになりました。
  • Inkscape の設定ダイアログを整理しました。
  • ドキュメントのメタデータをドキュメントのプロパティダイアログに統合しました。

スピンボックス内での簡易計算

ほとんどのスピンボックス (スピンボックスとは、入力フィールドと、その横に上下のボタン「スピンボタン」がついているウィジェットのことです) で、簡単な計算式を入力できるようになりました (例: "2 * 3"、"50 + 100"、あるいは "((12 + 34) * (5 + 5) - 2) / 2" など)。また、"2 + 2 cm" のように入力値に単位をつけることもでき、入力ごとに選択された単位に基づいて変換されます。

制御ハンドルの設定

新たにキャンバス上の制御ハンドルの大きさを設定できるようになりました。「設定」>「入出力」>「入力デバイス」セクションで設定できます。

国際化

  • キーとマウスのリファレンス (inkscape-docs project) およびカラーパレットのラベルがローカライズされました (Tango などの固有テーマのパレットについてはオリジナルのままです)。
  • ユーザーインターフェイスにラトビア語が追加されました。
  • チュートリアルにガリシア語とギリシャ語が追加されました。
  • Man page に日本語 (ja)、中国語/台湾 (zh_TW)、ギリシャ語 (el)、およびスロバキア語 (sk) が追加され、フランス語が更新されました。[ガリシア語 (gl) とポーランド語 (pl) も作業中です]
  • Man page のローカライズに PO ファイルを採用しました (inkscape-docs project)。
  • チュートリアル生成システムにおいて RTL 言語に完全対応しました。

ファイル形式のサポート

  • Flash XML Graphics (FXG) 形式へのエクスポートをサポートしました。
  • Synfig Animation Studio (SIF) 形式へのエクスポートをサポートしました。
  • Visio (VSD) 形式のインポートをサポートしました。これは libvisio を利用しています。
  • CorelDraw (CDR) 形式の内部インポートをサポートしました。これは libcdr を利用しています。
  • XAML へのエクスポートが強化されました。
  • SVG メディア付き圧縮が強化されました。新しく ZIP ファイル内に画像を格納するディレクトリを指定できるようになり、SVG ドキュメント上で使用されているフォントのリストをテキストファイルで格納できるようになりました。
  • ビットマップ画像のインポート時に、画像を常にリンクさせるか、常に埋め込むか、あるいは毎回尋ねるかを設定できるようになりました。
  • SVG の入力および/またはエクスポート時に、不正または無用な要素、属性、およびプロパティのチェックができるようになりました。それらアイテムが検出された場合、警告を出力する (コマンドラインからの起動時) か、削除するかを設定できます。
  • プレーン SVG へのエクスポートでも、オプション --export-text-to-path が動作するようになりました。

EMF/WMF

EMF および WMF の入力および出力フィルターは完全に書きなおされ、クロスプラットフォーム化されました。これにより、Wine 上で動作する Windows アプリケーションとネイティブ Linux 版 Inkscape との間で EMF ファイルのコピー&ペーストができるようになりました。

Gimp XCF

  • 「背景色を保存」オプションで、ページの背景色を各 Gimp レイヤーの背景にできるようになりました。
  • エクスポートされたレイヤーに label 属性が設定されていればその値を、無ければ id 属性の値を使用するようになりました。
  • ヘルプタブを用意しました。
  • いくつかのバグと警告を修正しました。

PDF

  • 「裁ち落とし/マージン」オプションが追加されました。エクスポートする境界枠を拡張するマージン幅を指定できます。これは PDF にエクスポートする際に描画の周囲に小さな余白を付けたり、ページの外側に数 mm の裁ち落とし幅をつける場合などに役立ちます。

PDF/EPS/PS + LaTeX

  • 画像を拡大縮小できるようになりました。プリアンブルに 'calc' パッケージが含まれていなくてはなりません。画像は '\svgwidth' ではなく '\svgscale' を定義することで拡大縮小できます。
  • フォントのシェイプもエクスポートされるようになりました。イタリック体テキストには '\textit{}' が、ボールドテキストには'\textbf{}' が、斜体 (slanted) テキストには '\textsl{}' が指定されます。重要な注意点として、例えば Arialイタリック体 ではなく 斜体 フォントシェイプを持つため、LaTeX への出力内では イタリック体ではなく斜体 になります。本当のイタリック体を使用したい場合はイタリック体を持つ他のフォントを使用したほうが良いでしょう。

エクステンション

単位における非互換

ドキュメント単位の適切な実装のため、inkex.unittouu および inkex.uutounit は修正され、inkex.Effect クラスに移動されました。単位の変換は inkex.Effect.unittouu および inkex.Effect.uutounit を呼びださなければならなくなりました (通常は "self.unittouu" and "self.uutounit")。

新しく追加されたもの

  • 「ギロチン」: 描画をスライスし PNG にエクスポートします。スライスはキャンバス内に設定された水平および垂直ガイドに沿って行われます。キャンバスの境界枠はスライスされる領域の全体のサイズとして使用されます。
  • G-code tools」: CNC 用途向けのエクステンションです。パスを (円形補間を使用した) G コードに変換し、オフセットパスを作成し、コーンカッターを使用したシャープコーナーを彫り込みます(?)。(日本語化されません)
  • QR コード
  • 「アイソメトリックグリッド」
  • ビットマップの「切り落とし」
  • テキストの「抽出」: ドキュメント内の text 要素を選択順に出力します。
  • テキストの「マージ」
  • 「HSL 調整」
  • 「フォントの置換」
  • 「N-up レイアウト」
  • 「ボロノイ図」: 選択オブジェクトの重心を基準に、ボロノイ図およびドロネー三角形分割を作成します。
  • 「グループに属性を付加」
  • 「タイポグラフィ」エクステンションメニュー

強化されたもの

  • 「パスの番号付け」: 開始ドット番号および 2 つのノード間のステップ数を指定できるようになりました。
  • 「マーカーの色をストロークに合わせる」エクステンション: マーカーはオブジェクトからフィル、ストローク、およびアルファチャンネルを継承するか、または色のカスタム指定が行えるようになり、名称も単に「マーカーの色」になりました。
  • エクステンションの数値パラメーターにオプションスライダーが追加されました (full and minimal modes(?))。
  • エクステンションのパラメーター値(属性は除く)がローカライズ可能になりました。
  • 「レンダリング」メニューにおいて、バーコード、グリッド、およびレイアウトエクステンションがサブメニューにまとめられました。

SVG サポート

  • clip-rule プロパティをサポートしました。現時点で XML エディター以外の設定 UI はまだ実装されていません。
  • color-interpolation-filters プロパティをサポートしました。これで Inkscape フィルター以外の色補間における "linearRGB" 指定が正しく描画されるようになります。このプロパティを設定する UI はまだ実装されていません。Inkscape 内部で作成されたフィルターは、デフォルトでは引き続き "sRGB" 色補間が使用されます。

スナップ

  • スナップの設定とスナップコントロールバーは GUI とともに基本的なコードから書きなおされました。これによりスナップの設定はわかりやすくなり、メンテナンスやバグの発見と修正が容易になりました。
  • Inkscape は、ペンツールでパスを作成する時、ノードをドラッグする時、あるいはガイドを操作する時、パスの垂直および接線方向にもスナップするようになりました。(ルーラーからドラッグして) 新たに作成されたガイドは、スナップされる曲線の垂直または接線方向にスナップされます。ドキュメントのプロパティダイアログ (のスナップタブ) に 2 つのチェックボックスが追加されました。なお、オブジェクトの変形または選択時、選択ツールでは垂直および接線方向にはスナップされません。
  • パスおよびガイドの交点にもスナップされるようになりました。
  • ノードツールにおいて、複数ノードの選択範囲の変形時のスナップも完全に実装されました。
  • テキストのアンカーおよびベースラインへのスナップが正しく行われるようになりました。
  • If one has chosen for only snapping the snap source closest to the mouse pointer, then the tab key can be used to cycle to the next closest snap source

重要なバグの修正

最後のバグフィックスリリース (0.48.4) 以降の重要なバグが修正されました:

  • JPEG 画像を埋め込みあるいはエクスポートした時に再圧縮 (劣化) されることがなくなりました。[1]
  • 画像への相対パスを絶対パスとして保存することはなくなりました (0.47 でのレグレッション)。
  • レンダリングに関する多くの問題が修正されました。
  • 変形されたオブジェクトのストロークのレンダリングが SVG 仕様に準拠するようになりました。
  • 選択ツールの数値入力ボックスに入力された値 (X/Y/高さ/幅) がより正確に適用されるようになりました。

既知の問題

  • Windows の場合、デスクトップの色深度 (画面の色) を16ビットにしていると、Inkscape のメモリ使用量が激増し、不安定になります。32ビットにしてください。
  • 新しいレンダラーで使用されている Cairo ライブラリはダウンスケーリングを実装していないため、大きなビットマップのエクスポート時のピクセル化で問題が生じます ([2])。

過去のリリース