Difference between revisions of "Release notes/0.91/de"

From Inkscape Wiki
Jump to navigation Jump to search
Line 1: Line 1:
 
{{Other languages|en=Release_notes/0.49}}
 
{{Other languages|en=Release_notes/0.49}}
  
==Inkscape 0.49==
+
==Inkscape 0.91==
  
'''(not released yet - [[AnnouncePlanning049]])'''
+
'''(not released yet - [[AnnouncePlanning091]])'''
  
 
==Release highlights==
 
==Release highlights==

Revision as of 00:09, 20 December 2013

Other languages: العربية Català Česky Deutsch English Español Français Italiano 日本語 한국어 Português Português do Brasil Русский Slovenčina 中文

Inkscape 0.91

(not released yet - AnnouncePlanning091)

Release highlights

Released on d month year.

  • Cairo-Rendering für Anzeige und PNG-Export
  • OpenMP-Multithreading für alle Filter

Rendering and Performance

Inkscape 0.49 verwendet einen neuen Renderer basierend auf der Cairo library. Dieser entstand wärend des Summer of Code 2010 and 2011 Projektes von Google.

  • Performanz-verbesserung. Der neue Renderer ist bei den meisten Bildern signifikant schneller. Renderings der komplexesten Objekte werden automatisch zwischengespeichert, damit die Benutzeroberfläche beim Bearbeiten schneller reagiert.
  • OpenMP-Multithreading für Filter. Filter nutzen alle möglichen Prozessorkerne für die Berechnung eines Bildes aus. Das Ergebnis ist eine starke Beschleunigung des Bildaufbaues bei Multi-Core-System. Bemerkbar macht sich dies besonders bei der Bearbeitung von Bildern die große gefilterte Objekte enthalten.
  • Markante Senkung des Arbeitsspeicherverbrauchs. Inkscape öffnet jetzt komplexe Bilder mit weniger Arbeitsspeicherplatz. In einigen Fällen werden biszu 75% Arbeitsspeicher-Kapazität gegenüber Inkscape 0.48. eingespart, dadurch können nun größere Dateien geöffnet werden.
  • Verbesserung der Antwortgeschwindigkeit. Das Randering des SVG-Bildes wird nun zwischengespeichert. Dies führt zu einer enormen Verbesserung der Antwortgeschwindigkeit bei hervorgehobenen Pfaden, Objekt aus- und abwahl, und Pfadbearbeitung im "delayed update mode"
  • Rendering-Bugfixes. Viele der Randering-Fehler in unserem Bug-Tracking-Systemen sind nicht länger Existent in Inkscape 0.49. Folgende Dinge werden nun korrekt angezeigt:
    • Musterfüllungen (keine Abstände mehr bei Übergängen ungeachtet der Transformation)
    • Striche von transformierten Objekten in Mustern
    • Muster, welche welche beschnittene Objekte beinhalten
    • Eingebettete Clipping-Pfade
    • Maskierte und beschnittene Objekte mit großen Masken/ Clipping-Pfade im "Outline View"
    • Pfade mit weiten Strichen und großen Abständen
    • Fonts


Graustufen-Anzeige-Modus

Ein Graustufen-Anzeige-Modus wurde hinzugefügt, dieser zeigt eine Vorschau auf das Bild in Graustufen. Mit Shift+numpad5 kann man zwischen Farb- und Graustufen-Anzeige-Modus hin und her wechseln.

Werkzeuge

Knotenwerkzeug

Die Knotenwerkzeug-Menüleiste enthält nun eine Schaltfläche zum Hinzufügen neuer Knoten auf die Extremas des ausgewählten Pfadelements. Klicken Sie auf den Pfeil neben der "Knoten hinzufügen"-Schaltfläche.

Messwerkzeug

Neu.

Textwerkzeug

  • Textgrößen Standardeinheit ist nun points (pt) und konfigurierbare Einheiten sind: px,pt,pc,mm,cm,in,em
  • Die Text-Menüleiste zeigt eine Liste von allen Font-Style-Varianten für den entsprechenden Font
  • Dateien mit Texten in der Einheit em werden nun korrekt gelesen.
  • Es gibt einen Warndialog, wenn ein Font verändert wird.

Farbverläufe

  • Farbverlaufs-Menüleiste wurde um die Auswahl und Bearbeitung von Verlauf-Stops, -Invertierungen, -Wiederholungen und -Verlinkungen erweitert.
  • Leinwand-Verlaufs-Bearbeitung repariert - bei Doppelklick wird ein Verlaufs-Stop erschaffen und der korrekte Fokus wird beim selektieren ausgewählt
  • Farbverläufe können nach Farbe, Namen, und Benutzung in "Füllung und Kontur" sortiert werden.
  • Farbverläufe können in "Füllung und Kontur" umbenannt werden

Dialogs, etc.

Align and distribute

  • New "Exchange position of selected objects" feature. It adds three buttons in the Align and Distribute dialog (rearrange group) that exchange the positions of the selected objects: 1. according to the selection order, 2. according to the Z-order, and 3. clockwise.
  • Keyboard shortcuts (Ctrl+Alt+Keypad numbers) for align operations

Find/Select

  • It is now easier to select items which are not at the top of the Z-order: use Alt+mouse wheel scroll to cycle through all items that are stacked on top of each other at the location of the mouse pointer (use Shift+Alt+mouse wheel scroll to add to the existing selection). At present, groups are not honoured, i.e., only individual items within groups are considered.
  • New Find/Replace dialog can operate on text or any attribute
  • "Select Same" by Color/Style/Type added to main and context menu

Layers

  • Drag and drop to reorder layers and create sublayers
  • Show All / Hide All layers options in context menu

Symbols

Inkscape has a new Symbols dialog. The dialog displays symbols from a symbol library. Inkscape 0.49 includes two example libraries, one for logic symbols and another for AIGA/DOT transportation symbols. The dialog will also create a pseudo-library of all existing symbols in the current Inkscape drawing. (A symbol is defined by an SVG <symbol> element.) Symbols can be dragged from the dialog onto the Inkscape canvas.

Any document with symbols can serve as a source for a symbol library. Simply copy it to the symbols directory in your configuration directory (typically share/inkscape). If proper care is taken, symbols can be provided with default fill and stroke colors that later can be overridden by the user.

Visio Stencil files (.vss) can also be used by dropping them in the same "symbols" directory. Results may not be as satisfactory as using SVG symbol libraries.

See the Symbols Dialog Wiki page for more details.

Transform

  • Rotation of objects clockwise or counterclockwise

Markers

  • Markers now take objects color

Trace Bitmap

  • Trace bitmap preview updates live and is resizeable

Live Path Effects

An object's Live Path Effects are now forked upon object duplication.

PowerStroke

Here a list of the current state. Note that this is very much work in progress and anything can change. I think this is the most efficient place of keeping track how the powerstroke LPE works.

  • stroke knots are purple diamonds
  • when first applied, 3 stroke knots are added one at start, one at end, one somewhere in the middle along the path.
  • adding nodes: Ctrl+click purple knot
  • deleting nodes: Ctrl+Alt+click purple knot
  • "sort points" reorders the stroke knots according to where they lie along the path (where they are closest to the path), instead of keeping them in original order.
  • start and end caps can be specified. The SVG cap types are available, as well as an extra type, "Zero width", that is identical to adding a width control knot at the start/end of the path with zero width.
  • join type can be specified. In addition to the SVG join types, there are two new types:
    • Extrapolated: this extrapolates the contour of the stroked path to obtain a more natural looking miter join.
    • Extrapolated arc: Mathematical explanation.
    • Spiro: rounds the join using a spiro curve (the rounded type rounds the curve using an elliptical arc).

example screenshot

Clone original

The Clone original LPE ignores the path data of the path it has been applied to; instead, it copies the original-d path data, i.e. the path data before LPE calculation, from the path linked to by the Linked path parameter.

The Clone original LPE is made to be used in conjunction with powerstroke. Powerstroke creates a path with a variable stroke, but this path can then not be filled (because the fill is used as the stroke). To fill a powerstroked path, one must create a second path (dummy path), apply the Clone original LPE and link it to the powerstroked path. Because this second path clones the original path data before the Powerstroke LPE, it can be used to fill the powerstroked path. To quickly create a dummy path and apply this effect, one can select the path to 'clone' and click the menu item Edit > Clone > Clone original path (LPE).

Like for normal clones, pressing Shift+D, when the selected path has the Clone original LPE applied, selects the path referred to by the LPE.

Another very useful ability of the Clone original LPE is to create a clone with a different style than its referred path. To facilitate this, the LPE dialog will add the Clone original LPE when a clone is selected and the "+" button is pressed.

Filters

The new Custom predefined filters allow users to create predefined filters with custom parameters. See SpecCustomPredefinedFilters.

Import/Export

  • New Flash XML Graphics (FXG) export format.
  • New Synfig Animation Studio (SIF) export format.
  • New Visio (VSD) import format.
  • XAML export improvements.
  • Compressed SVG and media export extension improvements. New options: set an image directory in the zip file, and add a text file that lists the fonts used in the SVG document.
  • New preference to allow users to always link, embed or ask when importing bitmaps.
  • New preferences that allow the checking of SVG on input and/or export for invalid or not useful elements, attributes, and properties. Options control whether such items generate warnings (when Inkscape is run from the command line) or in removing such items.
  • The --export-text-to-path option now works with Plain SVG export.

Gimp XCF improvements

  • The "Save Background" option allows users to choose if the page background is saved with each Gimp layer.
  • The exported layers now use the label attribute or, if not set, the id attribute.
  • New help tab.
  • Some bugs and warnings fixed.

PDF

  • "Bleed/margin" : Added an option to specify an extra margin by which the bounding box to be exported is expanded. This may be helpful to export a PDF with a small white margin around the drawing, or for exporting a bleed region a few mm outside the area of the page.

PDF/EPS/PS + LaTeX

  • Added the possibility of scaling the image. The 'calc' package must be included in the preamble. Then the image can be scaled by defining '\svgscale' instead of '\svgwidth'.
  • The font shape is now also exported. '\textit{}' for italic text, '\textbf{}' for bold text, and '\textsl{}' (slanted) for oblique text. It is important to note that Arial has an oblique font shape and not italic, so the result in LaTeX will be slanted instead of italic. It is better to use another font in Inkscape when you want true italics.

Extensions

New

  • The new guillotine extension is used for exporting png slices from a drawing. The slice rectangles are defined by adding horizontal and vertical guides within the canvas boundary, the canvas boundary serves as the outside of the sliced area.
  • The new G-code tools extension converts paths to G-code (using circular interpolation), makes offset paths and engraves sharp corners using cone cutters.
  • New QR code generator.
  • New isometric grid generator.
  • New bitmap crop extension.
  • New "Extract text" extension outputs the text elements of the document in a chosen order.
  • New HSL adjust extension.
  • New Replace font extension.
  • New N-Up layout extension.
  • New Voronoï diagram extension (creates Voronoï diagrams and Delaunay triangulations based on the selected objects' barycenter).
  • New Interpolate Attribute in a group extension.
  • New Typography extensions menu.

Improvements

  • Number nodes. New parameters allowing users to choose the starting dot number and the numbering step between two nodes.
  • Color Markers to Match Stroke extension improvements. The markers can now inherit the fill and stroke colors and alpha channels from the object, or be customized with color selectors in a separate tab.
  • Optional sliders added on float and int extension parameters (full and minimal modes).
  • Extension parameters values (except attributes!) can now be contextualized for translation (with msgctxt).
  • New sub-menus in the Render menu, grouping the bar-codes, grids and layout extensions.

User interface

General

  • Canvas background color can be set without exporting it (background transparency is only used for export but not the canvas).
  • Guides visibility can be toggled by clicking the ruler

Menu/Access

  • New keyboard shortcut editor
  • The interface elements are accessible through the keyboard with ALT+key in many more dialogs.
  • "Text and Font", "Fill and Stroke", and "Check Spelling" dialogs are added to the text object context menu (right click).
  • Menu items renamed - Edit->Preferences, Edit->Input Devices, File->Cleanup Document
  • Checkboxes to indicated status of View->Grid/Guides/Snap/Color Management
  • Group/Ungroup from the context menu

Dialogs

  • Dialog status and position is remembered between sessions
  • Most dialogs now dockable (including "Object properties", "Object attributes", "Text and Font", "Check spelling", "Export PNG image", "XML editor", "Find/Replace", and "Tiled clones")
  • New preference to allow Windows users to choose between native and Gtk open/save dialog
  • Preferences dialog cleanup
  • Document Metadata dialog merged into Document Properties

Simple calculations in spinboxes

In most spinboxes (a spinbox is an entry field with up and down "spinbuttons" next to it) you can now write simple calculations. For example: "2 * 3", "50 + 100", or "((12 + 34) * (5 + 5) - 2) / 2". Moreover, you can use units in entering values, like "2 + 2 cm". The result will be converted to the selected unit for the particular entry.

Configurable Control Handles

New preferences have been added to allow for the size of the on-canvas controls to be increased or decreased. The "Input Devices" section has been updated to control this.

Translations

  • The Keyboard and mouse reference (inkscape-docs project) and color palettes' labels are now translatable.
  • New UI translation in Latvian.
  • New tutorial translations in Galician and Greek.
  • New man pages in Chinese (zh_TW) Greek (el), Japanese (ja) and Slovak (sk), and updated French translation. [Galician (gl) and Polish (pl) in progress]
  • Man pages now use PO files for translation (inkscape-docs project).
  • The tutorial generation system now fully supports RTL languages.

SVG Support

  • The clip-rule property is now supported. No UI to set it exists at the moment, other than the XML editor.
  • The color-interpolation-filters property is now supported meaning that non-Inkscape filters that specify "linearRGB" color interpolation will render properly. No UI is yet available to set the property. Filters created inside Inkscape will still use "sRGB" color interpolation by default.

Snapping

  • The snapping preferences and the snap toolbar have been reworked, both in the underlying code as well as in the GUI. This should make the snapping preferences easier to understand, easier to maintain, and make it easier to find and fix any remaining snapping bugs
  • Inkscape now also snaps perpendicularly and tangentialy to paths, when creating paths in the pen tool, when dragging nodes, or when manipulating guides. Newly created guides (dragged off the ruler) will snap perpendicularly or tangentialy to any curve that is being snapped to. Two checkboxes have been added to the document properties dialog (on the snapping tab). Please note that snapping perpendicularly or tangetialy will not work in the selector tool when transforming an object or a selection of objects.
  • Intersections of paths and guides can now be snapped to too
  • Snapping has been implemented fully for transforming selections of multiple nodes in the node tool
  • Snapping to text anchors and baselines has been implemented properly
  • If one has chosen for only snapping the snap source closest to the mouse pointer, then the tab key can be used to cycle to the next closest snap source

Notable bug fixes

Notable bug fixes since last bug fix release (0.48.4):

  • Relative image paths are no longer stored as absolute (regression introduced with 0.47).
  • Many rendering glitches were fixed.
  • The rendering of the stroke on transformed objects now matches the SVG specification.
  • Values entered in the numeric input boxes for the selector tool (X/Y/width/height) are much more accurately applied.

Known issues

  • The Cairo library used in the new renderer does not implement downscaling, which causes large bitmaps to be pixelated on export. [1]

Previous releases