Difference between revisions of "Release notes/0.48/fr"

From Inkscape Wiki
Jump to navigation Jump to search
(Translated half of the notes)
 
(Some translation)
Line 3: Line 3:
 
== Inkscape 0.48 ==
 
== Inkscape 0.48 ==
  
'''[[AnnouncePlanning048|Calendrier des annonces]]'''
+
Sorti le '''23/08/2010'''.
  
 
== Nouveautés en lumière ==
 
== Nouveautés en lumière ==
 
Sorti le '''23 août 2010'''.
 
  
 
La livraison marque le retour vers des cycles de livraison courts afin que les nouvelles technologies souvent développées au cours des projets du Google Summer of Code soient disponibles plus rapidement.
 
La livraison marque le retour vers des cycles de livraison courts afin que les nouvelles technologies souvent développées au cours des projets du Google Summer of Code soient disponibles plus rapidement.
Line 43: Line 41:
 
: Les indications affichées pour les nœuds et les poignées sont plus concises et influencées par les touches modificatrices (Ctrl, Maj et Alt) enfoncées.
 
: Les indications affichées pour les nœuds et les poignées sont plus concises et influencées par les touches modificatrices (Ctrl, Maj et Alt) enfoncées.
  
Pour une comparaison détaillée entre l’ancien outil et le nouveau, consultez l’article sur la [[GSoC2009 réécriture de l’outil Nœuds]].
+
Pour une comparaison détaillée entre l’ancien outil et le nouveau, consultez l’article sur la [[GSoC2009 Node Tool Rewrite|réécriture de l’outil Nœuds]].
  
 
=== Outil Texte ===
 
=== Outil Texte ===
Line 52: Line 50:
 
* « Espacement entre les mots » ;
 
* « Espacement entre les mots » ;
 
* « Crénage horizontal » ;
 
* « Crénage horizontal » ;
* « Décalago vertical » ;
+
* « Décalage vertical » ;
 
* « Rotation des caractères ».
 
* « Rotation des caractères ».
  
Line 91: Line 89:
 
Les images matricielles sont maintenant toujours incorporées lorsque des données en pixels sont collées ou déplacées dans la fenêtre d’Inkscape (par exemple, lors de la copie de parties d’une image à partir de GIMP). Il n’y a plus de fichiers avec des noms automatiquement générés comme « inkscape_pasted_image_… » créés dans le répertoire du document. Lors de l’import ou de l’ouverture d’images matricielles, une boîte de dialogue est affichée et demande si vous souhaitez lier l’image ou l’incorporer.
 
Les images matricielles sont maintenant toujours incorporées lorsque des données en pixels sont collées ou déplacées dans la fenêtre d’Inkscape (par exemple, lors de la copie de parties d’une image à partir de GIMP). Il n’y a plus de fichiers avec des noms automatiquement générés comme « inkscape_pasted_image_… » créés dans le répertoire du document. Lors de l’import ou de l’ouverture d’images matricielles, une boîte de dialogue est affichée et demande si vous souhaitez lier l’image ou l’incorporer.
  
=== Nouvel export en LaTex pour PDF/EPS/PS ===
+
=== Nouvel export en LaTeX pour PDF/EPS/PS ===
  
 
De la même manière qu’avec la sortie du programme <code>epslatex</code> de GNUPlot et qu’avec la sortie combinée PDF/LaTeX d’Xfig, Inkscape peut exporter des images en PDF avec un fichier LaTeX l’accompagnant, qui place le texte par-dessus le PDF lorsque transmis à LaTeX. Le texte de l’image est composé par LaTeX, donc les expressions mathématiques par exemple sont rendues correctement, et tout le texte utilisera la police et le style du document LaTeX (même après avoir changé la police du document après coup).
 
De la même manière qu’avec la sortie du programme <code>epslatex</code> de GNUPlot et qu’avec la sortie combinée PDF/LaTeX d’Xfig, Inkscape peut exporter des images en PDF avec un fichier LaTeX l’accompagnant, qui place le texte par-dessus le PDF lorsque transmis à LaTeX. Le texte de l’image est composé par LaTeX, donc les expressions mathématiques par exemple sont rendues correctement, et tout le texte utilisera la police et le style du document LaTeX (même après avoir changé la police du document après coup).
Line 119: Line 117:
 
L’ancestral [https://bugs.launchpad.net/inkscape/+bug/168275 bogue 168275] a enfin été corrigé. Les documents avec une hauteur ou une largeur non entière sont maintenant correctement exportés en PDF, EPS et PS.
 
L’ancestral [https://bugs.launchpad.net/inkscape/+bug/168275 bogue 168275] a enfin été corrigé. Les documents avec une hauteur ou une largeur non entière sont maintenant correctement exportés en PDF, EPS et PS.
  
==Extensions==
+
== Extensions ==
===New and improved extensions===
 
  
* The new '''Generate from Path > Voronoi Pattern''' extension creates a random pattern of Voronoi cells. The pattern will be accessible from the Fill and Stroke dialog. The pattern can be made to be smooth at the edges by choosing a positive border, or sparse at the edges by using a negative border.
+
* La nouvelle extension '''Générer à partir du chemin > Motif de Voronoï''' crée un motif aléatoire de cellules de Voronoï. Le motif est accessible depuis le panneau Fond et contour. Il peut être lissé sur les bords par la sélection d’une bordure positive, ou creux sur les bords si une bordure négative est choisie.
* The new '''Render > Wireframe Sphere''' extension draws the globe as a collection of ellipses representing a sphere's latitude and longitude lines. The number of lines is adjustable, as well as the tilt and rotation. There is an option to hide the lines at the back of the sphere.
+
* La nouvelle extension '''Rendu > Sphère fil de fer''' dessine un globe sous la forme d’une collection d’ellipses représentant les lignes de latitude et de longitude. Le nombre de lignes est ajustable, ainsi que l’inclinaison et l’angle de rotation. Une option permet de cacher les lignes au dos de la sphère.
* The new '''Render > Barcode - Datamatrix''' extension renders a DataMatrix 2D barcode, as specified in BS ISO/IEC 16022:2006. The number of rows and columns of the DataMatrix is adjustable. If more data is given than can be contained in one DataMatrix, more than one DataMatrix will be produced.
+
* La nouvelle extension '''Rendu > Code-barres — Datamatrix''' produit le code-barre 2D d’une matrice de données, comme spécifié dans la norme BS ISO/IEC 16022:2006. Le nombre de lignes et de colonnes de la matrice de données est ajustable. Si les données fournies sont trop importantes pour être contenues dans une seule matrice de données, plus d’une matrice sera créée.
* The new '''Modify Path > Pixelsnap''' extension aligns rectangles and paths to pixel boundaries, to create sharp web and digital graphics.
+
* La nouvelle extension '''Modifier le chemin > Aligner au pixel''' aligne les rectangles et les chemins à des frontières de pixels, pour produire des graphismes web et numériques précis.
* The new '''Color > Black and White''' extension turns the selection colors into black and white.
+
* La nouvelle extension '''Couleur > Noir et blanc''' change les couleurs de la sélection en noir et blanc.
* The new '''Text > Split Text''' extension splits texts into different lines, words or letters.
+
* La nouvelle extension '''Texte > Diviser du texte''' divise des textes en lignes, mots ou lettres séparés.
* The new '''JessyInk''' extension for creating presentations viewable in browsers, See https://launchpad.net/jessyink.
+
* La nouvelle extension '''JessyInk''' crée des présentations faites pour être visualisées dans les navigateurs — voir [https://launchpad.net/jessyink la page du projet].
* The new '''Web > Slicer''' extensions to slice web layouts into multiple images and help the HTML+CSS creation.
+
* Les nouvelles extensions '''Web > Découpe''' découpe des mises en page web en plusieurs images et aide à la production des codes HTML et CSS.
* '''Images > Extract Image''': all relative paths (or filenames without path) are now relative to the user's home directory.
+
* '''Images > Extraire une image''' : tous les chemins relatifs (ou les noms de fichier sans chemin) sont maintenant relatifs au dossier personnel de l’utilisateur.
* '''Visualize Path > Measure Path''': new option to calculate area.
+
* '''Visualiser le chemin > Mesurer le chemin''' : nouvelle option pour calculer la surface.
  
==SVG Support==
+
== Prise en charge du SVG ==
  
The baseline-shift attribute is supported! The Text toolbar uses the "super" and "sub" values for implementing superscripts and subscripts. At the moment there is no other GUI access to the attribute.
+
L’attribut <code>baseline-shift</code> (mouvement de la ligne de base) est maintenant implanté ! La barre de contrôle de l’outil Texte utilise les valeurs <code>super</code> et <code>sub</code> pour faire fonctionner l’exposant et l’indice. C’est pour le moment la seule interaction (outre l’éditeur XML) que l’interface graphique offre avec l’attribut.
  
==Other features==
+
== Autres fonctionnalités ==
  
 
* Arch paper sizes are added in the Document Properties dialog
 
* Arch paper sizes are added in the Document Properties dialog
Line 161: Line 158:
 
Additionally hardware setup itself has been separated from general settings to allow for easier dynamic switching of settings appropriate to the task at hand.
 
Additionally hardware setup itself has been separated from general settings to allow for easier dynamic switching of settings appropriate to the task at hand.
  
==User interface==
+
== Interface utilisateur ==
  
 
===Adaptive UI===
 
===Adaptive UI===
Line 210: Line 207:
 
New Farsi (fa) and Telugu (te_IN) translations (in progress).
 
New Farsi (fa) and Telugu (te_IN) translations (in progress).
  
==Tutorials==
+
== Didacticiels ==
  
* SVG files are now optimized with Scour (filesize reduced by 40%).
+
* Les fichiers SVG sont maintenant optimisés avec Scour (taille de fichier réduite de 40 %).
* Bitstream Vera fonts replaced with generic sans and serif fonts (solves many font substitution issues).
+
* Les polices Bitstream Vera ont été remplacées par les polices Sans et Serif par défaut (ce qui résout de nombreux problèmes de substitution de police).
* New Interpolate tutorial (Help > Tutorials > Inkscape: Interpolate).
+
* Nouveau didacticiel sur l’interpolation (Aide > Didacticiels > Inkscape : Interpolation).
* New translations in Belarussian, Dutch, Farsi and Indonesian.
+
* Nouvelles traductions en biélorusse, en néerlandais, en farsi et en indonésien.
  
 
==Windows port improvements==
 
==Windows port improvements==
Line 239: Line 236:
 
Inkscape will now work correctly regardless of installation path. Previously, it was unusable when installed into a directory that contains characters not representable in the system codepage (icons were not shown in the UI, and no language files were found).
 
Inkscape will now work correctly regardless of installation path. Previously, it was unusable when installed into a directory that contains characters not representable in the system codepage (icons were not shown in the UI, and no language files were found).
  
==Notable bug fixes==
+
== Correctifs notables ==
  
* The 3D tool no longer inserts an inkscape:perspective element into SVG when it is not needed (i.e. when the document has no 3D box objects).
+
* L’outil Boîte 3D n’insère plus d’élément <code>inkscape:perspective</code> dans le SVG lorsque ce n’est pas nécessaire (c’est-à-dire lorsque le document ne comporte pas de boîtes 3D).
* Wrong clippaths and masks with cyclic recursion (i.e. clippaths or masks that refer to themselves via other clippaths or masks) no longer crash Inkscape.
+
* Les chemins de découpe et les masques comportant une récursion cyclique (c’est-à-dire qu’ils font appel à eux-mêmes via d’autres chemins de découpe ou masques, ce qui est techniquement irréalisable) ne font plus planter Inkscape.
* Default unit setting for the XY grid is now respected when creating a new grid.
+
* Le réglage de l’unité par défaut pour la grille XY est maintenant respecté lors de la création d’une nouvelle grille.
* Pasting Live Path Effect stacks now works. It adds the stack of the copied object to the end of the LPE stack (if present) of the object it is pasted to.
+
* Le collage de piles d’Effets de chemin interactifs fonctionne à présent. Il ajoute la pile de l’objet copié à la fin de la pile d’ECI (si présente) de l’objet sur lequel il est effectué.
* The accuracy of the bounding box calculation has been significantly improved when converting objects to patterns or markers. This should make it much easier to create patterns where the tiles should 'connect' to each other, e.g. a tile with a plus sign to create a hatched pattern.
+
* La précision du calcul des boîtes englobantes a été significativement amélioré lors de la conversion d’objets en motifs et en marqueurs. Cela devrait faciliter la création de motifs sur lesquels les carreaux doivent se « connecter » les uns aux autres, par ex. un carreau avec un signe plus pour créer un motif hachuré.
* The default font has been changed to ''Sans'', eliminating problems when the former default font, ''Bitstream Vera Sans'', is not available. (''Sans'' is a Pango pseudo-font.)
+
* La police de caractères par défaut est maintenant ''Sans'', ce qui élimine des problèmes lorsque la police par défaut précédente, ''Bitstream Vera Sans'', n’est pas disponible. ''Sans'' est en fait une pseudo-police Pango, s’associant à une police sans sérif installée.
* The Text toolbar bold and italic/oblique buttons are more likely to work as expected.
+
* Le comportement des boutons pour le gras et l’italique/oblique sur la barre de contrôle de l’outil Texte est maintenant plus intuitif.
* Bitmaps with transparency are now shown (and exported) correctly.
+
* Les pixelimages avec de la transparence sont maintenant rendues (à l’affichage comme à l’export) correctement.
* The emergency save function no longer mangles the file names (which used to make it fail quite often).
+
* La fonctionnalité de sauvegarde en urgence n’écorche plus le nom du fichier (ce qui la faisait régulièrement échouer).
  
 
== Ploblèmes connus ==
 
== Ploblèmes connus ==

Revision as of 17:10, 13 August 2017

Other languages: العربية Català Česky Deutsch English Español Français Italiano 日本語 한국어 Português Português do Brasil Русский Slovenčina 中文

Inkscape 0.48

Sorti le 23/08/2010.

Nouveautés en lumière

La livraison marque le retour vers des cycles de livraison courts afin que les nouvelles technologies souvent développées au cours des projets du Google Summer of Code soient disponibles plus rapidement.

Cette nouvelle version offre en particulier :

  • la modification multi-chemins ;
  • un outil texte amélioré : indice, exposant, champ numérique pour le crénage et l’interlettrage, et plus ;
  • l’outil Aérographe ;
  • l’export en LaTeX avec PDF/PS/EPS ;
  • l’extension JessyInk pour créer des présentations ;
  • un grand nombre de correctifs.

Outils

Outil Nœuds

Au cours du Google Summer of Code 2009, l’outil Nœuds a subi une profonde réécriture. En plus d’un code plus facile à maintenir, il propose de nouvelles fonctionnalités.

Modification multi-chemins
Plusieurs chemins peuvent être sélectionnés pour être modifiés en même temps avec l’outil Nœuds.
Modification de découpe et de masque améliorée
Le chemin utilisé comme découpe ou masque d’un objet peut être modifié en même temps que l’objet. Les boutons de modification des découpes et des masques avec l’outil Nœuds sont maintenant à bascule, au lieu d’être des boutons de changement de mode. Si l’objet est transformé après l’application d’une découpe, le chemin utilisé pour la découpe n’est plus décalé lorsque modifié avec l’outil Nœuds. Si le chemin est un groupe, tous les chemins dans le groupe peuvent être modifiés simultanément.
Jointure de nœuds améliorée
Il est maintenant possible de fusionner des nœuds provenant de différents chemins. Plus de deux nœuds terminaux peuvent être joints d’un coup — les distances entre les nœuds sont utilisées pour déterminer les nœuds à fusionner, les paires les plus proches étant fusionnées en premier. Lorsque rien ne peut être fusionné (il y a moins de deux nœuds terminaux dans la sélection), chaque tronçon de nœuds sélectionné est fusionné en un seul nœud.
Jointure de segments améliorée
Il est maintenant possible de créer un segment entre des nœuds terminaux de différents chemins. Plus d’un segment peut être créé en une fois — les distances entre les nœuds sont utilisées pour déterminer quels nœuds sont fusionnés en segment, les paires les plus proches étant fusionnées en premier. Lorsque rien ne peut être fusionné (il y a moins de deux nœuds terminaux dans la sélection), les nœuds intermédiaires de chaque tronçon de nœuds sélectionnés sont supprimés, de sorte qu’il ne reste qu’un unique segment.
Transformations de nœuds
Il est maintenant possible de transformer les nœuds en utilisant la souris et des poignées de transformation similaires à celles de l’outil Sélecteur. Ces poignées peuvent être activés et désactivés à l’aide du bouton de la barre de contrôle. Lorsque les poignées sont visibles, cliquer sur un nœud sélectionné alterne entre les modes redimensionnement et rotation, au lieu de sélectionner seulement ce nœud. Le raccourci clavier Maj+H peut également être utilisé pour changer de mode. Toutes les autres opérations fonctionnent normalement lorsque les poignées de transformation sont affichées.
Outils pour le sens des chemins
De petites flèches peuvent être affichées au milieu de chaque segment, pour indiquer le sens du chemin. Cela peut servir lors de la préparation d’un chemin qui doit guider un texte, lors de la disposition de marqueurs, et lors du débogage d’Inkscape ou d’extensions. La commande « Inverser » (Maj+R) inverse le sens des sous-chemins dont les nœuds sont sélectionnés, ou de tous les sous-chemins si la sélection est vide. Pour activer, sélectionnez « Toujours afficher le contour » et « Afficher la direction des chemins sur le contour » dans la section Nœuds de la boîte de dialogue des préférences d’Inkscape.
Mise à jour de chemin personnalisable
Deux nouvelles préférences vous permettent d’indiquer lorsque le chemin et son contour doivent être mis à jour. Désactiver la mise à jour en temps réel améliorera les performances pour les dessins complexes.
Indications améliorées
Les indications affichées pour les nœuds et les poignées sont plus concises et influencées par les touches modificatrices (Ctrl, Maj et Alt) enfoncées.

Pour une comparaison détaillée entre l’ancien outil et le nouveau, consultez l’article sur la réécriture de l’outil Nœuds.

Outil Texte

La barre de contrôle de l’outil Texte a été refondue avec de nombreuses corrections de bogues et améliorations. Un grand nombre de paramètres de disposition de texte sont maintenant directement accessibles :

  • « Espacement entre les lignes de base » : distance entre les lignes de base de lignes adjacentes ;
  • « Espacement entre les lettres » ;
  • « Espacement entre les mots » ;
  • « Crénage horizontal » ;
  • « Décalage vertical » ;
  • « Rotation des caractères ».

De plus, le support de l’exposant et de l’indice a été ajouté.

Ce travail a été en parti sponsorisé par des utilisateurs d’Inkscape via LinuxFund.org.

Outil Aérographe

Un ou plusieurs objets doivent être sélectionnés lorsque vous prenez l’outil Aérographe. Pour pulvériser, cliquez sur le canevas, puis déplacez la souriz ou tournez la molette de la souris.

Trois modes sont disponibles :

  • mode Pulvériser des copies : chaque élément pulvérisé est indépendant des autres ;
  • mode Pulvériser des clones : chaque élément pulvérisé est un clone de l’élément sélectionné (changer les propriétés de l’élément sélectionné affecte donc les clones) ;
  • mode Pulvériser un unique chemin : la pulvérisation s’assemble en un unique chemin (pour assurer le fonctionnement, l’élément initial doit éventuellement être converti en chemin).

Options de l’outil Aérographe :

  • Quantité : pulvériser plus ou moins d’éléments ;
  • Rotation : tourner aléatoirement les éléments autour de la valeur de rotation initiale ;
  • Mise à l’échelle : redimensionner aléatoirement les éléments autour de l’échelle initiale ;
  • Dispersion : valeur faible pour placer les éléments sous le pointeur, valeur élevée pour une répartition plus uniforme dans la zone pulvérisée ;
  • Focalisation : les éléments sont pulvérisés sur un cercle, ce paramètre modifie le rayon du cercle (0 par défaut pour pulvériser un point).

Les touches ↑ et ↓ permettent de régler la taille des éléments pulvérisés. Les touches ← et → permettent de définir la largeur du curseur.

L’outil Aérographe s’accorde parfaitement avec les modes Transformation, Duplication et Suppression de l’outil Ajuster.

Outil Connecteur

L’outil Connecteur peut maintenant produire des connecteurs orthogonaux (faits de segments de ligne verticaux et horizontaux, comme dans les diagrammes de circuits). Un bouton supplémentaire sur la barre de contrôle permet de choisir le type de connecteur : « polyligne » ou « orthogonal ».

Par ailleurs, des correctifs de bogues et de plantages ont été apportés au routage des connecteurs.

Importer/Exporter

Import d’images matricielles amélioré

Les images matricielles sont maintenant toujours incorporées lorsque des données en pixels sont collées ou déplacées dans la fenêtre d’Inkscape (par exemple, lors de la copie de parties d’une image à partir de GIMP). Il n’y a plus de fichiers avec des noms automatiquement générés comme « inkscape_pasted_image_… » créés dans le répertoire du document. Lors de l’import ou de l’ouverture d’images matricielles, une boîte de dialogue est affichée et demande si vous souhaitez lier l’image ou l’incorporer.

Nouvel export en LaTeX pour PDF/EPS/PS

De la même manière qu’avec la sortie du programme epslatex de GNUPlot et qu’avec la sortie combinée PDF/LaTeX d’Xfig, Inkscape peut exporter des images en PDF avec un fichier LaTeX l’accompagnant, qui place le texte par-dessus le PDF lorsque transmis à LaTeX. Le texte de l’image est composé par LaTeX, donc les expressions mathématiques par exemple sont rendues correctement, et tout le texte utilisera la police et le style du document LaTeX (même après avoir changé la police du document après coup).

(La description suivante prend l’hypothèse d’une exportation en PDF, mais s’applique de la même façon à l’EPS et au PS.) Deux fichiers seront créés : un fichier PDF contenant tous les graphismes, sans texte ; et un fichier LaTeX avec le même nom (et l’extension « .pdf_tex »), contenant tout le texte, et le code pour inclure le PDF et recouvrir le texte. Pour inclure l’image exportée dans LaTeX, il faut écrire :

 \begin{figure}
   \centering
   \def\svgwidth{\columnwidth} % optionnel, définit la largeur de l’image
   \input{image.pdf_tex}
 \end{figure}

Une description plus complète de l’usage de la nouvelle fonctionnalité (et l’automatisation de l’exportation et l’inclusion de l’image en LaTeX) est donnée dans ce document : svg-inkscape sur CTAN.

Depuis l’interface graphique

Lors de l’exportation en PDF/EPS/PS depuis l’interface graphique d’Inkscape, la boîte de dialogue habituelle s’affiche une fois que le format d’exportation (PDF, EPS ou PS) a été sélectionné. Dans cette boîte de dialogue, vous pouvez trouver l’option PDF/EPS/PS+LaTeX.

Option en ligne de commande

Lors de l’exportation en PDF/EPS/PS depuis la ligne de commande, ajouter --export-latex activera l’exportation du LaTeX. Par exemple :

 inkscape image.svg -z -D --export-pdf=image.pdf --export-latex

Correction de l’exportation en PDF/EPS/PS pour les documents ayant des dimensions non entières

L’ancestral bogue 168275 a enfin été corrigé. Les documents avec une hauteur ou une largeur non entière sont maintenant correctement exportés en PDF, EPS et PS.

Extensions

  • La nouvelle extension Générer à partir du chemin > Motif de Voronoï crée un motif aléatoire de cellules de Voronoï. Le motif est accessible depuis le panneau Fond et contour. Il peut être lissé sur les bords par la sélection d’une bordure positive, ou creux sur les bords si une bordure négative est choisie.
  • La nouvelle extension Rendu > Sphère fil de fer dessine un globe sous la forme d’une collection d’ellipses représentant les lignes de latitude et de longitude. Le nombre de lignes est ajustable, ainsi que l’inclinaison et l’angle de rotation. Une option permet de cacher les lignes au dos de la sphère.
  • La nouvelle extension Rendu > Code-barres — Datamatrix produit le code-barre 2D d’une matrice de données, comme spécifié dans la norme BS ISO/IEC 16022:2006. Le nombre de lignes et de colonnes de la matrice de données est ajustable. Si les données fournies sont trop importantes pour être contenues dans une seule matrice de données, plus d’une matrice sera créée.
  • La nouvelle extension Modifier le chemin > Aligner au pixel aligne les rectangles et les chemins à des frontières de pixels, pour produire des graphismes web et numériques précis.
  • La nouvelle extension Couleur > Noir et blanc change les couleurs de la sélection en noir et blanc.
  • La nouvelle extension Texte > Diviser du texte divise des textes en lignes, mots ou lettres séparés.
  • La nouvelle extension JessyInk crée des présentations faites pour être visualisées dans les navigateurs — voir la page du projet.
  • Les nouvelles extensions Web > Découpe découpe des mises en page web en plusieurs images et aide à la production des codes HTML et CSS.
  • Images > Extraire une image : tous les chemins relatifs (ou les noms de fichier sans chemin) sont maintenant relatifs au dossier personnel de l’utilisateur.
  • Visualiser le chemin > Mesurer le chemin : nouvelle option pour calculer la surface.

Prise en charge du SVG

L’attribut baseline-shift (mouvement de la ligne de base) est maintenant implanté ! La barre de contrôle de l’outil Texte utilise les valeurs super et sub pour faire fonctionner l’exposant et l’indice. C’est pour le moment la seule interaction (outre l’éditeur XML) que l’interface graphique offre avec l’attribut.

Autres fonctionnalités

  • Arch paper sizes are added in the Document Properties dialog
  • Displaying the font samples in the drop-down list of the Text tool is now optional. In Inkscape Preferences, go to Tools, Text, and uncheck "Show font samples in the drop-down list" if you don't want to see the samples. This will speed up displaying the list the first time you open it
  • Items in the File > Open Recent menu, when mouseovered, show tooltips with the full URI of each file in the list. Also, files that are in the list but are missing or unaccessible are automatically hidden
  • When a flowed text is truncated (i.e. the frame is too small for the entire text), the frame is shown red, and the statusbar hint includes [truncated]. You need to resize the frame to see the truncated end of the text. Analogously, if the path of a text-on-path object is too short to display the entire text, the statusbar will report it as [truncated]
  • Clicking the text alignment buttons (Left, Center, Right) on the Text tool's controls bar now does not let the text jump: it stays within the same bounding box as before, only changing the alignment
  • The position of text's baseline anchor (the small square) is now dependent of the alignment: for left-aligned text it is, as before, at the left end, for centered text in the middle, and for the right-aligned text it is at the right end of the text's first line (this is for horizontal text; for vertical, it is correspondingly at top, middle, or bottom of the first column). This allows snapping, aligning and distributing of text relative the side to which it's aligned
  • Snapping of gradient handles has been improved and now behaves similar to the snapping of all other handles and objects
  • When snapping to a bounding box, that bounding box will be shown for a moment (tied to the snap indicator)
  • If a new object is being created on the canvas with snapping enabled, then a snap indicator will also be shown for the first point
  • There are now options for Margins when resizing a document to a selection or the drawing in Document Properties
  • Preferences have been added to allow automatic grouping when setting a Clippath or Mask
  • Bitmap copies created using the Make a Bitmap Copy command (Alt+B) are now embedded. Previously they were saved in an automatically generated file and linked
  • The file preview size limit (in the File > Open and File > Import dialog box) is now 10 MB (1.3 MB in 0.47)
  • Blur, transformation, and layer visibility and opacity support in XAML export
  • Added preference in Filters section of Preferences for multi-threaded gaussian blur.

Extended input device configuration

The stock Input Devices dialog has been replaced with a completely redone version that provides a more useful representation of settings. It also contains a simple area for testing different inputs of different devices.

Additionally hardware setup itself has been separated from general settings to allow for easier dynamic switching of settings appropriate to the task at hand.

Interface utilisateur

Adaptive UI

Initial implementation of adaptive user interface has been introduced. This has internal work done to collect system and runtime information on the user and allow for decisions on how best to assist the user in working. The visible control is a menu to pick from different arrangements, including one optimized for wide-screen computers such as netbooks. Currently the system will detect the screen layout and set the appropriate default. Other minor internals are also run by this.

Custom Swatches

Custom swatches can be created and used on a per-document basis. An "Auto" color palette will track swatches in the current document and allow them to be set and used. The use is "live" with changes to the swatch being applied automatically to all objects set to it. The swatches can also be gradients and not just simple colors.

This iteration has been implemented via single-stop gradients. This results in fully SVG 1.1 compliant files that remain editable.

CMYK and ICC support

Support for using icc-color has been extended to more areas of the UI, including the use in gradient stops. This helps preserve custom colors, including CMYK.

Icon Dialog

The icon preview dialog has gone through a round of refinement. The newer functionality has been set to the most common defaults, but some behavior can be modified via preference settings.

  • Auto Refresh. The icon preview dialog will now auto-refresh as the document is edited.
  • Holding initial selection. When the "Selection" checkbox is enabled, the currently selected item selected will be remembered and tracked. Inkscape will use this item's bounding box as an area to be included in the Icon Preview dialog. To change the preview to track a new selection, uncheck and recheck the "Selection" checkbox.
  • Layout refinements. The icon previews have been updated, including the addition of visual frames and defaulting to a more compact arrangement.

Preferences

You can change the following attributes in group id="iconpreview" in your preferences.xml file:

  • autoRefresh (default 1) to enable (1) or disable (0) automatic refresh of preview.
  • pack (default 1) to arrange preview thumbnails in a more compact manner (1) to to force the previous vertical stacking (0)
  • selectionHold (default 1) to keep preview locked to the initial selection (1) or switch to each newly selected item (0)
  • showFrames (default 1) to paint outlines around thumbnails (1) or to suppress them (0)

Glyphs Dialog

A basic glyph selection dialog has been added. This allows for viewing which Unicode codepoints are represented in a given font, and to allow individual glyphs to be selected and included. Characters can be selected and inserted via copy and paste or inserted directly using the append button in the dialog. Text will be appended to the currently selected text object on the active canvas.

The range of glyphs/characters being viewed can be filtered by Unicode range and/or language 'script'. When an individual glyph is selected, the dialog status area shows the glyph's Unicode value and script name.

There is a known limitation where the list of glyphs in the dialog are not yet rendered in the selected font, but still in the system font (this mainly is an issue for fonts non-standard characters). When a font with a large character repertoire is selected for viewing, such as a CJK font set to show 'all', the display may pause momentarily as previews are generated.

New cursors in Selector

Selector tool has a new mouse cursor (arrow with an open hand) for when your mouse is over a selectable object, and another (arrow with clinched hand) for when you're dragging an object. This improves precision of selection and UI consistency (previously, the mouse cursor over a selectable object was different across platforms, e.g. hand icon on Linux or four-way arrow on Windows).

Translations

New Farsi (fa) and Telugu (te_IN) translations (in progress).

Didacticiels

  • Les fichiers SVG sont maintenant optimisés avec Scour (taille de fichier réduite de 40 %).
  • Les polices Bitstream Vera ont été remplacées par les polices Sans et Serif par défaut (ce qui résout de nombreux problèmes de substitution de police).
  • Nouveau didacticiel sur l’interpolation (Aide > Didacticiels > Inkscape : Interpolation).
  • Nouvelles traductions en biélorusse, en néerlandais, en farsi et en indonésien.

Windows port improvements

The quality of the Windows port was improved substantially.

Command line interface

Command line functionality on Windows is now on par with Unix.

Single executable

It's no longer needed to compile Inkscape with special flags or use third-party wrapper executables to see the command line output. Just type "inkscape" (without any extension) in the command prompt. This is made possible by a command-line wrapper named inkscape.com.

Relative paths

You can now specify relative paths to files in options like --export-png. Commands like this will now execute correctly:
C:\svg> inkscape tiger.svgz --export-png=tiger.png

Stability improvements

Thanks to library updates, Inkscape should no longer randomly crash when editing documents. Most of them were caused by a GDI resource leak in Pango. It will also no longer crash when trying to import a corrupted image.

Unicode compatibility

Inkscape will now work correctly regardless of installation path. Previously, it was unusable when installed into a directory that contains characters not representable in the system codepage (icons were not shown in the UI, and no language files were found).

Correctifs notables

  • L’outil Boîte 3D n’insère plus d’élément inkscape:perspective dans le SVG lorsque ce n’est pas nécessaire (c’est-à-dire lorsque le document ne comporte pas de boîtes 3D).
  • Les chemins de découpe et les masques comportant une récursion cyclique (c’est-à-dire qu’ils font appel à eux-mêmes via d’autres chemins de découpe ou masques, ce qui est techniquement irréalisable) ne font plus planter Inkscape.
  • Le réglage de l’unité par défaut pour la grille XY est maintenant respecté lors de la création d’une nouvelle grille.
  • Le collage de piles d’Effets de chemin interactifs fonctionne à présent. Il ajoute la pile de l’objet copié à la fin de la pile d’ECI (si présente) de l’objet sur lequel il est effectué.
  • La précision du calcul des boîtes englobantes a été significativement amélioré lors de la conversion d’objets en motifs et en marqueurs. Cela devrait faciliter la création de motifs sur lesquels les carreaux doivent se « connecter » les uns aux autres, par ex. un carreau avec un signe plus pour créer un motif hachuré.
  • La police de caractères par défaut est maintenant Sans, ce qui élimine des problèmes lorsque la police par défaut précédente, Bitstream Vera Sans, n’est pas disponible. Sans est en fait une pseudo-police Pango, s’associant à une police sans sérif installée.
  • Le comportement des boutons pour le gras et l’italique/oblique sur la barre de contrôle de l’outil Texte est maintenant plus intuitif.
  • Les pixelimages avec de la transparence sont maintenant rendues (à l’affichage comme à l’export) correctement.
  • La fonctionnalité de sauvegarde en urgence n’écorche plus le nom du fichier (ce qui la faisait régulièrement échouer).

Ploblèmes connus

Barres d’outils flottantes

Il s’est avéré que les barres d’outils flottantes présentent des problèmes avec certains gestionnaires de fenêtres. En conséquence, le flottement a été désactivé par défaut sous Ms Windows et le gestionnaire de fenêtres KDE par défaut. Le fichier preferences.xml comporte un groupe d’options appelé workarounds avec un paramètre appelé floatallowed, qui définit si le flottement est activé ou non. Mettre la valeur "1" réactivera le flottement sur ces systèmes problématiques. Les valeurs valides sont "0" et "1".

Versions précédentes