Difference between revisions of "Release notes/0.48"

From Inkscape Wiki
Jump to navigation Jump to search
Line 75: Line 75:
  
 
* Snapping of gradient handles has been improved and now behaves similar to the snapping of all other handles and objects
 
* Snapping of gradient handles has been improved and now behaves similar to the snapping of all other handles and objects
 +
 +
* When snapping to a bounding box, that bounding box will be shown for a moment (tied to the snap indicator)
  
 
* There are now options for Margins when resizing a document to a selection or the drawing in Document Properties.
 
* There are now options for Margins when resizing a document to a selection or the drawing in Document Properties.

Revision as of 20:18, 19 January 2010

Inkscape 0.48

(not released yet - AnnouncePlanning048)

Release highlights

(TODO)

Tools

Node Tool

During Google Summer of Code 2009, the node tool underwent an extensive rewrite. Along with more maintainable code, it brings several new features.

  • Multi-path editing - any number of paths can be selected for node editing at once.
  • Improved clippath / mask editing - the clipping path or mask of an object can be edited at the same time as the object. The clip / mask editing buttons in the node tool are now toggle buttons, rather than mode switch buttons. If the object is transformed after applying a clipping path, the clipping path is no longer offset when editing it in the node tool. If the clipping path is a group, all paths in the group can be edited simultaneously.
  • Improved node join - it is now possible to join nodes from different paths. More than two endnodes can be joined at once - the distances between nodes will be used to determine which nodes to join, with closest pairs being joined first. When nothing can be joined (less than 2 endnodes in selecion), each selected stretch of nodes will be joined into one node.
  • Improved segment join - it is now possible to create a segment between endnodes from different paths. More than one segment can be created at once - the distances between nodes will be used to determine which nodes to join with a segment, with closest pairs being joined first. When nothing can be joined (less than 2 endnodes in selecion), each selected stretch of nodes will have its middle nodes removed, leaving only one segment.
  • Node transforms - it is now possible to transform the nodes using the mouse and transformation handles similar to those in the selector tool. They can be turned on and off using the first button in the node toolbar. When the handles are visible, clicking on a selected node will switch between scaling and rotation mode, instead of selecting only that node. You can also use Shift+H to switch the mode. All other operations work normally.
  • Path direction tools - little half-arrows are shown in the middle of each segment, visualizing the direction of the path. This is useful when preparing a guide path for text, setting markers, and debugging extensions and Inkscape itself. The "Reverse" command (Shift+R) reverses the direction of subpaths that have some selected nodes, or all subpaths if the node selection is empty.
  • Improved tips - the tips displayed for nodes and handles are more concise and affected by what modifier keys are pressed.

For a detailed feature comparison between the old and new tool, see GSoC2009 Node Tool Rewrite.

Spray Tool

To use the spray tool, you first need to select one or several items and then click on the Spray icon.

Three modes are available.

  • Spray Copy mode : each sprayed item is independant from the others.
  • Spray Clone mode : each sprayed item is a clone of the selected item. Changing the properties of the original item will affect the clones.
  • Spray Single Path Mode : everything you spray is in a single path. You may need to convert your item into a path to make it work properly.

Spray options

  • Amount : probability of apparition of an item.
  • Scatter : for the gaussian spraying, it sets the width of the gaussian.
  • Focus : it sets the center of the gaussian. More precisely, it is the distance to the center of the cursor.
  • Scale : you can choose to scale your items taller or smaller than the original one. The scale is set between two values (Min and Max).
  • Rotation : you can rotate randomly your items. The rotation angle is set between two values (Min and Max).

You can also spray items by scrolling.

The Spray tool is a perfect match for the transforming, duplicating, and deleting modes of the Tweak tool.


Extensions

New and improved extensions

  • The new Render > Wireframe Sphere extension draws the globe as a collection of ellipses representing a sphere's latitude and longitude lines. The number of lines is adjustable, as well as the tilt and rotation. There is an option to hide the lines at the back of the sphere.
  • The new Render > Barcode - Datamatrix extension renders a DataMatrix 2D barcode, as specified in BS ISO/IEC 16022:2006. The number of rows and columns of the DataMatrix is adjustable. If more data is given than can be contained in one DataMatrix, more than one DataMatrix will be produced.


Other features

  • Arch paper sizes are added in the Document Properties dialog
  • Displaying the font samples in the drop-down list of the Text tool is now optional. In Inkscape Preferences, go to Tools, Text, and uncheck "Show font samples in the drop-down list" if you don't want to see the samples. This will speed up displaying the list the first time you open it.
  • Items in the File > Open Recent menu, when mouseovered, show tooltips with the full URI of each file in the list. Also, files that are in the list but are missing or unaccessible are automatically hidden.
  • When a flowed text is truncated (i.e. the frame is too small for the entire text), the frame is shown red, and the statusbar hint includes [truncated]. You need to resize the frame to see the truncated end of the text. Analogously, if the path of a text-on-path object is too short to display the entire text, the statusbar will report it as [truncated].
  • Clicking the text alignment buttons (Left, Center, Right) on the Text tool's controls bar now does not let the text jump: it stays within the same bounding box as before, only changing the alignment.
  • The position of text's baseline anchor (the small square) is now dependent of the alignment: for left-aligned text it is, as before, at the left end, for centered text in the middle, and for the right-aligned text it is at the right end of the text's first line (this is for horizontal text; for vertical, it is correspondingly at top, middle, or bottom of the first column). This allows snapping, aligning and distributing of text relative the side to which it's aligned.
  • Snapping of gradient handles has been improved and now behaves similar to the snapping of all other handles and objects
  • When snapping to a bounding box, that bounding box will be shown for a moment (tied to the snap indicator)
  • There are now options for Margins when resizing a document to a selection or the drawing in Document Properties.

Extended input device configuration

The stock Input Devices dialog has been replaced with a completely redone version that provides a more useful representation of settings. It also contains a simple area for testing different inputs of different devices.

Additionally hardware setup itself has been separated from general settings to allow for easier dynamic switching of settings appropriate to the task at hand.

User interface

Adaptive UI

(In progress JonCruz)

Notable bug fixes

  • The 3D tool no longer inserts an inkscape:perspective element into SVG when it is not needed (i.e. when the document has no 3D box objects).
  • Wrong clippaths and masks with cyclic recursion (i.e. clippaths or masks that refer to themselves via other clippaths or masks) no longer crash Inkscape.

Known issues

Previous releases