Difference between revisions of "Release notes/0.45"

From Inkscape Wiki
Jump to navigation Jump to search
Line 266: Line 266:
  
 
* Grid and guidelines no longer vanish when changing their color.
 
* Grid and guidelines no longer vanish when changing their color.
 +
 +
* Group transformation is now correctly applied when ungrouping and undo'ing the ungroup.
  
 
= Known problems =
 
= Known problems =

Revision as of 10:50, 8 January 2007

Inkscape 0.45: overview

This release brings the exciting new features developed by the Google Summer of Code 2006 participants, as well as tons of other improvements across the board.

Gaussian blur

Thanks to Google's Summer of Code program, Inkscape now has basic support for SVG filters. The only filter enabled so far is Gaussian blur.

With it, you can softly and naturally blur any Inkscape objects: paths, shapes, groups, text], images. Clones inherit blurring from their original, but they can also be blurred independently from the original (you can create blurred clones with Tile Clones, too). Both the fill and stroke of an object are blurred together, creating semitransparent margins that smoothly blend into the background.

Gaussian blur enables a wide range of photorealistic effects: arbitrarily shaped shades and lights, depth of field, drop shadows, glows, etc. Also, blurred objects can be used as masks for other objects to achieve the "feathered mask" effect.

  • To blur selected objects, open the Fill and Stroke dialog (Ctrl+Shift+F) and use the Blur slider. The blur value is a percentage, with 100% corresponding to a blurring radius of 1/8 of the object's bounding box' perimeter (that is, for a square, a blur of 100% will have the radius equal to half a side).
  • The Tile Clones dialog also supports blurring. On the Blur & opacity tab, you can set the blur percentage per row or per column of your tiling, as well as randomize blurring and make it alternate (all the same options as for Opacity).
  • The quality of on-screen blur display is controlled by the Blur quality option on the new Filters tab of Inkscape Preferences (Ctrl+Shift+P). The available options range from best quality/slowest display to worst quality/fastest display, the default being in the middle of the range. Any setting except the "best quality" may introduce some rendering artifacts, especially when blurring thin strokes; on the other hand, the "best quality" setting may make Inkscape extremely slow at high zooms. These settings only affect the screen display of blurred objects; bitmap export always uses the best quality.

Here are a few tips on using blur:

  • Masks and clipping are applied after blur. That is, if you clip an object and then blur it (or blur it first and then clip - it makes no difference), the clipped edges will remain crisp. Often, this is what you want. If, however, you want to blur the clipped/masked edges too (possibly with a different radius), you can use grouping: group the clipped object with some other object (which you can then delete from the group) and blur the group.
  • A simple drop shadow is now very easy to do: just copy the object, paint the copy black, blur it, shift away a bit and lower it to the bottom. However, such a shadow does not update when you edit the foreground object. If your object is already black (or, more generally, if you want the shadow to be the same color as the object), you can clone instead of copy to make the shadow auto-updating. But what if your foreground object is not black but you need a black shadow? Here's a recipe: unset the object's fill (it becomes black); create two clones of it; put one clone on top and paint any color you want; put the other clone at bottom, blur it and shift sideways. Now you can edit the unset-fill original (use Alt+click to select it) and everything will update.
  • If an object has a fill that you don't want to blur (e.g. pattern, or if it's a bitmap), but you just want to feather its edges, use a blurred transparency mask. For this, copy the object; paint it white; blur it as needed; scale the blurred copy down so its blur margins are entirely within the original object; select both the original and the blurred mask; do Object > Mask > Set.
  • Transforming a blurred object transforms its blur, too. This applies to a non-uniform scaling as well, so by squeezing a blurred object you make its blur squeezed as well. So, the easiest way to blur a path horizontally more than vertically is this: stretch it upwards without blur, then apply blur and squeeze it back into the original shape.
  • You can combine blurring with gradients. For example, an ellipse with elliptic opacity gradient will look much softer and more natural when blurred. An object with a horizontal linear opacity gradient, when blurred, will look like it is more blurred on its transparent side than on its opaque side.
  • Note that Firefox 2.0 does not support SVG filters, so your files will be displayed in Firefox 2.0 without blur. However, support has been added in the current development version ("trunk") and will be included in Firefox 3.0. The Opera web browser, as well as Batik, support filters correctly.

Undo history

  • Inkscape now features a History Dialog accessible through Ctrl+Shift+H or Edit→Undo History. All changes to the document since it was opened are recorded here.
    • In the dialog, changes are listed from the oldest (top) to the newest (bottom).
    • The type of each change is indicated by an icon and a short description.
    • For readability, consecutive changes of the same type are placed in a collapsable branch showing a triangle marker and the number of the hidden actions in the branch.
    • By clicking on an event event in the list, you can easily move through the undo history, i.e. undo or redo any number of actions with one click.
  • The Undo and Redo commands in the Edit menu display the descriptions of the commands to be undone and redone, correspondingly. (These are the same descriptions that you see in the History dialog.)

Rendering improvements

  • Interruptible display: Previously, Inkscape could not do anything until it finishes the current screen redraw. Now the redraw is made interruptible, so that Inkscape responds to mouse and keyboard input and can abort the current redraw and start over if you do some screen-changing operation. As a result, Inkscape now feels much snappier and more interactive. This interruptibility is fine-tuned for some interactive operations (such as node dragging) so that a balance is achieved between responsiveness and completeness of display.
  • Radial gradients are rendered faster by at least 10%.
  • Screen render is faster by 2-3%, up to 5% for complex drawings with transparency.
  • Display is more responsive when working at high zoom levels when using a tablet.
  • Rendering (compositing) quality has been improved. This is most visible with (partially) transparent gradients, banding is a lot less pronounced now. Speed has also been improved in some cases.

Tools

Node tool

  • You can grow or shrink node selection by hovering the mouse pointer over a node and using mousewheel (up = grow, down = shrink) or the keys PageUp (grow) and PageDown (shrink). Growing adds the closest unselected node to the selection; shrinking deselects the farthest selected node. There are two modes that differ by how the closest/farthest nodes are chosen:
    • Spatial selection (Mousewheel, PageUp/PageDown): distances to nodes are measured directly, regardless of which subpath a node belongs to.
    • Linear selection (Ctrl+Mousewheel, Ctrl+PageUp/Ctrl+PageDown): node distances are measured along the path, and only the nodes belonging to the same subpath as the hovered node are considered (i.e. other subpaths are never selected).
This technique is convenient for quickly selecting an area in a complex path starting from a center - for example, for node sculpting.

Dropper

  • Instead of the confusing toggle button, now the Controls bar for the Dropper tool has two checkboxes, "Pick alpha" and "Set alpha", which work as follows. Suppose you have an object selected and, using Dropper, click on an object which has red (#FF0000) fill and 0.5 opacity (half-transparent).
    • If the "Pick alpha" checkbox is off, the selected object will get the fill color #800000 (i.e. faded-out red) and fill opacity will be at 1.0 (opaque).
    • If the "Pick alpha" checkbox is on but "Set alpha" is off, the selected object will get the fill color #FF0000 (red) and fill opacity will be at 1.0.
    • If both "Pick alpha" and "Set alpha" are on, the selected object will get the fill color #FF0000 (red) and fill opacity will be at 0.5 (half-transparent).
If you Shift+click instead of click, the same changes will be made to stroke color and stroke opacity, correspondingly. Note that in no situation can Dropper change the master opacity of the selected object(s), although it can pick it just as it does any other kind of opacity.

Calligraphy

  • A new numeric parameter, Caps, controls the amount of protruding at the ends of calligraphic strokes. This parameter can range from 0 (flat caps, default behavior in previous versions) through 1 (approximately half-circle caps) and up to 5 (long elliptic caps). Rounded caps much improve the look of low-fixation strokes, simulating a rounded pen.
  • The "Drag" parameter has been renamed to Wiggle with a value inversion (i.e. low drag corresponds to high wiggle, and vice versa). Increase this parameter (default is 0) to make the pen waver and wiggle in curly patterns.

Outline mode

  • A new menu command (View > Display Mode > Toggle) and a new keyboard shortcut (Ctrl+<keypad 5>) switch the display mode from Normal to Outline and back.
  • The window title displays "(outline)" next to the file name when that editing window is in Outline mode.
  • An object with mask and/or clipping path, when viewed in Outline mode, now displays both the object itself and its clipping path and mask as objects, using different outline colors. By default, clippaths use green outlines, and masks use blue.
  • Images in Outline mode are displayed as red (by default) frames with two diagonals.
  • An object with no fill and no stroke, invisible and not selectable by mouse clicking in normal mode, can now be picked by a mouse click in the Outline mode using its visible outline.
  • The bug whereby stroked shapes didn't change stroke width when switching to Outline mode or back is fixed.
  • All outline colors are changeable by editing the "wireframecolors" group inside "options" in the preferences file (~/.inkscape/preferences.xml). The "onlight" and "ondark" attributes set the colors of the regular object outlines on light and dark backgrounds (default black and white correspondingly); the "images", "clips", and "masks" attributes set the colors of images, clipping paths, and masks (defaults are red, green, and blue correspondingly). Each attribute is a decimal integer corresponding to the hex RRGGBBAA of the color.
  • To cater for specialized uses, such as preparing input for personal media cutters, Inkscape now has an option to start in the Outline mode upon launch. To enable this, add the following line to your preferences.xml file:
<group id="startmode" outline="1"/>
placing it after the <group id="options"> opening tag.

PDF export

  • A new Cairo-based PDF exporter has been added to Inkscape. Inkscape 0.45 can export shapes, strokes, transparency, gradients, patterns, text, and images correctly to Cairo. While clipping paths and masks are known to be faulty or missing. Cairo will write a PDF with vector graphics when possible and fall back to raster graphics when needed. What can be exported as vectors and how much of the image will be rasterized when the fallback kicks in depends on your version of Cairo. Cairo version 1.2 with the pdf backend compiled in is the minimum requirement for any Cairo-based PDF exports.
  • [removed? - mental] The native PDF exporter introduced in Inkscape 0.44 is improved along with the new Cairo-based PDF exporter. Changes since Inkscape 0.44 include: New features: bitmap images can be embedded, pdf files can be exported from commandline. Changed behaviour: the pointless text to path question is gone. Fixed bugs: save failure is now detected, miter limits are now >= 1, pdfs with transparent gradient are now embeddable, eccentric elliptic gradients fixed, dash style inheritance fixed, transparency inheritance fixed.

PS/EPS export

  • There's a new option to embed the fonts used in the document in the PS or EPS exported file. As of now, this works for Type 1 fonts only, not TrueType. The option is available when performing the export from the GUI as well as from the command line via the --export-embed-fonts option.

EMF export

  • Inkscape has a limited support for exporting EMF (Enhanced Meta File) format. This works only on Windows, and only exports strokes and fills with constant colours. No text, no images, no gradients, no transparency.

Command line

  • The new --export-pdf command line parameter allows exporting an SVG image to PDF from command line.

Keyboard profiles

The previous release allowed sets of keybinding to be created for Inkscape in the style of other applications. Two more sets of keybindings have been added.

  • Adobe Illustrator
  • Macromedia Freehand

Of course not every feature in these other programs has a direct match to features in Inkscape so if you can please do help us out by reporting any problems you may have or improvements you would like to request.

Additionally, a keybinding that focuses on tablet-based illustration and drawing work has been added:

  • right-handed-illustration.xml

This keybinding places all commonly-used commands under the left hand, so that the user's hands rarely leave the keyboard or the tablet/stylus.

More of Inkscape's keys are implemented as actions and are therefore available for remapping via keyboard profiles. New actions include: EditSelectNext and EditSelectPrev for selecting next/previous object or node (by default, bound to Tab/Shift+Tab; as a result of becoming global actions, these keys now work in all tools and not only in Selector and Node tool as before); [].

Extension effects

  • 3 new parameter types have been added to the extension effect UI: tabs, enumerations and optiongroups (radiobuttons). Examples are available of how to use these parameters in the definition of extensions: the new function plotter uses tabs; enumerations are used by the 'Pattern along path' extension; and a small developer example is given to illustrate the use of optiongroups (identical to enumerations).
  • A new extension, Render > Lorem ipsum creates the traditional Latin-like random text for design mock-ups. The number of paragraphs, the number of sentences per paragraph and the possible fluctuation of the number of sentences (for uneven paragraphs) can be adjusted. If no flowed text element is selected, a new one in a new layer is created, matching the size of the canvas.
  • Pattern along path: A new powerful extension (in "Generate from path" submenu) allows you to bend, repeat and/or stretch a pattern object (which can be a path or a group) along a "skeleton" path. This makes it easy to create a variety of patterned and shaped strokes. This obsoletes the old "Kochify" extension which is removed.
  • Color effects: A new group of extensions in the Color submenu of the Effects menu allows you to adjust all colors of a selection at once. These commands affect both fill and stroke colors, including gradients (but not bitmaps). The commands include a full set of HSL adjustments (increasing/decreasing hue, saturation, or lightness by 5%), Brighter and Darker (adjust brightness by up or down by 10%), Desaturate, Grayscale, Negative, commands for removing or swapping the Red, Green, Blue channels, as well as a Custom command where you can set your own formulas for modifying the color channels. These extensions are a temporary solution; in a future version, similar functionality will be added to Inkscape core.
Note: Adjusting gradient colors may be buggy because a gradient is sometimes shared by more than one object. Also, undoing color changes on gradients exposes a bug where an object seems to "disappear"; this is however only a display issue (probably caused by the order in which gradients and their users are restored on undo) not causing any loss of information. Finally, on large documents and large selections with gradients, Python's XPath code may get quite slow. Despite these shortcomings, we decided to add this, because it's genuinely useful functionality which was so far missing in Inkscape.
  • The Function Plotter has been extended, providing greater flexibility in x- and y-range definition.
  • g2png: The new group-to-PNG Python extension (g2png) is an easy way to export any group or layer to individual PNG files. It was first created for use in the Inkscape User Manual (also available in SVN's user_manual module) but is also interesting for many other uses. If e.g. you have to draw a set of icons, you can draw them in the same document, thus making copying, duplicating, cloning etc. easier. Then just create a group for each icon, and with the extension, each group ends up in its own PNG file.
  • [color markers to match stroke - acspike]
  • The "Blur Edge" extension is renamed into Inset/Outset Halo to avoid confusion with the real Gaussian blur that we now support, as well as to better describe what this extension actually does: From the selected path, it creates a group of inset and outset paths that form a stepped "halo" around the object.
  • The Extract One Image extension automatically appends filename extension to the created bitmap file.
  • In an extension's INX file, you can specify <effects-menu hidden="yes"/> to hide that extension from the Effects menu. However, such a "hidden" extension can still be assigned a keyboard shortcut (by using its id as an "action" in your ~/.inkscape/keys/default.xml).

SVG output

For specialized uses, several aspects of Inkscape's SVG output can now be customized via editing the preferences.xml file (there's no UI for these options). A <group id="svgoutput"> inside <group id="options"> can have the following attributes:

  • usenamedcolors (default is 0). If nonzero, Inkscape uses symbolic color names (such as "white" or "lime") and three-digit color designations (such as $dfe) where appropriate; otherwise, it always uses six-digit colors (such as $d0f0e0). Note that in 0.44, the default was to use named colors, which created problems for some extension effects.
  • numericprecision (default is 8). This is the number of significant digits written for each number into SVG. You can lower this number to get slightly more compact SVG at the expense of precision.
  • minimumexponent (default is -8). In transform= attributes, any number whose absolute value is less than 10 to the power of minimumexponent (i.e. less than 10-8 by default) is written as 0.
  • indent (default is 2) controls the number of spaces that each level of nesting in SVG is shifted. Set this to 0 to disable indentation.
  • inlineattrs (default is 0). If nonzero, attributes are placed on the same line as their tags; otherwise they are separated by newlines.

Bitmap tracing

  • A new color quantization algorithm for multiscan traces works faster (especially for large numbers of colors) and gives more adequate results with less colors used. This improves tracing results both for full-color photographs and for limited-color drawings.
  • The Trace Bitmap dialog now provides access to three more tracing parameters:
    • Suppress speckles: If set, spots or speckles larger than the given size are suppressed in the trace.
    • Smooth corners: This parameter controls how much smoothing is applied to corners in the traced path.
    • Optimize paths: If set, trace paths are optimized by joining adjacent Bezier segments with the given tolerance.
  • All controls in the Trace Bitmap dialog are reorganized to be easier to find. The dialog is redesigned to use two main tabs: Mode (where you select the tracing mode, such as brightness cutoff or color multiscan) and Options (where you set various tracing options, such as corner smoothing). The preview is placed horizontally to the right of the tabs. Most labels and tooltips are rewritten for clarity. The trace preview image is made twice larger.

Even more improvements

  • A 'Save a copy'-function has been added to the file menu, similar to the 'Save a copy' functionality of e.g. Adobe Illustrator. With this function, you can save your document under a new filename, but Inkscape will 'forget' it has done this: later saves will be to the old filename. The default shortcut assigned to this function is: Shift+Ctrl+Alt+S.
  • [new Help commands]
  • Exported PNG images have the correct resolution set in the headers.
  • [sculpt profiles - bbyak]
  • [new toolbar: squeezable, expansion menu, right-click menus - joncruz]
  • [union of a single object - acspike]
  • We removed the "hacked" filename entry field that we had added to the Open and Save dialogs because starting from version 2.10, GTK+ has finally restored this field in their standard file dialog (better late than never!). The standard field at the top of the dialog supports type-ahead find and performs the default dialog action (open or save) by pressing Enter, which means you can now do a quick Ctrl+O, Ctrl+V, Enter sequence to open the file whose path is in your clipboard (this closes a long-standing usability bug). Those who use older versions of GTK are advised either to upgrade to 2.10 or use Ctrl+L to open a pop-up filename box. (Our Windows builds are shipped with GTK+ 2.10.)
  • The Create Bitmap function (Alt+B in the default keymap) is made more useful. Unless you have specific resolution or minimum size set for this command in preferences.xml (<group id="createbitmap"/>), it will take the resolution hint from the object whose bitmap copy you are creating (in other words, it will use the resolution that you specified for that object when exporting it via the Export Bitmap dialog), or the default 90 dpi if that object was not yet exported. Also, a 90 dpi bitmap (with its pixels exactly 1 px in size) will be snapped to the pixel grid. This makes it easy to use Create Bitmap for quick rasterization preview of an object or document. (Note: if you have used a previous version of Inkscape, your preferences.xml may contain minsize="250"; delete this for objects' resolution hints to work.)
  • Using extended input (i.e. tablet pressure and tilt) can now be disabled via Preferences (Misc tab). This is intended to be a last-resort option for those platform/hardware combinations that are not properly supported by GTK. With extended input disabled, you can still use your tablet as a mouse.
  • Simplify Path now had two modes when working with a group of paths: the default mode, which treats all of the paths as one large object to simplify, or the new mode, which acts the same as using Simplify on each path in a group separately. In preferences.xml, set options.simplifyindividualpaths to 1 to get the new mode.
  • For long Simplify operations (more than 20 paths at a time), Inkscape provides user feedback via the status bar as to how many paths have been simplified. This change also prevents Inkscape from appearing to have locked up during the operation.
  • New templates added for video formats (PAL, NTSC and HDTV 1080) as well as DVD cover templates that were not installed in the previous version. This will help video and DVD authoring with Inkscape. The business card 85x54 template was not installed too.
  • The opacity of objects is now displayed as percentage, from 0 to 100, both in the Fill & Stroke dialog (with one fractional digit) and in the statusbar style indicator (with no fractional digits), instead of from 0 to 1.0 as before. This makes opacity values easier to read, type, and say.
  • "Other" license type was added to the metadata/license dialog so that people know that they are entering a URI to an "other" license.
  • Doxygen DoxyFile is updated.
  • Thanks to patches submitted by users, Inkscape can now be built on SGI IRIX 6.5.28, gcc 3.4.0 systems and on Tru64 systems.

Examples

  • With all the recent additions - clipping, masking, and especially blur - Inkscape is now able to produce extremely photorealistic art. In the share/examples folder in Inkscape distribution, you will find two brand new, stunningly realistic images of shiny cars: car.svgz by Konstantin Rotkevich and gallardo.svgz by Michael Grosberg.
  • Inkscape 0.45 does not yet have gradient meshes. But with the addition of Gaussian Blur, this feature suddenly got within reach. A new example file, gradient-mesh-experimental.svgz, explains the approach Inkscape will likely take to implement this feature in a fully SVG-compatible way.

Translations

  • Remarkable improvements are in the Danish, Finnish, Nepalese and the Vietnamese translations of the user interface. They all jumped from 0 to over 90 percent in a very short timespan.
  • All people which are familiar with pig latin are now able to use Inkscape's user interface in that language. Isthay isway oughtbray otay usway ybay away ewnay anslatortray.
  • default lituanian template was not installed. Fixed.
  • Updated British English, Catalan, Bulgarian and Thai translations.

Tutorials and Templates

  • New tutorial "Easter Eggs" by Steve Karg.
  • Added Catalan default template and elements tutorial.
  • Russian header and footer templates are added.

Bugfixes

  • When deleting a node, neighboring smooth nodes are converted to cusp.
  • Releasing the mouse button while dragging nodes using a tablet will now always release the nodes. Before this, a race condition could occur where dragging could continue after the mouse button was released.
  • An object's mask and clipping path are now preserved after Simplify, Object/Stroke to path, or boolean operations.
  • Ungrouping a group containing clipped/masked objects might sometime break the clip/mask (move it away); fixed.
  • User-supplied templates in ~/.inkscape/templates can now be SVGZ files in addition to SVG.
  • Previously, Inkscape didn't check if there's enough free memory for its pixel buffers and could crash without warning due to insufficient memory e.g. upon zooming in. This problem became much worse after implementing Gaussian blur, because rendering blurred objects at high zooms may require a pixel buffer much bigger than the visible canvas. Now this situation is handled more gracefully: if a display operation requires more memory than available, or more than 100Mb (which corresponds to a 5000x5000 pixel buffer), it is skipped. This may result in blurred objects "disappearing" at high zooms. This is purely a display issue, however, it never corrupts data; just zoom out (or reduce blur radius) and the disappeared object will show up OK.
  • When resizing objects, scaling numbers in the statusbar are no longer overwritten by other text when pressing special keys (alt, shift, ctrl).
  • To work around problems some users have had with pressure sensitive tablets (bug), the pressure sensitivity can be disabled from the misc tab of Inkscape preferences dialogue. The tablet can then be used, though with reduced functionality.
  • The layer widget in the statusbar used to lose its current layer after an effect run; this is fixed.
  • When using different display resolutions or a dual screen setup, dialogs could be displayed off-screen; this is fixed: now Inkscape checks whether the saved position of the dialog is offscreen, if so it will move the dialog to the center of the screen. Note that this not solve all problems. If the dialog is still not visible, go to the bugreport where a procedure is given to make the dialog visible (editting preferences.xml).
  • Performing a boolean union without selecting an object no longer crashes Inkscape.
  • Grid and guidelines no longer vanish when changing their color.
  • Group transformation is now correctly applied when ungrouping and undo'ing the ungroup.

Known problems

Problem with Dialogs on Top on Microsoft Windows (win32)

[Describe minimizing of document window problem, and solution: right-click taskbar button and press "Restore"]

OSX 10.3.9: cannot open files

This bug is due to a missing symbol (_statvfs) in the system library /usr/lib/libSystem.B.dylib on 10.3.9. The dependency is introduced by one of the gnome-vf2 modules. It is not something we can easily fix other than by not linking with gnome-vfs2, which we will do for or upcoming 0.45 release if no other solution becomes apparent. [mjwybrow]

Problems with some Debian libgc-6.7 packages

  • Inkscape will hang or crash when linked with the first Debian packaged version of the Boehm garbage collection library. This problem was fixed in version 1:6.7-2 of the package. If you have libgc 6.7 on your Debian-based system, make sure that you are using that version of the package or later.

Beware of defective themes on Linux

  • Inkscape and other Gtk programs can crash on any Linux, when the gtk2-engines-smooth / libsmooth package is installed. We have filed a bug against libsmooth which is now in gtk-engine and part of gnome. Removing the package resolves the problem. Update: this bug appears to be fixed in newer versions of gtk-engines. If you are affected by this problem please update to a newer version of gtk-engines. If problems persist then please inform the gtk-engines maintainers of the problem.
  • A similar crash happens if the KDE Baghira theme or the package gtk_qt_engine are installed. If you experience Inkscape crashes on KDE, please try to install a different theme from Baghira, or uninstall the gtk_qt_engine package from your system. Both problems also affect older versions of Inkscape.

Previous releases