Difference between revisions of "IllustratorUsers"

From Inkscape Wiki
Jump to navigation Jump to search
(I have restored some of my versions in parallel with yours, so people could easily compare them)
Line 4: Line 4:
  
 
::I'd prefer for us to come to a concensus first and then reopen the document to discussion and revision by the community, but I'm the new kid on the block, so ... umm ... Guess this means I need to sign up for the dev list. -kw
 
::I'd prefer for us to come to a concensus first and then reopen the document to discussion and revision by the community, but I'm the new kid on the block, so ... umm ... Guess this means I need to sign up for the dev list. -kw
 +
 +
::I have restored some of my versions in parallel with yours, so people could easily compare them. --bb
  
 
With Inkscape an artist can create most of the same illustrations that can be made with Adobe Illustrator. However, many of the functions and tools that the two applications share are used in different ways.   
 
With Inkscape an artist can create most of the same illustrations that can be made with Adobe Illustrator. However, many of the functions and tools that the two applications share are used in different ways.   

Revision as of 17:38, 9 March 2005

{Buliabyak, dude. I've spent hours and hours working to make a really good document from what was an unfinished page that hadn't been touched in over six months, and I know what I'm doing. Why you messing with me so bad? I appreciate your input, but maybe this isn't the best way to discuss our differences. Please email me at the address I have listed on the UserManual documentation page under People and we can work together and come up with something we can both be happy with. Thx. -kw}
I think we can both benefit from a wider discussion, not just talking to each other. What if we both post to the devel mailing list (and maybe user too) describing our premises and disagreements, and see what others will say. --bb
I'd prefer for us to come to a concensus first and then reopen the document to discussion and revision by the community, but I'm the new kid on the block, so ... umm ... Guess this means I need to sign up for the dev list. -kw
I have restored some of my versions in parallel with yours, so people could easily compare them. --bb

With Inkscape an artist can create most of the same illustrations that can be made with Adobe Illustrator. However, many of the functions and tools that the two applications share are used in different ways.

Terminology

  • Anchor Points: in Inkscape, anchor points are known as "Nodes"
  • Palettes: in Inkscape, "palettes" are called "dialogs", such as the Fill and Stroke dialog.
  • Marquee: this is called "the rubberband" when selecting
  • Tools: see [AdobeToolMap Adobe Tool Map] for complete tool equivalency reference.

Things Illustrator can do that Inkscape can't:

  • Gradient mesh (planned for future release via multiple transparent gradient fills)
  • Multiple strokes and fills for one object
  • Filters & effects (guassian blur, etc.)
  • Select line segments by clicking on the segment
  • Blend objects
  • Color management for print (ICC Profiles, etc.)
  • PMS color
  • Save swatches
  • Wireframe mode
  • Natively work with graphs based on data
  • Free transform and perspective transform

Things Inkscape can do that Illustrator can't:

  • Edit SVG source directly


{Buliabyak, please remove these below after you've read, my comments. Thx!}

  • Clones, Tile clones (Yes it can. Illustrator calls cloned objects Symbols. Symbols can be modified and all instances of the symbol will be changed. Illustrator actually does this better than Inkscape because of the multitude of tools and uses for symbols in Illustrator, and the availability of a symbol library.)
I don't see symbols in AI9. Can you create a linked copy from the selected object? Can you make it move in parallel when you move the original? Can you edit the original right on canvas and have its clones update? If not, it's not the same, and this item should stay. --bb
Yes. In CS (AI10) all this is can be done with symbols, according to the docs (except that there's a two step process to updating symbol instances.) I haven't actually tested it, and it sounds harder in AI than it is in IS, but it's still roughly functionally equivalent. -kw
  • Keys to move/rotate/scale by screen pixels (Plain ol' arrow keys navigate the document in Illustrator, and the step and units can be set in preferences. It can't be reduced to screen pixels, just document pixels, but the difference is too insignificant to mention here. Otherwise, there is a bunch of similarly minor features to be added to the above list for Illustrator.)
Have you read Jimmac's review of Inkscape? He's an old AI user, and he wrote that screen-pixel-size transformations in Inkscape "absolutely rock". It was one of the things that won him over. Besides I'm speaking about rotates and scales too, while AI can only do moves. So this IS important. Please do not judge from your AI perspective only. As for adding minor features of AI, please do! What seems minor to you may be major for some other user. I want this document to be complete -- bb
This is not and cannot be full documentation of AI and IS and every little difference between them. The resulting document, were it otherwise, would be massive, unwieldy and unread. The rest of IS's features will be documented in the documentation, not this one page. AI has already documented all of their features in their docs. Anyone interested in a play by play can pull up the two sets of docs side by side and go to it. This document must remain limited to just the highlights, and take a macro view at IS from an AI POV. So, yes, there is some editorial judgement rightly involved. And I'm not just basing what I've chosen to include simply on my own experience. I've presented Inkscape in a number of venues, including a local professional association of graphic designers and a college class, and I'm hitting the bases they defined in those presentations with their questions.
  • Richer shape controls (This is intended to be a boolean feature comparison, not a qualitative one. Again, if we go there then there's a lot to add to the above list for Illustrator, and this shouldn't be a "which program is better" kind of document, don't you think?)
OK, I agree that this item needs to be detailed. There are many advantages to Inkscape shapes that can be listed. And seeing that this document is for users who are comparing two programs, I don't see why it cannot be a detailed objective comparison listing _everything_. Please add as much as you can for AI and I will do the same for Inkscape. BTW you may want to look at the Xara_X page in this wiki too, which I'm working on. --bb
Again, we can't go into all the features of both programs, or even all of our favorites, or else this document will get bogged down. If you're really that interested in creating such a document then you're working on a different project than I am, you're working on a book about Inkscape for Illustrator users and not what amounts to an overview, because it would just about take a book to explain it all. Let's leave the "What X program can do that Y program can't" sections strictly to those large things that the other program can't do in any way shape or form, and only those things that AI users will care about (since that is who this particular page is written for, after all.) In fact, I wouldn't mind dropping the "Things That Inkscape Can Do..." section altogether, since there's really (with all due respect to Jimmac) nothing that die hard AI professionals are going to care about. -kw

Getting Things Done In Inkscape

Hand Tool : Navigating the Canvas

Instead of using the Spacebar for panning around a document, in Inkscape an artist can press and hold the middle mouse button (or mouse wheel) and drag the canvas in any direction. {This doesn't work for me. -kw Are you pressing the mouse wheel (which is usually the same as middle button) or just rotating it? If still does not work, please file a bug. --bb I'm using a three button mouse that doesn't have a scroll wheel. It's not a bug so much as it is a feature request, I would guess. In any event, for people with three button mice, it just doesn't work like you describe. --kw} Alternatively, rotate mouse wheel to pan vertically, rotate with shift to pan horizontally. In Inkscape, the artist can also pan around the canvas by holding the Ctrl key and pressing the arrow keys. Holding the arrow key speeds up the pan in that direction.

Zooming : Plus and Minus Keys

Instead of holding down the Ctrl key and pressing + or - to zoom the canvas, in Inkscape the artist simply presses the + or - key to zoom.

Selecting : Selector and Nodes Tool

In order to select objects with the rubberband in Inkscape, an artist must completely select the entire area of the object, not just select over part of it, to include it in the selection. Individual nodes of paths can be selected with the Node tool rubberband, the same as in Illustrator; however the object must be selected first, and only the nodes from one object (which may combine several subpaths) can be selected. Unlike Illustrator, nodes from multiple uncombined objects cannot be selected at the same time.

Group Select : Selector

In Inkscape there is no special group select tool. To select an individual object in a group of objects, hold the Ctrl key and click on the object with the Selector. Or you can right-click the group and do "Enter group" after which objects in the group can be selected as if they are not grouped.

Fill & Stroke : Fill and Stroke Window

Since fill and stroke are not a tool, they do no appear on the Toolbox, as is the case in Adobe Illustrator. Instead there is a Fill and Stroke window, activated through the Fill and Stroke icon on the Commands bar, or through the Menu, or by Ctrl+Shift+F.

Styles : Cut 'N Paste

There's no palette of stored styles yet. However you can copy style from one object to another: select the source object, do Edit > Copy (Ctrl+C), select the destination object, do Edit > Paste Style (Ctrl+Shift+V). These copied styles are not linked to the original as they are in Illustrator.

Symbols : Cloning

Inkscape is capable of creating "clones" of objects, which are similar to Illustrator's Symbols. When you edit the original, the changes are propagated to all of its clones. Clones can be transformed, but their nodes cannot be edited. Clones can themselves be cloned. You can use the Edit > Tile clones command to create patterns and arrangements of clones.

{The keyboard shortcuts and all the various ways to accomplish a given task will be documented in the appropriate places in the documentation. It is not necessary, or desirable, to document them here. I want to go through this document later, after it has settled down some, and reduce each solution to one method, without the shortcuts, and leave the shortcuts and whatnot to the pages of the documentation that detail that specific tool or feature. --kw}

Proportional Scaling and Center Point : Shift and Control Keys

In Inkscape, the keys to maintain proportions while scaling, and to center on point are reversed. To scale objects proportionally in Inkscape, press and hold the Ctrl key, and to use the center point for scaling, hold the Shift key.

Rotate & Skew : The Second Click

Inkscape does not have special skew or rotate tools. Instead, with the Selector tool, click on an object to select it, then click on it again to change the handles to Rotate and Skew handles. Dragging the corner handles will rotate and dragging the middle handles will skew.

Palettes

Instead of palettes, Inkscape has dialogs that can be called up by various commands through which the artist communicates with the program. Dialogs function similarly to palettes. (In Windows, they do not stay on top of the Document window; this is a known problem.) You can toggle visibility of all active dialogs with F12 key.

These are traditionally called dialogs. I don't see a reason to rename them. Just "windows" is too vague. --bb
You're going to have to duke this out with Cedric (the head documentor guy) et al. I got it from him, the developers I was chatting with on IRC the other night didn't have a problem with it as far as I know, and it seems to make sense. A dialog requires a response before the command can continue--it's having a dialog (two way interaction) with the user. Everyting else is technically just a window. It's not vague if they have a name, like the Document Preferences window. How is that any more vague than the Document Preferences dialog. Sounds like a stylistic bias. I frankly don't care, as long as it's consistent and I was simply going with what had already been established. See the style guide for more detials. --kw

Working with Nodes (Anchor Points) and Paths

{Note: this section was very carefully constructed to make the most sense to long time users of Illustrator. It is aimed at acclimatizing a recent convert as gently as possible while at the same time remaining honest about Inkscape's limitations with respect to node editing as compared to Illustrator. Due to the relative importance of node editing, please do not hack and slash this section; edit with care.}

I have no problem with making sense for AI users, but I have a problem with incorrect and vague statements. What is "responsive" for example? Please be specific. Deselecting is done by many ways, but NOT by rubberband. This section applies to paths, not shapes, and the tool is Node tool, not Nodes (use the correct terminology please). What do you mean by "you must click only on nodes"? Will it break if you won't? No. etc, etc. --bb
For someone who uses AI professionally day after day, AI is more "responsive" by any objective measure. Again, this is legacy text that I left in place because it makes sense to AI users. In AI you can add a node, convert a node from a smooth to a corner and back again, go back and tack on another node (or fifty), edit the node handles, add some more nodes, and so on, all without moving the cursor away from the path (to click on a command icon, or select another tool). This makes creating paths in Illustrator more responsive. In actual fact it is perhaps more appropriately called "more context sensitive." You can replace "responsive" with "context sensitive" if you want, but it doesn't help reader comprehension, so why do it? You're right to correct my mistake at using "Nodes" instead of "Node", but I've used "Node" most of the time so it's obviously just a mistake. I wrote that section of the Terminology reference, so please tone it down a touch.

Editing paths post drawing is done with the Node tool, N key. Selecting nodes is done by clicking on them, by Tab/Shift+Tab keys, or by the rubberband around several nodes. To deselect nodes, press Esc or click in an empty space. While in the node tool, you can also select a different object by clicking on it, after which its nodes become selectable.

{BB version:} To continue a path, select its endnode and duplicate it (Shift+D), then drag the new node. You can break the path at any selected node(s), or join two end nodes, using the correspondint toolbar buttons. You can edit the nodes of only one path object at a time, but that path object may consist of any number of distinct subpaths. Use the Break Apart and Combine commands to break a path into its subpaths and combine separate paths into a single path.

{KW version:} An artist will need to continue a line segment by creating two paths distinctly. When the second path has been created, select both paths and "Combine" them Control+K. Then edit nodes in the newly combined shape and attach those nodes to each other. Joining nodes is a two step process. First, join the nodes, then select whether or not the join should be a corner, or a smooth curve.

This paragraph is very strange. Why go to all this length if you can duplicate nodes in Node tool, as well as continue the path or create new subpaths in Pen tool, all without doing any combining and joining? Please explain better what you're trying to achieve by this process. --bb
This paragraph is legacy text from the original author, by the way, but I understood why he/she wrote it that way...becaue in AI it is common to start a path by putting down a few anchor points, go back and edit them a little, then pick back up where the path left off and continue to add a few (or a dozen) more anchor points, go back and edit them a bit, and so on until the complete path for the shape is built. In AI when you hover the pen tool over the end anchor point of an open path and click the anchor point, AI knows you are continuing the same path. This is the work flow that AI users are used to. Duplicating a node a dozen or a hundred times in order to continue a path is not productive. It is much faster, and more like the workflow that AI users are already used to, to simply start a new path segment near the end of the previous, and go back and join them later. Groovy? In short, this paragraph makes sense to people used to using AI. --kw

{BB version:} To convert a straight path segment to a curve, select both endnodes of the segment and press the "Make selected segments curves" button on the toolbar. Conversely, you can convert a segment from a curve to a straight line with the "Make selected segments lines" button.

{KW version:} Converting a straight node to a curve node is not as intuitive in Inkscape as it is in Illustrator. To convert a straight node to a curve, the line segments on either side must be converted. To select a line segment, select one node with the Node tool, then Shift+Click the connecting node so that both ends of the segment are selected. Then click the "Make selected segments curves" conversion command. This procedure adds Node Vector Handles (or simply handles) to both nodes on the line segment. Repeat this process with the line segment on the other side of the node being converted to give it handles on both sides. The node can then be converted to corner, smooth or symmetrical as needed. The nodes on either side will have handles, and they cannot be converted to straight nodes again, since only line segments can be converted, but placing the handle on the node will work to emulate straight node behavior.

Again a very strange advice. In my version I have described how to easily convert segments from curve to straight (real straight, not "emulated") and back. What you describe is 10 times more difficult and sounds like a mess. Please read my version carefully and add to it if you have something to add, or propose a different version. This one won't do. --bb
In Illustrator you can convert a single node without affecting the nodes on either side in any way. In IS, you can't. The way node conversion is done in IS is hack, looking at it as an AI user does. Sorry, just the truth. Again, what I'm describing here is what an AI user should do to in order do something in IS that they do in AI, from an AI POV. Again, this paragraph is written based on user feedback, not just some rabbit I'm pulling out of my own hat. You can rest assured that the description of converting nodes (it's actually converting line segments) won't be like this on the page of the actual docs that talks about that feature. It's just the way it needs to be for this document, which is written for AI users trying IS, not IS users who happen to get their hands on AI. --kw

The Node tool currently has some limitations; notably, you can only drag nodes, not path fragments between nodes; and you can only add new nodes over the old ones or in the middle between them, instead of an arbitrary point on path.

Working with nodes in Inkscape has several distinct advantages over Illustrator:

  1. The node appearance changes according to the kind of node it is. When a corner node is converted to a smooth node, it changes from a diamond shape to a square. Thus, without a particular node selected it is still possible to tell what kind of node it is.
  2. Inkscape can restrain node movement to the handle vector or to the adjacent straight line segment (dragging node with Ctrl+Alt).
  3. Inkscape can lock the handle length (dragging handle with Alt).
  4. You can move nodes, rotate handles, scale handles, and move selection from one node to the next using keyboard shortcuts. For moves, scales, and rotates, use Alt to move by one screen pixel.
See above for why I restored this. Keyboard control is the cornerstone of Inkscape usability. If AI users are not used to it, they need to be taught about it because it matters. --bb
I understand, but we're not documenting shortcuts on this page. Nor are we proselytizing for IS directly. Nor are we teaching AI users how to use IS in its full glory. We are (or should be,) simply making a transition from AI to IS easier for the user, in the first few moments of using the program. These other fine features you want to include are dandy indeed, and when an AI users happens across them in the docs I'm sure they'll go "Oh, neat!" but it's not our job here to cover things in that detail. I would agree to a more emphatically worded general note at the begining of the doc that says something to the effect of "The key to productivity in Inkscape is use of the keyboard shortcuts." I agree that that's a strength of IS. I don't agree that it's necessary for this page that we mention every shortcut and every cool feature. Our scope is very narrow. --kw

Editing Shapes

In this section you again fail to take a wider perspective. AI does not seem to have any distinction between path and shapes, but this is NOT an advantage. This is a big problem with AI. We must explain to users why Inkscape treats shapes differently, and why this is an advantage. Instead you only tell them how to quickly degrade higher level abstractions (shapes) to low level (paths), seemingly implying that the fact that you can't edit nodes in shapes is some king of a "problem" that needs to be "fixed" asap by Shift+Ctrl+C. No it's NOT a problem. I restored my version --bb
This isn't about a wider perspective, it's a very narrow one: What do AI users care about when they're taking a look at Inkscape for the first time? Period. I appreciate the fact that you are so passionate about the virtues of Inkscape, I really am. But the best thing you can do to convince AI users to use IS is to tell them how to do what they do every day in AI in IS and leave it at that. My version is a direct response to multiple questions from actual AI users. I've sat them down in front of IS and watched them try to take the Node tool to a square they just created and get frustrated when it didn't work. To them it is a problem. They'll learn the virtues you want to express with your version eventually, but only if they don't have so much frustration at first that they give up and go back to AI. In a sense I'm taking a wider perspective than you are, because I'm recognizing that there are other pages of documentation, pages where some of this stuff you want to add is better put, and I'm looking at documentation as a whole. I'm putting it back the way I had it. -kw

{BB version:} Shapes created with the shapes tools (i.e., Rectangle, Ellipse, Star, Spiral) can be immediately edited in the same tool which created them. Each kind of shape has its own handles which you can drag, possibly with keyboard modifiers, to achieve various effects (such as rounding corners of a rectangle). There are also various numeric fields in the controls bars of the shape tools. Consult the Shapes tutorial (in Help menu) for details on Inkscape shapes. Overall, shapes in Inkscape are more rich and flexible than in Illustrator.

You can also convert any shape to path, to be able to edit its nodes freely. Select the object with the Selector or Nodes tool, and then select Path>Object To Path (Shift+Ctrl+C) or if the Nodes Tool Controls bar is visible, click on the Object To Path command icon.

{KW version:} The nodes of basic shapes created with the shapes tools (i.e., Rectangle, Ellipse, Spiral) can not be immediately edited. Before editing nodes of a shape created with the shape tool, it must first be converted to paths. Select the object with the Selector or Nodes tool, and then select Path>Object To Path (Shift+Ctrl+C) or if the Nodes Tool Controls bar is visible, click on the Object To Path command icon. Then the nodes on of the object can be edited normally.

Pathfinder

Inkscape calls Pathfinder operations "boolean operations" on paths.

Working with Layers

Inkscape has perfectly serviceable layers, although working with layers in Inkscape is not yet very convenient. Layers are located in the Status bar, with the lock and visibility toggle located beside it. An artist can select the layer from the spinbox, and then select its visibility and lock status. Previews are not shown, and art is moved from one layer to another by means of a key command (Shift+PgUp / Shift+PgDn.) Layers can nest, and you can enter a group making it a temporary layer.

Working with Text

Create Outlines

Converting a text object to outlines (i.e. to path) in Inkscape produces a single path object. If you want to manipulate each letter separately, you can break this path into subpaths (Path>Break Apart, Shift+Ctrl+K) and, for letters with holes, reselect parts of each letter and recombine them (Path>Combine, Ctrl+K) to fix the holes.

{Note: the above selection describes a process frequently employed in AI to embed text in the document so that the document is no longer dependent on fonts being installed. "Text to outlines" is the actual AI wording, by the way. It's hack, but is routinely done in AI, so that's why it's written as it is. Please edit with care.}

I don't understand why you need to always do Break Apart and Combine. Simply converting text to outlines works fine in Inkscape without it. If you have to do this "hack" in AI, why are you saying Inkscape is "not very productive"??? It needs this hack ONLY in specific circumstances, as I explained. Restored. --bb
Okay, you're right. I had been playing around with it (because the process doesn't seem to be documented anywhere as far as I could tell,) and it seemed like the first step wasn't doing the trick. It was just IS was being slower than I expected and I thought you had to do the break apart step too, because I was trying different things and it worked when I did that and then combine again. You're right. It only takes that first step, and that's okay.


Text Boxes

While putting text in shapes is possible in Inkscape, it is not yet well supported. See documentation for Flow Text into Shape for more information.

Guides

Guides can be hidden in Inkscape with the Shift+| key combination. The | symbol is called a pipe and is generally paired with the backslash character on the keyboard. Ctrl+; does not do anything in Inkscape. A guide cannot be selected by drawing a rubberband through it, as is done in Illustrator. Rather, to move or delete a guide the artist must use the Selector to grab the guide and move it to another location or to the ruler. Guides cannot be locked, and guides are global to the layers instead of bound to individual layers as they are in Illustrator. Double clicking a guide will open a dialog where you can set the guide position precisely.