Difference between revisions of "IllustratorUsers"

From Inkscape Wiki
Jump to navigation Jump to search
(Restored previous version and reintroduced acceptable edits.)
Line 11: Line 11:
  
 
* Gradient mesh (planned for future release via multiple transparent gradient fills)
 
* Gradient mesh (planned for future release via multiple transparent gradient fills)
* Multiple stokes and fills for one object
+
* Multiple strokes and fills for one object
 
* Filters & effects (guassian blur, etc.)
 
* Filters & effects (guassian blur, etc.)
 
* Select line segments by clicking on the segment
 
* Select line segments by clicking on the segment
Line 25: Line 25:
  
 
* Edit SVG source directly
 
* Edit SVG source directly
* Clones, Tile clones  
+
 
* Keys to move/rotate/scale by screen pixels
+
 
* Richer shape controls
+
{Buliabyak, please remove these below after you've read, my comments. Thx!}
 +
 
 +
* Clones, Tile clones (''Yes it can. Illustrator calls cloned objects Symbols. Symbols can be modified and all instances of the symbol will be changed. Illustrator actually does this better than Inkscape because of the multitude of tools and uses for symbols in Illustrator, and the availability of a symbol library.'')
 +
* Keys to move/rotate/scale by screen pixels (''Plain ol' arrow keys navigate the document in Illustrator, and the step and units can be set in preferences. It can't be reduced to screen pixels, just document pixels, but the difference is too insignificant to mention here. Otherwise, there is a bunch of similarly minor features to be added to the above list for Illustrator.'')
 +
* Richer shape controls (''This is intended to be a boolean feature comparison, not a qualitative one. Again, if we go there then there's a lot to add to the above list for Illustrator, and this shouldn't be a "which program is better" kind of document, don't you think?'')
  
 
== Getting Things Done In Inkscape ==  
 
== Getting Things Done In Inkscape ==  
Line 33: Line 37:
 
=== Hand Tool : Navigating the Canvas ===
 
=== Hand Tool : Navigating the Canvas ===
  
Instead of using the Spacebar for panning around a document, in Inkscape you press and hold the middle mouse button (or mouse wheel) and drag the canvas in any direction. Alternatively, rotate mouse wheel to pan vertically, rotate with shift to pan horizontally. You can also pan around the canvas by holding the Ctrl key and pressing the arrow keys. Holding the arrow key speeds up the pan in that direction.
+
Instead of using the Spacebar for panning around a document, in Inkscape an artist can press and hold the middle mouse button (or mouse wheel) and drag the canvas in any direction. {''This doesn't work for me. -kw''} Alternatively, rotate mouse wheel to pan vertically, rotate with shift to pan horizontally. In Inkscape, the artist can also pan around the canvas by holding the Ctrl key and pressing the arrow keys. Holding the arrow key speeds up the pan in that direction.
  
 
=== Zooming : Plus and Minus Keys ===
 
=== Zooming : Plus and Minus Keys ===
  
Instead of holding down the Ctrl key and pressing + or - to zoom the canvas, in Inkscape the artist simply presses the + or - key to zoom. (Much more convenient!)
+
Instead of holding down the Ctrl key and pressing + or - to zoom the canvas, in Inkscape the artist simply presses the + or - key to zoom.
  
 
=== Selecting : Selector and Nodes Tool ===
 
=== Selecting : Selector and Nodes Tool ===
  
In order to select objects with the Rubberband in Inkscape, an artist must completely select the entire area of the object, not just select over part of it, to include it in the selection. Individual nodes of paths can be selected with the Node tool rubberband, the same as in Illustrator.
+
In order to select objects with the rubberband in Inkscape, an artist must completely select the entire area of the object, not just select over part of it, to include it in the selection. Individual nodes of paths can be selected with the Node tool rubberband, the same as in Illustrator, however the object must be selected with the Nodes tool first, and only the nodes from one (combined) object can be selected. Nodes from multiple, uncombined objects cannot be selected with the rubberband as is done in Illustrator.
  
 
=== Group Select : Selector ===
 
=== Group Select : Selector ===
  
In Inkscape there is no special group select tool. To select an individual object in a group of objects, Ctrl+click it in Selector.
+
In Inkscape there is no special group select tool. To select an individual object in a group of objects, hold the Ctrl key and click on the object with the Selector.
  
 
=== Fill & Stroke : Fill and Stroke Window ===
 
=== Fill & Stroke : Fill and Stroke Window ===
Line 51: Line 55:
 
Since fill and stroke are not a tool, they do no appear on the Toolbox, as is the case in Adobe Illustrator. Instead there is a Fill and Stroke window, activated through the Fill and Stroke icon on the Commands bar, or through the Menu, or by Ctrl+Shift+F.
 
Since fill and stroke are not a tool, they do no appear on the Toolbox, as is the case in Adobe Illustrator. Instead there is a Fill and Stroke window, activated through the Fill and Stroke icon on the Commands bar, or through the Menu, or by Ctrl+Shift+F.
  
=== Cloning ===
+
=== Styles : Cut 'N Paste ===
  
Inkscape is capable of creating "clones" of objects. When you edit the original, the changes are propagated to all of its clones. Clones can be transformed, but their nodes cannot be edited. Clones can themselves be cloned. You can use the Edit > Tile clones command to create patterns and arrangements of clones.
+
There's no palette of stored styles yet. However you can copy style from one object to another: select the source object, do Edit > Copy (Ctrl+C), select the destination object, do Edit > Paste Style (Ctrl+Shift+V). These copied styles are not linked to the original as they are in Illustrator.
  
=== Styles ===
+
=== Symbols : Cloning ===
  
There's no palette of stored styles yet. However you can copy style from one object to another: select the source object, do Edit > Copy (Ctrl+C), select the destination object, do Edit > Paste Style (Ctrl+Shift+V).
+
Inkscape is capable of creating "clones" of objects, which are similar to Illustrator's Symbols. When you edit the original, the changes are propagated to all of its clones. Clones can be transformed, but their nodes cannot be edited. Clones can themselves be cloned. You can use the Edit > Tile clones command to create patterns and arrangements of clones.
  
 
=== Proportional Scaling and Center Point : Shift and Control Keys ===
 
=== Proportional Scaling and Center Point : Shift and Control Keys ===
Line 69: Line 73:
 
=== Palettes ===
 
=== Palettes ===
  
Instead of palettes, Inkscape has '''dialogs''' that can be called up by various commands through which the artist communicates with the program. Dialogs function similarly to palettes. (In Windows, they do not stay on top of the Document window; this is a known problem.) You can toggle visibility of all active dialogs with F12 key.
+
Instead of palettes, Inkscape has windows that can be called up by various commands through which the artist communicates with the program. Dialogs function similarly to palettes. (In Windows, they do not stay on top of the Document window; this is a known problem.) You can toggle visibility of all active windows with F12 key.
  
 
=== Working with Nodes (Anchor Points) and Paths ===
 
=== Working with Nodes (Anchor Points) and Paths ===
  
Editing shapes and paths after drawing is done with the Node tool, N key. It currently has some limitations; notably, you can only drag nodes, not path fragments between nodes; and you can only add new nodes over the old ones or in the middle between them, instead of an arbitrary point on path.
+
{''Note: this section was very carefully constructed to make the most sense to long time users of Illustrator. It is aimed at acclimatizing a recent convert as gently as possible while at the same time remaining honest about Inkscape's limitations with respect to node editing as compared to Illustrator. Due to the relative importance of node editing, please do not hack and slash this section; edit with care.''}
  
Nodes can be cusp (curner), smooth, or symmetric. Symmetric is the same as smooth but the handles are always the same length. There are conveninent keyboard shortcuts for switching the types of selected nodes.
+
Editing shapes post drawing must be done with the "Nodes" tool, N key. Shapes can be tweaked using this tool but it is by no means as responsive as the Illustrator counterpart. You must click on only the control nodes, and deselecting nodes is done by dragging a rubberband (marquee) with the "Nodes" tool.
  
To continue a path, select its endnode and duplicate it (Shift+D), then drag the new node. You can break the path at any selected node(s), or join two end nodes, using the correspondint toolbar buttons. You can edit the nodes of only one path object at a time, but that path object may consist of any number of distinct subpaths. Use the Break Apart and Combine commands to break a path into its subpaths and combine separate paths into a single path.  
+
An artist will need to continue a line segment by creating two paths distinctly. When the second path has been created, select both paths and "Combine" them Control+K. Then edit nodes in the newly combined shape and attach those nodes to each other. Joining nodes is a two step process. First, join the nodes, then select whether or not the join should be a corner, or a smooth curve.
  
To convert a straight path segment to a curve, select both endnodes of the segment and press the "Make selected segments curves" button on the toolbar. Conversely, you can convert a segment from a curve to a straight line with the "Make selected segments lines" button.
+
Converting a straight node to a curve node is not as intuitive in Inkscape as it is in Illustrator. To convert a straight node to a curve, the line segments on either side must be converted. To select a line segment, select one node with the Node tool, then Shift+Click the connecting node so that both ends of the segment are selected. Then click the "Make selected segments curves" conversion command. This procedure adds Node Vector Handles (or simply handles) to both nodes on the line segment. Repeat this process with the line segment on the other side of the node being converted to give it handles on both sides. The node can then be converted to corner, smooth or symmetrical as needed. The nodes on either side will have handles, and they cannot be converted to straight nodes again, since only line segments can be converted, but placing the handle on the node will work to emulate straight node behavior.
  
Nodes cannot be added to a path with a tool. Instead the artist must select a line segment by selecting both nodes on either end, and selecting the Add Node command from the Tool Controls bar. This will place a node in the center of the line segment.
+
Editing shapes and paths after drawing is done with the Node tool, N key. It currently has some limitations; notably, you can only drag nodes, not path fragments between nodes; and you can only add new nodes over the old ones or in the middle between them, instead of an arbitrary point on path.
  
 
==== Working with nodes in Inkscape has several distinct advantages over Illustrator: ====
 
==== Working with nodes in Inkscape has several distinct advantages over Illustrator: ====
 
 
# The node appearance changes according to the kind of node it is. When a corner node is converted to a smooth node, it changes from a diamond shape to a square. Thus, without a particular node selected it is still possible to tell what kind of node it is.
 
# The node appearance changes according to the kind of node it is. When a corner node is converted to a smooth node, it changes from a diamond shape to a square. Thus, without a particular node selected it is still possible to tell what kind of node it is.
 
# Inkscape can restrain node movement to the handle vector or to the adjacent straight line segment (dragging node with Ctrl+Alt).
 
# Inkscape can restrain node movement to the handle vector or to the adjacent straight line segment (dragging node with Ctrl+Alt).
# Inkscape can lock the handle length (dragging handle with Alt).
+
# Inkscape can lock the handle length (dragging handle with Alt).
# You can move nodes, rotate handles, scale handles, and move selection from one node to the next using keyboard shortcuts. For moves, scales, and rotates, use Alt to move by one screen pixel.
 
  
 
=== Editing Shapes ===
 
=== Editing Shapes ===
  
Shapes created with the shapes tools (i.e., Rectangle, Ellipse, Star, Spiral) can be immediately edited in the same tool which created them. Each kind of shape has its own handles which you can drag, possibly with keyboard modifiers, to achieve various effects (such as rounding corners of a rectangle). There are also various numeric fields in the controls bars of the shape tools. Consult the Shapes tutorial (in Help menu) for details on Inkscape shapes. Overall, shapes in Inkscape are more rich and flexible than in Illustrator.
+
The nodes of basic shapes created with the shapes tools (i.e., Rectangle, Ellipse, Spiral) can not be immediately edited. Before editing nodes of a shape created with the shape tool, it must first be converted to paths. Select the object with the Selector or Nodes tool, and then select Path>Object To Path (Shift+Ctrl+C) or if the Nodes Tool Controls bar is visible, click on the Object To Path command icon. Then the nodes on of the object can be edited normally.
 
 
You can also convert any shape to path, to be able to edit its nodes freely. Select the object with the Selector or Nodes tool, and then select Path>Object To Path (Shift+Ctrl+C) or if the Nodes Tool Controls bar is visible, click on the Object To Path command icon.  
 
  
 
=== Pathfinder ===
 
=== Pathfinder ===
Line 102: Line 102:
 
=== Working with Layers ===
 
=== Working with Layers ===
  
Inkscape has perfectly serviceable layers, although working with layers in Inkscape is not yet very convenient. Layers are located in the Status bar, with the lock and visibility toggles located on the left. An artist can select the layer from the list, and then select its visibility and lock status. Previews are not shown. Selected objects can be moved from one layer to another by Shift+PgUp / Shift+PgDn. Layers can nest, and you can enter a group making it a temporary layer.
+
Inkscape has perfectly serviceable layers, although working with layers in Inkscape is not yet very convenient. Layers are located in the Status bar, with the lock and visibility toggle located beside it. An artist can select the layer from the spinbox, and then select its visibility and lock status. Previews are not shown, and art is moved from one layer to another by means of a key command (Shift+PgUp / Shift+PgDn.) Layers can nest, and you can enter a group making it a temporary layer.
  
 
=== Working with Text ===
 
=== Working with Text ===
Line 108: Line 108:
 
==== Create Outlines ====
 
==== Create Outlines ====
  
Converting a text object to outlines (i.e. to path) in Inkscape produces a single path object. If you want to manipulate each letter separately, you can break this path into subpaths (Path>Break Apart, Shift+Ctrl+K) and, for letters with holes, reselect parts of each letter and recombine them (Path>Combine, Ctrl+K) to fix the holes.
+
Converting large blocks of text to outlines in Inkscape is not very productive. Text is converted to vector shapes in a three part process:
 +
1.) With the text selected, select Path>Object to Path (Shift+Ctrl+C)
 +
2.) Select Path>Break Apart (Shift+Ctrl+K)  
 +
3.) Select Path>Combine (Ctrl+K)
 +
 
 +
{''Note: the above selection describes a process frequently employed in AI to embed text in the document so that the document is no longer dependent on fonts being installed. "Text to outlines" is the actual AI wording, by the way. It's hack, but is routinely done in AI, so that's why it's written as it is. Please edit with care.''}
  
 
==== Text Boxes ====
 
==== Text Boxes ====
  
While putting text in shapes is possilbe in Inkscape, it is not yet well supported. See documentation for Flow Text into Shape for more information.
+
While putting text in shapes is possible in Inkscape, it is not yet well supported. See documentation for Flow Text into Shape for more information.
  
 
==== Guides ====
 
==== Guides ====
  
 
Guides can be hidden in Inkscape with the Shift+| key combination. The | symbol is called a pipe and is generally paired with the backslash character on the keyboard. Ctrl+; does not do anything in Inkscape. A guide cannot be selected by drawing a rubberband through it, as is done in Illustrator. Rather, to move or delete a guide the artist must use the Selector to grab the guide and move it to another location or to the ruler. Guides cannot be locked, and guides are global to the layers instead of bound to individual layers as they are in Illustrator. Double clicking a guide will open a dialog where you can set the guide position precisely.
 
Guides can be hidden in Inkscape with the Shift+| key combination. The | symbol is called a pipe and is generally paired with the backslash character on the keyboard. Ctrl+; does not do anything in Inkscape. A guide cannot be selected by drawing a rubberband through it, as is done in Illustrator. Rather, to move or delete a guide the artist must use the Selector to grab the guide and move it to another location or to the ruler. Guides cannot be locked, and guides are global to the layers instead of bound to individual layers as they are in Illustrator. Double clicking a guide will open a dialog where you can set the guide position precisely.

Revision as of 23:30, 8 March 2005

With Inkscape an artist can create most of the same illustrations that can be made with Adobe Illustrator. However, many of the functions and tools that the two applications share are used in different ways.

Terminology

  • Anchor Points: in Inkscape, anchor points are known as "Nodes"
  • Palettes: in Inkscape, "palettes" are called "dialogs", such as the Fill and Stroke dialog.
  • Marquee: this is called "the rubberband" when selecting
  • Tools: see [AdobeToolMap Adobe Tool Map] for complete tool equivalency reference.

Things Illustrator can do that Inkscape can't:

  • Gradient mesh (planned for future release via multiple transparent gradient fills)
  • Multiple strokes and fills for one object
  • Filters & effects (guassian blur, etc.)
  • Select line segments by clicking on the segment
  • Blend objects
  • Color management for print (ICC Profiles, etc.)
  • PMS color
  • Save swatches
  • Wireframe mode
  • Natively work with graphs based on data
  • Free transform and perspective transform

Things Inkscape can do that Illustrator can't:

  • Edit SVG source directly


{Buliabyak, please remove these below after you've read, my comments. Thx!}

  • Clones, Tile clones (Yes it can. Illustrator calls cloned objects Symbols. Symbols can be modified and all instances of the symbol will be changed. Illustrator actually does this better than Inkscape because of the multitude of tools and uses for symbols in Illustrator, and the availability of a symbol library.)
  • Keys to move/rotate/scale by screen pixels (Plain ol' arrow keys navigate the document in Illustrator, and the step and units can be set in preferences. It can't be reduced to screen pixels, just document pixels, but the difference is too insignificant to mention here. Otherwise, there is a bunch of similarly minor features to be added to the above list for Illustrator.)
  • Richer shape controls (This is intended to be a boolean feature comparison, not a qualitative one. Again, if we go there then there's a lot to add to the above list for Illustrator, and this shouldn't be a "which program is better" kind of document, don't you think?)

Getting Things Done In Inkscape

Hand Tool : Navigating the Canvas

Instead of using the Spacebar for panning around a document, in Inkscape an artist can press and hold the middle mouse button (or mouse wheel) and drag the canvas in any direction. {This doesn't work for me. -kw} Alternatively, rotate mouse wheel to pan vertically, rotate with shift to pan horizontally. In Inkscape, the artist can also pan around the canvas by holding the Ctrl key and pressing the arrow keys. Holding the arrow key speeds up the pan in that direction.

Zooming : Plus and Minus Keys

Instead of holding down the Ctrl key and pressing + or - to zoom the canvas, in Inkscape the artist simply presses the + or - key to zoom.

Selecting : Selector and Nodes Tool

In order to select objects with the rubberband in Inkscape, an artist must completely select the entire area of the object, not just select over part of it, to include it in the selection. Individual nodes of paths can be selected with the Node tool rubberband, the same as in Illustrator, however the object must be selected with the Nodes tool first, and only the nodes from one (combined) object can be selected. Nodes from multiple, uncombined objects cannot be selected with the rubberband as is done in Illustrator.

Group Select : Selector

In Inkscape there is no special group select tool. To select an individual object in a group of objects, hold the Ctrl key and click on the object with the Selector.

Fill & Stroke : Fill and Stroke Window

Since fill and stroke are not a tool, they do no appear on the Toolbox, as is the case in Adobe Illustrator. Instead there is a Fill and Stroke window, activated through the Fill and Stroke icon on the Commands bar, or through the Menu, or by Ctrl+Shift+F.

Styles : Cut 'N Paste

There's no palette of stored styles yet. However you can copy style from one object to another: select the source object, do Edit > Copy (Ctrl+C), select the destination object, do Edit > Paste Style (Ctrl+Shift+V). These copied styles are not linked to the original as they are in Illustrator.

Symbols : Cloning

Inkscape is capable of creating "clones" of objects, which are similar to Illustrator's Symbols. When you edit the original, the changes are propagated to all of its clones. Clones can be transformed, but their nodes cannot be edited. Clones can themselves be cloned. You can use the Edit > Tile clones command to create patterns and arrangements of clones.

Proportional Scaling and Center Point : Shift and Control Keys

In Inkscape, the keys to maintain proportions while scaling, and to center on point are reversed. To scale objects proportionally in Inkscape, press and hold the Ctrl key, and to use the center point for scaling, hold the Shift key.

Rotate & Skew : The Second Click

Inkscape does not have special skew or rotate tools. Instead, with the Selector tool, click on an object to select it, then click on it again to change the handles to Rotate and Skew handles. Dragging the corner handles will rotate and dragging the middle handles will skew.

Palettes

Instead of palettes, Inkscape has windows that can be called up by various commands through which the artist communicates with the program. Dialogs function similarly to palettes. (In Windows, they do not stay on top of the Document window; this is a known problem.) You can toggle visibility of all active windows with F12 key.

Working with Nodes (Anchor Points) and Paths

{Note: this section was very carefully constructed to make the most sense to long time users of Illustrator. It is aimed at acclimatizing a recent convert as gently as possible while at the same time remaining honest about Inkscape's limitations with respect to node editing as compared to Illustrator. Due to the relative importance of node editing, please do not hack and slash this section; edit with care.}

Editing shapes post drawing must be done with the "Nodes" tool, N key. Shapes can be tweaked using this tool but it is by no means as responsive as the Illustrator counterpart. You must click on only the control nodes, and deselecting nodes is done by dragging a rubberband (marquee) with the "Nodes" tool.

An artist will need to continue a line segment by creating two paths distinctly. When the second path has been created, select both paths and "Combine" them Control+K. Then edit nodes in the newly combined shape and attach those nodes to each other. Joining nodes is a two step process. First, join the nodes, then select whether or not the join should be a corner, or a smooth curve.

Converting a straight node to a curve node is not as intuitive in Inkscape as it is in Illustrator. To convert a straight node to a curve, the line segments on either side must be converted. To select a line segment, select one node with the Node tool, then Shift+Click the connecting node so that both ends of the segment are selected. Then click the "Make selected segments curves" conversion command. This procedure adds Node Vector Handles (or simply handles) to both nodes on the line segment. Repeat this process with the line segment on the other side of the node being converted to give it handles on both sides. The node can then be converted to corner, smooth or symmetrical as needed. The nodes on either side will have handles, and they cannot be converted to straight nodes again, since only line segments can be converted, but placing the handle on the node will work to emulate straight node behavior.

Editing shapes and paths after drawing is done with the Node tool, N key. It currently has some limitations; notably, you can only drag nodes, not path fragments between nodes; and you can only add new nodes over the old ones or in the middle between them, instead of an arbitrary point on path.

Working with nodes in Inkscape has several distinct advantages over Illustrator:

  1. The node appearance changes according to the kind of node it is. When a corner node is converted to a smooth node, it changes from a diamond shape to a square. Thus, without a particular node selected it is still possible to tell what kind of node it is.
  2. Inkscape can restrain node movement to the handle vector or to the adjacent straight line segment (dragging node with Ctrl+Alt).
# Inkscape can lock the handle length (dragging handle with Alt).

Editing Shapes

The nodes of basic shapes created with the shapes tools (i.e., Rectangle, Ellipse, Spiral) can not be immediately edited. Before editing nodes of a shape created with the shape tool, it must first be converted to paths. Select the object with the Selector or Nodes tool, and then select Path>Object To Path (Shift+Ctrl+C) or if the Nodes Tool Controls bar is visible, click on the Object To Path command icon. Then the nodes on of the object can be edited normally.

Pathfinder

Inkscape calls Pathfinder operations "boolean operations" on shapes.

Working with Layers

Inkscape has perfectly serviceable layers, although working with layers in Inkscape is not yet very convenient. Layers are located in the Status bar, with the lock and visibility toggle located beside it. An artist can select the layer from the spinbox, and then select its visibility and lock status. Previews are not shown, and art is moved from one layer to another by means of a key command (Shift+PgUp / Shift+PgDn.) Layers can nest, and you can enter a group making it a temporary layer.

Working with Text

Create Outlines

Converting large blocks of text to outlines in Inkscape is not very productive. Text is converted to vector shapes in a three part process: 1.) With the text selected, select Path>Object to Path (Shift+Ctrl+C) 2.) Select Path>Break Apart (Shift+Ctrl+K) 3.) Select Path>Combine (Ctrl+K)

{Note: the above selection describes a process frequently employed in AI to embed text in the document so that the document is no longer dependent on fonts being installed. "Text to outlines" is the actual AI wording, by the way. It's hack, but is routinely done in AI, so that's why it's written as it is. Please edit with care.}

Text Boxes

While putting text in shapes is possible in Inkscape, it is not yet well supported. See documentation for Flow Text into Shape for more information.

Guides

Guides can be hidden in Inkscape with the Shift+| key combination. The | symbol is called a pipe and is generally paired with the backslash character on the keyboard. Ctrl+; does not do anything in Inkscape. A guide cannot be selected by drawing a rubberband through it, as is done in Illustrator. Rather, to move or delete a guide the artist must use the Selector to grab the guide and move it to another location or to the ruler. Guides cannot be locked, and guides are global to the layers instead of bound to individual layers as they are in Illustrator. Double clicking a guide will open a dialog where you can set the guide position precisely.