Difference between revisions of "Current PDF Support"

From Inkscape Wiki
Jump to navigation Jump to search
Line 39: Line 39:
 
Weaknesses:  
 
Weaknesses:  
 
* Doesn't support fill patterns and clipping, see bugs 1208874 and 1170322
 
* Doesn't support fill patterns and clipping, see bugs 1208874 and 1170322
* Postscript doesn't support gradients or transparency and Inkscape doesn't emulate this, so gradients and transparency are just ignored.
+
* Postscript doesn't support transparency and Inkscape doesn't emulate this, so they are just ignored, that is you get the color you would get with opacity:1
  
 
== Current Adobe Illustrator support ==
 
== Current Adobe Illustrator support ==

Revision as of 07:01, 21 March 2006

Current PDF support

PDF Import

There is currently no support to automatically import PDF files in Inkscape.

PDF Export

pdf_output.inx exports PDF files by first saving them as Postscript and use an external converter to creat PDFs.

Requirements:

  • ps2pdf (Installed separately)

Strengths:

Weaknesses:

Current Postscript support

PS Import

ps_input.inx imports Postscript files by using two external conversion scripts:

Requirements:

  • pstoedit (Installed separately)
  • skconvert (Installed separately)

Strengths:

Weaknesses:

PS Export

Inkscape has built-in support to write Postscript files.

Strengths:

  • Outputs nice readable Postscript

Weaknesses:

  • Doesn't support fill patterns and clipping, see bugs 1208874 and 1170322
  • Postscript doesn't support transparency and Inkscape doesn't emulate this, so they are just ignored, that is you get the color you would get with opacity:1

Current Adobe Illustrator support

The files used by AdobeIllustrator were earlier postscript files but are now Pdf files.

AI Import

Requirements:

  • ill2svg.pl requires perl

Strengths:

Weaknesses:

  • Only works on the old Postscript-based Adobe format
  • Code is sort of a hack
  • No maintainer exists for this code

AI Export

ai_output.inx exports Illustrator files by first saving them as Postscript and use an external converter to creat AIs.

Requirements:

  • ps2ai.ps (requires gs)

Strengths:

Weaknesses: