Difference between revisions of "Creating a new multicolor icon theme"

From Inkscape Wiki
Jump to navigation Jump to search
m (Next piece.)
(Done.)
Line 44: Line 44:
 
## Click on the + button next to the desired class, e.g. if you want the fill to be green (.success), you will click on + button next to .success.
 
## Click on the + button next to the desired class, e.g. if you want the fill to be green (.success), you will click on + button next to .success.
 
## If you changed your mind and want a different class, you can click on the triangle to expand the list of paths that use the class, and remove the class from the path by clicking on the x button.
 
## If you changed your mind and want a different class, you can click on the triangle to expand the list of paths that use the class, and remove the class from the path by clicking on the x button.
# To preview your icon designs, save the icon file (Ctrl+S), and then toggle the box for the dark theme twice in the preferences to force a reload of the current theme.
+
# To preview your new icon, save the icon file (Ctrl+S), and switch to a different theme, and then back to your new theme in the preferences to force a reload of the current theme.
# Now you can see how they look when used in the Inkscape interface (note that this technique does not work for dock icons you need to restart inksacpe to see thees icons change )
+
# Now you can see how the icon looks when it is used in the Inkscape interface.
# Now do it 450 more times and you made '''SUPER COOL ICONS'''
+
# Repeat the process 450 more times to finish your very own '''Super Cool Icons'''.
# Congratulation you did it dont forget to share your '''SUPER COOL ICONS''' theme with comunity on inkcape.org
+
# Congratulation you did it! Dont forget to share your '''Super Cool Icons''' theme with the community on [https://inkscape.org/gallery/=inkscape-gui-icon-set/ the Inkscape website].
  
 
== Feature support ==
 
== Feature support ==
  
==== Suported: ====
+
==== Supported: ====
  
* 4 colors + opacities of this colors (set by classes)
+
* 4 solid fill colors (set by classes)
* solid fills (set by classes)
+
* arbitrary opacity values (not alpha, but object opacity)
* LPE (life paths effects)
+
* LPEs (live path effects)
* Cliping masks
+
* clipping masks
* Filters ( dont reccomend to us it )
+
* Filters (not recommended)
* Bitmaps embeds ( dont reccomend to us it )
+
* embedded bitmaps (not recommended)
  
==== Unsuported: ====
+
==== Unsupported: ====
  
* strokes ( workaorund in [[##Tips%20and%20Tricks|Tips and Tricks]])
+
* strokes with any color different from the theme base color
* gradients ( workaorund in [[##Tips%20and%20Tricks|Tips and Tricks]])
+
** Workaround: add the 'Join type' LPE (it nondestructively converts strokes to paths)
 +
* gradients
 +
** Workaround: you can simulate linear gradients by creating a bunch of rectangles in a row and changing their opacity (0,10,20,30...), and then clipping this group with the shape you want to have a linear gradient. You can simulate radial gradients by using blur on paths.
 
* mesh gradients
 
* mesh gradients
 
* blend modes
 
* blend modes
* diffrent colors than set by clases ( .base, .danger, .warning, .danger) ( workaorund in [[##Tips%20and%20Tricks|Tips and Tricks]])
+
* different colors than those set by .success, .warning, .error.
 +
** Workaround: you can create more than 4 colors by layering objects with lowered opacity. Create a duplicate of the path, then change the new path's opacity and select one of the color classes. E.g. use one object with the class .success at 30% opacity, placed on top of another object with an unset fill for a different shade of the .success color.
  
== Best technical practisies ==
+
== Best practices ==
  
<ul>
+
* Keep it all in one layer and '''do not change the name''' of the layer.
<li>Keep it all in one layer and DONT change name of layer</li>
+
* Keep in mind that the icons are going to be very small (16 x 16px), so use a grid for drawing to ensure crisp rendering.
<li>Keep in mind that this icons are going to be very small (16*16px) so use grid for chrisp rendering</li>
+
* Add a color class to all paths, or unset the fill. If no class is set, the default class .base will be used.
<li>Add color class to all paths If you cont defoult class is .base</li>
+
* Try to keep the SVG file small and simple so it does not take a long time to render them (this can impact start up time).
<li>Try to keep SVG small and simple so it does not take long time to render them (this can impact start up time )</li>
+
* Try to use discrete opacity values: 0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100% to keep the SVG files small.
<li>Try use opacities 0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100, % to keep SVGs small</li>
+
* Use a low precision for your file's coordinates (maximally 0.xx). This includes node poritions, object transformations etc.).
<li>Try to use max 0.xx on in your cordinations ( nodes poritions , object transformations etc)</li>
 
== Tips and tricks ==
 
</li>
 
<li>to render Strokes add LPE Join paths ( It just nondestractivly convert strokes to paths )</li>
 
<li>you can create more than 4 colors by mixing 4 colors with opacity. Create duplicat of path you want to mix color add new color and change opaciy. Succes 100% + Base 50% for darker shade of Succes color</li>
 
<li>keep your icon folder in (WIN) C: '''YOUR USER NAME''' </li>
 
<li>You can set your defoult colors of '''normal theme''' and '''''dark theme''''' in '''highlights.css'''</li>
 
<li>you simulate linear gradients by creating buch of rectangles in row and changing their opacity (0,10,20,30...) and than clip this grupe with shape you want to make linear gradient</li>
 
<li>you simulate radial gradient by making circles goign from small to big and changing their opacity (0,10,20,30...) and cliping this grupe with shape you want to make linear gradient</li>
 
<li>you can simulate gradients by using blur on paths</li>
 
<li>to preview your icon designs live-ish keep preference panel ('''Edit/Preferences> Interface> Theming''') open in corener a SAVE ( ctrl+S ) and double click chcek box Dark theme this will reload Icons and you can see how they look (Note that this technique does not work for dock icons you need to restart ink to see changes)</li>
 
<li>you can ajust your color schem in dark mode by editing '''highlights.css''' dark.'''class name''' ( contras works diffrently on dark and white backround)</li>
 
<li>Have a fun</li></ul>
 

Revision as of 17:38, 11 February 2020

What are multicolor icons?

From Inkscape 1.0 on, Inkscape icon sets can make use of 4 user-customizable highlight colors, plus a user definable base color (colors can be mixed and blended). A user can select the colors in Edit > Preferences > Interface > Theme: Display icons.

The stock multicolor icon theme was designed and documented by Adam Belis. Most of its icons are based upon those contained in the hicolor symbolic icon theme.

Since Inkscape's switch to Gtk3, every icon is saved in a separate file. There are about 450 different icons used in Inkscape. When you're creating your own icon theme, you don't need to make a new one for each of those, but can base your changes on an existing icon theme.

How does it work?

Gtk supports up to 4 classes of colors: .base, .success, .warning and .error. Normally, .error is set to red, .warning is orange and .success is green. .base is black and the background is white (transparent?). The default colors can be set in a CSS file in /share/inkscape/icons/<theme_name>/highlights.css.

How to build a new set of icons: Practical Guide

Creating a new icon theme and setting its default colors

  1. Find the Inkscape data folder at Edit > Preferences > System: Inkscape data.
  2. Find you Inkscape user icon folder at Edit > Preferences > System: User icons.
  3. Open the folder 'icons' in the Inkscape data folder.
  4. Copy the 'multicolor' icon folder from there into your Inkscape user icon folder.
  5. Rename the new folder to your new name (for example, call it Super Cool Icons).
  6. Open the file index.theme in your new icon folder with a text editor (e.g. Notepad), and adjust the name and comment there, too. Save the file.
  7. To set up your default colors:
    1. Open the file 'highlights.css' in your new 'Super Cool Icons' folder with your favorite text editor.
    2. Adjust the hex color codes of the classes to your liking, e.g. if you want your .success class to be green, you will change it to #009909.
    3. You can copy hex colors from Inscape's Fill and Stroke dialog or use an online color chooser, e.g. https://htmlcolorcodes.com .
    4. The .dark classes can be used to adjust your color scheme to dark themes.
    5. Save and close the 'highlights.css' file.
  8. You can also come back and tweak the colors later, if you like.

Editing or creating your first icon

Now when you are happy with your colors, we can jump into Icon editing:

  1. Think about how you want to use the three available colors for your theme, e.g. maybe you want to sort icons by functionality, placement, or any other attribute.
  2. Open any icon file in the folder 'symbolic/actions' inside your 'Super Cool Icons' folder with Inkscape 1.0.
  3. Open the dialog Object > Selectors and CSS.
  4. Also open Edit > Preferences > Interface > Theme and select the icon theme you have just created.
  5. Delete the current icon.
  6. Design your own icon.
  7. To assign a color to a fill:
    1. Select the path.
    2. In the Selectors and CSS dialog, you will see 3 classes (.success, .warning, .error) (you may need to expand the dialog, or switch to vertical mode to be able to see them).
    3. Click on the + button next to the desired class, e.g. if you want the fill to be green (.success), you will click on + button next to .success.
    4. If you changed your mind and want a different class, you can click on the triangle to expand the list of paths that use the class, and remove the class from the path by clicking on the x button.
  8. To preview your new icon, save the icon file (Ctrl+S), and switch to a different theme, and then back to your new theme in the preferences to force a reload of the current theme.
  9. Now you can see how the icon looks when it is used in the Inkscape interface.
  10. Repeat the process 450 more times to finish your very own Super Cool Icons.
  11. Congratulation you did it! Dont forget to share your Super Cool Icons theme with the community on the Inkscape website.

Feature support

Supported:

  • 4 solid fill colors (set by classes)
  • arbitrary opacity values (not alpha, but object opacity)
  • LPEs (live path effects)
  • clipping masks
  • Filters (not recommended)
  • embedded bitmaps (not recommended)

Unsupported:

  • strokes with any color different from the theme base color
    • Workaround: add the 'Join type' LPE (it nondestructively converts strokes to paths)
  • gradients
    • Workaround: you can simulate linear gradients by creating a bunch of rectangles in a row and changing their opacity (0,10,20,30...), and then clipping this group with the shape you want to have a linear gradient. You can simulate radial gradients by using blur on paths.
  • mesh gradients
  • blend modes
  • different colors than those set by .success, .warning, .error.
    • Workaround: you can create more than 4 colors by layering objects with lowered opacity. Create a duplicate of the path, then change the new path's opacity and select one of the color classes. E.g. use one object with the class .success at 30% opacity, placed on top of another object with an unset fill for a different shade of the .success color.

Best practices

  • Keep it all in one layer and do not change the name of the layer.
  • Keep in mind that the icons are going to be very small (16 x 16px), so use a grid for drawing to ensure crisp rendering.
  • Add a color class to all paths, or unset the fill. If no class is set, the default class .base will be used.
  • Try to keep the SVG file small and simple so it does not take a long time to render them (this can impact start up time).
  • Try to use discrete opacity values: 0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100% to keep the SVG files small.
  • Use a low precision for your file's coordinates (maximally 0.xx). This includes node poritions, object transformations etc.).