CompilingUbuntu

From Inkscape Wiki
Revision as of 06:55, 20 December 2005 by Verbalshadow (talk | contribs) (Added Breezy info)
Jump to navigation Jump to search

The following packages are need to compile cvs inkscape under a default Ubuntu Hoary/Breezy system:

  apt-get install cvs build-essential intltool libtool libgtkmm-2.4-dev libglib2.0-dev libpng12-dev libxslt1-dev libsigc++-2.0-dev libpopt-dev libgc-dev

Inkscape requires libgc-6.4.

Breezy doesn't require any further work.

Hoary uses version 6.3 is provided in the Repos. (Is there somewhere to get a .deb for 6.4?)

To overwrite libgc-6.3 with libgc-6.4:

  Download gc6.4
  ./configure --prefix=/usr
  make
  sudo make install

libgc 6.5 debs for ubuntu

http://inkscape.modevia.com/ap/libgc-dev_6.5-1_i386.deb

http://inkscape.modevia.com/ap/libgc1_6.5-1_i386.deb