From Inkscape Wiki
Jump to navigation Jump to search

Dapper and Edgy

If you're going to build Inkscape, you'll need to have a full complement of build requirements. This is very easy to do in Ubuntu Dapper and Edgy:

Note: the libgc-6.7 that is available in Edgy removes the need for the following:

   sudo apt-get build-dep inkscape
   sudo apt-get install liblcms-dev build-essential
   echo "deb-src unstable main" >> /etc/apt/sources.list
   sudo apt-get update
   sudo apt-get source libgc-dev
   sudo apt-get install fakeroot debhelper
   cd libgc*
   sudo fakeroot dpkg-buildpackage -uc -us
   sudo dpkg -i ../libgc*.deb

If you want version 0.44 from Debian Unstable, you can compile it in the same way as libgc above:

   apt-get source inkscape
   cd inkscape*
   fakeroot dpkg-buildpackage -uc -us
   sudo dpkg -i ../inkscape*.deb

To build the SVN snapshots:

   # Untar and navigate to the inkscape source folder
   sudo make install

Instead of doing "make install", on Debian-based distributions (such as Ubuntu) it is better to do

   sudo checkinstall

since checkinstall first builds the .deb package and then installs it, thus making the package system aware of the newly installed inkscape. If you get the "command not found" message, do

   sudo apt-get install checkinstall

Notes: build-dep gets all the dependencies for the version of Inkscape that comes with Ubuntu. We're not building the same version, but most of the dependencies are the same.

libcms-dev was required for ./configure to work

This was done on a recently installed Dapper (Ubuntu 6.06) system. I built Inkscape version 0.44.

The following packages are need to compile cvs inkscape under a default Ubuntu Hoary/Breezy/Dapper system:

  apt-get install cvs build-essential intltool libtool libgtkmm-2.4-dev libglib2.0-dev libpng12-dev libxslt1-dev libsigc++-2.0-dev libpopt-dev libgc-dev

Inkscape requires libgc-6.7.

Breezy uses 6.4, Dapper uses 6.6, Edgy uses 6.7

Hoary uses version 6.3, which is provided in the Repos. (Is there somewhere to get a .deb for 6.4?)

To overwrite libgc-6.3 with libgc-6.4:

  Download gc6.4
  ./configure --prefix=/usr
  sudo make install

Old libgc 6.5 debs for Breezy