Difference between revisions of "Release notes/0.45"

From Inkscape Wiki
Jump to: navigation, search
(Even more improvements)
(Translations: Piglatin)
Line 90: Line 90:
  
 
* Remarkable improvements are the Danish, Finnish, Nepalese and the Vietnamese translation of the user interface. They all jumped from 0 to over 90 percent in a very short timespan.
 
* Remarkable improvements are the Danish, Finnish, Nepalese and the Vietnamese translation of the user interface. They all jumped from 0 to over 90 percent in a very short timespan.
 +
* All people, which are familiar with the language '''piglatin''', are now able to use Inkscapes userinterface in that language. Isthay isway oughtbray otay usway ybay away ewnay anslatortray.
  
 
= Known problems =
 
= Known problems =

Revision as of 08:58, 28 September 2006

Inkscape 0.45: overview

Filters

  • [blur slider]

Undo history

  • Inkscape now features a History Dialog accessible through [CTRL] + [SHIFT] + H or Edit→Undo History. All changes to the document since it was opened are recorded here.
    • In the dialog, changes are listed from the oldest (top) to the newest (bottom).
    • The type of each change is indicated by an icon and a short description.
    • For readability, consecutive changes of the same type are placed in a collapsable branch showing a triangle marker and the number of the hidden actions in the branch.
    • By clicking on an event event in the list, you can easily move through the undo history, i.e. undo or redo any number of actions with one click.
  • The Undo and Redo commands in the Edit menu display the descriptions of the commands to be undone and redone, correspondingly.

Speed

  • Interruptible display: Previously, Inkscape could not do anything until it finishes the current screen redraw. Now the redraw is made interruptible, so that Inkscape responds to mouse and keyboard input and can abort the current redraw and start over if you do some screen-changing operation. As a result, Inkscape now feels much snappier and more interactive. This interruptivility is fine-tuned for some interactive operations (such as node dragging) so that a balance is achieved between responsiveness and completeness of display.
  • Radial gradients are rendered faster by at least 10%.
  • Screen render is faster by 2-3%, up to 5% for complex drawings with transparency.
  • Display is more responsive when working at high zoom levels when using a tablet.
  • Rendering (compositing) quality has been improved. This is most visible with (partially) transparent gradients, banding is a lot less pronounced now. Speed has also been improved in some cases.

Command line

  • The new --export-pdf command line parameter allows exporting an SVG image to PDF from command line.

Keyboard profiles

The previous release allowed sets of keybinding to be created for Inkscape in the style of other applications. Two more sets of keybindings have been added.

  • Adobe Illustrator
  • Macromedia Freehand

Of course not every feature in these other programs has a direct match to features in Inkscape so if you can please do help us out by reporting any problems you may have or improvements you would like to request.

Additionally, a keybinding that focuses on tablet-based illustration and drawing work has been added:

  • right-handed-illustration.xml

This keybinding places all commonly-used commands under the left hand, so that the user's hands rarely leave the keyboard or the tablet/stylus.

Even more improvements

  • [Save a copy]
  • [new cursors - scislac]
  • [tabs in extension effect UI - Johan Engelen]
  • [axonometric grid]
  • Exported PNG images have the correct resolution set in the headers.
  • A new Cairo-based PDF exporter has been added to Inkscape. Inkscape 0.45 can export shapes, strokes, transparency, gradients, patterns, text, and images correctly to Cairo. While clipping paths and masks are known to be faulty or missing. Cairo will write a PDF with vector graphics when possible and fall back to raster graphics when needed. What can be exported as vectors and how much of the image will be rasterized when the fallback kicks in depends on your version of Cairo. Cairo version 1.2 with the pdf backend compiled in is the minimum requirement for any Cairo-based PDF exports.
  • The native PDF exporter introduced in Inkscape 0.44 is improved along with the new Cairo-based PDF exporter. Changes since Inkscape 0.44 include: New features: bitmap images can be embedded, pdf files can be exported from commandline. Changed behaviour: the pointless text to path question is gone. Fixed bugs: save failure is now detected, miter limits are now >= 1, pdfs with transparent gradient are now embeddable, eccentric elliptic gradients fixed, dash style inheritance fixed, transparency inheritance fixed.
  • [expand/contract selection in node tool, sculpt profiles - bbyak]
  • Simplify Path now had two modes when working with a group of paths: the default mode, which treats all of the paths as one large object to simplify, or the new mode, which acts the same as using Simplify on each path in a group separately. In preferences.xml, set options.simplifyindividualpaths to 1 to get the new mode.
  • For long Simplify operations (more than 20 paths at a time), Inkscape provides user feedback via the status bar as to how many paths have been simplified. This change also prevents Inkscape from appearing to have locked up during the operation.
  • A new extension, Render > Lorem ipsum creates the traditional Latin-like random text for design mock-ups. The number of paragraphs, the number of sentences per paragraph and the possible fluctuation of the number of sentences (for uneven paragraphs) can be adjusted. If no flowed text element is selected, a new one in a new layer is created, matching the size of the canvas.

Bugfixes

  • When deleting a node, update neighboring smooth nodes to be cusp nodes because symmetry is broken.
  • Releasing the mouse button while dragging nodes using a tablet will now always release the nodes. Before this, a race condition could occur where dragging could continue after the mouse button was released.

Tools

Dropper

  • Instead of the confusing toggle button, now the Controls bar for the Dropper tool has two checkboxes, "Pick alpha" and "Set alpha", which work as follows. Suppose you have an object selected and, using Dropper, click on an object which has red (#FF0000) fill and 0.5 opacity (half-transparent).
    • If the "Pick alpha" checkbox is off, the selected object will get the fill color #800000 (i.e. faded-out red) and fill opacity will be at 1.0 (opaque).
    • If the "Pick alpha" checkbox is on but "Set alpha" is off, the selected object will get the fill color #FF0000 (red) and fill opacity will be at 1.0.
    • If both "Pick alpha" and "Set alpha" are on, the selected object will get the fill color #FF0000 (red) and fill opacity will be at 0.5 (half-transparent).
If you Shift+click instead of click, the same changes will be made to stroke color and stroke opacity, correspondingly. Note that in no situation can Dropper change the master opacity of the selected object(s), although it can pick it just as it does any other kind of opacity.

Calligraphy

  • A new option adds the ability to round the ends of calligraphic strokes, which is useful when the calligraphic tool is being used with low "fixity" to simulate a rounded pen. This setting on the calligraphy toolbar ranges from 0.0 (flat) to 1.0 (an approximate half-circle).

Translations

  • Remarkable improvements are the Danish, Finnish, Nepalese and the Vietnamese translation of the user interface. They all jumped from 0 to over 90 percent in a very short timespan.
  • All people, which are familiar with the language piglatin, are now able to use Inkscapes userinterface in that language. Isthay isway oughtbray otay usway ybay away ewnay anslatortray.

Known problems

Problems with some Debian libgc-6.7 packages

  • Inkscape will hang or crash when linked with the first Debian packaged version of the Boehm garbage collection library. This problem was fixed in version 1:6.7-2 of the package. If you have libgc 6.7 on your Debian-based system, make sure that you are using that version of the package or later.

Beware of defective themes on Linux

  • Inkscape and other Gtk programs can crash on any Linux, when the gtk2-engines-smooth / libsmooth package is installed. We have filed a bug against libsmooth which is now in gtk-engine and part of gnome. Removing the package resolves the problem. Update: this bug appears to be fixed in newer versions of gtk-engines. If you are affected by this problem please update to a newer version of gtk-engines. If problems persist then please inform the gtk-engines maintainers of the problem.
  • A similar crash happens if the KDE Baghira theme or the package gtk_qt_engine are installed. If you experience Inkscape crashes on KDE, please try to install a different theme from Baghira, or uninstall the gtk_qt_engine package from your system. Both problems also affect older versions of Inkscape.

Make sure to remove menus.xml if you have it

  • If you were using certain CVS/SVN builds from autumn of 2005, you may have the file menus.xml hanging around in your profile directory (e.g. ~/.inkscape on Linux). In that case you will see many errors about verbs that cannot be found, and some commands in menus will be disabled. Make sure to delete menus.xml to fix this.

Previous releases