Tracking Dependencies

From Inkscape Wiki
Jump to: navigation, search

Contents

Overview

We need help getting our basic lib dependencies listed out and kept up to date. Also we need to track which versions of which distros have the needed dependencies.

To get glib and GTK+ dependencies figured out, people can go through the API documentation and look for the 'since' entries saying when calls were added. Then look for those calls in our source. Voila! we'll have base minimum dependencies figured out.

Libs

C++ bindings are not included, since their required versions match those of the C counterparts.

Library v 0.48.4 trunk trunk (GTK+ 3.0 build)
Boehm-GC >= 6.4
< 7.41
7.1 7.1
Cairo  ? 1.10 1.10
GDL N/A N/A 3.3.4
Glib 2.16* 2.28 2.28
GTK+ 2.12* 2.24 3.2
GNU Scientific Library  ?  ?  ?
LittleCMS 1.13 1.13 1.13
libxml 2.6.11* 2.6.11* 2.6.11*
libxslt 1.0.15* 1.0.15* 1.0.15*
Pango  ?  ? 1.24
Poppler 0.5.9* 0.5.9* 0.5.9*
libsigc++ 2.0.12* 2.0.12* 2.0.12*

* Tentative dependency

1 Inkscape 0.48.4 fails to compile with boehm-gc 7.4.0+

Distros

Note: This table is not relevant to (non-fink) MacOS X, where we ship the desired version with Inkscape.

Distro cairo cairomm glib glibmm gtk+ gtkmm pango poppler gdl lcms libsigc++ libgc
Windows Devlibs (r46) 1.11.2 1.10.0 2.28.8 2.28.2 2.24.10 2.24.2 1.28.3 0.12.1 (none) 1.17 2.2.11 7.1
Windows Devlibs Gtk+ 3 branch (r28) 1.10.2 1.10.0 2.38.0 2.36.0 2.24.18
3.8.1
2.24.2
3.8.0
1.34.0 0.22.5 3.4.2 1.19
2.4
2.2.10 7.2d
Debian 7.0 (Wheezy, stable) 1.12.2 1.10.0 2.33.12 2.32.1 2.24.10
3.4.2
2.24.2
3.4.2
1.32.5 0.18.4 3.4.2 1.19
2.2
2.2.10 7.1
Fedora 191 1.12.14 1.10.0 2.36.3 2.36.2 2.24.19
3.8.2
2.24.3
3.8.1
1.34.1 0.22.1 3.8.1 1.19
2.5
2.3.1 7.2d
Fedora 201 1.13.1+git 1.10.0 2.38.2 2.38.1 2.24.22
3.10.6
2.24.4
3.10.1
1.36.1 0.24.3 3.10.0 1.19
2.5
2.3.1 7.2d
OpenSuSE 12.3 EOL 2014-09-15[1] 1.12.8 1.10.0 2.34.3 2.34.1 2.24.14
3.6.4
2.24.2
3.6.0
1.32.5 0.22.0 3.6.2 1.19
2.4
2.2.11 7.1.9.6
OpenSuSE 13.11 EOL 2015-05-01[2] 1.12.16 1.10.0 2.38.1 2.38.0 2.24.22
3.10.2
2.24.4
3.10.0
1.36.0 0.24.3 3.10.0 1.19
2.5
2.3.1 7.2d
Ubuntu 12.04 LTS (Precise) EOL 2017-04 1.10.2 1.10.0 2.32.3 2.32.0 2.24.10
3.4.2
2.24.2
3.4.0
1.30.0 0.18.4 3.3.91 1.19
2.2
2.2.10 7.1
Ubuntu 13.10 (Saucy) EOL 2014-07 1.12.16 1.10.0 2.38.0 2.37.4 2.24.20
3.8.6
2.24.4
3.8.1
1.32.5 0.24.1 3.8.1 1.19
2.5
2.2.10 7.2d
Ubuntu 14.04 (Trusty)1 EOL 2019-04 1.13.0 1.10.0 2.40.0 2.39.93 2.24.23
3.10.8
2.24.4
3.10.1
1.36.3 0.24.5 3.8.1 1.19
2.5
2.2.10 7.2d
Ubuntu 14.10 (Utopic)1 (As of 2014-05-16), EOL 2015-07 1.13.0 1.10.0 2.40.0 2.40.0 2.24.23
3.10.8
2.24.4
3.10.1
1.36.3 0.24.5 3.8.1 1.19
2.5
2.2.10 7.2d
Legend
Inkscape 0.48 unsupported
Inkscape trunk unsupported
GTK+ 3 builds unsupported

1 FTBFS with GCC 4.8

Getting and Installing Source packages

If your distro does not have some packages available (like many don't, ie, Fedora Core 2), you must often download source packages and build and install them yourself. Actually this is not that hard, and is similar to doing a Gentoo 'emerge.'

  • Usually you download a file with a name like somepackage-1.0.tar.gz. Unpack it with
   $ tar zxf somepackage-1.0.tar.gz
   or
   $ tar jxf somepackage-1.0.tar.bz2
  • Then 'cd' into the new directory.
  • Configure it with the command:
   $ ./configure
  • Build it with:
   $ make
  • As the 'root' user, install it with:
   # make install

Boehm-GC

Source: http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source

Binaries: If searching for a package for GC, the name of it is sometimes:

  • gc
  • libgc
  • gc-devel
  • libgc-devel
  • boehm-gc (on Gentoo)
  • debian/ubuntu: sudo apt-get install libgc-dev

libSigc++

Source: http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/libsigc++-2.2.3.tar.bz2

With this file, and for GlibMM and GtkMM below, it is usually desirable for us developers to build this C++ library statically. This removes a dependency that might be difficult for an end-user during installation. Configure it with:

   ./configure --enable-static --disable-shared

GlibMM

Try to match your Glib2 version with GlibMM's version. For example, if your Glib2 is 2.16.6, download glibmm-2.16.4.tar.bz2.

Latest source: http://ftp.gnome.org/pub/GNOME/sources/glibmm/

GtkMM

Usually you can try the latest version of GtkMM, but if you get version mismatch errors, try older releases.

Source: http://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.12/gtkmm-2.12.7.tar.bz2

cairomm

if you got prompted about cairomm, try first solve your cairo version, so you can grab there a compatible version.


Boost

Many users have reported when building from source that after installing the above dependencies, the configure script still requires a "boost" package. It can be found below, but even after installing, you will need to create a symlink to allow the configure script to find it:

   ln -s /usr/local/include/boost_1_xx_x/boost /usr/local/include/boost

Source: http://www.boost.org/users/download/

Poppler

Source: http://poppler.freedesktop.org/

Poppler is required for PDF import. There are several potential issues:

  • Some Linux distributions do not ship the Xpdf headers required by Inkscape. In such cases, you need to recompile Poppler, passing --enable-xpdf-headers on the configure line or install the libpoppler-private-dev package. See this wishlist bug. This typically manifests in error messages like this:
In file included from extension/internal/pdfinput/svg-builder.cpp:19:
extension/internal/pdfinput/svg-builder.h:32:23: error: CharTypes.h: No such file or directory
...
make[2]: *** [extension/internal/pdfinput/svg-builder.o] Error 1
make[2]: Leaving directory `/tmp/build/inkscape-0.46/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/build/inkscape-0.46'
make: *** [all] Error 2
  • Inkscape 0.47 does not compile with Poppler >= 0.12.2. If you need to compile Inkscape on such systems, use the development version from Bazaar, where this bug is fixed. See the bug report for details and a minimal patch.
  • Inkscape compiled with Poppler <= 0.12.1 will run on systems with Poppler >= 0.12.2, but the PDF import function will crash instantly. This problem does not concern Windows users, since the correct Poppler version is contained in the Windows installer package. This cannot be fixed on Inkscape's side: those two versions of Poppler are not ABI compatible, yet share the same soname. See this bug for more details.
  • Poppler's Xpdf headers are not guaranteed to be API-compatible between releases. It's likely that future Poppler versions will break PDF import in some way. PDF import works at least up to 0.12.4 but might not work with later versions.
Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox