Release notes/0.92/fr

From Inkscape Wiki
Jump to: navigation, search

Other languages: العربية Català Česky Deutsch English Español Français Italiano 日本語 한국어 Português Русский Slovenčina 中文

Contents

Inkscape 0.92

Sorti le 01/01/2017.

Nouveautés en lumière

  • Les filets de dégradés peuvent désormais être utilisés.
  • De nombreuses propriétés SVG 2 et CSS 3 sont à présent supportées pour le rendu (par ex. paint-order, mix-blend-mode). Toutes ne sont pas disponibles à partir de l'interface graphique.
  • La nouvelle boîte de dialogue Objet permet de sélectionner, étiqueter, masquer et verrouiller tout objet du dessin depuis une liste.
  • Les ensembles de sélection permettent de « grouper » des objets indépendamment de la structure du document.
  • Les guides peuvent à présent être verrouillés afin d’éviter d’être déplacés involontairement.
  • Plusieurs nouveaux effets de chemin ont été ajoutés, parmi lesquels Enveloppe/Perspective, Déformation par grille, Copies en miroir et tournées.
  • Il y a plusieurs nouvelles extensions (par ex. une extension de motif sans couture) et un nouveau filtre (simulation de couleurs pour daltoniens) inclus dans la version ; de nombreuses anciennes extensions ont été mises à jour et ont obtenu de nouvelles fonctionnalités.
  • Les outils Aérographe et Mesurer ont acquis un lot de nouvelles fonctionnalités très pratiques.
  • Les lignes créées avec l’outil Crayon sont lissées interactivement.
  • Les B-splines (et plus) sont disponibles avec l’outil Stylo.
  • Un arrière-plan en damier peut être utilisé pour distinguer plus aisément les objets transparents.

Visionner la vidéo de présentation de la nouvelle version

Changements importants

  • La résolution par défaut a été changée de 90 ppp à 96 ppp afin de se conformer au standard CSS. Pour obtenir davantage d’informations, consultez l’article du wiki sur la manipulation d’unités dans Inkscape. Inkscape 0.92 essaiera de détecter les documents Inkscape « hérités » qui doivent être convertis. Si un tel document est détecté, trois options seront proposées à l’utilisateur :
    1. Définir la « zone de vue ». Inkscape ajoutera une « zone de vue » (view box) au document qui effectuera un redimensionnement global, et ajustera la largeur et la hauteur du document si nécessaire.
    2. Redimensionner les éléments. Inkscape redimensionnera chacun des éléments, un par un.
    3. Ignorer. Ne rien faire. Choix approprié pour les documents prévus pour être affichés sur écran.
    [Consultez le rapport de bogue à régler pour la livraison pour plus de détails.]

Manipulation des objets

Boîte de dialogue Objet

Nouvelle boîte de dialogue pour manipuler l’arborescence d’objets.

  • Glisser-déposer pour ordonner les objets.
  • Verrouiller et masquer un ou plusieurs éléments.
  • Utiliser Ctrl+F pour rechercher un élément.
  • Sélectionner un ou plusieurs objets du dessin.
  • Afficher des objets individuels comme des calques.
  • Possibilité de changer la couleur de surbrillance des objets.
  • Possibilité de définir le mode de fondu pour chaque objet.

Fonctionnalité importée depuis le projet Ponyscape.

Boîte de dialogue Ensembles de sélection

Nouvelle boîte de dialogue qui permet de créer des ensembles de sélection qui ne sont pas affectés par la structure du document.

Utilisation :

  • Ouvrir la boîte de dialogue avec Objet > Ensembles de sélection
  • Pour créer un nouvel ensemble de sélection : cliquer sur le bouton « + » en bas du panneau (double-cliquer sur son libellé pour le modifier).
  • Pour ajouter des objets à un ensemble de sélection :
    1. sélectionner les objets sur le canevas ;
    2. dans le panneau « Ensembles de sélection », cliquer sur l’icône « + » avant l’ensemble de sélection dans la liste.
  • Pour sélectionner tous les objets d’un ensemble de sélection : tout désélectionner puis cliquer sur l’ensemble de sélection dans la liste.
  • Pour retirer un objet d’un ensemble de sélection :
    1. sélectionner l’ensemble de sélection dans le panneau ;
    2. cliquer sur « Éléments » pour afficher tous les objets de l’ensemble ;
    3. sélectionner un objet sur le canevas ou la liste d’éléments dans le panneau ;
    4. cliquer sur l’icône « Supprimer » (poubelle) à côté de l’objet dans la liste.
  • Pour supprimer un ensemble de sélection : le sélectionner dans la liste et cliquer sur le bouton « − » en bas du panneau.

Texte

Polices de caractères

Il est dorénavant possible d’utiliser les tables OpenType pour choisir des glyphes alternatifs à partir d’une police de caractères. À cette fin, un troisième onglet (« Variantes ») a été ajouté au panneau « Texte et police ». À noter toutefois que le support par les navigateurs reste limité. Inkscape doit également être lié à une version récente de la bibliothèque Pango.

Texte vertical

Le support du texte vertical a été amélioré.

  • Le comportement par défaut pour les glyphes de caractères latins a été changé. Ils sont à présent tournés de côté comme spécifié dans le standard SVG 1.1.
  • Le support de la propriété CSS 3 « text-orientation » a été ajouté (notez que cette propriété n’est pas encore entièrement prise en charge par les navigateurs).
  • Les valeurs CSS 3 pour la propriété « writing-mode » sont supportées pour le rendu. L’enregistrement utilise toujours les valeurs SVG 1.1 dépréciées.

Accessibilité

Convertir du texte en chemin enregistrera le texte dans l’attribut « aria-label ». Cela peut permettre aux outils d’accessibilité de s’en servir et pourra peut-être être utilisé par Inkscape pour reconstruire le texte.

Interlignage

L’interlignage dans Inkscape fonctionne maintenant comme défini dans le standard CSS avec la propriété « line-height ». Notez les choses suivantes :

  • Pour l’ensemble : font-size: 40px; line-height: 1.25;
    Pour l’ensemble : font-size: 40px; line-height: 1.25em;
    L’unité pour la hauteur de ligne peut maintenant être choisie. Les versions précédentes d’Inkscape utilisaient une valeur sans unité. Lorsqu’aucune unité n’est indiquée, l’espacement entre les lignes est proportionnel à la taille de la police. Il s’agit du comportement habituellement souhaité. Lorsqu’une unité est indiquée, l’espacement entre les lignes est indépendant de la taille de la police. Cependant, les lignes ne seront pas forcément uniformément espacées en raison des règles de la spécification. (Consultez le billet de Tav CSS Text Line Spacing Exposed pour connaître les détails.)
  • Pour l’ensemble : font-size: 40px; line-height: 0;, pour l’intérieur : line-height: 1.25em;
    L’espacement minimum entre les lignes dépend de la valeur « strut », déterminée par le produit de la taille de la police et la hauteur de ligne de l’élément principal. Ces valeurs peuvent être visionnées et modifiées lorsque le bouton « Afficher le style extérieur » est enfoncé dans la barre de contrôle de l’outil Texte. Pour définir le « strut » à zéro, définissez la hauteur de ligne du style extérieur à zéro.
    Si la hauteur du « strut » est nulle, vous devez définir la hauteur de ligne de tous les éléments texte descendants pour éviter que les lignes se superposent. Sélectionnez tout le texte avec Ctrl+A et relâchez le bouton « Afficher le style extérieur » pour définir la hauteur de ligne de tous les descendants.
    Note : lorsque le bouton n’est pas enfoncé, les composants « Taille de police » et « Hauteur de ligne » affichent les valeurs soit pour le texte sélectionné soit à l’emplacement du curseur (s’il n’y a pas de texte sélectionné). Les changements dans la taille de police et la hauteur de ligne s’appliqueront à la hauteur de ligne ou à tous les descendants (s’il n’y a pas de texte sélectionné). La hauteur de ligne pour chaque caractère n’est pas repérable visuellement (contrairement aux autres propriétés de style, comme la couleur de remplissage). Vous devez déplacer votre curseur pour déterminer quels caractères ont la même hauteur de ligne.
  • Pour l’ensemble : font-size: 40px; line-height: 1.25;, pour l’intérieur : line-height: 0;
    Pour que les lignes soient uniformément espacées indépendamment de la taille de la police, définissez la valeur « strut » à la hauteur de ligne désirée et définissez la hauteur des lignes internes à zéro.

Effets de chemin interactifs (ECI)

  • Certains effets de chemin interactifs peuvent maintenant être appliqués aux découpes et aux masques.
  • Les « lignes adjointes » sont de retour.
  • L’option pour ajouter un chemin incurvé directement a été ajoutée à la liste déroulante des outils Stylo et Crayon.

Spiro interactif

Vidéo détaillée : https://www.youtube.com/watch?v=bFakiI5f0-Y

Basé sur l’ECI Spiro, affiche désormais le résultat pendant le dessin.

  • Les nœuds de rebroussement peuvent être créés en enfonçant la touche Maj.
  • Lorsque vous ajoutez un chemin en mode rebroussement ou Spiro, le chemin adjoint d’aperçu est affiché.

Spirolive.gif

B-spline

Vidéo détaillée : https://www.youtube.com/watch?v=vwV0DHvA-OE

Outils Nœuds et Stylo

Utilisent l’ECI B-spline en créant et modifiant des chemins.

  • Fonctionne directement avec les outils Stylo et Crayon.
  • Avec l’outil Stylo, enfoncez Maj pour créer des nœuds de rebroussement.
  • Lorsqu’un chemin est ajouté, un chemin adjoint d’aperçu sera également affiché.
  • Enfoncez Maj et déplacez une poignée pour changer le poids d’une B-spline avec l’outil Nœuds.
  • Des incréments de poids sont utilisés lorsque Ctrl est enfoncée et qu’une poignée est déplacée avec l’outil Nœuds (pas besoin de Maj).
  • Double-cliquez sur une poignée pour réinitialiser son poids à la valeur par défaut.

Bspline.gif Bspline2.gif

Outil Effet de chemin interactif

ECI B-spline

Les options du panneau Effet de chemin interactif donnent un contrôle complet sur les chemins B-spline.

  • Option pour utiliser le Poids par défaut (0,3333 fois le segment incurvé).
  • Option pour transformer les nœuds en points de rebroussement.
  • Champ pour saisir le poids au clavier.
  • Option pour définir la taille des incréments avec Ctrl pour définir rapidement des poids précis en édition de nœuds/poignées.
  • Appliquer les changements si le poids… applique les changements saisis dans le formulaire à tous les nœuds de poids nul, supérieur à zéro ou les deux ; par exemple, conserve les points de rebroussement lorsque vous modifiez le poids et avez désélectionné « Appliquer les changements si le poids = 0 ».
  • Ne changer que les nœuds sélectionnés s’applique pour tous les autres changements saisis.
  • Affichage d’un chemin adjoint avec la forme finale et les nouveaux nœuds générés.

Agitation

ECI Agitation

Vidéo détaillée : https://www.youtube.com/watch?v=130Dbt0juvY

Cet effet de chemin est un semi-clone de deux extensions : « ajouter des nœuds » et « éparpiller les nœuds » et permet d’utiliser des unités.

Les paramètres sont similaires à ceux des deux extensions et comprennent en plus un taux d’aléatoire global.

  • Peut être appliqué aux chemins, formes et groupes.
  • Peut être appliqué aux découpes et aux masques s’il s’agit d’objets vectoriels.

Roughen.gif

Simplifier

ECI Simplifier

En vidéo : https://www.youtube.com/watch?v=gaWujN_iTSk

Simplifie un composant vectoriel avec un ECI non destructif.

  • Peut être utilisé sur des chemins et des formes éventuellement au sein de groupes.
  • Peut être appliqué sur des découpes et des masques si ce sont des objets vectoriels.
  • Le seuil de l’effet peut être modifié dans la fenêtre des préférences, avec un paramètres numérique.
  • La simplification peut être répétée dans le même ECI.

Simplify.gif

Cet effet de chemin peut éventuellement être appliqué directement avec la barre de contrôle de l’outil Crayon lors de la création d’un nouveau chemin. Il remplace alors le lissage habituel (qui serait une opération destructive).

Perspective et enveloppe

ECI Perspective et enveloppe

Vidéo détaillée : https://www.youtube.com/watch?v=CjKGatyxTZ8

Les deux déformations s’appliquent en sélectionnant 4 points.

  • Deux modes : perspective et enveloppe.
  • Peuvent être utilisés sur des chemins, des formes et des groupes.
  • Fonctionne aussi sur les découpes et masques vectoriels.

Perspective-envelope.gif

Déformation par grille 2

ECI Déformation par grille 2

Vidéo détaillée : https://www.youtube.com/watch?v=YlK9L88_tWE
Vidéo de la symétrie : https://www.youtube.com/watch?v=jhuVjqFA6ig

  • Déforme un objet avec 25 poignées organisées sur un filet.
  • Déforme éventuellement symétriquement le long de l’axe vertical ou horizontal, ou bien les deux.
  • Peut être utilisé sur des chemins, des formes et des groupes.
  • Fonctionne aussi sur sur les découpes et masques vectoriels.

Latice2.gif

Afficher les poignées

ECI Afficher les poignées

Vidéo détaillée : https://www.youtube.com/watch?v=h9ul_PR9XYo

Une version en ECI de l’extension Afficher les poignées.

  • Fonctionne sur les chemins, les formes et les groupes.
  • Fonctionne sur les clones.
  • Les formes avec nœuds et poignées peuvent être redimensionnées.
  • S’il n’est pas appliqué sur un clone, l’ECI est destructif : il n’enregistre pas les styles. Il vaut mieux travailler sur une copie !

ShowHandles.gif

Transformation par deux points

ECI Transformation par deux points

Vidéo détaillée : https://www.youtube.com/watch?v=ZLmYdWoXXIw
Vidéo détaillée (gomme élastique) : https://www.youtube.com/watch?v=lOWTeZC_LjM

Transforme un élément selon deux points de contrôle (par ex. pour déplacement, inclinaison, redimensionnement et rotation). Les points de contrôle peuvent être au choix le milieu d’un côté de la boîte englobante ou l’un des nœuds du chemin original défini par son indice. Merci à Ivan Louette d’avoir proposé cet effet !

  • Fonctionne sur les chemins et formes. Pour les groupes, les fonctionnalités sont limitées à la boîte englobante.
  • Les deux points de contrôle peuvent être sensibles au magnétisme.
  • L’angle ou la distance peuvent être fixés.
  • Le mode élastique peut simuler un chemin élastique.
  • Deux milieux de côté de la boîte englobante peuvent être utilisé comme points de contrôle si « Depuis l’épaisseur originale » est activé.

TransformByTwoKnots.gif

Tourner les copies

ECI Tourner les copies

Vidéo détaillée (fonte partielle de chemin) : https://www.youtube.com/watch?v=UpI8gRbkTu4
Vidéo détaillée (édition interactive) : https://www.youtube.com/watch?v=fBQpvfgT4mE
Vidéo détaillée (kaléidoscope) : https://www.youtube.com/watch?v=LfMixSKy3Eo

Organise dynamiquement des éléments identiques sur un arc ou un cercle.

  • Fonctionne sur les chemins, les formes et les groupes de chemins.
  • Permet de fondre le résultat pour produire des effets façon kaléidoscope.
  • Permet d’organiser les copies sur un arc lorsque la case des copies sur 360° n’est pas cochée.
  • Rendu en temps réel.

Reflet miroir

ECI Miroir

Vidéo détaillée : https://www.youtube.com/watch?v=m1sj4AeU3Yo

Reflète un élément dynamiquement.

  • Fonctionne sur les chemins, les formes et les groupes.
  • Permet de fusionner l’original et le résultat.
  • Différents axes de symétrie possibles : libre, abscisse centre de la boîte englobante, ordonnée centre de la boîte englobante, abscisse centre du document et ordonnée centre du document.

Joindre un chemin

ECI Joindre un chemin

Connecter un chemin à un autre chemin (éventuellement à chaque extrémité), en le joignant à l’emplacement spécifié sur l’autre chemin (valeur de la forme <n° du nœud>.<fraction de la longueur du segment>, ou en déplaçant une poignée).

Le segment incurvé se connectant peut être formé avec des poignées ou par saisie d’un nombre.

Cet ECI rend possibles pour la première fois les « croisements » entre chemins suivant les mouvements du chemin après modifications, ce que la spécification du SVG ne prend pas en charge.

Boîte englobante

ECI Boîte englobante

Un chemin quelconque peut être utilisé comme boîte englobante rectangulaire pour le chemin lié. Les transformations appliquées au chemin lié s’appliqueront également sur la boîte englobante. Cela peut, par exemple, être utilisé pour ajouter un arrière-plan pour l’export en PNG.

Ellipse par cinq points

ECI Ellipse par cinq points

Une ellipse sera construite, et sa circonférence passera par tous les nœuds d’un chemin à 5 nœuds.

Remplir dans les nuées

ECI Remplir dans les nuées

Ajoute un fond à un ensemble de chemins ouverts indépendants, connectant leurs extrémités avec des lignes droites.

  • L’ECI s’applique à un chemin (qui sera converti en fond, et sert de « conteneur » pour l’effet).
  • Les autres chemins, qui font partie du dessin, peuvent alors être ajoutés à l’effet par copier-coller dans le panneau des ECI.
  • L’ordre dans lequel les chemins sont remplis peut être changé, et le sens peut être inversé indépendamment pour chaque chemin.

Il est maintenant possible d’appliquer la série d’effets de chemin qui ne fonctionnent que sur un chemin sans sous-chemins (Contour dynamique, Contour fuselé…) aux chemins seuls (voir l’image pour un exemple).

Remplir entre les contours

ECI Remplir entre les contours

Similaire à « Remplir dans les nuées » mais peut seulement être utilisé sur deux chemins ouverts, afin de les remplir sans couture.

  • Nécessite un chemin « conteneur », qui sera converti en fond une fois que le premier chemin a été ajouté à l’ECI.
  • Connecte un couple d’extrémités de chemin à un contour, si le chemin qui sert de conteneur a un contour.
  • Peut également être utilisé pour réutiliser un contour.

Interpoler des points

Variantes obtenues avec l’ECI Interpoler des points

Cet ECI redessine tous les segments du chemin, en utilisant l’une des méthodes d’interpolation suivantes :

  • Catmull-Rom centripète,
  • adaptation Bézier cubique,
  • Johan Bézier cubique,
  • linéaire,
  • interpolateur Spiro.

Type de jointure

Variantes obtenues avec l’ECI Type de jointure

Cet ECI permet de définir le type de connexion à utiliser sur des nœuds en pointe et les terminaisons de chemins.

  • Types de jointure disponibles :
    • biseautée,
    • arc extrapolé,
    • arc extrapolé Alt1,
    • arc extrapolé Alt2,
    • arc extrapolé Alt3,
    • raccordée,
    • raccordée et coupée,
    • arrondie.
  • Types de terminaison possibles :
    • sur le nœud,
    • sur l’arête,
    • arrondie,
    • carrée.
  • Le taux de raccord peut être défini.
  • L’épaisseur du contour peut être définie.

Contour fuselé

Variantes obtenues avec l’ECI Contour fuselé

Dessiner des contours fuselés avec différents réglages pour des chemins ouverts sans sous-chemins.

  • Changer l’épaisseur du contour aux extrémités avec des poignées sur chaque extrémité, ou en entrant un décalage numériquement.
  • Différents taux d’arrondi peuvent être appliqués.
  • L’épaisseur du contour peut être changée.
  • Le type de jointure des nœuds de terminaison peut être sélectionné :
    • biseautée,
    • extrapolée,
    • raccordée,
    • arrondie.

Outil Stylo/Bézier

  • Nouveau raccourci pour fermer automatiquement un chemin en cours de dessin : Maj+Entrée.

Outil Aérographe

Vidéo détaillée 1 (pas de recouvrement) : https://www.youtube.com/watch?v=uehj4ATOWos
Vidéo détaillée 2 (pas de recouvrement de plusieurs éléments) : https://www.youtube.com/watch?v=1eTG2U3qlb4
Vidéo détaillée 3 (sur les surfaces, sélection de couleur) : https://www.youtube.com/watch?v=aTdKu7mAZE8
Vidéo détaillée 4 (pression) : https://www.youtube.com/watch?v=kWdQnxd_z30
Vidéo détaillée 5 (options de vectorisation des clones): https://www.youtube.com/watch?v=Zn3vzf-yA_w

  • Nouveau mode : effacement.
  • Nouveaux interrupteurs de pression ajoutés.
  • Option « Pas de chevauchement » pour des éléments multiples.
  • Option « Pas de chevauchement » pour des couleurs de fond différentes.
  • Décalage paramétrable pour les recouvrements.
  • Sélecteur de couleur depuis le centre ou la zone moyenne.
  • Couleur applicable au fond.
  • Couleur applicable au contour.
  • Les couleurs sélectionnées peuvent être inversées.
  • L’éclaboussement peut se limiter aux fonds transparents.
  • L’éclaboussement peut se limiter aux fonds non transparents.
  • Options de la section « Vectoriser le dessin » du panneau de pavage de clones intégrées.

Outil Mesurer

Vidéo de présentation : https://www.youtube.com/watch?v=OE0cVDGCzbM

  • Le rapporteur reste posé en attendant qu’une nouvelle mesure soit réalisée (lorsque l’outil Mesurer est utilisé).
  • L’origine est l’extrémité peuvent être repositionnées.
  • La mesure peut être convertie en objet ou en guides.
  • La mesure de la distance peut être ajoutée en tant qu’objets : un texte éditable et une ligne allant de l’origine à l’extrémité.
  • Une « mesure fantôme » peut être temporairement affichée afin de pouvoir comparer deux mesures.
  • L’origine et l’extrémité peuvent être inversées.
  • La mesure peut être globale ou liée au calque en cours d’utilisation.
  • La précision peut être modifiée.

Outil Dégradé

  • Afin d’être plus accessible aux claviers ne comprenant pas de touche Insertion, l’ajout d’un stop dans un dégradé peut désormais également se faire avec le raccourci clavier Maj+I.

Aligner et distribuer

  • Options pour aligner les nœuds les uns par rapport aux autres avec l’outil Nœuds.

Import / Export

Exporter en PDF / EPS / PS

  • Le niveau PostScript par défaut à l’exportation en ligne de commande est passé de 2 à 3 (s’accordant ainsi avec l’interface graphique pour laquelle le niveau par défaut est le 3). Le niveau 3 est requis pour le support des dégradés.

Exporter en SVG optimisé

  • Fenêtre des réglages complètement repensée.
  • À partir de sa version 0.92, Inkscape utilise la version de Scour installée sur le système (par ex. avec pip install scour) au lieu d’une version empaquetée avec Inkscape de sorte que les améliorations les plus récentes puissent être utilisées.
  • Tout un lot de nouvelles fonctionnalités et correctifs dans le module Scour lui-même. Consultez les notes de version (Inkscape 0.91 utilisait Scour 0.26 du 09/05/2011).

Exporter en PNG

  • L’extension de nom de fichier .png est désormais forcée, afin d’empêcher l’export avec des extensions incorrectes.

Extensions

Nouveautés

  • Rendu > Motif sans couture (en vidéo)
  • Images > Définir les attributs de l’image (bogue #1357808, peut être utilisé pour résoudre le souci de redimensionnement des pixelimages insérées dans les SVG créés avec des versions antérieures)
  • Rendu > Jolis graphiques (dépôt GitHub, non maintenu)
  • Organiser > Dégrouper récursivement (bogue #171117)

Pilote de traceur

Stylos multiples

Le pilote de traceur (Extensions > Exporter > Traceur) peut désormais gérer plusieurs stylos afin de réaliser des dessins colorés sur les traceurs à stylos :

  • créer un calque pour chaque stylo à utiliser et déplacer les dessins correspondants dessus ;
  • nommer le calque avec un nom tel que « Stylo 1 » ou « NomDeMonCalque Stylo 1 » où le nombre correspond au numéro du stylo que le traceur doit utiliser ;
  • le nom du calque a toujours priorité sur le stylo à utiliser défini dans le menu de traçage.

Connexion série

Les paramètres de connexion vous permettent maintenant de spécifier des réglages d’usage très spécifique tels que la taille d’octet, les bits d’arrêt et la parité. La plupart des traceurs fonctionnent avec les réglages par défaut, ne les changez donc que si vous savez ce que vous faites.

Export HPGL

L’export HPGL (Fichier > Enregistrer sous… > Fichier HP Graphics Language pour table traçante) gère à présent la même fonctionnalité que le #Pilote de traceur : les stylos multiples.

Import HPGL

L’import HPGL (Fichier > Ouvrir… > Fichier HP Graphics Language) peut maintenant importer des stylos multiples dans les calques correspondants ; voir la section #Pilote de traceur.

Import PDF

La valeur « Interpoler » de l’image est dorénavant utilisée pour déterminer comment les pixelimages doivent être affichées (avec interpolation ou en bloc).

Améliorations diverses

  • Organiser > Ré-empiler… propose de nouvelles options pour inverser et mélanger les objets sélectionnés dans l’empilement.
  • Rendu > Arbre aléatoire… propose une nouvelle option pour ignorer les segments redondants.
  • Visualisation de chemin > Mesurer un chemin… propose de nouvelles options pour la disposition de texte.
  • Rendu > Code-barres a été mis à jour avec le nouveau code EAN2 et le code EAN13 étendu avec EAN2 et EAN5 automatiques.
  • Couleur > Aléatoire… permet dorénavant de définir le niveau d’aléatoire, et (dans une certaine limite) de modifier l’opacité.
  • Modifier le chemin > Déplacer les nœuds aléatoirement a été partiellement réécrit et supporte maintenant les lois de Pareto et log-normale.

Développement d’extensions

  • Il est désormais possible pour une extension de récupérer la liste des nœuds sélectionnés (extension d’exemple avec le bogue #171640).

Filtres / modes de fondu

Nouveaux filtres

  • Le filtre Couleur > Perception des couleurs permet de simuler différentes conditions de perception des couleurs.

Nouveaux modes de fondu

Les modes de fondu peuvent maintenant être appliqués à de simples objets aussi bien qu’à des calques.

Aux modes déjà disponibles (« Produit », « Superposition » (tamise), « Obscurcir » et « Éclaircir ») ont été ajoutés les suivants :

  • Superposition (tapissage),
  • Estompage de couleur,
  • Brûlage de couleur,
  • Lumière crue,
  • Lumière douce,
  • Différence,
  • Exclusion,
  • Teinte,
  • Saturation,
  • Coloration,
  • Luminosité.

Autres panneaux

Propriétés du document : Licences

La liste des licences pouvant être choisies a été mise à jour avec les versions les plus récentes.

Éditeur de filtres

La liste des filtres affiche à présent à quelle fréquence les filtres ont été utilisés.

Menus

  • « Ajuster la page à la sélection » ajouté au menu « Édition », raccourci : Ctrl+Maj+R.
  • « Sortir la sélection du groupe » disponible dans le menu contextuel des objets faisant partie d’un groupe, lorsque l’édition s’effectue au sein d’un groupe, et également dans le menu « Objets ». Cette action remonte l’objet d’un niveau dans la hiérarchie des groupes.
  • « Créer un groupe de découpe » du menu contextuel groupe les objets sélectionnés et découpe le groupe avec un clone de lui-même. Cela permet de produire rapidement, entre autres, des ombres propres.

Autres éléments d’interface utilisateur

Magnétisme des nœuds

Le magnétisme avec l’outil Nœuds a été amélioré :

  • Avec un double-clic pour insérer de nouveaux nœuds, la position de ces nouveaux nœuds va s’aimanter, par exemple aux intersections entre chemins/guides.
  • Lors du déplacement du segment d’un chemin afin de le déformer, le pointeur sera affecté par le magnétisme.

Arrière-plan en damier

Il est à présent possible d’utiliser un arrière-plan en damier pour l’édition, afin de discerner plus facilement la transparence des objets (voir l’onglet « Page » de la boîte de dialogue « Propriétés du document »).

Zone de vue

Il est désormais possible de définir la valeur de l’attribut « viewBox » depuis un panneau de réglages. Cet attribut définit l’échelle du dessin en déterminant la valeur réelle de l’unité utilisateur SVG (taille du pixel).

Verrouillage des guides

Les guides peuvent dorénavant être verrouillés et déverrouillés, tous ensemble ou individuellement.

Déplacement sur le canevas

Le déplacement sur le canevas avec la barre d’espace peut désormais être désactivé dans les Préférences (en décochant Comportement > Défilement > Le bouton gauche de la souris fait défiler quand la touche Espace est enfoncée).

SVG et CSS

  • La propriété « marker-orientation » prend à présent en charge les unités (« deg », « rad », « grad » et « turn »).
  • Les nouvelles propriétés SVG 2 « context-fill » et « context-stroke » sont implémentées, ce qui permet aux pointes en flèche d’utiliser automatiquement la couleur du contour du chemin comme couleur de fond.
  • La nouvelle valeur SVG 2 pour l’attribut « marker-orientation », « auto-start-reverse », est désormais implémentée. Cela permet à une pointe en flèche d’être utilisée pour les deux extrémités d’un chemin.
  • Les nouvelles propriétés CSS 3 « mix-blend-mode » et « isolation » sont implémentées, ce qui permet de définir le mode de fondu entre les objets sans utiliser de filtre.
  • La nouvelle propriété SVG 2 « paint-order » est maintenant fonctionnelle. Cela permet de définir l’ordre dans lequel le fond, le contour et les marqueurs sont dessinées (voir l’onglet « Style du contour » de la boîte de dialogue « Fond et contour »).
  • La valeur « non-scaling-stroke » de la propriété SVG 1.2/SVG 2 « vector-effect » est désormais supportée. Elle permet de conserver une largeur de contour fixe indépendamment du facteur de zoom.
  • Le nouveau serveur de dessins « mesh » (filets) SVG 2 est supporté, incluant auto-lissage bicubique. Une interface graphique primitive est disponible.
  • La propriété SVG 1.1 « text-decoration » est maintenant supportée dans le rendu (soulignement, barré, etc.). La propriété CSS 3 « text-decoration » est également rendue.
  • Le nouveau serveur de dessin « hatch » (hachures) SVG 2 est maintenant supporté.
  • La propriété CSS « white-space » est à présent supportée. L’usage de cette propriété a été ajoutée en SVG 2 pour remplacer l’attribut « xml:space » désormais déprécié.
  • Les attributs SVG 1.1 « textLength » et « textAdjust » sont implémentés, mais aucune interface n’est dédiée à leur édition.
  • Le rendu de la primitive de filtre Transfert de composantes a été corrigé.
  • Les unités sont maintenant prises en charge pour les attributs « x », « y », « dx » et « dy » des balises text et tspan.
  • Les valeurs de pourcentage sont maintenant interprétées correctement pour les formes.

Les nouvelles fonctionnalités SVG 2 et CSS 3 ne sont généralement pas mises à disposition dans l’interface avant d’être largement prises en charge par les navigateurs.

Nouvelles dépendances

  • Les outils Pot de peinture et Vectoriser l’objet matriciel utilisent désormais une copie externe de la bibliothèque Potrace, disponible dans de nombreuses distributions Linux et téléchargeable depuis http://potrace.sourceforge.net.
  • L’export vers SVG optimisé dépend maintenant d’une copie externe du module Python Scour, qui peut être obtenu avec pip (pip install scour), avec le gestionnaire de paquets (fournissant potentiellement une version obsolète) ou depuis la page du projet sur GitHub. Pour Windows, le module est inclus.

Traductions

Nouvelles traductions de l’interface : assamais, bodo, cachemiri (écritures perso-arabe et dévanagari), dogri, gujarati, hindi, islandais, kannara, konkanî (écritures latine et dévanagari), maïthili, malayalam, manipuri (écritures meitei et bengali), marathe, odia, santal (écritures dévanagari et ol-chiki), sanskrit, sindhi, tamoul, urdu (écritures perso-arabe et dévanagari). De nombreuses autres traductions ont été mises à jour et améliorées.

Correctifs notables

  • Problèmes de performance sévères sous Ms Windows (paquetages 64 bits) sur les installations utilisant des cartes graphiques Intel (masquer les règles permettait de contourner le problème sous Inkscape 0.91) (bogue #1351597).
  • Sous Ms Windows (paquetages 64 bits), l’impression pouvait donner des pages presque noires lorsque de l’opacité partielle est utilisée dans le document (bogue #1418865).
  • L’impression décalait la page sous Windows (bogue #918319).
  • Les « clones en mosaïques » au sein des groupes/calques transformés dans les documents mis à l’échelle étaient incorrectement placés (bogue #168651).
  • Clones et décalages mal positionnés (bogue #844909, bogue #653574, bogue #1152657, bogue #1245339, bogue #168013, bogue #177751).
  • Plantage à la fermeture avant que l’enregistrement soit complètement effectué, donnant des fichiers enregistrés incomplets (bogue #967416).
  • Guides : La couleur n’était pas restaurée à l’ouverture d’un document enregistré (bogue #1374870).
  • Outil Texte : Échec lors du réglage de la famille de police par défaut (bogue #1227232).
  • Extensions : Échec avec les documents n’ayant pas d’attributs « width » et « height » (bogue #1461346, bogue #1463623).
  • Interface : Certaines icônes étaient absentes avec le thème d’icônes de GTK+ intégré sous Windows et OS X (bogue #1269698).
  • Le rendu des textes coupait parfois le caractère terminal (bogue #1283194, bogue #1450675).
  • Coller le style : Les marqueurs n’étaient pas repris (bogue #1467674).
  • L’export en DXF ne prenait pas en charge les éléments <line> et <circle> (bogue #1474347, bogue #1489320).
  • Plantage à l’import d’images matricielles avec différents types de fichiers (bogue #1467103).
  • Le réglage de la qualité des effets de filtre et du flou fonctionnaient mal (bogue #1512729). Pour obtenir sous Inkscape 0.92 la même qualité de rendu que celle que vous aviez sous Inkscape 0.91, vous devez régler la qualité des effets de filtres à « Moyenne » et la qualité du flou à « Meilleure ».
  • Formes : « Triangle décroissant » et « Triangle croissant » étaient identiques (bogue #1525401).

De nombreux autres plantages, des fuites de mémoire et tout un tas d’autres petites choses ont également été traités. Pour obtenir une liste exhaustive de tous les bogues corrigés, consultez la page des jalons pour Inkscape 0.92 et la page des jalons pour la version (jamais sortie) 0.91.1.

Problèmes connus

  • Les polices de caractères chargées par les logiciels de gestion de polices sous Windows ne peuvent pas être sélectionnés sous Inkscape (bogue #1416674).
  • Les panneaux qui ont été icônifiés ne s’ouvrent plus avant qu’un clic soit effectué sur l’icône dans le point d’ancrage (bogue #1270295, correction prévue pour 0.93).
  • L’indicateur d’opacité ne s’initialise pas correctement (opacité à 0 % même lorsque l’objet est complètement opaque, bogue #1463078, correction prévue pour 0.93).
  • Pour certains textes, la hauteur de ligne utilisée pour afficher le texte avec Inkscape 0.91 ne correspond pas à celle utilisée dans 0.92 ; la hauteur de ligne est donc plus grande qu’elle devrait l’être (il existe une extension qui répare automatiquement les textes).

Versions précédentes