Release notes/0.92/de

From Inkscape Wiki
Jump to: navigation, search

Other languages: العربية Català Česky Deutsch English Español Français Italiano 日本語 한국어 Português Русский Slovenčina 中文

Contents

Inkscape 0.92

Veröffentlicht am 1.1.2017

Die Highlights in dieser Version

  • Gitterverläufe sind jetzt verfügbar
  • Viele SVG2- und CSS3-Eigenschaften werden jetzt korrekt dargestellt (z.B. paint-order, mix-blend-mode). Nicht alle lassen sich über die Benutzeroberfläche ändern.
  • Mithilfe des neuen 'Objekte'-Dialogs, in dem alle Objekte der Zeichnung aufgelistet werden, lässt sich jedes Objekt auswählen, umbennenen, ausblenden oder sperren.
  • Auswahlgruppen ermöglichen es, Objekte unabhängig von der Dokumentenstruktur zu 'gruppieren'.
  • Hilfslinien lassen sich sperren, so dass sie nicht mehr versehentlich verschoben werden können.
  • Es gibt mehrere neue Pfadeffekte, unter anderem Perspektive/Umhüllung, Gitterverformung, Spiegelsymmetrie und Gedrehte Kopien.
  • Es stehen einige neue Erweiterungen zur Verfügung (z.B. eine zum Erstellen nahtloser Muster) und ein neuer Filter (zum Simulieren verschiedener Arten von Farbenblindheit). Viele der bestehenden Erweiterungen wurden aktualisiert oder erhielten neue Funktionen.
  • Die Spraydose und das Messwerkzeug haben ein paar praktische neue Funktionen spendiert bekommen.
  • Pfade, die mit dem Bleistift-/Freihandwerkzeug gezeichnet werden, können jetzt interaktiv geglättet werden.
  • BSplines können jetzt mit dem Füller-/Bézierwerkzeug erstellt werden.
  • Der Hintergrund kann jetzt auch ein Schachbrettmuster zeigen, so dass Transparenzen in Objekten besser zu erkennen sind.

Video mit Präsentation der neuen Funktionen ansehen

Wichtige Änderungen

  • Die Standardauflösung wurde von 90dpi auf 96dpi angehoben, um dem CSS-Standard zu entsprechen. Weitere Hintergrundinformationen hierzu gibt es im Wiki-Artikel über die Verwendung von Einheiten in Inkscape. Inkscape 0.92 wird versuchen 'alte' Inkscape-Dateien, die konvertiert werden müssen, automatisch zu erkennen. Wenn eine solche Datei erkannt wird, bietet Inkscape dem Benutzer die folgenden drei Möglichkeiten an:
    1. 'viewBox' verwenden. Inkscape fügt eine passendes 'viewBox'-Attribut in die Datei ein, wodurch das Dokument als ganzes skaliert wird. Dokumentbreite und Höhe werden, falls nötig, ebenfalls angepasst.
    2. Elemente skalieren. Inkscape wird die Größe jedes enthaltenen Elementes verändern.
    3. Ignorieren. Inkscape nimmt keine Änderung vor. Dies ist eine geeignete Wahl, wenn das Dokument auf einem Bildschirm angezeigt werden soll.
    [Siehe den Fehlerbericht über diesen veröffentlichungskritischen Fehler für weitere Informationen.]
  • Für Entwickler und Paketierer ist der Wechsel von autotools zu CMake relevant (Nutzer, die nicht ihre eigene Version kompilieren, sind nicht von der Änderung betroffen). Während das alte System für 0.92 noch zur Verfügung steht, ist es jetzt auch möglich, Inkscape mit CMake zu kompilieren (Hintergrundinfo und Gründe für den Wechsel und Wie man mit CMake arbeitet).

Objekte verändern

Objekte-Dialog

Dieser neue Dialog ermöglicht es, den Objektbaum zu bearbeiten.

  • Ändern der Z-Ordnung und Gruppierung mittels Drag-and-Drop von Objekten
  • Sperren und Ausblenden eines oder mehrerer gewählter Objekte
  • Suche nach einem Objekt mit Strg + F
  • Auswählen eines oder mehrerer Objekte in der Zeichnung
  • Zeigt sowohl Objekte als auch Ebenen an
  • Erlaubt die Änderung der Hervorhebungsfarbe von Objekten
  • Ermöglicht das Setzen von Mischmodi pro Objekt

Diese Funktion wurde aus Ponyscape importiert.

Auswahlgruppen-Dialog

Dieser neue Dialog ermöglicht das Anlegen von Auswahlgruppen, die unabhängig von der Baumstruktur des Dokumentes sind.

Anleitung:

  • Öffen des Dialogs über 'Objekt > Auswahlgruppen'
  • Erstellen einer neuen Auswahlgruppe:
  1. Auf die Schaltfläche '+' unten im Dialog klicken, um eine neue Auswahlgruppe zu erstellen (nach einem Doppelklick auf den Namen lässt sich dieser bearbeiten)
  • Objekte zu einer Auswahlgruppe hinzufügen:
  1. Objekt auf der Zeichenfläche auswählen
  2. Auf das '+'-Symbol vor der gewünschten Auswahlgruppe in der Liste des 'Auswahlgruppen'-Dialogs klicken
  • Auswählen aller Objekte einer Auswahlgruppe:
  1. Aktuelle Auswahl aufheben und auf die entsprechende Auswahlgruppe in der Liste klicken
  • Objekte aus einer Auswahlgruppe entfernen
  1. Auswahlgruppe im Dialog auswählen
  2. Ein Objekt auf der Zeichenfläche auswählen oder auf 'Objekte' klicken, um alle Objekte in der Gruppe anzuzeigen
  3. Auf das 'Löschen'-Symbol vor dem Objekt in der Liste klicken
  • Zum Löschen einer Auswahlgruppe diese in der Liste auswählen und auf die '-'-Schaltfläche am Unterrand des Dialogs klicken

Text

Schrift-Features

OpenType-Tabellen können jetzt verwendet werden um alternative Zeichen einer Schriftart auszuwählen. Hierfür wurde ein dritter Reiter ('Merkmale') zum 'Text und Schriftart'-Dialog hinzugefügt. Dabei ist zu beachten, dass noch nicht alle Browser diese Funktionen unterstützen. Inkscape muss außerdem eine aktuelle Version der Pango-Bibliothek nutzen.

Vertikaler Text

Die Unterstützung für senkrecht geschriebene Texte wurde verbessert.

  • Das Standardverhalten für Zeichen aus einer lateinischen Schrift wurde geändert. Die Buchstaben sind jetzt seitwärts gedreht, wie es vom SVG-1.1-Standard gefordert wird.
  • Inkscape unterstützt jetzt die Eigenschaft 'text-orientation' von CSS3. (Diese Eigenschaft wird von Webbrowsern noch nicht vollständig unterstützt.)
  • Die CSS3-Werte für die 'writing-mode'-Eigenschaft werden bei der Darstellung unterstützt. Beim Speichern werden noch die alten Werte für SVG 1.1 verwendet.

Barrierefreiheit

Wenn Text in einen Pfad umgewandelt wird, wird der Inhalt des Textes jetzt im Attribut 'aria-label' gespeichert. Dies ist nützlich für barrierefreie Zeichnungen und könnte vielleicht auch irgendwann dazu genutzt werden, den Text mit Inkscape wieder zu rekonstruieren.

Zeilenabstände

Zeilenabstände in Inkscape verhalten sich jetzt gemäß des CSS-Standards für die Eigenschaft 'line-height'. Dabei gibt es folgendes zu beachten:

  • Outer: "font-size:40px;line-height:1.25"
    Outer: "font-size:40px;line-height:1.25em"
    Es kann jetzt eine Einheit für die Zeilenhöhe gewählt werden. Die Vorgängerversionen verwendeten hierfür einen einheitenlosen Wert. Wenn der Wert keine Einheit hat, wird der Zeilenabstand bei jeder Änderung der Schriftgröße neu berechnet. Das ist das Verhalten, das meistens erwartet wird. Wenn der Wert jedoch eine Einheit hat, wird der Zeilenabstand dann berechnet, wenn die CSS-Eigenschaft 'line-height' definiert wird. Dieser Wert wird dann unabhängig von darauffolgenden Änderungen der Schriftgröße verwendet. Hierdurch entstehen jedoch nicht immer gleichmäßige Zeilenabstände, wegen einiger Eigenarten in der Berechnung von Zeilenabständen in CSS. (Siehe hierzu Tavs Zusammenfassung "CSS Text Line Spacing Exposed".)
  • Outer: "font-size:40px;line-height:0", Inner: "line-height:1.25em"
    Der kleinste Abstand zwischen zwei Zeilen wird durch den 'strut'-Wert (englisch: Strebe, Stütze) bestimmt. Dieser berechnet sich als Produkt der Werte für 'font-size' (Schriftgröße) und 'line-height' (Zeilenhöhe) des äußersten Textelements. Diese Werte werden, wenn die Schaltfläche 'Äußerer Stil' in der Werkzeugleiste des Textwerkzeuges aktiviert ist, angezeigt und können verändert werden. Um diesen 'strut' auf Null zu setzen, setzt man die Zeilenhöhe im äußeren Stil auf Null.
    Wenn der 'strut'-Wert eine Höhe von 0 hat, muss man für alle enthaltenen Textelemente eine Zeilenhöhe setzen, damit die Zeilen nicht direkt aufeinander zu liegen kommen. Dazu wählt man beim Bearbeiten des Textes mit Strg+A den ganzen Text aus, und deaktiviert die Schaltfläche für den Stil des gesamten Textelementes.
    Hinweis: Wenn die Schaltfläche "Äußerer Stil" nicht aktiv ist, zeigen die Eingabefelder für Schriftgröße und Zeilenhöhe entweder die Werte des ausgewählten Textes oder den Wert am Ort des Textcursors an (wenn kein Text ausgewählt ist). Änderungen der Schriftgröße und des Zeilenabstandes werden auf den ausgewählten Text, oder, wenn kein Text ausgewählt ist, auf das gesamte Textobjekt angewendet. Anders als bei anderen Stileigenschaften (z.B. Füllfarbe) kann man nicht einfach sehen, welche Zeichen einen bestimmten Wert für Zeilenhöhe haben. Man kann mit dem Cursor Zeichen für Zeichen durch den Text gehen, um sich anzeigen zulassen, von wo bis wo ein Bereich mit gleichem Wert für Zeilenhöhe geht.
  • Outer: "font-size:40px;line-height:1.25", Inner: "line-height:0"
    Um Zeilen zu erhalten, die unabhängig von der Schriftgröße einzelner Textteile immer gleich hoch sind, setzt man den Wert für die Zeilenhöhe des gesamten Textes (den 'strut') auf den gewünschten Wert, und die Werte für die Zeilenhöhe der inneren Textteile auf Null.

Pfadeffekte

  • Einige Pfadeffekte können jetzt auch für Ausschneidepfade und Maskenn genutzt werden.
  • Es gibt wieder eine Vorschauanzeige.
  • Über das Ausklappmenü für die Form des Bézier-/Freihandpfades lässt sich jetzt auch direkt ein Biegepfad zuweisen.
  • Der "Breite"-Parameter der Pfadeffekte "Muster entlang Pfad" und "Biegen" kann jetzt mit einem Anfasser direkt auf der Zeichenfläche verändert werden.

Spiro Live

Ausführliches Video: https://www.youtube.com/watch?v=bFakiI5f0-Y

Diese Funktion basiert auf dem Spiro-Pfadeffekt und zeigt jetzt das Ergebnis schon während des Zeichnens an.

  • Spitze Knoten werden beim Festhalten der Umschalttaste erstellt.
  • Wenn an einem solchen Pfad später ein neuer Pfad angehängt wird, wird auch die Vorschau für das Ergebnis bereits angezeigt.

Spirolive.gif

BSpline

Ausführliches Video <https://www.youtube.com/watch?v=vwV0DHvA-OE>

Bézier-Werkzeug- und Knoten-Modus

Beim Erstellen und Bearbeiten von Pfaden kann der BSpline-Pfadeffekt verwendet werden.

  • Funktioniert direkt mit dem Bézier- und Freihandwerkzeug
  • Spitze Knoten können erstellt werden, wenn die Umschalttaste gedrückt wird (nur Bézierwerkzeug).
  • Wenn ein Pfad später weitergezeichnet wird, wird auch eine Vorschau angezeigt.
  • Die Gewichtung einer BSpline-Kurve kann bei Verwendung des Knotenwerkzeugs durch Festhalten der Umschalttaste und Ziehen an einem Anfasser geändert werden.
  • Einrasten in benutzerdefinierten Gewichtungsschritten, wenn die Strg-Taste festgehalten wird und mit dem Knotenwerkzeug an einem Knoten gezogen wird (Umschalttaste nicht notwendig)
  • Ein Doppelklick auf einen Anfasser setzt die Gewichtung wieder auf den Standardwert zurück.

Bspline.gif Bspline2.gif

Pfadeffekt-Modus

Bspline3.gif

Die Einstellungen im Pfadeffektdialog ermöglichen es, den Bspline-Effekt noch weiter zu kontrollieren.

  • Option, die Gewichtung auf den Standardwert zu setzen (0,3333faches Kurvensegment)
  • Option, Knoten spitz zu machen
  • Eingabe von Zahlenwerten für Gewichtung
  • Option, die Schritte beim Festhalten von Strg einzustellen, mit der beim Bearbeiten der Knoten/Anfasser direkt auf der Zeichenfläche eingerastet werden kann
  • Änderungen anwenden, wenn Gewichtung ... wendet Änderungen in den Einstellfeldern auf alle Knoten an, deren Gewichtung = 0, > 0 oder beides ist. So können zum Beispiel spitze Knoten erhalten werden, wenn das Gewicht geändert wird und die Option "Änderungen anwenden, wenn Gewichtung == 0" deaktiviert ist.
  • Nur ausgewählte Knoten ändern wendet die Änderungen im Dialog nur auf ausgewählte Knoten an.
  • Zeigt eine Pfadvorschau mit der Form des Ergebnispfades und den neuen Knoten an.

Aufrauen

Roughen.png

Ausführliches Video: https://www.youtube.com/watch?v=130Dbt0juvY

Dieser Pfadeffekt hat Ähnlichkeit mit zwei Erweiterungen ("Knoten hinzufügen" und "Knoten zittrig verteilen") und kann mit Einheiten umgehen.

Die Parameter ähneln denen der beiden Erweiterungen und fügen noch einen globalen Zufallswert hinzu.

  • Der Effekt kann auf Pfade, Formen und Gruppen angewendet werden.
  • Er funktioniert auch mit Ausschneidepfaden und Masken, sofern diese Vektorobjekte sind.

Roughen.gif

Vereinfachen

Simplify.png

Ausführliches Video: https://www.youtube.com/watch?v=gaWujN_iTSk

Vereinfacht ein Vektorobjekt mittels eines nicht-destruktiven Pfadeffektes

  • Kann mit Pfaden, Formen und Gruppen davon verwendet werden
  • Kann auf Ausschneidepfade und Masken angewendet werden, sofern diese Vektorobjekte sind
  • Die Basisvereinfachung kann in den Einstellungen für das Malwerkzeug durch Eingabe einer Zahl verändert werden.
  • Vereinfachen kann mehrmals im selben Pfadeffekt angewendet werden.

Simplify.gif

Der Pfadeffekt kann optional direkt über die Werkzeugleiste des Bleistift-/Freihandwerkzeugs ausgewählt werden, wenn ein neuer Pfad damit erstellt wird. Er ersetzt dann die normale Glättung (bei der es sich um einen destruktiven Vorgang handelt).

Perspektive/Umhüllung

Perspective-envelope.png

Ausführliches Video: https://www.youtube.com/watch?v=CjKGatyxTZ8

Für beide Transformationsmodi müssen 4 Punkte angegeben werden.

  • Zwei Modi: Perspektive und Umhüllung
  • Kann mit Pfaden, Formen oder Gruppen verwendet werden
  • Funktioniert auch mit Ausschneidepfaden und Masken, die aus Vektorobjekten bestehen

Perspective-envelope.gif

Gitterverformung 2

Latice2.png

Ausführliches Video: https://www.youtube.com/watch?v=YlK9L88_tWE
Video zur Demonstration der symmetrischen Modi: https://www.youtube.com/watch?v=jhuVjqFA6ig

  • Verformt ein Objekt mit Hilfe von 25 gitterförmig angeordneten Anfassern
  • Optional können die Verformungen entlang der senkrechten / waagerechten Achse (oder beider) durch die Objektmitte gespiegelt werden.
  • Kann auf Pfade, Formen und Gruppen angewendet werden.
  • Funktioniert auch mit Ausschneidepfaden und Masken, sofern diese aus Vektorobjekten bestehen.

Latice2.gif

Anfasser zeigen

ShowHandles.png

Ausführliches Video: https://www.youtube.com/watch?v=h9ul_PR9XYo

Die Pfadeffekt-Version der Erweiterung 'Anfasser zeichnen'.

  • Funktioniert mit Pfaden, Formen und Gruppen
  • Funktioniert auch mit Klonen
  • Knoten- und Anfassergröße können geändert werden
  • Wenn dieser Pfadeffekt nicht mit einem Klon verwendet wird, ist er destruktiv, denn er verändert die Stile des Objektes. Daher am besten mit einer Kopie/einem Klon verwenden!

ShowHandles.gif

Transformation an 2 Punkten

TransformByTwoKnots.png

Ausführliches Video: https://www.youtube.com/watch?v=ZLmYdWoXXIw
Ausführliches Video (elastisches Gummi): https://www.youtube.com/watch?v=lOWTeZC_LjM

Verformt ein Objekt mittels zweier Kontrollpunkte (d.h. verschieben, scheren, Größe ändern und drehen). Die Kontrollpunkte können entweder an den Mittelpunkten der Kanten des Objektrahmens positioniert werden, oder durch Angabe der Knotennummer an einem beliebigen Knoten des Originalpfades. Dank an Ivan Louette für die Idee zu diesem Pfadeffekt!

  • Funktioniert mit Pfaden und Formen. Bei Gruppen können die Kontrollpunkte nur auf dem Objektrahmen positioniert werden.
  • Beide Kontrollpunkte können an anderen Punkten der Zeichnung eingerastet werden.
  • Winkel oder Abstand können gesperrt werden.
  • Im elastischen Modus wird ein Gummibandeffekt erzielt.
  • Die Mittelpunkte der Objektrahmenkanten können als Kontrollpunkte verwendet werden, wenn 'Ursprüngliche Breite' aktive ist.

TransformByTwoKnots.gif

Gedrehte Kopien

Pfadeffekt 'Gedrehte Kopien'

Ausführliches Video (teilweises Verschmelzen der Pfade): https://www.youtube.com/watch?v=UpI8gRbkTu4
Ausführliches Video (Livebearbeitung): https://www.youtube.com/watch?v=fBQpvfgT4mE
Ausführliches Video (Kaleidoskop): https://www.youtube.com/watch?v=LfMixSKy3Eo

Richtet identische Elemente dynamisch an einem Bogen oder Kreis aus.

  • Funktioniert mit Pfaden, Formen und Gruppen von Pfaden
  • Das Ergebnis kann verschmolzen werden um Kaleidoskop-ähnliche Effekte zu erzielen
  • Die Kopien können auch entlang eines Kreisbogens ausgerichtet werden, wenn das Kästchen '360°-Kopien' nicht angekreuzt ist.
  • Livebearbeitung

Spiegelsymmetrie

Pfadeffekt 'Spiegelsymmetrie'

Ausführliches Video: https://www.youtube.com/watch?v=m1sj4AeU3Yo
Erzeugt dynamisch ein Spiegelbild eines Objektes.

  • Funktioniert mit Pfaden, Formen und Gruppen
  • Das Ergebnis kann verschmolzen werden
  • Verschiedene Spiegelachsen: Frei, Objektrahmenzentrum X, Objektrahmenzentrum Y, Seitenmittelpunkt X, Seitenmittelpunkt Y

Pfad anheften

Pfadeffekt 'Pfad anheften'

Verbindet einen Pfad mit einem anderen (optional an beiden Enden), indem der Pfad an einem bestimmten Punkt des anderen Pfades (angegeben als <Knotennummer>,<Anteil an der Länge des aktuellen Segments>, oder durch Ziehen an einem Anfasser) angeheftet wird.

Das verbindende Pfadsegment kann mit Anfassern oder über Zahleneingabefelder verformt werden.

Dieser Pfadeffekt ermöglicht es erstmals, 'Kreuzungen' zwischen Pfaden zu erzeugen, die sich mit dem Pfad bewegen, wenn dieser verändert wird, was in der SVG-Spezifikation so nicht vorgesehen ist.

Objektrahmen

Pfadeffekt 'Objektrahmen'

Ein beliebiger Pfad kann dazu verwendet werden, ein Objektrahmenrechteck für den verknüpften Pfad zu bilden. Dieses Rechteck folgt allen Formänderungen des verknüpften Pfades. Diese Funktion kann beispielsweise dazu verwendet werden, einen Hintergrund für den Export als PNG zu bilden.

Ellipse durch 5 Punkte

Pfadeffekt 'Ellipse durch 5 Punkte'

Es wird eine Ellipse konstruiert, deren Kontur alle Knoten eines aus 5 Knoten bestehenden Pfades passiert.

Zwischen Vielen füllen

Pfadeffekt 'Zwischen Vielen füllen'

Fügt mehreren unabhängigen, offenen Pfaden eine Füllung hinzu, indem deren Enden durch gerade Linien verbunden werden.

  • Der Pfadeffekt wird auf einen Pfad angewendet (der später in die Füllung umgewandelt wird, und der als 'Container' für den Pfadeffekt dient).
  • Die anderen Pfade, die Teil der eigentlichen Zeichnung sind, können dann durch Kopieren/Einfügen im Dialog des Pfadeffektes hinzugefügt werden.
  • Die Reihenfolge, in der die Pfade gefüllt werden, kann verändert werden, und die Richtung kann für jeden einzelnen Pfad umgekehrt werden.

Jetzt können andere Pfadeffekte, die nur mit Pfaden ohne Unterpfade funktionieren (Dynamische Kontur, Pfad verjüngen, ...) auf die einzelnen Pfade angewendet werden (Beispiel s. Bild).

Zwischen Pfaden füllen

Pfadeffekt 'Zwischen Pfaden füllen'
  • Ähnlich 'Zwischen Vielen füllen', füllt jedoch nur zwei offene Pfade.
  • Benötigt einen 'Container'-Pfad, der sich, sobald der erste Pfad zum Effekt hinzugefügt wurde, in die Füllung verwandelt.
  • Verbindet ein Paar Pfadenden mit einer Kontur, sofern der 'Container'-Pfad eine Kontur hat.
  • Kann auch dazu verwendet werden, eine doppelte Außenlinie zu erzeugen.

Punkte interpolieren

Variationen des Pfadeffekts 'Punkte interpolieren'

Dieser Pfadeffekt zeichnet alle Pfadsegmente neu. Dabei kann eine der folgenden Interpolationsmethoden verwendet werden:

  • Centripetal Catmull-Rom
  • CubicBezierFit
  • CubicBezierJohan
  • Linear
  • Spiro-Interpolieren

Verbindungsart

Variationen des Pfadeffektes 'Verbindungsart'

Mit diesem Pfadeffekt können die Art der Verbindung für spitze Knoten und die Pfadenden verändert werden.

  • Wählbare Verbindungsarten:
    • Abgeleitete Kurve
    • Abgeleitete Kurve Variante 1
    • Abgeleitete Kurve Variante 2
    • Abgeleitete Kurve Variante 3
    • Abgerundet
    • Abgeschrägt
    • Gehrung
    • Gestutzte Gehrung
  • Available end cap types:
    • Stoß
    • Spitze
    • Abgerundet
    • Quadrat
  • Gehrungslimit festlegen
  • Linienbreite festlegen

Pfad verjüngen

Variationen des Pfadeffekts 'Pfad verjüngen'

Zeichnet für offene Pfade ohne Unterpfade Konturen, die sich zu den Enden hin verjüngen, enthält verschiedene Optionen.

  • Die Breite der Pfadenden kann mit Anfassern an beiden Enden oder durch Eingabe in Zahlenfelder verändert werden.
  • Die Stärke der Abrundung kann eingestellt werden.
  • Die Konturbreite kann verändert werden.
  • Die Verbindungsart für spitze Knoten kann ausgewählt werden:
    • Abgeschrägt
    • Abgeleitet
    • Gehrung
    • Abgerundet

Füller / Bézier-Werkzeug

  • Neues Tastaturkürzel zum automatischen Schließen eines Pfades, während dieser gezeichnet wird: Shift + Enter

Spraydose

Ausführliches Video 1 (No overlap): https://www.youtube.com/watch?v=uehj4ATOWos
Ausführliches Video 2 (No overlap multiple items): https://www.youtube.com/watch?v=1eTG2U3qlb4
Ausführliches Video 3 (Over visible, pick color): https://www.youtube.com/watch?v=aTdKu7mAZE8
Ausführliches Video 4 (Pressure): https://www.youtube.com/watch?v=kWdQnxd_z30
Ausführliches Video 5 (Trace -clones- dialog): https://www.youtube.com/watch?v=Zn3vzf-yA_w

  • Neu: Löschen-Modus
  • Weitere Optionen können jetzt durch Stiftdruck eines Grafiktabletts beeinflusst werden
  • "Überlappung verhindern"-Option
  • "Überlappung zwischen Farben verhindern"-Option verhindert, dass Objekte auf Übergängen zwischen Hintergrundfarben zu liegen kommen
  • Abstand für Überlappungen ist einstellbar
  • Farbe vom Zentrum oder aus der Durchschnittsfarbe eines Gebietes übernehmen
  • Aufgenommene Farbe auf die Füllung anwenden
  • Aufgenommene Farbe auf die Kontur anwenden
  • Aufgenommene Farben invertieren
  • Auch über transparenten Bereichen sprühen
  • Nur über nicht-transparenten Bereichen sprühen
  • Verwendet die Nachzeichnen-Funktion des Dialogs für gekachelte Klone

Messwerkzeug

Ausführliches Video: https://www.youtube.com/watch?v=OE0cVDGCzbM

  • Bemaßung bleibt erhalten bis eine neue erstellt wird (nur sichtbar, wenn Messwerkzeug verwendet wird)
  • Ursprung und Ende der Bemaßung können verschoben werden
  • Umwandeln der Bemaßung in ein Objekt
  • Umwandeln zu Hilfslinien
  • Hinzufügen einer Linie mit dem Ergebnis der Messung (bearbeitbarer Text) zur Zeichnung
  • Vorübergehende Anzeige eines 'Phantombildes' der letzten Messung, so dass zwei Messungen verglichen werden können
  • Ursprung/Ende umkehren
  • Alles ausmessen
  • Nur in aktueller Ebene messen
  • Genauigkeit ändern

Verlaufswerkzeug

  • Benutzer von Tastaturen ohne Einfügen-Taste können jetzt auch die Tastenkombination Umschalt+I verwenden, um neue Stopps in einen Verlauf einzufügen.

Ausrichten und Verteilen

  • NEU: Ausklappmenü mit Optionen zur Ausrichtung von Knoten aneinander im Knotenbearbeitungsmodus

Import / Export

PDF-/ PS-/ EPS-Export

  • Der standardmäßig verwendete PostScript-Level für das Exportieren von der Kommandozeile wurde von 2 auf 3 geändert (und entspricht damit dem Export aus der Benutzeroberfläche, der ebenfalls standardmäßig Level 3 nutzt). Level 3 wird für Farbverläufe benötigt.

Exportieren eines Optimierten SVG

  • Vollständig überarbeiteter Einstellungsdialog
  • Beginnend mit Version 0.92 verwendet Inkscape die Scour-Version, die auf dem System installiert ist (z.B. über "pip install scour") anstelle der zuvor direkt enthaltenen Version. Dadurch können Benutzer immer von den neuesten Verbesserungen profitieren.
  • Das Scour-Modul selbst erhielt viele neue Funktionen und Fehlerkorrekturen, siehe auch die Veröffentlichungshinweise (Scour 0.26 vom 9.5.2011 war die Version, die in Inkscape 0.91 enthalten war)

Exportieren als PNG

  • Die Dateinamenserweiterung für PNG-Dateien wird jetzt erzwungen, um das Exportieren von Dateien mit ungültigen / irreführenden Dateinamenserweiterungen zu verhindern.

Erweiterungen

Neu

  • Rendern > Nahtloses Muster (Screencast)
  • Bilder > Bildattribute festlegen (Bug #1357808)
  • Rendern > Diagramme (Github-Repositorium)
  • Anordnen > Alle Gruppen aufheben (Bug #171117)
  • Pfad modifizieren > Knoten zittrig verteilen wurde teilweise neu geschrieben und unterstützt jetzt auch Pareto- und logarithmische Verteilungen.

Plotter-Treiber

Mehrere Stifte

Der Plottertreiber (Erweiterungen -> Exportieren -> Plotten) kann jetzt mit mehr als einem Stift umgehen, so dass mit Stiftplottern bunte Bilder erstellt werden können:

  • Für jeden Stift, der verwendet werden soll, muss eine eigene Ebene mit den entsprechenden Pfaden erstellt werden.
  • Die Ebene muss so benannt werden, dass sie entweder dem Schema "Pen 1" oder "MeinEbenenName Pen 1" entspricht, wobei die Zahl der Stiftnummer des Plotters entspricht
  • Der Ebenenname hat Priorität vor den Standardeinstellungen im Plotten-Dialog.

Serielle Verbindung

In den Verbindungseinstellungen können jetzt auch selten genutzte Einstellungen für serielle Verbindungen wie Bytegröße, Stopbits und Parität gesetzt werden. Die meisten Plotter verwenden die Standardeinstellungen, daher sollten diese Werte nur geändert werden, wenn genau bekannt ist, was sie bewirken.

HPGL-Export

Der HPGL-Export (Datei -> Speichern unter -> HP Grafics Language-Datei) funktioniert nun genauso wie der #Plotter-Treiber mit mehreren Stiften.

HPGL-Import

Der HPGL-Import (Datei -> Öffnen -> .hpgl-Datei wählen) kann jetzt auch mehrere Stiftspuren in getrennte Ebenen importieren, weitere Informationen siehe #Plotter-Treiber.

PDF-Import

Der Wert für 'interpolate' bei Rastergrafiken wird nun verwendet, um zu bestimmen ob das Bild geglättet oder pixelig dargestellt werden soll.

Verschiedene Verbesserungen

  • Anordnen > Umschichten hat neue Optionen zum Umkehren und zufälligen Mischen der Stapelordnung.
  • Rendern > Zufälliger Baum bietet jetzt die Möglichkeit, redundante Segmente auszulassen.
  • Pfad visualisieren > Pfad ausmessen hat neue Möglichkeiten für das Text-Layout.
  • Rendern > Strichcode kann jetzt auch EAN2-Codes generieren, und EAN13 wurde durch automatische EAN2- und EAN5- Erweiterungen ergänzt
  • Farbe > Zufallsänderung kann jetzt auch die Stärke der Zufallsänderung und (mit ein paar Begrenzungen) die Deckkraft ändern.

Entwicklung von Erweiterungen

  • Inkscape kann jetzt an Erweiterungen auch eine Liste der ausgewählten Knoten übergeben (Siehe bug #171640, dort ist auch eine Beispielerweiterung verfügbar).

Filter / Überblendmodi

Neue Filter

  • Farbe > Farbenblindheit simuliert verschiedene Typen von Farbenblindheit.

Neue Überblendmodi

Überblendmodi können jetzt sowohl auf einzelne Objekte als auch auf Ebenen angewandt werden.

Zusätzlich zu den bereits bekannten Modi 'Multiplizieren', 'Negativ multiplizieren', 'Abdunkeln' und 'Aufhellen' stehen jetzt die folgenden Modi zur Verfügung:

  • Überlagerung
  • Farbig abwedeln
  • Farbig nachbelichten
  • Grelles Licht
  • Gedämpftes Licht
  • Differenz
  • Exclusiv-Oder (Ausschluss)
  • Farbton
  • Sättigung
  • Farbe
  • Leuchtkraft

Weitere Dialoge

Dokumenteneigenschaften: Lizenzen

Die wählbaren Lizenzen wurden jeweils auf die aktuelle Version aktualisiert.

Filtereditor

In der Filterliste wird nun auch angezeigt, wie oft ein Filter im Dokument verwendet wird.

Menüs

  • 'Seitengröße auf Auswahlgröße' wurde in das Bearbeiten-Menü aufgenommen und erhielt auch ein Tastaturkürzel: Umschalt + Strg + R.
  • 'Auswahl aus Gruppe herauslösen' ist neu im Kontextmenü von Objekten, die Teil einer Gruppe sind, und deren Gruppe betreten wurde, und im 'Objekt'-Menü. Hiermit wird das Objekt in der Gruppenhierarchie um eine Ebene angehoben.
  • 'Ausschneidemaske erzeugen' im Kontextmenü gruppiert die ausgewählten Objekte und setzt eine Ausschneidemaske bestehend aus einem Klon dieser Gruppe. Hiermit können zum Beispiel schnell und einfach innenliegende Schatten erzeugt werden.

Weitere Änderungen in der Benutzeroberfläche

Einrasten von Knoten

Das Einrasten bei Verwendung des Knotenwerkzeugs wurde verbessert:

  • Bei einem Doppelklick zum Einfügen neuer Knoten rastet die Position dieser Knoten nun zum Beispiel an Pfadüberschneidungen und Pfad-Hilfslinien-Überschneidungen ein.
  • Beim Ziehen an einem Pfadsegment rastet der Mauszeiger jetzt ein

Schachbrettmuster für den Hintergrund

Beim Bearbeiten kann jetzt auch ein Schachbrettmuster als Hintergrund genutzt werden, so dass Transparenzen klar erkennbar sind.

'View Box'-Attribut

Das SVG-Attribut 'viewBox' kann jetzt über die Benutzeroberfläche gesetzt werden. Dieses Attribut bestimmt die Größe der Zeichnung, indem damit der Wert der SVG-Benutzereinheit (user unit) (in Pixeln) in der 'wirklichen Welt' berechnet wird.

Hilfslinien sperren

Hilfslinien können jetzt einzeln oder global gesperrt und entsperrt werden.

Verschieben der Arbeitsfläche

Das Verschieben der Arbeitsfläche mit der Leertaste kann jetzt in den Einstellungen deaktiviert werden (das Häkchen bei 'Verhalten > Rollen > Bewegen der Maus verschiebt die Arbeitsfläche, wenn die Leertaste gedrückt ist' entfernen).

SVG und CSS

  • Die Eigenschaft 'marker-orientation' kann jetzt mit Einheiten umgehen ('deg', 'rad', 'grad' and 'turn').
  • Die neuen SVG2-Eigenschaften 'context-fill' und 'context-stroke' sind jetzt implementiert, wodurch Pfeilkopffarbe und Pfadkonturfarbe automatisch übereinstimmen können.
  • Der neue Attributwert für die 'marker orientation' in SVG 'auto-start-reverse' wurde implementiert. Dieselbe Pfeilmarkierung kann dadurch für beide Enden eines Pfades verwendet werden.
  • Die neuen CSS3-Eigenschaften 'mix-blend-mode' und 'isolation' werden unterstüzt, und erlauben damit das Setzen von Mischmode zwischen Objekten, ohne dass dazu ein Filter verwendet werden muss.
  • Die neue SVG2-Eigenschaft 'paint-order' wird unterstützt. Dadurch kann die Reihenfolge, in der Füllung, Kontur und Markierungen gezeichnet werden, bestimmt (die Schaltflächen dazu finden sich im Füllung-und-Kontur-Dialog).
  • Der neue 'mesh'-Zeichenserver von SVG2 wird unterstützt, inklusive bicubischem Autoglätten. Es steht hierfür eine einfache GUI zur Verfügung.
  • Die SVG1.1-Eigenschaft 'text-decoration' wird jetzt dargestellt (unterstreichen, durchstreichen etc.). Die CSS3-Eigenschaften für 'text-decoration' werden auch dargestellt.
  • Der neue SVG2-Zeichenserver 'hatch' (Schraffuren) wird unterstützt.
  • Die CSS-Eigenschaft 'white-space' wird jetzt unterstützt. Die Verwendung der Eigenschaft wurde in SVG2 festgelegt, als Ersatz für das wegfallende Attribut 'xml;space'.
  • Die SVG1.1-Attribute 'textLength' und 'textAdjust' wurden implementiert, es gibt jedoch keine Benutzeroberfläche, um diese zu setzen.
  • Die Darstellung der Komponententransfer-Filterbasis wurde korrigiert.
  • Einheiten im Text und in den tspan-Attributen 'x', 'y', 'dx' und 'dy' werden jetzt beachtet.
  • Prozentwerte für Formen werden jetzt korrekt interpretiert.

Die neuen SVG2- und CSS3-Funktionen sind allgemein noch nicht über die Benutzeroberfläche einstellbar, da sie noch nicht von Webbrowsern unterstützt werden.

Neue Abhängigkeiten

  • Das Füllwerkzeug und die Vektorisierungswerkzeuge verwenden jetzt eine externe Kopie der Potrace-Bibliothek, die für viele Linuxdistributionen zur Verfügung steht oder unter http://potrace.sourceforge.net heruntergeladen werden kann.
  • Der Export als optimiertes SVG hängt jetzt von einer externen Kopie des Python-Moduls Scour ab. Dieses kann über pip (pip install scour), das Paketmanagement (Version ist jedoch möglicherweise veraltet) oder direkt von der Github-Seite des Scour-Projektes installiert werden. In den Windows-Versionen von Inkscape ist das Modul bereits enthalten.

Übersetzungen

Neue Übersetzungen für Assamesisch, Bodo, Dogri, Gujarati, Hindi, Isländisch, Kannada, Kashmiri (Perso-Arabische und Devanagari-Schrift), Konkani (Lateinische und Devanagari-Schrift), Maithili, Malayalam, Manipuri (Meetei-Mayek- und Bengali-Schrift), Marathi, Odia, Santali (Devanagari- und Ol-Chiki-Schrift), Sanskrit, Sindhi, Tamil, Urdu (Perso-Arabische und Devanagari-Schrift).

Viele weitere Übersetzungen wurden verbessert und aktualisiert.

Wichtige Fehlerkorrekturen

  • Schwerwiegender Performanceeinbruch mit 64bit-Versionen auf MS-Windows-Systemen mit Intel-Grafikkarten (das Verstecken der Seitenlineale half dagegen in Inkscape 0.91). (Bug #1351597)
  • In 64bit-Inkscape-Versionen auf MS Windows werden nahezu vollständig schwarze Seiten ausgedruckt, wenn im Dokument Teiltransparenzen verwendet werden (Bug #1418865)
  • Beim Drucken wird der Ausdruck verschoben gedruckt (Windows) (Bug #918319)
  • "Gekachelte Klone" innerhalb transformierter Gruppen/Ebenen (in Dokumenten, bei denen die Seitengröße geändert wurde) werden verschoben (bug #168651)
  • Verschobene Klone und Versätze (Bug #844909, Bug #653574, Bug #1152657, Bug #1245339, Bug #168013, Bug #177751)
  • Absturz beim Verlassen des Programms bevor das Speichern abgeschlossen wurde, mit dem Ergebnis, dass Dateien unvollständig gespeichert werden (Bug #967416)
  • Hilfslinien: Die gesetzte Farbe wird beim Öffnen eines gespeicherten Dokuments nicht verwendet (Bug #1374870)
  • Textwerkzeug: Neue Schriftart wird nicht gesetzt (Bug #1227232)
  • Erweiterungen: Fehler in Dokumenten, in denen das 'width'- oder 'height'-Attribut nicht vorhanden ist (Bug #1461346, Bug #1463623)
  • Benutzeroberfläche: Fehlende Icons bei Verwendung des in Gtk+ enthaltenen Themas (Windows, OS X) (Bug #1269698)
  • Textdarstellung schneidet das letzte Zeichen ab (Bug #1283194, Bug #1450675)
  • Stil übertragen - Markierungen gehen verloren (Bug #1467674)
  • DXF-Export unterstützt keine <line>- und <circle>-Elemente (Bug #1474347, Bug #1489320
  • Absturz beim Importieren von Rastergrafiken mit unterschiedlichen Dateitypen (Bug #1467103)
  • Optionen für die Qualität der Filter und des Weichzeichners funktionieren nicht (bug #1512729)(Für identische Darstellungsqualität in 0.91 und 0.92 muss 'Gut' für Filtereffekte und 'Durchschnittlich' für Weichzeichner eingestellt werden.)
  • Form: 'Dreieck Anfang' und 'Dreieck Ende' sind identisch (Bug #1525401)


Viele weitere Abstürze, Speicherlecks und viele kleine Dinge wurden repariert. Eine ausführliche Liste von Fehlerkorrekturen gibt es auf der Meilensteine-Seite für Inkscape 0.92 und der für die (nicht veröffentlichte) Inkscape-Version 0.91.1.

Bekannte Probleme

  • Schriften, die unter Windows von einer Schriftarten-Management-Software geladen wurden, stehen in Inkscape nicht zur Verfügung (Bug #1416674)
  • Minimierte Dialoge öffnen sich erst wieder, wenn auf das entsprechende Icon in der Andockleiste geklickt wird (Bug #1270295, wird in 0.93 behoben sein)
  • Die Deckkraftanzeige unten links wird nicht korrekt initialisiert (0%, auch wenn das Objekt vollständig deckend ist), Bug #1463078, wird in 0.93 behoben sein)
  • Bei einigen Texten entspricht der Zeilenabstand, der in Inkscape 0.91 angezeigt wird, nicht dem in Inkscape 0.92. Der Abstand ist dabei größer als er sein sollte (das Problem kann durch die Verwendung einer Erweiterung, die diese Texte reparieren kann, umgangen werden).

[ Please fill in]

Vorgängerversionen