Release notes/0.48/fr

From Inkscape Wiki
Jump to: navigation, search

Other languages: العربية Català Česky Deutsch English Español Français Italiano 日本語 한국어 Português Русский Slovenčina 中文

Inkscape 0.48

Sorti le 23/08/2010.

Nouveautés en lumière

La livraison marque le retour vers des cycles de livraison courts afin que les nouvelles technologies souvent développées au cours des projets du Google Summer of Code soient disponibles plus rapidement.

Cette nouvelle version offre en particulier :

  • la modification multi-chemins ;
  • un outil texte amélioré : indice, exposant, champ numérique pour le crénage et l’interlettrage, et plus ;
  • l’outil Aérographe ;
  • l’export en LaTeX avec PDF/PS/EPS ;
  • l’extension JessyInk pour créer des présentations ;
  • un grand nombre de correctifs.

Outils

Outil Nœuds

Au cours du Google Summer of Code 2009, l’outil Nœuds a subi une profonde réécriture. En plus d’un code plus facile à maintenir, il propose de nouvelles fonctionnalités.

Modification multi-chemins
Plusieurs chemins peuvent être sélectionnés pour être modifiés en même temps avec l’outil Nœuds.
Modification de découpe et de masque améliorée
Le chemin utilisé comme découpe ou masque d’un objet peut être modifié en même temps que l’objet. Les boutons de modification des découpes et des masques avec l’outil Nœuds sont maintenant à bascule, au lieu d’être des boutons de changement de mode. Si l’objet est transformé après l’application d’une découpe, le chemin utilisé pour la découpe n’est plus décalé lorsque modifié avec l’outil Nœuds. Si le chemin est un groupe, tous les chemins dans le groupe peuvent être modifiés simultanément.
Jointure de nœuds améliorée
Il est maintenant possible de fusionner des nœuds provenant de différents chemins. Plus de deux nœuds terminaux peuvent être joints d’un coup — les distances entre les nœuds sont utilisées pour déterminer les nœuds à fusionner, les paires les plus proches étant fusionnées en premier. Lorsque rien ne peut être fusionné (il y a moins de deux nœuds terminaux dans la sélection), chaque tronçon de nœuds sélectionné est fusionné en un seul nœud.
Jointure de segments améliorée
Il est maintenant possible de créer un segment entre des nœuds terminaux de différents chemins. Plus d’un segment peut être créé en une fois — les distances entre les nœuds sont utilisées pour déterminer quels nœuds sont fusionnés en segment, les paires les plus proches étant fusionnées en premier. Lorsque rien ne peut être fusionné (il y a moins de deux nœuds terminaux dans la sélection), les nœuds intermédiaires de chaque tronçon de nœuds sélectionnés sont supprimés, de sorte qu’il ne reste qu’un unique segment.
Transformations de nœuds
Il est maintenant possible de transformer les nœuds en utilisant la souris et des poignées de transformation similaires à celles de l’outil Sélecteur. Ces poignées peuvent être activés et désactivés à l’aide du bouton de la barre de contrôle. Lorsque les poignées sont visibles, cliquer sur un nœud sélectionné alterne entre les modes redimensionnement et rotation, au lieu de sélectionner seulement ce nœud. Le raccourci clavier Maj+H peut également être utilisé pour changer de mode. Toutes les autres opérations fonctionnent normalement lorsque les poignées de transformation sont affichées.
Outils pour le sens des chemins
De petites flèches peuvent être affichées au milieu de chaque segment, pour indiquer le sens du chemin. Cela peut servir lors de la préparation d’un chemin qui doit guider un texte, lors de la disposition de marqueurs, et lors du débogage d’Inkscape ou d’extensions. La commande « Inverser » (Maj+R) inverse le sens des sous-chemins dont les nœuds sont sélectionnés, ou de tous les sous-chemins si la sélection est vide. Pour activer, sélectionnez « Toujours afficher le contour » et « Afficher la direction des chemins sur le contour » dans la section Nœuds de la boîte de dialogue des préférences d’Inkscape.
Mise à jour de chemin personnalisable
Deux nouvelles préférences vous permettent d’indiquer lorsque le chemin et son contour doivent être mis à jour. Désactiver la mise à jour en temps réel améliorera les performances pour les dessins complexes.
Indications améliorées
Les indications affichées pour les nœuds et les poignées sont plus concises et influencées par les touches modificatrices (Ctrl, Maj et Alt) enfoncées.

Pour une comparaison détaillée entre l’ancien outil et le nouveau, consultez l’article sur la réécriture de l’outil Nœuds.

Outil Texte

La barre de contrôle de l’outil Texte a été refondue avec de nombreuses corrections de bogues et améliorations. Un grand nombre de paramètres de disposition de texte sont maintenant directement accessibles :

  • « Espacement entre les lignes de base » : distance entre les lignes de base de lignes adjacentes ;
  • « Espacement entre les lettres » ;
  • « Espacement entre les mots » ;
  • « Crénage horizontal » ;
  • « Décalage vertical » ;
  • « Rotation des caractères ».

De plus, le support de l’exposant et de l’indice a été ajouté.

Ce travail a été en parti sponsorisé par des utilisateurs d’Inkscape via LinuxFund.org.

Outil Aérographe

Un ou plusieurs objets doivent être sélectionnés lorsque vous prenez l’outil Aérographe. Pour pulvériser, cliquez sur le canevas, puis déplacez la souriz ou tournez la molette de la souris.

Trois modes sont disponibles :

  • mode Pulvériser des copies : chaque élément pulvérisé est indépendant des autres ;
  • mode Pulvériser des clones : chaque élément pulvérisé est un clone de l’élément sélectionné (changer les propriétés de l’élément sélectionné affecte donc les clones) ;
  • mode Pulvériser un unique chemin : la pulvérisation s’assemble en un unique chemin (pour assurer le fonctionnement, l’élément initial doit éventuellement être converti en chemin).

Options de l’outil Aérographe :

  • Quantité : pulvériser plus ou moins d’éléments ;
  • Rotation : tourner aléatoirement les éléments autour de la valeur de rotation initiale ;
  • Mise à l’échelle : redimensionner aléatoirement les éléments autour de l’échelle initiale ;
  • Dispersion : valeur faible pour placer les éléments sous le pointeur, valeur élevée pour une répartition plus uniforme dans la zone pulvérisée ;
  • Focalisation : les éléments sont pulvérisés sur un cercle, ce paramètre modifie le rayon du cercle (0 par défaut pour pulvériser un point).

Les touches ↑ et ↓ permettent de régler la taille des éléments pulvérisés. Les touches ← et → permettent de définir la largeur du curseur.

L’outil Aérographe s’accorde parfaitement avec les modes Transformation, Duplication et Suppression de l’outil Ajuster.

Outil Connecteur

L’outil Connecteur peut maintenant produire des connecteurs orthogonaux (faits de segments de ligne verticaux et horizontaux, comme dans les diagrammes de circuits). Un bouton supplémentaire sur la barre de contrôle permet de choisir le type de connecteur : « polyligne » ou « orthogonal ».

Par ailleurs, des correctifs de bogues et de plantages ont été apportés au routage des connecteurs.

Importer/Exporter

Import d’images matricielles amélioré

Les images matricielles sont maintenant toujours incorporées lorsque des données en pixels sont collées ou déplacées dans la fenêtre d’Inkscape (par exemple, lors de la copie de parties d’une image à partir de GIMP). Il n’y a plus de fichiers avec des noms automatiquement générés comme « inkscape_pasted_image_… » créés dans le répertoire du document. Lors de l’import ou de l’ouverture d’images matricielles, une boîte de dialogue est affichée et demande si vous souhaitez lier l’image ou l’incorporer.

Nouvel export en LaTeX pour PDF/EPS/PS

De la même manière qu’avec la sortie du programme epslatex de GNUPlot et qu’avec la sortie combinée PDF/LaTeX d’Xfig, Inkscape peut exporter des images en PDF avec un fichier LaTeX l’accompagnant, qui place le texte par-dessus le PDF lorsque transmis à LaTeX. Le texte de l’image est composé par LaTeX, donc les expressions mathématiques par exemple sont rendues correctement, et tout le texte utilisera la police et le style du document LaTeX (même après avoir changé la police du document après coup).

(La description suivante prend l’hypothèse d’une exportation en PDF, mais s’applique de la même façon à l’EPS et au PS.) Deux fichiers seront créés : un fichier PDF contenant tous les graphismes, sans texte ; et un fichier LaTeX avec le même nom (et l’extension « .pdf_tex »), contenant tout le texte, et le code pour inclure le PDF et recouvrir le texte. Pour inclure l’image exportée dans LaTeX, il faut écrire :

 \begin{figure}
   \centering
   \def\svgwidth{\columnwidth} % optionnel, définit la largeur de l’image
   \input{image.pdf_tex}
 \end{figure}

Une description plus complète de l’usage de la nouvelle fonctionnalité (et l’automatisation de l’exportation et l’inclusion de l’image en LaTeX) est donnée dans ce document : svg-inkscape sur CTAN.

Depuis l’interface graphique

Lors de l’exportation en PDF/EPS/PS depuis l’interface graphique d’Inkscape, la boîte de dialogue habituelle s’affiche une fois que le format d’exportation (PDF, EPS ou PS) a été sélectionné. Dans cette boîte de dialogue, vous pouvez trouver l’option PDF/EPS/PS+LaTeX.

Option en ligne de commande

Lors de l’exportation en PDF/EPS/PS depuis la ligne de commande, ajouter --export-latex activera l’exportation du LaTeX. Par exemple :

 inkscape image.svg -z -D --export-pdf=image.pdf --export-latex

Correction de l’exportation en PDF/EPS/PS pour les documents ayant des dimensions non entières

L’ancestral bogue 168275 a enfin été corrigé. Les documents avec une hauteur ou une largeur non entière sont maintenant correctement exportés en PDF, EPS et PS.

Extensions

  • La nouvelle extension Générer à partir du chemin > Motif de Voronoï crée un motif aléatoire de cellules de Voronoï. Le motif est accessible depuis le panneau Fond et contour. Il peut être lissé sur les bords par la sélection d’une bordure positive, ou creux sur les bords si une bordure négative est choisie.
  • La nouvelle extension Rendu > Sphère fil de fer dessine un globe sous la forme d’une collection d’ellipses représentant les lignes de latitude et de longitude. Le nombre de lignes est ajustable, ainsi que l’inclinaison et l’angle de rotation. Une option permet de cacher les lignes au dos de la sphère.
  • La nouvelle extension Rendu > Code-barres — Datamatrix produit le code-barre 2D d’une matrice de données, comme spécifié dans la norme BS ISO/IEC 16022:2006. Le nombre de lignes et de colonnes de la matrice de données est ajustable. Si les données fournies sont trop importantes pour être contenues dans une seule matrice de données, plus d’une matrice sera créée.
  • La nouvelle extension Modifier le chemin > Aligner au pixel aligne les rectangles et les chemins à des frontières de pixels, pour produire des graphismes web et numériques précis.
  • La nouvelle extension Couleur > Noir et blanc change les couleurs de la sélection en noir et blanc.
  • La nouvelle extension Texte > Diviser du texte divise des textes en lignes, mots ou lettres séparés.
  • La nouvelle extension JessyInk crée des présentations faites pour être visualisées dans les navigateurs — voir la page du projet.
  • Les nouvelles extensions Web > Découpe découpe des mises en page web en plusieurs images et aide à la production des codes HTML et CSS.
  • Images > Extraire une image : tous les chemins relatifs (ou les noms de fichier sans chemin) sont maintenant relatifs au dossier personnel de l’utilisateur.
  • Visualiser le chemin > Mesurer le chemin : nouvelle option pour calculer la surface.

Prise en charge du SVG

L’attribut baseline-shift (mouvement de la ligne de base) est maintenant implanté ! La barre de contrôle de l’outil Texte utilise les valeurs super et sub pour faire fonctionner l’exposant et l’indice. C’est pour le moment la seule interaction (outre l’éditeur XML) que l’interface graphique offre avec l’attribut.

Autres fonctionnalités

  • Dans le menu Fichier > Documents récents, vous pouvez maintenant placer le pointeur de la souris sur un élément pour que s’affiche une bulle avec le chemin complet du fichier. Par ailleurs, les fichiers de la liste qui sont absents ou inaccessibles sont automatiquement masqués.
  • Des préférences ont été ajoutées pour permettre le groupement automatique lors de la définition d’une découpe ou d’un masque.
  • Les copies en pixelimages créées à l’aide de la commande Créer une copie matricielle (Alt+B) sont maintenant incorporées. Auparavant, elles étaient enregistrées dans un fichier généré automatiquement, et liées.
  • La limite de taille de fichier pour l’aperçu (dans les boîtes de dialogue Fichier > Ouvrir et Fichier > Importer) est maintenant de 10 Mo au lieu de 1,3 Mo.
  • Le flou, la transformation et la visibilité et l’opacité des calques sont maintenant pris en charge dans l’export en XAML.
  • Une préférence a été ajoutée dans la section Filtres pour que le flou gaussien soit réalisé avec plusieurs fils d’exécution.

Propriétés du document

  • Les formats de papier architecturaux ont été ajoutés.
  • Il y a maintenant des options pour définir des marges lors du redimensionnement d’un document en fonction de la sélection ou du dessin complet.

Texte

  • L’affichage des échantillons de police dans la liste déroulante de l’outil Texte est maintenant facultatif. Dans les préférences d’Inkscape, section Outils > Texte, décochez « Afficher les échantillons de police dans la liste déroulante » si vous ne voulez pas voir les échantillons. La liste sera ainsi affichée plus rapidement à la première ouverture sous une instance d’Inkscape.
  • Lorsqu’un texte encadré est tronqué (parce que le cadre est trop petit pour le texte complet), le cadre est affiché en rouge, et la barre d’état affiche [tronqué]. Vous devez changer la taille du cadre pour voir la fin tronquée du texte. De la même manière, si le chemin d’un objet texte suivant un chemin est trop court pour l’affichage du texte complet, la barre d’état affichera [tronqué] dans ses indications.
  • Cliquer sur les boutons d’alignement du texte (à gauche, centré, à droite) sur la barre de contrôle de l’outil Texte ne fait plus « sauter » le texte : il reste dans la même boîte englobante qu’auparavant, et seul l’alignement est changé.
  • La position de l’ancre de la ligne de base du texte (le petit carré blanc) dépend maintenant de l’alignement : pour le texte aligné à gauche, il est placé comme avant dans le coin gauche, pour le texte centré il est au milieu, et pour le texte aligné à droite il est sur la droite de la première ligne du texte (cela s’applique au texte horizontal ; pour le texte vertical, l’ancre se trouve respectivement en haut, au milieu et en bas de la première colonne). Cela permet d’aimanter, aligner et distribuer le texte relativement au côté sur lequel il est aligné.

Magnétisme

  • Le magnétisme des poignées de dégradé a été amélioré et fonctionne maintenant de façon similaire au magnétisme de toutes les autres poignées et objets.
  • Lors de l’aimantation à une boîte englobante, celle-ci est affichée pendant un moment (attachée à l’indicateur de magnétisme).
  • Lorsqu’un nouvel objet est créé sur le canevas et que le magnétisme est activé, un indicateur de magnétisme est également affiché pour le premier point.

Configuration de périphérique de saisie étendu

Le panneau Périphériques de saisie auparavant présent a été remplacé par une toute nouvelle version qui fournit une représentation plus utile des réglages. Il contient également une zone pour tester les différentes saisies des différents appareils.

De plus, les réglages relatifs au matériel ont été séparés des réglages de saisie pour permettre de changer plus facilement les réglages relatifs à une tâche à la main.

Interface utilisateur

Comportement adaptatif

Une forme initiale d’interface utilisateur adaptative a été implantée. Il s’agit d’un traitement interne effectué afin de collecter des informations sur le système et les opérations de l’utilisateur, afin de déterminer comment l’assister au mieux dans son travail. Le contrôle visible est un menu qui propose différentes dispositions de l’interface, parmi lesquelles une est optimisées pour les petits écrans comme les ultraportables. Actuellement, le système détectera la forme de l’écran et activera l’option par défaut correspondante. D’autres traitements internes mineurs sont également exécutés de cette façon.

Palettes personnalisées

Des palettes personnalisées peuvent être créées et utilisées, enregistrées avec le document. Une palette de couleurs « Auto » stocke les données des palettes du document actuel, et permet de les définir et de les utiliser. L’utilisation est immédiate : les changements à la palette sont appliqués automatiquement à tous les objets utilisant la palette. Les éléments des palettes peuvent être des couleurs simples mais aussi des dégradés.

Cette version de l’outil a été implantée avec des dégradés à simple stop. De cette manière, les fichiers sont parfaitement conformes au standard SVG 1.1 avec leurs données de modification.

Prise en charge de la quadrichromie CMJN et des profils ICC

La prise en charge des profils ICC a été étendue à de nouvelles zones de l’interface, y compris pour les stops de dégradés. Cela aide à préserver des couleurs personnalisées, incluant la quadrichromie.

Panneau d’aperçu d’icône

Le panneau d’aperçu d’icône a été raffiné. Les nouvelles fonctionnalités ont des comportements par défaut correspondant aux choix les plus courants ; certains peuvent être changés dans la boîte de dialogue des préférences.

  • Actualisation automatique. Le panneau d’aperçu d’icône se met maintenant automatiquement à jour lorsque le document est modifié.
  • Maintien de la sélection initiale. Lorsque la case « Sélection » est cochée, l’élément actuellement sélectionné est mémorisé et suivi. Inkscape utilise la boîte englobante de cet élément comme zone à inclure dans le panneau d’aperçu d’icône. Pour que l’aperçu suive une nouvelle sélection, décochez et recochez la case « Sélection ».
  • Raffinements de la disposition. Les aperçus d’icône ont été mis à jour, gagnant ainsi des cadres visuels et une organisation par défaut plus compacte.

Préférences

Les attributs suivants peuvent être modifiés dans group id="iconpreview" dans votre fichier preferences.xml. La valeur par défaut est 1 pour chacun des quatre attributs.

  • autoRefresh pour activer (1) ou désactiver (0) l’actualisation automatique de l’aperçu.
  • pack pour organiser les miniatures d’aperçu de façon plus compacte (1) ou pour forcer l’empilement vertical antérieur.
  • selectionHold pour que l’aperçu reste attaché à la sélection initiale (1) ou passe à chaque nouvel élément sélectionné (0).
  • showFrames pour dessiner des contours autour des miniatures (1) ou bien les supprimer (0).

Panneau des glyphes

Un panneau de sélection de glyphe a été ajouté. Il permet de visionner quels caractères Unicode sont représentés avec une police donnés, et permet aux glyphes individuels d’être sélectionnés et inclus. Les caractères peuvent être sélectionnés et insérés par copier-coller ou insérés directement à l’aide du bouton Ajouter du panneau. Le texte sera ajouté à l’objet texte actuellement sélectionné sur le canevas actif.

La séquence de glyphes/caractères visionnée peut être déterminée par intervalle Unicode ou « script » de langue. Lorsqu’un glyphe individuel est sélectionné, la zone d’état de la boîte de dialogue affiche la valeur Unicode du glyphe et le nom du script.

Une limitation connue survient lorsque la liste des glyphes du panneau ne sont pas encore rendus avec la police sélectionnée, mais le sont avec la police du système. Cela concerne principalement les caractères non standards des polices. Lorsqu’une police avec un large répertoire de caractères est sélectionnée pour l’aperçu, par exemple vous demandez d’afficher l’ensemble chinois-japonais-coréen avec une police, l’affichage peut être momentanément suspendu le temps que les aperçus soient générés.

Nouveaux curseurs avec le sélecteur

L’outil Sélecteur dispose d’un nouveau curseur de souris (la flèche avec une main ouverte) qui apparaît lorsque votre souris se trouve sur un objet sélectionnable, et un autre (flèche avec une main serrée) qui apparaît lorsque vous déplacez un objet. Cela améliore la précision de la sélection et la consistance de l’interface (auparavant, le curseur de souris sur un objet sélectionnable dépendait de la plateforme, par exemple c’était une main sous Linux et quatre flèches sous Windows).

Traductions

De nouvelles traductions sont disponibles en farsi (fa) et télougou (te_IN), toujours en cours de production.

Didacticiels

  • Les fichiers SVG sont maintenant optimisés avec Scour (taille de fichier réduite de 40 %).
  • Les polices Bitstream Vera ont été remplacées par les polices Sans et Serif par défaut (ce qui résout de nombreux problèmes de substitution de police).
  • Nouveau didacticiel sur l’interpolation (Aide > Didacticiels > Inkscape : Interpolation).
  • Nouvelles traductions en biélorusse, en néerlandais, en farsi et en indonésien.

Améliorations pour le port Windows

La qualité du port Windows a été substantiellement améliorée.

Interface en ligne de commande

Les fonctionnalités de la ligne de commande sous UNIX sont maintenant utilisables sous Windows de manière identique.

Exécutable simple
Il n’est plus nécessaire de compiler Inkscape avec des drapeaux spéciaux ou d’utiliser des exécutables conteneurs tiers pour voir la sortie de la ligne de commande. Saisissez simplement inkscape (sans extension) dans l’invite de commande. Cela est rendu possible par un conteneur en ligne de commande nommé inkscape.com.
Chemins relatifs
Vous pouvez maintenant spécifier des chemins relatifs vers les fichiers pour les options comme --export-png. Une commande comme celle-ci aura maintenant le comportement voulu :
C:\svg> inkscape tiger.svgz --export-png=tiger.png

Stabilité

Grâce à des mises à jour de bibliothèques, Inkscape ne devrait plus subir de plantages aléatoires lors de la modification de documents. La plupart de ces plantages étaient causés par la fuite d’une ressource GDI dans Pango. L’import d’une image corrompue ne cause plus de plantage non plus.

Compatibilité Unicode

Inkscape fonctionnera maintenant correctement quel que soit le dossier d’installation. Auparavant, il était inutilisable lorsqu’il était installé dans un répertoire contenant des caractères qui ne pouvaient pas être représentés dans la page de code du système (les icônes n’étaient pas affichées dans l’interface, et aucun fichier de langue n’était trouvé).

Correctifs notables

  • L’outil Boîte 3D n’insère plus d’élément inkscape:perspective dans le SVG lorsque ce n’est pas nécessaire (c’est-à-dire lorsque le document ne comporte pas de boîtes 3D).
  • Les chemins de découpe et les masques comportant une récursion cyclique (c’est-à-dire qu’ils font appel à eux-mêmes via d’autres chemins de découpe ou masques, ce qui est techniquement irréalisable) ne font plus planter Inkscape.
  • Le réglage de l’unité par défaut pour la grille XY est maintenant respecté lors de la création d’une nouvelle grille.
  • Le collage de piles d’Effets de chemin interactifs fonctionne à présent. Il ajoute la pile de l’objet copié à la fin de la pile d’ECI (si présente) de l’objet sur lequel il est effectué.
  • La précision du calcul des boîtes englobantes a été significativement amélioré lors de la conversion d’objets en motifs et en marqueurs. Cela devrait faciliter la création de motifs sur lesquels les carreaux doivent se « connecter » les uns aux autres, par ex. un carreau avec un signe plus pour créer un motif hachuré.
  • La police de caractères par défaut est maintenant Sans, ce qui élimine des problèmes lorsque la police par défaut précédente, Bitstream Vera Sans, n’est pas disponible. Sans est en fait une pseudo-police Pango, s’associant à une police sans sérif installée.
  • Le comportement des boutons pour le gras et l’italique/oblique sur la barre de contrôle de l’outil Texte est maintenant plus intuitif.
  • Les pixelimages avec de la transparence sont maintenant rendues (à l’affichage comme à l’export) correctement.
  • La fonctionnalité de sauvegarde en urgence n’écorche plus le nom du fichier (ce qui la faisait régulièrement échouer).

Ploblèmes connus

Barres d’outils flottantes

Il s’est avéré que les barres d’outils flottantes présentent des problèmes avec certains gestionnaires de fenêtres. En conséquence, le flottement a été désactivé par défaut sous Ms Windows et le gestionnaire de fenêtres KDE par défaut. Le fichier preferences.xml comporte un groupe d’options appelé workarounds avec un paramètre appelé floatallowed, qui définit si le flottement est activé ou non. Mettre la valeur "1" réactivera le flottement sur ces systèmes problématiques. Les valeurs valides sont "0" et "1".

Versions précédentes