Inkscape for Adobe Illustrator users (Japanese)

From Inkscape Wiki
Jump to: navigation, search

Inkscapeを使えば、Adobe Illustratorで作れるたいていのものと同様のイラストレーションを制作することができます。しかし、この二つのアプリケーションに共通な機能やツールの多くは異なるやり方で用いられ、異なる名前やショートカットを持ち、扱い方も異なります。このドキュメントにはInkscape / Illustratorの同一機能、異なる点、いいところとよくないところについての情報をなんでも追加してください。

ファイル形式

IllustratorはInkscape SVG形式をインポートでき、またInkscapeがたいてい問題なく開くことのできるSVG形式をエクスポートできます。逆に、InkscapeはAdobeのAI形式(バージョン9以降)およびPDF形式(グラデーションメッシュが短いパスの格子として近似される、透明モードが機能しないなどの制限あり)を開くことができます。またInkscapeはドキュメントをPDF形式としてエクスポートできます。

WIndows版InkscapeでIllustratorファイルを保存するには

この例はGIMPに関してのものですが、Windows版Inkscapeにai形式として保存オプションを追加するのにも同様に使えます(英語)

このページで説明されている通り、GS実行ファイルの場所にパスを通す必要があります(英語)

高い互換性を得られるかわりに一部の要素を失う(テキストがパスに変換されるなど)他の方法(バージョン0.48.3でテスト済)があり、それはPDF形式で保存してからAcrobat Xを用いてEPS形式にエクスポートすることです。Illustratorでこのファイルを安全に開き、AI形式で保存できます。このAIファイルはExpression Blend 4で安全に開くことができます。

用語

  • アンカーポイント:Inkscapeでは、アンカーポイントは「ノード」と呼ばれます。
  • パレット:Inkscapeでは、「パレット」は「ダイアログ」と呼ばれます。フィル/ストロークのダイアログといったように。
  • マーキー:選択時に「ラバーバンド」と呼ばれます。
  • ツール:ツールの対応一式が示されているAdobeToolMap_(Japanese)を参照してください。

Illustratorにできて、Inkscapeにできないこと

  • グラデーションメッシュ
  • 単一オブジェクトに対する複数のストロークとフィル
  • 印刷のためのカラーマネジメント(ICCプロファイルなど)
  • PMSカラー
  • データに基づくグラフのネイティブな処理
  • 自由変形と遠近法変形(エクステンションによってのみ可能)
  • ブレンド(エクステンションによってのみ可能)

Inkscapeにできて、Illustratorにできないこと

  • SVGソースファイルの直接編集
  • クローン、タイルクローン、キャンバス上でのクローンの編集
  • キー押しによりスクリーンピクセル単位で移動/回転/拡大縮小
  • オブジェクトとしてのシェイプ
  • キャンバス上でグラデーションをハンドル操作により編集(CS4からは導入)
  • ノードをキーボードで編集
  • ワンクリックでペイントバケツでの塗りつぶし
  • オブジェクト上にカラーペイント(CS4でこの機能を塗りブラシツールとして導入)

手のひらツール:キャンバス上の移動

スペースキーを使ってドキュメント上を移動する代わりに、Inkscapeではマウスの中ボタン(またはマウスホイール)を押しながらキャンバスを任意の方向にドラッグすることができます。別の方法として、マウスホイールを回して垂直に、またはシフトさせて水平に移動することもできます。Ctrlキーを押しながら矢印キーを押すことでキャンバスを移動することもできます。矢印キーを押しっぱなしにすると移動を速くできます。

バージョン0.46以降では、スペースキーをIllustratorと同じように設定することもできます。Inkscapeの設定→スクロール→「スペースキー+左ボタンでキャンバスをパンする」をチェックすると、スペースキーを押しながらキャンバスをドラッグすることができます。

ズーム:+とーキー

Ctrlキーを押しながら+またはーキーでキャンバスをズームする代わりに、Inkscapeでは単に+かーキーを押すことでズームできます。

選択ツールとノードツール

Inkscapeでラバーバンドを使ってオブジェクトを選択するには、オブジェクトの一部分だけではなくて全体を選択する必要があります。

パスに含まれる個々のノードは、Illustratorと同じようにノードツールのラバーバンドで選択できます。しかしまずオブジェクトを最初に選択する必要があります。

選択ツールではタッチ選択も使えます。Altキーを押しながらオブジェクトの上をなぞり、キーを離せば触ったオブジェクトが選択されます。

グループ選択

Inkscapeでは特別なグループ選択ツールはありません。オブジェクトのグループの中からある一つのオブジェクトを選択するには、Ctrlキーを押しながら選択ツールでオブジェクトをクリックします。

またはグループを右クリックして「グループに入る」を選ぶと、グループ化されていないときと同じようにグループ内のオブジェクトを選択できます。

多くのツール(ノードツール、微調整ツール、シェイプツールなど)はグループ化を無視します。これらのツールでは、グループ化の有無にかかわらずどのオブジェクトでもクリックで選択することができます。

回転と歪曲:二回クリック

Inkscapeには傾斜や歪曲専用のツールはありません。その代わりに、選択ツールでオブジェクトをクリックして選択し、さらにもう一度クリックするとハンドルが回転と歪曲ハンドルに変わります。四隅のハンドルをドラッグすれば回転し、中辺のハンドルをドラッグすれば歪曲できます。

フィルとストロークダイアログ

フィルとストロークはツールではないので、Illustratorのようにツールボックスにはありません。代わりにフィルとストロークウィンドウがあります。コマンドバーのフィルとストロークアイコンをクリックするか、メニューから選ぶか、Ctrl+Shift+Fでアクティブにできます。

スタイル:カットアンドペースト

スタイルを保存できるパレットはまだありません。しかし一つのオブジェクトから他のオブジェクトへスタイルをコピーすることはできます。コピー元のオブジェクトを選択し、編集→コピー(Ctrl+C)、コピー先のオブジェクトを選択、編集→スタイルを貼り付け(Ctrl+Shift+V)。Illustratorとは異なり、コピーしたスタイルはオリジナルとリンクされません。

シンボルとクローン

Inkscapeはオブジェクトの「クローン」を作ることができます。これはIllustratorのシンボルと似たようなものです。オリジナルを編集すると、変化はクローンすべてに及びます。クローンは変形できますが、ノードを編集することはできません。

クローンをさらにクローンすることもできます。編集→クローン→タイルクローンを作成でクローンのパターンと配置を作成することができます。

拡大縮小時の縦横比固定と中心点:シフトとコントロールキー

Inkscapeでは、拡大縮小時に縦横比を固定するキーとオブジェクトの中心点を基準とするキーが入れ替わっています。オブジェクトを縦横比を保ったまま拡大縮小するにはCtrlキーを押したままにし、オブジェクトの中心点を基準として拡大縮小するにはShiftキーを押したままにします。

パレット

Inkscapeではパレットを「ダイアログ」と呼びます。さまざまなコマンドにより呼び出すことができ、ダイアログを通じてアーティストはソフトウェアとやりとりすることができます。ダイアログはパレットと同様に機能します。自由に移動することも、ドキュメントウィンドウに固定することもできます。アクティブなダイアログすべての表示をF12キーで切り替えることができます。

ノード(アンカーポイント)とパスの操作

パスを描いたのちに編集するにはノードツール(Nキー)を使います。ノードを選択するにはクリックするか、Tab/Shift+Tabキーで選ぶか、複数のノードをラバーバンドで囲みます。ノードを選択解除するには、Escを押すかなにもないスペースをクリックします。またノードツールの使用中、異なるオブジェクトをクリックして選択するとそのオブジェクトに含まれるノードが選択可能になります。

パスを延長するには、端点ノードを選択して複製し(Shift+D)、新しいノードをドラッグします。選択したノードのどこからでもパスを分離でき、また対応するツールバーボタンを用いて二つの端点ノードを結合することができます。パス→分解と連結コマンドを用いてパスをサブパスに分解したり、別個のパスを一つのパスに連結したりできます。

直線のパスセグメントを曲線に変えるには、そのセグメントの端点ノードを両方とも選択してからツールバーの「選択セグメントを曲線に」ボタンを押してください。逆に「選択セグメントを直線に」ボタンを用いて曲線から直線にセグメントを変換することもできます。

Inkscapeのノード編集の利点

  1. 種類に応じてノードの見た目が変わります。シャープノードがスムーズノードに変えられたとき、ノードの形はダイアモンド形から正方形に変わります。つまり特定のノードが選択されていなくても、ノードがどの種類かわかるのです。
  2. ノードの動きをハンドルのベクトルあるいは隣接する直線セグメントによって限定することができます(Ctrl+Altでノードをドラッグ)。
  3. ハンドルの長さを固定できます(Altを押しながらドラッグ)
  4. ノードの移動、ハンドルの回転、ハンドルの拡大縮小、次のノードへ選択を移動することがキーボードショートカットでできます。移動、拡大縮小、回転についてはAltキーで1スクリーンピクセル単位の移動ができます。

シェイプの編集

シェイプツール(矩形、3Dボックス、円/弧、星形、らせん)で作成したシェイプオブジェクトはただちに同じツールで編集することができます。それぞれのシェイプは独自のハンドルを持ち、ドラッグすることでさまざまな効果が得られます(矩形の角を丸めるなど)。またシェイプツールのコントロールバーにはさまざまな数値フィールドがあります。ヘルプメニュー内のシェイプチュートリアルでInkscapeのシェイプの詳細について調べてみてください。全体として、InkscapeのシェイプはIllustratorにおけるものより豊かで柔軟性に富んでいます。

どのシェイプもパスに変換でき、ノードを自由に編集することができます。選択ツールかノードツールでオブジェクトを選択し、「パス」→「オブジェクトをパスへ」(Shift+Ctrl+C)を実行するか、ノードツールのコントロールバーから「選択オブジェクトをパスへ変換」のアイコンをクリックしてください。

パスファインダー

Inkscapeはパスファインダー操作をパスの「ブーリアン操作」と呼びます。

レイヤー

Inkscapeのレイヤーはステータスバーのドロップダウンメニューから操作できます。隣のアイコンからは現在のレイヤーに対するロックと表示を切り替えることができます。リストからレイヤーを選択でき、その表示とロック属性を選択できます。別の方法としてはレイヤーダイアログ(Ctrl+Shift+L)も使えます。

プレビューは表示されません。オブジェクトはあるレイヤーから他のレイヤーへキーコマンドにより移動することができます(Shift+PgUp / Shift+PgDn)。

レイヤーは入れ子にできます。またグループの中に一時的レイヤーを作って入ることもできます。

テキスト:アウトラインの作成

テキストオブジェクトをアウトライン(すなわちパス)に変換するには、InkscapeではCtrl+Shift+Cで単一パスのオブジェクトが生成されます。各文字を別々に操作したい場合、このオブジェクトをサブパスに分解します(パス→分解、Shift+Ctrl+K)。穴を含む文字の場合は各文字を再選択して連結(パス→連結、Ctrl+K)し、穴をふさぎます。

テキストボックス

テキストツールでは、キャンバスをクリックするとシンプルな(流し込みなし、つまり折り返しなしの)テキストが作成されます。クリックしてドラッグするとテキストボックス(「流し込みテキスト」と呼ばれます)が作成され、テキストは自動的に改行されます。「テキスト」メニューからの「テキストの流し込み」コマンドで、テキストを任意の形に流し込むこともできます。

ガイド

InkscapeではガイドはShift+|(縦線)で表示を切り替えることができます。Ctrl+を押してもなにも起こりません。 Illustratorとは異なり、ガイドをラバーバンドで選択することはできません。ガイドを移動したり削除したりするには、選択ツールを使ってガイドをつかみ、別の位置に動かすか、ルーラーに戻すかします。

ガイドはロックすることができず、またIllustratorのように個別のレイヤーに結び付けられているのではなく、レイヤー全体に対して独立しています。ガイドをダブルクリックするとダイアログが開き、位置を精密に設定することができます。

グラデーション

Illustratorと異なり、グラデーションを適用されたオブジェクトはキャンバス上で常にグラデーションラインと全ての停止点を表示します。停止点をドラッグし、色を変えるなどがその場でできます。方向を微調整したとき、グラデーションを再描画する必要はありません。

ワープ、うねり、収縮、膨張など

これらのIllustratorのツールはInkscapeの微調整ツールのさまざまなモードと同様です。

ブラシ

Inkscapeにはブラシパレットはまだありませんが、任意のブラシパスを適用した編集可能なパスを作ることはできます。まずブラシパス(パターンと呼びます)を選択し、クリップボードにコピーします。次にブラシを適用したいパス(スケルトンと呼びます)を選択し、パスエフェクトエディタを開き(Ctrl+Shift+7)、「パスに沿うパターン」を選択し、「Add」をクリックし、「繰り返し、引き伸ばし」を選択し、「パスを貼り付け」ボタンをクリックしてパターンを適用します。

参照

IllustratorUsers(英語)はこの文書の古いバージョンで、当時の議論が保存されています。