Inkscape for Adobe Illustrator users

From Inkscape Wiki
Jump to: navigation, search

With Inkscape an artist can create most of the same illustrations that can be made with Adobe Illustrator. However, many of the functions and tools that the two applications share are used in different ways, with different names, shortcuts, and approaches. Please add to this document any relevant information on Inkscape/Illustrator parallels, constrasts, hits, and misses.

Contents

Formats

Illustrator can import Inkscape SVG and export SVG which Inkscape usually opens without problems (there's one issue to be aware of). Conversely, Inkscape opens Adobe's AI (since version 9) and PDF files (with some limitations: gradient meshes are approximated by lattices of small paths, and transparency modes don't work). Inkscape can also export its documents as PDF.

To Save Illustrator Files in Inkscape for Windows

This post on We Rock Your Web is for GIMP, but works equally to create save-as-.ai options in Inkscape for Windows.

You also need to add the location of the GS executable to the PATH, as detailed on this page.

Another way(tested on 0.48.3) that achieves good compatibility but drops some stuff on the way(like converting text to paths) is to save it as PDF and then export as EPS from Acrobat X. Illustrator safely opens this and saves as *.AI. Which is safely opened in Expression Blend 4.

Terminology

  • Anchor Points: in Inkscape, anchor points are known as "Nodes"
  • Palettes: in Inkscape, "palettes" are called "dialogs", such as the Fill and Stroke dialog.
  • Marquee: this is called "the rubberband" when selecting
  • Tools: see AdobeToolMap for complete tool equivalency reference.

Things Illustrator can do that Inkscape cannot do:

  • Gradient meshes
  • Multiple strokes and fills for one object
  • Color management for print (ICC Profiles, etc.)
  • PMS color
  • Natively work with graphs based on data
  • Free transform and perspective transform (only via extension)
  • Blends (only via extension)

Things Inkscape can do that Illustrator cannot:

  • Edit SVG source directly
  • Clones, tiled clones, edit clones on canvas
  • Keys to move/rotate/scale by screen pixels
  • Shapes as objects
  • Edit gradients with handles on-canvas (CS4 added this feature)
  • Edit nodes with keyboard
  • One-click paint bucket fill
  • Color painting over objects (CS4 added this feature with the name Blob brush)

Hand Tool : Navigating the Canvas

Instead of using the Spacebar for panning around a document, in Inkscape an artist can press and hold the middle mouse button (or mouse wheel) and drag the canvas in any direction. Alternatively, rotate mouse wheel to pan vertically, rotate with shift to pan horizontally. In Inkscape, the artist can also pan around the canvas by holding the Ctrl and pressing the arrow keys. Holding the arrow key speeds up the pan in that direction.

In 0.46, it is possible to set up Space to work as in Illustrator: even though there's no Hand tool, holding Space and dragging canvas will work if you turn on this mode in Inkscape Preferences (Scrolling tab).

Zooming : Plus and Minus Keys

Instead of holding down the Ctrl key and pressing + or - to zoom the canvas, in Inkscape the artist simply presses the + or - key to zoom.

Selector and Nodes Tool

In order to select objects with the rubberband in Inkscape, an artist must completely select the entire area of the object, not just select over part of it, to include it in the selection.

Individual nodes of paths can be selected with the Node tool rubberband, the same as in Illustrator; however the object must be selected first, and only the nodes from one object (which may combine several subpaths) can be selected. Unlike Illustrator, nodes from multiple uncombined objects cannot be selected at the same time (as of 0.46).

You can also use touch selection in Selector tool: draw over objects with Alt and, when you release, objects which you touched will be selected.

Group Select

In Inkscape there is no special group select tool. To select an individual object in a group of objects, hold the Ctrl key and click on the object with the Selector.

Or you can right-click the group and do "Enter group" after which objects in the group can be selected as if they are not grouped.

Many tools (such as Node tool, Tweak tool, shape tools) simply ignore grouping and allow you to click-select any object regardless of whether it is grouped or not.

Rotate & Skew : The Second Click

Inkscape does not have special skew or rotate tools. Instead, with the Selector tool, click on an object to select it, then click on it again to change the handles to Rotate and Skew handles. Dragging the corner handles will rotate and dragging the middle handles will skew.

Fill and Stroke dialog

Since fill and stroke are not a tool, they do no appear on the Toolbox, as is the case in Adobe Illustrator. Instead there is a Fill and Stroke window, activated through the Fill and Stroke icon on the Commands bar, or through the Menu, or by Ctrl+Shift+F.

Styles : Cut and Paste

There's no palette of stored styles yet. However you can copy style from one object to another: select the source object, do Edit > Copy (Ctrl+C), select the destination object, do Edit > Paste Style (Ctrl+Shift+V). These copied styles are not linked to the original as they are in Illustrator.

Symbols vs Cloning

Inkscape is capable of creating "clones" of objects, which are similar to Illustrator's Symbols. When you edit the original, the changes are propagated to all of its clones. Clones can be transformed, but their nodes cannot be edited. Clones can themselves be cloned. You can use the Edit > Tile clones command to create patterns and arrangements of clones.

Proportional Scaling and Center Point : Shift and Control Keys

In Inkscape, the keys to maintain proportions while scaling, and to center on point are reversed. To scale objects proportionally in Inkscape, press and hold the Ctrl key, and to use the center point for scaling, hold the Shift key.

Palettes

Inkscape calls its palettes "dialogs". They can be called up by various commands through which the artist communicates with the program. Dialogs function similarly to palettes. Dialogs can be free-floating or docked in the document window. You can toggle visibility of all active dialogs with F12 key.

Working with Nodes (Anchor Points) and Paths

Editing paths post drawing is done with the Node tool, N key. Selecting nodes is done by clicking on them, by Tab/Shift+Tab keys, or by the rubberband around several nodes. To deselect nodes, press Esc or click in an empty space. While in the node tool, you can also select a different object by clicking on it, after which its nodes become selectable.

To continue a path, select its endnode and duplicate it (Shift+D), then drag the new node. You can break the path at any selected node(s), or join two end nodes, using the correspondint toolbar buttons. You can edit the nodes of only one path object at a time, but that path object may consist of any number of distinct subpaths. Use the Break Apart and Combine commands to break a path into its subpaths and combine separate paths into a single path.

To convert a straight path segment to a curve, select both endnodes of the segment and press the "Make selected segments curves" button on the toolbar. Conversely, you can convert a segment from a curve to a straight line with the "Make selected segments lines" button.

Inkscape's node editing advantages

  1. The node appearance changes according to the kind of node it is. When a corner node is converted to a smooth node, it changes from a diamond shape to a square. Thus, without a particular node selected it is still possible to tell what kind of node it is.
  2. Inkscape can restrain node movement to the handle vector or to the adjacent straight line segment (dragging node with Ctrl+Alt).
  3. Inkscape can lock the handle length (dragging handle with Alt).
  4. You can move nodes, rotate handles, scale handles, and move selection from one node to the next using keyboard shortcuts. For moves, scales, and rotates, use Alt to move by one screen pixel.

Editing Shapes

Shape objects created with the shapes tools (i.e., Rectangle, 3D Box, Ellipse, Star, Spiral) can be immediately edited in the same tool which created them. Each kind of shape has its own handles which you can drag, possibly with keyboard modifiers, to achieve various effects (such as rounding corners of a rectangle). There are also various numeric fields in the controls bars of the shape tools. Consult the Shapes tutorial (in Help menu) for details on Inkscape shapes. Overall, shapes in Inkscape are more rich and flexible than in Illustrator.

You can also convert any shape to path, to be able to edit its nodes freely. Select the object with the Selector or Nodes tool, and then select Path>Object To Path (Shift+Ctrl+C) or if the Nodes Tool Controls bar is visible, click on the Object To Path command icon.

Pathfinder

Inkscape calls Pathfinder operations "boolean operations" on paths.

Layers

Inkscape's layers are accessible as a drop-down menu in the Status bar, with the lock and visibility toggles beside it affecting the current layer. An artist can select the layer from the list, and then select its visibility and lock status. Alternatively, use the Layers dialog (Ctrl+Shift+L).

Previews are not shown. Objects are moved from one layer to another by means of a key command (Shift+PgUp / Shift+PgDn.)

Layers can nest, and you can enter a group making it a temporary layer.

Text: Create Outlines

Converting a text object to outlines (i.e. to path) in Inkscape by Ctrl+Shift+C produces a single path object. If you want to manipulate each letter separately, you can break this path into subpaths (Path>Break Apart, Shift+Ctrl+K) and, for letters with holes, reselect parts of each letter and recombine them (Path>Combine, Ctrl+K) to fix the holes.

Text Boxes

In Text tool, when you click on the canvas, you created simple (non-flowed, i.e. not wrapping) text. If you click a drag, you create a text box (called "flowed text") where text will wrap automatically. You can also flow text into an arbitrary shape by the 'Flow into Frame' command under the 'Text' menu.

Guides

Guides can be hidden (or shown again) in Inkscape with the Shift+| key combination. The | symbol (called a pipe) is generally paired with the backslash character on the keyboard. Ctrl+; does not do anything in Inkscape.

A guide cannot be selected by drawing a rubberband through it, as is done in Illustrator. Rather, to move or delete a guide the artist must use the Selector to grab the guide and move it to another location or to the ruler.

Guides cannot be locked, and guides are global to the layers instead of bound to individual layers as they are in Illustrator. Double clicking a guide will open a dialog where you can set the guide position precisely.

Gradients

Unlike Inkscape, an object with gradient applied always displays the gradient line with all the stops, right on canvas, where you can drag the stops, color them, etc. No need to redraw the gradient anew if you want to slightly change direction.

Warp, Twirl, Pucker, Bloat, etc.

These Illustrator tools are analogous to the various modes of Inkscape's Tweak tool.

Brushes

There's no brushes palette in Inkscape yet, but you can have an editable path with any brush path applied. Select the brush path (called pattern), copy it to clipboard, then select the path you will apply brush to (called skeleton), open Path Effects (Ctrl+Shift+7), select "Path along path", click Apply, select "Single, stretched", and click the Paste button to apply the pattern.

See also

IllustratorUsers is an old version of this document preserving the discussions

Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox