IllustratorUsers

From Inkscape Wiki
Jump to: navigation, search

Note: a newer version of this document is available: Inkscape for Adobe Illustrator Users

The composition of this page is being discussed via the developer mailing list. Please provide any comments you have regarding this document to that mailing list. Once all of the major issues have been resolved a new version will be posted here. Thanks, -kw

With Inkscape an artist can create most of the same illustrations that can be made with Adobe Illustrator. However, many of the functions and tools that the two applications share are used in different ways.

Contents

Terminology

  • Anchor Points: in Inkscape, anchor points are known as "Nodes"
  • Palettes: in Inkscape, "palettes" are called "dialogs", such as the Fill and Stroke dialog.
  • Marquee: this is called "the rubberband" when selecting
  • Tools: see AdobeToolMap for complete tool equivalency reference.

Things Illustrator can do that Inkscape can not do:

  • Gradient mesh (planned for future release)
  • Multiple strokes and fills for one object
  • Color management for print (ICC Profiles, etc.)
  • PMS color
  • Natively work with graphs based on data
  • Free transform and perspective transform (only via extension)
  • Blends (only via extension)

Things Inkscape can do that Illustrator can not:

  • Edit SVG source directly
  • Clones, tiled clones, edit clones on canvas
  • Keys to move/rotate/scale by screen pixels
  • Shapes as objects
  • Edit gradients with handles on-canvas
  • Edit nodes with keyboard
  • One-click paint bucket fill
  • Color painting over objects

Getting Things Done In Inkscape

Hand Tool : Navigating the Canvas

Instead of using the Spacebar for panning around a document, in Inkscape an artist can press and hold the middle mouse button (or mouse wheel) and drag the canvas in any direction. Alternatively, rotate mouse wheel to pan vertically, rotate with shift to pan horizontally. In Inkscape, the artist can also pan around the canvas by holding the Ctrl and pressing the arrow keys. Holding the arrow key speeds up the pan in that direction.

In 0.46, it is possible to set up Space to work as in Illustrator: even though there's no Hand tool, holding Space and dragging canvas will work if you turn on this mode in Inkscape Preferences (Scrolling tab).

Zooming : Plus and Minus Keys

Instead of holding down the Ctrl key and pressing + or - to zoom the canvas, in Inkscape the artist simply presses the + or - key to zoom.

Selecting : Selector and Nodes Tool

In order to select objects with the rubberband in Inkscape, an artist must completely select the entire area of the object, not just select over part of it, to include it in the selection.

Individual nodes of paths can be selected with the Node tool rubberband, the same as in Illustrator; however the object must be selected first, and only the nodes from one object (which may combine several subpaths) can be selected. Unlike Illustrator, nodes from multiple uncombined objects cannot be selected at the same time (as of 0.46).

You can also use touch selection in Selector tool: draw over objects with Alt and, when you release, objects which you touched will be selected.

Group Select : Selector

In Inkscape there is no special group select tool. To select an individual object in a group of objects, hold the Ctrl key and click on the object with the Selector. Or you can right-click the group and do "Enter group" after which objects in the group can be selected as if they are not grouped. Many tools (such as Node tool, Tweak tool, shape tools) simply ignore grouping and allow you to click-select any object regardless of whether it is grouped or not.

Fill & Stroke : Fill and Stroke Window

Since fill and stroke are not a tool, they do no appear on the Toolbox, as is the case in Adobe Illustrator. Instead there is a Fill and Stroke window, activated through the Fill and Stroke icon on the Commands bar, or through the Menu, or by Ctrl+Shift+F.

Styles : Cut 'N Paste

There's no palette of stored styles yet. However you can copy style from one object to another: select the source object, do Edit > Copy (Ctrl+C), select the destination object, do Edit > Paste Style (Ctrl+Shift+V). These copied styles are not linked to the original as they are in Illustrator.

Symbols : Cloning

Inkscape is capable of creating "clones" of objects, which are similar to Illustrator's Symbols. When you edit the original, the changes are propagated to all of its clones. Clones can be transformed, but their nodes cannot be edited. Clones can themselves be cloned. You can use the Edit > Tile clones command to create patterns and arrangements of clones.

{The keyboard shortcuts and all the various ways to accomplish a given task will be documented in the appropriate places in the documentation. It is not necessary, or desirable, to document them here. I want to go through this document later, after it has settled down some, and reduce each solution to one method, without the shortcuts, and leave the shortcuts and whatnot to the pages of the documentation that detail that specific tool or feature. --kw}
{At the very least, a link to the appropriate place in the documentation needs to be included for each feature, if how to achieve it is not described. Plus, if this is for seasoned AI veterans, they know how to do it in AI and would most likely want to know how to achieve said function in Inkscape. --ja}

Proportional Scaling and Center Point : Shift and Control Keys

In Inkscape, the keys to maintain proportions while scaling, and to center on point are reversed. To scale objects proportionally in Inkscape, press and hold the Ctrl key, and to use the center point for scaling, hold the Shift key.

Rotate & Skew : The Second Click

Inkscape does not have special skew or rotate tools. Instead, with the Selector tool, click on an object to select it, then click on it again to change the handles to Rotate and Skew handles. Dragging the corner handles will rotate and dragging the middle handles will skew.

Palettes

Instead of palettes, Inkscape has dialogs that can be called up by various commands through which the artist communicates with the program. Dialogs function similarly to palettes. (In Windows, they do not stay on top of the Document window; this is a known problem.) You can toggle visibility of all active dialogs with F12 key.

These are traditionally called dialogs. I don't see a reason to rename them. Just "windows" is too vague. --bb
You're going to have to duke this out with Cedric (the head documentor guy) et al. I got it from him, the developers I was chatting with on IRC the other night didn't have a problem with it as far as I know, and it seems to make sense. A dialog requires a response before the command can continue--it's having a dialog (two way interaction) with the user. Everyting else is technically just a window. It's not vague if they have a name, like the Document Preferences window. How is that any more vague than the Document Preferences dialog. Sounds like a stylistic bias. I frankly don't care, as long as it's consistent and I was simply going with what had already been established. See the style guide for more detials. --kw
"traditionally called dialogs" a tradition from the GIMP. Nothing else in Gnome really has the same kind of widgets as this very specific subset of Dialogs (just as dialogs are a subset of Windows) and what Gnome normally means by Dialogs can be very different so I hope you will consider that using the term Palettes could help reduce ambiguity -- Alan
I think palettes is more appropriate. Dialogs have "OK" buttons. And that F12 trick needs to use the html "blink" attribute (j/k)... I've been so irked using Inkscape on windows and didn't know about the F12 trick until I was reading this doc. Inkscape is significantly more tolerable on Windows now. --ja

Working with Nodes (Anchor Points) and Paths

{Note: this section was very carefully constructed to make the most sense to long time users of Illustrator. It is aimed at acclimatizing a recent convert as gently as possible while at the same time remaining honest about Inkscape's limitations with respect to node editing as compared to Illustrator. Due to the relative importance of node editing, please do not hack and slash this section; edit with care.}

I have no problem with making sense for AI users, but I have a problem with incorrect and vague statements. What is "responsive" for example? Please be specific. Deselecting is done by many ways, but NOT by rubberband. This section applies to paths, not shapes, and the tool is Node tool, not Nodes (use the correct terminology please). What do you mean by "you must click only on nodes"? Will it break if you won't? No. etc, etc. --bb
For someone who uses AI professionally day after day, AI is more "responsive" by any objective measure. Again, this is legacy text that I left in place because it makes sense to AI users. In AI you can add a node, convert a node from a smooth to a corner and back again, go back and tack on another node (or fifty), edit the node handles, add some more nodes, and so on, all without moving the cursor away from the path (to click on a command icon, or select another tool). This makes creating paths in Illustrator more responsive. In actual fact it is perhaps more appropriately called "more context sensitive." You can replace "responsive" with "context sensitive" if you want, but it doesn't help reader comprehension, so why do it? You're right to correct my mistake at using "Nodes" instead of "Node", but I've used "Node" most of the time so it's obviously just a mistake. I wrote that section of the Terminology reference, so please tone it down a touch.
The only way you can say that Inkscape is not as responsive as Illustrator is on the application level and it seems like it is mostly due to rendering. On topic, I think that the node tool has significantly changed since this document was last updated, and until all of the changes are done to that tool, we should hold off on this part. --ja

Editing paths post drawing is done with the Node tool, N key. Selecting nodes is done by clicking on them, by Tab/Shift+Tab keys, or by the rubberband around several nodes. To deselect nodes, press Esc or click in an empty space. While in the node tool, you can also select a different object by clicking on it, after which its nodes become selectable.

{BB version:} To continue a path, select its endnode and duplicate it (Shift+D), then drag the new node. You can break the path at any selected node(s), or join two end nodes, using the correspondint toolbar buttons. You can edit the nodes of only one path object at a time, but that path object may consist of any number of distinct subpaths. Use the Break Apart and Combine commands to break a path into its subpaths and combine separate paths into a single path.

{KW version:} An artist will need to continue a line segment by creating two paths distinctly. When the second path has been created, select both paths and "Combine" them Control+K. Then edit nodes in the newly combined shape and attach those nodes to each other. Joining nodes is a two step process. First, join the nodes, then select whether or not the join should be a corner, or a smooth curve.

This paragraph is very strange. Why go to all this length if you can duplicate nodes in Node tool, as well as continue the path or create new subpaths in Pen tool, all without doing any combining and joining? Please explain better what you're trying to achieve by this process. --bb
This paragraph is legacy text from the original author, by the way, but I understood why he/she wrote it that way...becaue in AI it is common to start a path by putting down a few anchor points, go back and edit them a little, then pick back up where the path left off and continue to add a few (or a dozen) more anchor points, go back and edit them a bit, and so on until the complete path for the shape is built. In AI when you hover the pen tool over the end anchor point of an open path and click the anchor point, AI knows you are continuing the same path. This is the work flow that AI users are used to. Duplicating a node a dozen or a hundred times in order to continue a path is not productive. It is much faster, and more like the workflow that AI users are already used to, to simply start a new path segment near the end of the previous, and go back and join them later. Groovy? In short, this paragraph makes sense to people used to using AI. --kw
methods for continuing a path are now outdated at this point -ja

{BB version:} To convert a straight path segment to a curve, select both endnodes of the segment and press the "Make selected segments curves" button on the toolbar. Conversely, you can convert a segment from a curve to a straight line with the "Make selected segments lines" button.

{KW version:} Converting a straight node to a curve node is not as intuitive in Inkscape as it is in Illustrator. To convert a straight node to a curve, the line segments on either side must be converted. To select a line segment, select one node with the Node tool, then Shift+Click the connecting node so that both ends of the segment are selected. Then click the "Make selected segments curves" conversion command. This procedure adds Node Vector Handles (or simply handles) to both nodes on the line segment. Repeat this process with the line segment on the other side of the node being converted to give it handles on both sides. The node can then be converted to corner, smooth or symmetrical as needed. The nodes on either side will have handles, and they cannot be converted to straight nodes again, since only line segments can be converted, but placing the handle on the node will work to emulate straight node behavior.

Again a very strange advice. In my version I have described how to easily convert segments from curve to straight (real straight, not "emulated") and back. What you describe is 10 times more difficult and sounds like a mess. Please read my version carefully and add to it if you have something to add, or propose a different version. This one won't do. --bb
In Illustrator you can convert a single node without affecting the nodes on either side in any way. In IS, you can't. The way node conversion is done in IS is hack, looking at it as an AI user does. Sorry, just the truth. Again, what I'm describing here is what an AI user should do to in order do something in IS that they do in AI, from an AI POV. Again, this paragraph is written based on user feedback, not just some rabbit I'm pulling out of my own hat. You can rest assured that the description of converting nodes (it's actually converting line segments) won't be like this on the page of the actual docs that talks about that feature. It's just the way it needs to be for this document, which is written for AI users trying IS, not IS users who happen to get their hands on AI. --kw
converting node types and working with nodes is now outdated thanks to recent improvements to the node tool --ja

The Node tool currently has some limitations; notably, you can only drag nodes, not path fragments between nodes; and you can only add new nodes over the old ones or in the middle between them, instead of an arbitrary point on path.

Working with nodes in Inkscape has several distinct advantages over Illustrator:

  1. The node appearance changes according to the kind of node it is. When a corner node is converted to a smooth node, it changes from a diamond shape to a square. Thus, without a particular node selected it is still possible to tell what kind of node it is.
  2. Inkscape can restrain node movement to the handle vector or to the adjacent straight line segment (dragging node with Ctrl+Alt).
  3. Inkscape can lock the handle length (dragging handle with Alt).
  4. You can move nodes, rotate handles, scale handles, and move selection from one node to the next using keyboard shortcuts. For moves, scales, and rotates, use Alt to move by one screen pixel.
See above for why I restored this. Keyboard control is the cornerstone of Inkscape usability. If AI users are not used to it, they need to be taught about it because it matters. --bb
I understand, but we're not documenting shortcuts on this page. Nor are we proselytizing for IS directly. Nor are we teaching AI users how to use IS in its full glory. We are (or should be,) simply making a transition from AI to IS easier for the user, in the first few moments of using the program. These other fine features you want to include are dandy indeed, and when an AI users happens across them in the docs I'm sure they'll go "Oh, neat!" but it's not our job here to cover things in that detail. I would agree to a more emphatically worded general note at the begining of the doc that says something to the effect of "The key to productivity in Inkscape is use of the keyboard shortcuts." I agree that that's a strength of IS. I don't agree that it's necessary for this page that we mention every shortcut and every cool feature. Our scope is very narrow. --kw
The more I use Inkscape, the more I fall in love with the shortcuts. I've learned many shortcuts recently that I wish I had known about sooner and they have significantly eased my workflow (more time with my mouse on the canvas, versus going to toolbars or menus). I think that the items that Bulia restored here are very informative as they are, and need no modification (maybe expansion, but no reduction). --ja

Editing Shapes

In this section you again fail to take a wider perspective. AI does not seem to have any distinction between path and shapes, but this is NOT an advantage. This is a big problem with AI. We must explain to users why Inkscape treats shapes differently, and why this is an advantage. Instead you only tell them how to quickly degrade higher level abstractions (shapes) to low level (paths), seemingly implying that the fact that you can't edit nodes in shapes is some king of a "problem" that needs to be "fixed" asap by Shift+Ctrl+C. No it's NOT a problem. I restored my version --bb
This isn't about a wider perspective, it's a very narrow one: What do AI users care about when they're taking a look at Inkscape for the first time? Period. I appreciate the fact that you are so passionate about the virtues of Inkscape, I really am. But the best thing you can do to convince AI users to use IS is to tell them how to do what they do every day in AI in IS and leave it at that. My version is a direct response to multiple questions from actual AI users. I've sat them down in front of IS and watched them try to take the Node tool to a square they just created and get frustrated when it didn't work. To them it is a problem. They'll learn the virtues you want to express with your version eventually, but only if they don't have so much frustration at first that they give up and go back to AI. In a sense I'm taking a wider perspective than you are, because I'm recognizing that there are other pages of documentation, pages where some of this stuff you want to add is better put, and I'm looking at documentation as a whole. I'm putting it back the way I had it. -kw
This is most definitely about wider perspective. What they care about when using the program for the first time is how usable and powerful our software is. Can they achieve what they're looking to do? I can see the issue with the example of the drawn square and node tool. BUT, if it is explained as to why it is different and what the benefits of our shape tools are it will make more sense to them (instead of it's unnecessarilly a 2-step process). First impressions make a difference, and if things are explained more clearly it will only benefit everyone in the end. --ja

{BB version:} Shapes created with the shapes tools (i.e., Rectangle, Ellipse, Star, Spiral) can be immediately edited in the same tool which created them. Each kind of shape has its own handles which you can drag, possibly with keyboard modifiers, to achieve various effects (such as rounding corners of a rectangle). There are also various numeric fields in the controls bars of the shape tools. Consult the Shapes tutorial (in Help menu) for details on Inkscape shapes. Overall, shapes in Inkscape are more rich and flexible than in Illustrator.

You can also convert any shape to path, to be able to edit its nodes freely. Select the object with the Selector or Nodes tool, and then select Path>Object To Path (Shift+Ctrl+C) or if the Nodes Tool Controls bar is visible, click on the Object To Path command icon.

{KW version:} The nodes of basic shapes created with the shapes tools (i.e., Rectangle, Ellipse, Spiral) can not be immediately edited. Before editing nodes of a shape created with the shape tool, it must first be converted to paths. Select the object with the Selector or Nodes tool, and then select Path>Object To Path (Shift+Ctrl+C) or if the Nodes Tool Controls bar is visible, click on the Object To Path command icon. Then the nodes on of the object can be edited normally.

BB version is more appropriate. And perhaps a combination of the two versions would actually be the best way to go. --ja

Pathfinder

Inkscape calls Pathfinder operations "boolean operations" on paths.

Working with Layers

Inkscape has perfectly serviceable layers, although working with layers in Inkscape is not yet very convenient. Layers are located in the Status bar, with the lock and visibility toggle located beside it. An artist can select the layer from the spinbox, and then select its visibility and lock status. Previews are not shown, and art is moved from one layer to another by means of a key command (Shift+PgUp / Shift+PgDn.) Layers can nest, and you can enter a group making it a temporary layer.

Working with Text

Create Outlines

Converting a text object to outlines (i.e. to path) in Inkscape produces a single path object. If you want to manipulate each letter separately, you can break this path into subpaths (Path>Break Apart, Shift+Ctrl+K) and, for letters with holes, reselect parts of each letter and recombine them (Path>Combine, Ctrl+K) to fix the holes.

{Note: the above selection describes a process frequently employed in AI to embed text in the document so that the document is no longer dependent on fonts being installed. "Text to outlines" is the actual AI wording, by the way. It's hack, but is routinely done in AI, so that's why it's written as it is. Please edit with care.}

I don't understand why you need to always do Break Apart and Combine. Simply converting text to outlines works fine in Inkscape without it. If you have to do this "hack" in AI, why are you saying Inkscape is "not very productive"??? It needs this hack ONLY in specific circumstances, as I explained. Restored. --bb
Okay, you're right. I had been playing around with it (because the process doesn't seem to be documented anywhere as far as I could tell,) and it seemed like the first step wasn't doing the trick. It was just IS was being slower than I expected and I thought you had to do the break apart step too, because I was trying different things and it worked when I did that and then combine again. You're right. It only takes that first step, and that's okay.


Text Boxes

While putting text in shapes is possible in Inkscape, it is not yet well supported. Briefly, you select the object you want the text to flow into, select 'Flow Text into Shape' from the context menu, and edit the text with the XML editor. See documentation for the 'Flow into Frame' command under the 'Text' menu for more information.

Guides

Guides can be hidden in Inkscape with the Shift+| key combination. The | symbol is called a pipe and is generally paired with the backslash character on the keyboard. Ctrl+; does not do anything in Inkscape. A guide cannot be selected by drawing a rubberband through it, as is done in Illustrator. Rather, to move or delete a guide the artist must use the Selector to grab the guide and move it to another location or to the ruler. Guides cannot be locked, and guides are global to the layers instead of bound to individual layers as they are in Illustrator. Double clicking a guide will open a dialog where you can set the guide position precisely.

Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox