FrFAQ

From Inkscape Wiki
Jump to: navigation, search

Other languages: العربية Català Česky Deutsch English Español Français Italiano 日本語 한국어 Português Русский Slovenčina 中文

Dear Inkscape User,
please find a continuously updated and improved version of the User FAQ on our main website. If your language version is incomplete or missing, please consider helping us with translation.

Traduction en cours.

Contents

Général

Qu'est ce qu'Inkscape ?

Inkscape est un logiciel de dessin vectoriel libre similaire à Adobe Illustrator, Corel Draw, Freehand ou Xara X. La principale originalité d'Inkscape est l'utilisation du Scalable Vector Graphics (SVG) comme format natif. Le SVG est un standard du W3C dérivé du XML.

Qu'est ce que le dessin vectoriel ?

Contrairement aux logiciels d'imagerie matricielle (bitmap) tels que Adobe Photoshop ou The Gimp, Inkscape représente ses images dans un format vectoriel. Les images vectorielles décrivent les formes et objets observables sur l'image indépendamment de la résolution. Un moteur graphique dit de "rastérisation" utilise cette description pour représenter l'image sous forme de pixels à n'importe quelle résolution ou niveau de zoom, afin de l'afficher ou de l'imprimer.

C'est toute la différence avec les formats matriciels qui sont liés à une résolution spécifique et qui stockent l'image sous forme d'une grille de pixels.

Le dessin vectoriel est plus un complément qu'une alternative aux images matricielles. Chacun a ses propres objectifs et s'utilise dans différents contextes. Les images matricielles sont généralement meilleures pour les photographies et certains dessins artistiques, tandis que les images vectorielles sont mieux adaptées à la création assistée par ordinateur, aux logos, aux images avec du texte, aux illustrations techniques, etc.

A noter que Inkscape peut aussi importer et afficher des images matricielles. Elles seront alors de simples objets du dessin vectoriel, manipulables comme tous les autres (déplacement, transformation, découpe, etc.)

Qu'est ce que 'Scalable Vector Graphics' ?

Scalable Vector Graphics (SVG) est un format XML ouvert pour les images vectorielles et standardisé par le W3C. Son utilisation s'étend rapidement. La plupart des logiciels de dessin vectoriels de nos jours peuvent importer et exporter au format SVG, et certains navigateurs modernes (tels que Firefox et Opera) peuvent l'afficher directement, c'est-à-dire sans aucun plug-in supplémentaire. (Pour Internet Explorer, il existe un plug-in d'Adobe appelé SVG Viewer. Pour plus d'informations, se référer à la section #Inkscape et SVG ci-dessous.

Inkscape peut-il être utilisé par des utilisateurs avertis ?

Bien sûr ! Bien qu'Inkscape n'offre pas toutes les possibilités des principaux logiciels de dessins vectoriels, les dernières versions offrent tous les outils d'édition vectorielle basiques. De nombreux utilisateurs rapportent avoir utilisé Inkscape avec succès dans des projets divers (Illustrations web, diagrammes techniques, icônes, art, logos, cartes). Par exemple, des milliers d'images de wikipédia sont crées avec Inkscape, de même que la majorité du contenu de OpenClipart ; de nombreux exemples d'art Inkscape sont consultables ici et ici. Nous essayons de toujours avoir un code utile pour les utilisateurs réels, car nous pensons que des liens étroits entre les développeurs et les utilisateurs donnent de meilleurs résultats. Vous pouvez commencer à utiliser Inkscape parallèlement à vos autres outils dès maintenant !

Sur quelles plateformes Inkscape peut-il être utilisé ?

Nous fournissons des distributions binaires pour Linux, Windows 2000/2003/XP (avec installateur inclus), et OSX (paquet dmg). Nous savons que Inkscape est utilisé avec succès sur FreeBSD et d'autres systèmes Unix. Windows 98/ME n'est plus supporté, mais le sera peut-être dans le futur.

Comment Inkscape a-t-il démarré ?

Inkscape est un descendant de Sodipodi. La séparation s'est effectuée fin 2003, par la volonté de quatre développeurs de Sodipodi : Bryce Harrington, MenTaLguY, Nathan Hurst, et Ted Gould. Le but du projet était de créer un logiciel de dessin avec support complet de SVG, développé en C++ avec une nouvelle interface graphique plus simple d'utilisation (implémentant Gnome HIG) et un cycle de développement ouvert, orienté communauté. En l'espace de quelque mois le projet a publié plusieurs versions, affichant une série de nouvelles fonctionnalités importantes et des améliorations du code source. Il devint rapidement un projet Open Source remarquable.

Que signifie Inkscape ?

Le nom est formé à partir de mots anglais 'ink' et 'scape'. Ink (encre) est une substance généralement utilisée pour dessiner, et est utilisée lorsque le croquis est prêt à être appliqué sur le papier de façon permanente. Le mot évoque donc le fait qu'Inkscape peut être utilisé comme outil de production. Scape (vue) est une vue regroupant un grand nombre d'objets, comme dans landscape (paysage), et fait donc référence à l'approche orientée objet de l'imagerie vectorielle.

Puis-je créer des pages web avec Inkscape ?

Pas pour le moment, bien que de nombreux utilisateurs utilisent Inkscape pour travailler la mise en page ou créer les illustrations (bannières, logos, icônes, etc.).

Grâce au support SVG récemment ajouté dans certains navigateurs Internet (tels que Firefox ou Opera), l'utilisation de SVG directement sur le web devient une possibilité réelle. Par exemple, avec Firefox 1.5 ou plus, vous pouvez ouvrir un document SVG créé avec Inkscape directement dans le navigateur, et il sera affiché correctement. En théorie, SVG et XHTML peuvent être utilisé ensemble dans un même page, c'est donc une possibilité à explorer pour les utilisateurs ou développeurs intéressés.

Puis-je créer des animations avec Inkscape ?

Non, Inkscape ne supporte pas encore les animations SVG, seulement les images 2D et statiques. Cependant, vous pouvez exporter les images depuis Inkscape pour les utiliser dans Flash ou des animations GIF. Et depuis Février 2006, Blender peut importer des documents SVG et utiliser l'extrusion pour en faire des objets 3D.

Y aura-t-il un Inkscape 1.00 un jour ? A quoi ressemblera-t-il ?

En partant du principe que le développement continue régulièrement, nous atteindrons inévitablement la version 1.00, mais aucune date particulière n'a encore été mentionnée.

Avant de pouvoir atteindre le Nirvana avec une version 1.00, nous aurons besoin d'efforts importants pour réduire les points faibles, améliorer la stabilité et adoucir quelques détails épineux. Cela nécessitera du temps, et il y aura sûrement des changements importants dans les versions avant que cela n'arrive.


Utilisation d'Inkscape

Comment faire pivoter des objets ?

Inkscape suit la convention utilisée par CorelDraw, Xara et d'autres logiciels : au lieu d'utiliser un "outil de rotation" séparé, sélectionnez un objet en cliquant desssus avec le Sélecteur (la flèche), et cliquez dessus une fois de plus. Les poignées autour de l'objet deviennent alors des poignées de rotation - faites les glisser pour pivoter. Vous pouvez aussi utiliser la boîte de dialogue de transformation pour une rotation précise et les touches [ et ] pour faire pivoter la sélection depuis le clavier.

Comment changer la couleur des textes ?

Le texte est un objet comme les autres dans Inkscape. Vous pouvez changer la couleur de son remplissage et de ses contours avec n'importe quelle couleur, comme vous le feriez pour tout autre objet. La palette, la boîte remplissage et contour, le collage du style - tout ceci s'applique au texte exactement comme, par exemple, aux rectangles. De plus, si avec l'outil Texte vous sélectionner du texte avec Shift+flèches ou avec la souris, toute modification de la couleur s'appliquera seulement au texte sélectionné.

Comment insérer des symboles mathématiques ou spéciaux dans le dessin ?

Lorsque vous éditez du texte sur le canevas, faites Ctrl+U, et tapez le code Unicode du symbole dont vous avez besoin. Un aperçu du symbole est affiché dans la barre de statut. Une fois terminé, validez avec la touche Entrée. Une liste des codes Unicode est disponible sur unicode.org. Par exemple, le code du signe intégrale est 222b. Vous devez avoir une police installée sur votre système qui possède ce caractère, sinon un rectangle s'affichera à la place.

Quand vous éditez du texte dans l'onglet Texte de la boîte de dialogue Texte et police, vous pouvez utilisez toutes les méthodes de saisie GTK offertes par votre distribution GTK. Consultez la documentation de GTK pour plus de détails.

Pour sauvegarder votre travail au format eps, nous vous recommendons de choisir l'option "convertir les textes en chemins" lors de l'export pour conserver le symbole.

Comment dessiner des courbes sinusoïdales dans Inkscape ?

Dans la version 0.43 de Inkscape es incluse une extension nommée Function Plotter (auparavant appelée Wavy). Elle peut être utilisée pour créer des courbes sinusoïdales ou tout autre tracé de fonction. D'autres logiciels, tels que Xfig, KiG, ou KSEG peuvent aussi être utilisés pour créer des courbes plus complexes et les exporter au format SVG afin d'être utilisées dans Inkscape.

Comment mesurer des distances et des angles ?

Inkscape ne possède pas encore d'outil dédié à la mesure. Cependant, l'outil Courbe de Bézier peut être utilisé à cette fin. Sélectionnez cet outil (Shift+F6), cliquez à une extrémité du segment que vous voulez mesurez, et déplacez la souris (sans cliquer) jusqu'à l'autre extrémité. Dans la barre de statut, vous verrez apparaître la mesure de la distance et de l'angle. Appuyez sur Echap pour annuler.

L'angle est mesuré l'est par défaut à partir de l'horizontale dans le sens inverse des aiguilles d'une montre (la convention mathématique), mais dans les Préférences vous pouvez choisir la méthode de navigation (dans le sens des aiguilles d'une montre depuis la verticale).

Depuis la version 0.44, l'extension Mesurer un chemin peut mesurer la longueur d'un chemin arbitraire.

Est-ce que Inkscape supporte les palettes ? Comment puis-je "sauvegarder" des couleurs pour une utilisation ultérieure ?

Depuis la version 0.42, les palettes sont supportées et utilisent le même format que The GNU Image Manipulation Program (platettes GIMP, .gpl). Le nom utilisé dans Inkscape est "échantillons". Lors du choix de la terminologie, on s'est référé à différents programmes, et il s'est avéré que "palettes" et "échantillons" sont tous les deux couramment utilisés. Comme le terme "palettes" était déjà utilisé dans Inkscape pour un type particulier de boîtes de dialogue, le mot "échantillons" a été adopté pour décrire cette fonctionnalité.

Comment faire fonctionner les extensions ?

Le méchanisme des extensions permet d'utiliser des programmes externes et des scripts écrits dans n'importe quel langage pour augmenter les capacités d'Inkscape. La part la plus délicate est faire en sorte de satisfaire toutes les dépendances des programmes externes. Pour obtenir de l'aide sur ces dépendances pour l'ouverture de nouveaux formats de fichie, jetez un oeil à GettingExtensionsWorking. Si vous êtes intéressés par par les effets artistiques (menu Effets) regardez GettingEffectsWorking.

Comment puis-je imprimer les tutoriels ? L'impression depuis Inkscape ne tient pas sur la page, et je n'aime pas lire à l'écran.

Tous les tutoriels dans tous les langages sont disponibles en ligne au format HTML sur cette page et peuvent être facilement imprimés depuis votre navigateur.

Est-il possible d'utiliser d'autres paramètres pour les nouveaux documents créés par Inkscape ?

Oui. Lorsque vous faites Fichier > Nouveau (Ctrl+N) ou commencez une nouvelle session Inkscape, le logiciel charge un modèle par défaut qui contient le format de la page, les paramètres de la grille, du guide, d'adhérence d'export, etc. Il peut même contenir des objets pré-créés quelconques. Vous pouvez sauvegardez n'mporte quel document comme le nouveau document par défaut en l'enregistrant sous ~/.inkscape/templates/default.svg sous Linux et [inkscape dir]/share/templates/default.svg sous Windows. Si vous le sauvegardez sous un autre nom que default.svg dans le même répertoire, il apparaîtra dans le sous-menu Fichier > Nouveau, mais il ne sera pas chargé si il n'est pas choisi.

Si vous utilisez une version localisée d'Inkscape, par exemple en français, le document default.fr.svg est utilisé à la place de default.svg. De cette manière vous pouvez adapter le document chargé par défaut à la langue d'utilisation.

Est-il possible d'appliquer un dégradé à un contour de manière à ce qu'il suive le contour ?

A contour peut-être coloré avec un dégradé, mais celui-ci ne se courbera pas avec le contour. Il restera linéaire ou élliptique. Si vous pensiez à quelque chose comme ceci, SVG peut émuler de tels effets avecs les filtres SVG, mais ils ne sont pas encore supportés par Inkscape.

Il y a cependant quelques moyens de contourner le problème. L'un d'eux décrit ici (en anglais). L'autre consiste à utiliser l'extension Interpoler pour créer une interpolation entre deux chemins de couleur différente ou avec un niveau d'opacité différent. Avec suffisament d'étapes intermédiaires, une telle interpolation ressemblera beaucoup à un dégradé courbé.

Je voudrais faire un pavage de clones colorés, mais les pavés ne changent pas de couleur.

L'objet initial que vous voulez cloner doit avoir un remplissage ou un contour dont la couleur est indéfini (pas absent, mais indéfini !) pour que cela marche. Utilisez le bouton "?" dans la boîte de dialogue Remplissage et contour pour rendre la couleur indéfinie, ou utilisez la commande "indéfini" dans le menu apparaissant avec un clic droit sur l'indicateur du style dans la barre de statut. Si l'original est un groupe, vous pouvez n'avoir qu'un sous ensemble des objets dont la couleur est indéfinie, seulement ces objets verront leur couleur changer lors du pavage.

Lorsque j'essaie d'appliquer un masque d'opacité dégradé à un objet, l'objet disparait complètement.

Veuillez notez que d'après les spécifications SVG, noir désigne opaque pour un masque (i.e. il cache l'objet), alors que blanc désigne transparent (on voit l'objet au travers). De plus, l'absence de couleur ou la transparence complète est équivalent à noir transparent, c'est-à-dire (contre-intuitivement) que cela désigne aussi opaque pour un masque. Donc, si vous voulez que votre objet soit masqué progressivement, créez un masque dégradé soit de blanc à transparent, soit de blanc à noir. Les spécifications détaillées des masques SVG sont définies [ici.

Les PNG exportés par Inkscape ont des bords pixélisés / pas d'antialiasing / de drôles d'arrière-plans.

Le problème vient de ce que vous utilisez pour visualiser ces fichiers PNG, pas d'Inkscape. Par exemple, les versions d'Internet Explorer antérieures à la 7 ne peuvent afficher correctement des fichiers PNG avec des parties transparentes. Utilisez par exemple Firefox pour visualier vos PNG. Si vous devez absolument utiliser IE 6, vous ne pouvez pas avoir d'arrière-plan transparent dans vos PNG. Rendez le opaque dans les préférences du document et exportez les fichier à nouveau.

Si vous voulez ouvrir les PNG exportés dans MS-Word, vous devrez faire de même, le résultat sera bien meilleur.

J'ai deux objets adjacents dont les bords se joignent parfaitement, mais à certains niveaux de zoom, un jour est quand même visible

C'est un problème connu de notre moteur de rendu (ainsi que pour beaucoup d'autres moteurs, tels que celui de Xara). L'antialiasing rend parfois certains pixels pas entièrement opaques le long des bordures de deux objets, même si il n'y a absolument aucun espace entre eux.

Il a plusieurs façons d'éviter ce problème. Si la bordure est verticale ou horizontale, vous pouvez désactiver l'antialiasing en utilisant l'adhérence (cf. question suivante). Souvent, vous pouvez simplement grouper les deux objets et le jour disparaîtra. Si ce n'est pas possible, faites les deux objets se superposer légèrement. SI ce n'est pas possible non plus (à cause de leur transparence par exemple), le flou peut aider : à partir de Inkscape 0.45, vous pouvez grouper les deux objets et mettre une légère touche de flou pour faire disparaître l'espace entre les objets.

Comment supprimer l'antialiasing ?

Avec notre moteur de rendu actuel, il n'est pas possible de le désactiver complètement. Cependant, il est possible de le supprimer partiellement lors de l'export. Généralement, l'antialiasing est regrettable sur des lignes verticales ou horizontales qui deviennent "floues". Pour contourner ceci, assurez-vous que les bords adhèrent à la grille de pixels, et que tous les contours ont une largeur entière en nombre de pixels. Exporter ensuite le bitmap avec la résolution par défaut de 90 ppp de façon à ce qu'un pixel unitaire corresponde à un pixel du bitmap. Le bitmap qui en résulte aura des lignes bien nettes.

Inkscape peut-il être utilisé en ligne de commande ?

Oui, Inkscape a une puissante interface en ligne de commande et peut-être utilisé dans des scripts pour diverses tâches, telles que l'export ou la conversion de format. Pour plus de détails, référez vous à la pade de manuel (en ligne ou via Aide > Options de la ligne de commande, ou en tapant man inkscape sur les sytèmes Unix).

Je suis sous Windows, et les arguments en ligne de commande semblent ne pas marcher !

En fait, les trucs tels que exporter ou convertir en SVG marchent bien, c'est juste qu'ils ne produisent aucun message dans la console. C'est parce que Inkscape sous Windows est une application graphique qui n'est pas conséquent pas autorisée à écrire dans la console. Cela signifie que les options de type "query" (telles que --query-x) ne marcheront pas du tout. Mais cela paut-être corrigé en recompilant Inkscape en tant qu'application textuelle. Référez-vous à cette page pour les instructions de compilations sous Windows. Editez le fichier Makefile.mingw.common à la source du répertoires des sources et remplacez :

-lgc -mwindows -lws2_32 -lintl

par

-lgc -mconsole -lws2_32 -lintl -lgdi32 -lcomdlg32

et recompilez. Cela vous donnera un fichier inkscape.exe qui fonctionne exactement comme sous Linux en ce qui concerne la console. Si vous utilisez régulièrement l'interface en ligne de commande sous Windows, envoyez un message à la liste inkscape-devel, et peut-être que nous envisagerons de fournir un exécutable pour console dans nos distribution pour Windows.

Comment faire fonctionnner Alt+clic et Alt+glisser sous Linux ?

Alt+clic et Alt+glisser sont des raccourcis très utiles sous Inkscape ("Sélectionner en dessous" et "Déplacer la sélection" avec le Sélecteur, "Sculpture de noeuds" avec l'outil Noeud). Cependant, sous Linux, Alt+clic et Alt+glisser sont souvent utilisés par le gestionnaire de fenêtres pour manipuler les fenêtres. Vous devez désactiver cette fonction dans votre gestionnaire de fenêtre pour pouvoir l'utiliser dans Inkscape.

GNOME

Allez dans Système > Préférences > Fenêtres. Vous avez le choix entre trois options pour déplacer les fenêtres : "Alt", "Ctrl" ou "Super" (touche Windows). Choisissez "Super".

KDE

Vous pouvez par exemple aller dans le Centre de Contrôle > Bureau > Comportement des fenêtres > Actions sur les fenêtres.

XFCE4

Reportez-vous à xfwm4.html

J'ai des problèmes avec les noms de fichiers non latins sous Linux.

Si l'encodage de votre locale est UTF-8, vous devez définir cette variable d'environnement :

$  G_BROKEN_FILENAMES=1
$  export G_BROKEN_FILENAMES

Ceci est nécessaire pour que la conversion des noms de fichiers en UTF-8 (utilisé en SVG) par Glib. Pour plus de détails.

Comment faire fonctionner Alt+clic at Alt+glisser sous Mac OS X ?

Si il vous est impossible d'utiliser les fonctions d'Inkscape qui utilisent la touche Alt (telles que la sculpture de noeuds), vous devez désactiver "l'émulation d'une souris à trois boutons" dans les préférences de X11.

J'ai un machine avec un système d'exploitation dont la langue par défaut est xxx, mais je veux que Inkscape soit dans la langue yyy, comment faire ?

Linux
Tapez tout d'abord locale -a dans la console pour connaître les paramètres régionaux installés et savoir comment les écrire.
export LANGUAGE="C" sur la ligne de commande sélectionne la langue par défaut (anglais).
export LANGUAGE="fr_FR.utf-8" permet de sélectionner le français de France.
Cette commande ne fonctionne que temporairement. Les paramètres initiaux seront restaurés après un redémarrage du système. Cela ne fonctionne que si les paramètres régionaux choisis sont installés sur votre système (dans le cas contraire, la langue par défaut est choisie).
MacOSX
La méthode officielle pour Mac OS x est de fournir des fichiers .lproj qui permettent aux applications de choisir leur langue préférée à partir des Préférences Systèmes. Cependant, c'est une méthode qui ne sera considérée que plus tard. En attendant, la méthode Linux devrait marcher.
Windows
Méthode facile
Créez un fichier batch dans le répertoire d'installation de Inkscape et nommez-le inkscape.bat
Tapez les lignes suivantes (en remplaçant avec votre langue) :
@set LANG=fr_FR
@start inkscape.exe
Sauvegardez et double-cliquez dessus pour l'utiliser
En utilisant les paramètres systèmes :
A. En supprimant les fichiers de la langue xxx
Notez que ce changement affecte tous les utilisateurs d'Inkscape sur cet ordinateur.
1. Repérez le répertoire d'installation
2. Allez dans le répertoire Inkscape\locale
3. Trouvez le répertoire avec la langue que vous ne voulez pas utiliser.
4. Renommez le en quelque chose comme x_fr, ou supprimez le.
5. Redémarrez Inkscape et le langage par défaut (anglais) sera utilisé.
B. En définissant la variable d'environnement LANGUAGE
Cela ne marche probablement que si vous avez les droits d'administrateurs (ou utilisateur privilégié ?) sur votre PC.
1. Allez dans le panneau de configuration, puis dans "Système".
2. Sélectionnez l'onglet "Avancé" et cliquez sur le bouton "Variables d'envionnement".
3. Vous pouvez ajouter la variable LANGUAGE soit pour l'utilisateur courant soit pour tous les utilisateurs (variables système). Cliquez sur le bouton "Nouveau" et entrez 'LANGUAGE' comme nom de variable, et 'C' comme valeur si vous voulez l'anglais comme langue ou par exemple 'fr' pour sélectionner le français.

J'ai installé une nouvelle police sur mon système Windows, mais Inkscape ne la voit pas.

C'était un bug dans les versions d'Inkscape antérieures à 0.43, causé par un cache de polices obsolète. Ce cache est stocké dans le fichier nommé .fonts.cache-1. Ce fichier peut-être dans votre répertoire Windows, ou votre répertoire Temp, ou dans votre répertoire "Mes documents", ou dans le répertoire indiqué dans la variable d'environnement $HOME. Utilisez la recherche de fichiers pour le trouver. Il suffit alors de le supprimer et de redémarrer Inkscape. Les nouvelles polices seront alors disponibles.

J'ai installé Inkscape sur OS X 10.4.x, mais lorsque je le lance, rien ne se passe. L'interface n'apparaît pas.

Sous OS X 10.4.x, même sur les machines très rapides, les versions d'Inskcape antérieures à 0.44 pouvaient prendre un temps très long pour se charger la première fois qu'elle étaient exécutées. Ceci était dû à une mauvaise implémentation temporaire du cache de polices. Le problème a été résolu dans la version 0.44 (mais pas dans les présorties 0 à 3).

Sous Linux, Inkscape plante avec un message "invalid pointer".

Si Inkscape plante au lancement avec un message d'erreur similaire à :

*** glibc detected *** free(): invalid pointer: 0x086143b0 ***

cela est dû à une incompatibilité entre des versions de GCC affectant les applications c++. Votre version d'Inkscape est compilée avec une version de GCC différente de celle pour l'utiliser. Recompilez soit Inkscape soit ses librairies C++ (libstdc++, libsigc++, libglibmm et libgtkmm) avec la bonne version de GCC et le problème sera résolu.

Contribuer à Inkscape

Comment puis-je participer au projet ?

Si vous savez programmer, récupérez simplement le code et faites ce qui vous intéresse. Envoyez un patch quand vous êtes content de votre travail et prêt à partager vos efforts avec la communauté. Nous avons aussi besoin de rédacteurs et de traducteurs pour internationaliser le manuel utilisateur et l'interface (Il8N).

Nous prenons les contributions très au sérieux et suivons le principe du "patcher d'abord, discuter ensuite". Il est donc tout à fait probable que vos efforts apparaîtront rapidement dans le code source. Il y a bien entendu des règles et standards à respecter, mais nous essayons de faire en sorte qu'ils coulent de source. En bref, lancez-vous !

Est-il possible d'aider sans programmer ?

Certainement ! Bien qu'il y ait à n'en pas douter beaucoup de code à écrire, il y a aussi beaucoup d'autres tâches nécessaires à la réalisation du projet :

Chasse aux bugs et tests

Identifier et caractériser les bugs peut aider ENORMEMENT en réduisant le temps de développement passé à corriger les bugs.

  • Trouvez et reportez les bugs - C'est un besoin critique pour s'assurer de la qualité du code.
  • Vérifiez les rapports de bugs - Quelques fois les rapports de bugs ne contiennent pas assez d'informations ou sont difficiles à reproduire. Essayez de voir si vous constatez aussi le bug et ajoutez des détails à sa description.
  • Tests de performance - Créez des fichiers SVG poussant Inkscape à ses limites, et envoyez les au système de gestion des bugs de Inkscape en tant que cas de test, avec vos mesures de performances.
  • Tests de compatibilité - Comparez le rendu de fichiers SVG de Inkscape avec celui d'autres logiciels tels que Batik ou Cairo, et reportez les différences observées (aux deux projets concernés).
  • Prioritisation des bugs - Les bugs ayant une priorité égale à 5 sont des nouveaux bugs. Relisez les et assignez leur une priorité basse/moyenne/haute en fonction de leur gravité. Voir Updating Tracker Items pour plus de détails.

Ton prochain tu aideras

En plus d'un logiciel de dessin de bonne qualité, une communauté soudée autour de celui-ci nous paraî extrêmement important. Vous pouvez nous aider à l'obtenir directement en aidant les autres utilisateurs. Par dessus tout, gardez à l'esprit que nous voulons maintenir la communauté d'Inkscape sympathique et polie, montrez donc le bon exemple à travers vos interactions avec les autrez membres du groupe.

  • Rédigez des tutoriaux - Si un procédé n'est pas encore documenté dans un tutoriel, décrivez comment y parvenir.
  • Participez sur inkscape-user@ - Répondez aux questions posées par les autres utilisateurs sur la mailing-list. Vous pouvez aussi partagez vos trucs et astuces, et montrer de nouvelles façons d'utiliser Inkscape pour obtenir des trucs cools.
  • Créez des cliparts - Vous pouvez les envoyer au projet openclipart.org.
  • Donnez des cours d'Inkscape - Apprenez autour de vous comment utiliser Inkscape. Vous pouvez aussi donner des présentation lors d'événements locaux, de réunions de votre GUL, etc. sur Inkscape (et les autres logiciels d'art Open Source).

Développement (sans programmation)

  • Traductions - La création de traductions pour l'interface est documentée en ligne sur la page TranslationInformation du wiki. C'est grâce à des traducteurs que vous lisez cette page :)
  • Concevez des icônes et thèmes SVG - Créez de nouvelles icônes pour des thèmes existants ou créez un nouveau thème.
  • Créez de nouveaux styles de boîtes de dialogues - Dessinez vos idées sur une maquette pour améliorer ou ajouter de nouvelles boîtes de dialogues. C'est pratique pour les développeurs de l'interface lorsqu'ils doivent décider ce qu'il y a de mieux à faire.
  • Améliorez les paquets - Déterminez comment améliorer l'installation d'un paquet sur votre système d'exploitation ou votre distribution Linux. Lisez la page CreatingDists du wiki.
  • Ajoutez des extensions - Pour l'écriture/lecture de fichiers, des fonctionnalités spéciales, etc., Inkscape peut être lié à un programme externe. Créez de nouveaux fichiers .inx pour attacher de nouvelles extensions. Vous pouvez aussi vous essayer à améliorer les extensions si vous êtes familiers avec les scripts Perl, Python, etc.
  • Documentez le code - Le code source nécessite à certains endroits d'être commenté, parfois même de façon rudimentaire. Documenter les fonctions aidera certainement les prochains programmeurs.
  • Créez des modèles - Jetez un coup d'oeil au répertoire share/templates d'Inkscape.
  • Editez le wiki - Le wiki est un endroit merveilleux pour accumuler des informations sur le développement, mais il a constamment besoin d'être mis à jour, amélioré, et traduit.
  • Plannifiez le développement - Relisez et aider à mettre à jour la feuille de route sur le wiki. Typiquement, discutez avec les développeurs à propos de ce sur quoi ils travaillent, ce qu'ils prévoient de faire, ou ce qu'ils viennent de terminer. Mettez ensuite à jour la feuille de route en conséquence.

Faites passer le mot - Le marketing et l'évangélisme d'Inkscape

Augmenter le nombre d'utilisateur est important. Un réseau étendu d'utilisateurs intéressés amènera de nouveaux contributeurs potentiels grâce aux compliments (espérons-le) des utilisateurs et au bouche-à-oreille, qui est pour nous important. Tous nos utilisateurs représentent les ambassadeurs d'Inkscape et notre entourage jugera Inkscape à la façon dont nous nous comportons. Il est important que nous soyons tous amicaux et sympathiques, que nous fassions de Inkscape un projet appréciable. Toute autre forme d'évangélisme suivra naturellement.

Cependant, nous préférons plutôt la qualité à la quantité, faites donc attention à ne pas faire de la vente forcée. Nous voulons collaborer avec les autres applications, plutôt que de les dénigrer. De tels commentaires sont par ailleurs contre-productifs.

Nous avons aussi besoin de gérer l'attente qu'ont les utilisteurs de notre projet. Nous voulons des utilisateurs agréablement surpris par ce dont est capable Inkscape, et non déçus par le fait qu'il ne fasse pas exactement tout ce que font d'autres programmes. Inkscape devrait être vu comme un outil fournissant aux artistes d'autres moyens de créativité complétant leurs autres outils et compétences.

  • Rédigez des articles - Faites publier des articles dans divers blogs et journaux en ligne (ou même imprimés). N'oubliez pas d'inclure un lien vers Inkscape !
  • Prenez des captures d'écran - En particulier pour les nouvelles fonctionnalités.
  • Créez des exemples - Les exemples sont utiles pour présenter les différentes façons dont Inkscape peut être utiliser. Prenez des captures d'écrans, commentez-les, et proposez aux administrateurs du site (via la mailing-list inkscape-devel@) de les ajouter.
  • Améliorez le site web - De l'aide pour le site est TOUJOURS appréciée. La connaissance du HTML est requise, un savoir en PHP est utile. Récupérez le code du site depuis le dépot Subversion, et faites part de vos patches, ou demandez un accès à svn pour travailler en temps réel.
  • Donnez des présentations - Organisez des présentations d'Inkscape lors d'expositions, conférences ou autres événements importants. Assurez-vous de l'annoncer sur une mailing-list d'Inkscape afin qu'on puisse l'afficher sur le site.
  • Recrutez d'autres développeurs - Trouvez des personnes intéressées par la programmation, et encouragez-les à rejointre l'équipe des développeurs d'Inkscape.

Où puis-je trouver une bannière Inkscape ?

En voici une :

http://www.inkscape.org/images/inkscape_80x15.png

N'hésitez pas à proposer vos propres banières ou boutons pour la promotion d'Inkscape. Les meilleures se verront attribuer un lien ici.

Comment puis-je éviter de lancer un troll sur la mailing liste ?

Inkscape se veut être une communauté amicale. Cependant, nous somme tous passionnés et avons différentes vues, il peut donc arriver que les discussions prennent un peu de piment. Le problème est que lorsque des personnes commencent à avoir des positions trop fermes, les arguments peuvent rapidement devenir improductif voire n'importe quoi, allant jusqu'à amener des contributeurs talentueux à quitter le projet. Nous accordons donc une grande importance au fait que la mailing liste doit rester civilisée.

Voici quelques astuces pour avoir des communications productives au sein de la communauté d'Inkscape.

1) Avant tout, donnez vos arguments sans faire de comparaison. Les fonctionnalités d'un réel intérêt n'ont besoin de rien d'autre pour convaincre, et se démarquent au premier coup d'oeil d'après les cas d'utilisations reportés. La plupart du temps les comparaisons ne vous aidront pas. En fait, elles peuvent souvent se retourner contre vous car la communauté est souvent allergique à ce genre de raisonnement. Beaucoup d'utilisateurs dessinent avec Inkscape pour échapper aux logiciels auxquels vous voulez comparer Inkscape :)

2) Ne supposez pas que les développeurs, les utilisateurs, et les professionnels de l'industrie sont groupes mutuellement exclusifs. C'est généralement le contraire pour des projets développant à la demande. Les développeurs sont des utilisateurs programmant le logiciel pour leur propre utilisation. Certains développeurs sont des professionnels utilisant Inkscape dans leur vie de tous les jours. Cela signifie aussi que des arguments qui commencent par des généralisations sur les besoins et attentes des utilisateurs doivent combattre le fait que les utilisateurs développent le programme comme bon leur semble.

3) Ne supposez pas non plus qu'une réticence à l'égard de vos idées signifie que les besoins et souhaits des non-développeurs sont méprisés. Beaucoup de développeurs passent un temps considérable à discuter avec les utilisateurs en personne, sur IRC ou sur la miling liste. Nous savons lorsque le problème est important car nous pouvons entendre le consensus. Un grand nombre de fonctionnalités ont été codées en réponse directe aux besoins et requêtes d'utilisateurs ayant fait des demandes polies et convaincantes.

En effet, vu que les développeurs d'Inkscape jugent d'après la taille du consensus des utilisateurs, une bonne approche consiste à pointer du doigt un motif récurrent de demandes parmi un groupe d'utilisateurs, ou de montrer pourquoi votre proposition va satisfaire un grand nombre d'utilisateurs. (Cela ne veut pas dire que ce que demande la foule est toujours correct, mais il y a généralement des coorélations fortes.)

4)On ne demande pas la renommée, on la gagne. :-) Ceci est un fait décevant mais réel de la vie communautaire. Le projet a besoin de contributeurs pour vivre et se développer, et tout le monde est heureux de voir de l'huile de coude fraîche s'impliquer, et se pliera en quatre pour aider. Plus vous vous impliquez, plus vous donnez de votre sueur, plus la communauté vous donnera du répondant. Ce qu'il y a de bien, c'est que les contributions simples comptent vraiment.

Retenez le slogan d'Inskcape : Patchez d'abord, discuter ensuite. Ce n'est pas un qu'un aphorisme. Il est fréquent que les différentes parties d'une discussion ne comprendront pas tous les facteurs tant qu'ils n'auront pas vu les choses en pratique, ne serait-ce qu'une ébauche ou un prototype. Le fait de présenter vos idées sous forme de patch vous permet aussi d'éviter les réticences des autres à se mettre au travail pour implémenter vos idées.

5) N'oubliez pas que nous partageons des buts communs, ou au moins un : améliorer Inkscape. Lorsqu'une discussion commence à chauffer, les différentes parties doivent chercher les points d'accord, et se concentrer sur celles-ci.

Inkscape et SVG

Est-ce que les fichiers SVG créés par Inkscape sont valides ?

Oui. Inkscape ne supporte pas encore toutes les possibilités de SVG, mais tous les fichiers qu'il génère sont des fichiers SVG valides (avec l'exception partielle et temporaire des zones de texte, voir ci-dessous). Toutes les visionneuses SVG se conformant au standard SVG affichent les fichiers comme Inkscape. Si ce n'est pas le cas, c'est un bug. Si c'est un bug d'Inkscape, nous le corrigerons (surtout si vous nous aidez en le reportant !).

Qu'en est-il des zones de texte ?

Quand le support des zones de texte a été ajouté à Inkscape, il était conforme à l'ébauche des spécifications de SVG 1.2 (et était toujours décrit comme une fonctionnalité expérimentale). Malheureusement, dans les ébauches suivantes, le W3C décida de changer les spécifications de cette fonctionnalité. Actuellement SVG 1.2 n'est pas terminé, et par conséquent, très peu de visionneuses SVG implémentent actuellement les zones de texte, que ce soit l'ancienne ou la nouvelle syntaxe. Donc techniquement, les fichiers SVG de Inkscape qui utilisent les zones de textes ne sont pas conformes SVG 1.1, et causent généralement des problèmes (erreurs ou des boîtes noires sans texte).

Cependant, à cause de l'utilité de cette fonctionnalité très demandée, nous avons décidé de la conserver. Lorsque les spécifications finales de SVG 1.2 seront publiées, nous changerons notre implémentation pour qu'elle soit conforme à celles-ci, et nous fournirons une méthode pour passer de l'ancien format des zones de texte au nouveau.

En attendant, vous ne devriez pas utiliser les zones de texte dans des documents que vous comptez utiliser en dehors de Inkscape. Les zones de texte sont créées en cliquant et glissant avec l'outil Texte, tandis qu'un simple clic crée du texte pur SVG 1.1. Donc si nous n'avez pas vraiment besoin d'une zone de texte, contentez-vous de cliquer au lieu de dessiner un cadre. Si par contre vous en avez vraiment besoin, vous devrez le convertir en texte normal en utilisant la fonction "Convertir en texte" du menu Texte. Cette commande conserve complètement l'apparence et le format de la zone de texte, mais le texte ne sera plus une zone et sera conforme SVG 1.1.

Alors pourquoi peut-on sauvegarder au format "SVG simple" et "SVG Inkscape" ?

Les fichiers SVG Inkscape utilisent l'espace de nom inkscape pour stocker des informations supplémentaires utilisées par le programme. Les autres programmes SVG ne comprendront pas ces extensions, mais ça ne pose pas de problème vu que cela concerne uniquement l'édition du document, et non son apparence. Les extensions ne causent aucun problème de rendu dans les visionneuses conformes au format SVG. Cependant, certaines visionneuses peuvent rencontrer des problèmes en présence d'extensions, ou vous pouvez avoir envie d'économiser de l'espace disque en supprimant les informations d'Inkscape (si vous ne comptez pas éditer le fichier avec Inkscape par la suite). C'est pourquoi le format "SVG simple" est fourni.

Quelles sont les fonctionnalités SVG implémentées par Inkscape ?

Les principaux éléments de SVG qu'Inkscape de supporte pas encore sont les filtres (sauf les flous Gaussien depuis la version 0.45), les animations et les polices de caractères SVG. Tout le reste fonctionne quasiment, bien qu'évidemment il y ait quelques bugs que nous réparons constamment. Pour une comparaison entre Inkscape et d'autres outils SVG open source du banc de tests du W3C, rendez-vous ici.

J'ai écrit un fichier SVG à la main. Est-ce que tout va être désordonné si je l'ouvre et sauvegarde avec Inkscape ?

Inkscape fait de son mieux pour éviter de modifier le SVG juste parce qu'il ne reconnaît pas certains éléments. Il y aura cependant certaines modifications :

  • Tous les objets se verront attribuer un attribut "id" unique. Si il en existe déjà un (et si il est unique), il sera conservé, sinon il sera dérivé du nom du nœud.
  • Des métadonnées seront aujoutées au début du document dans les espaces de nom sodipodi: et inkscape:.
  • Si vous éditez un dégradé, celui-ci sera séparé en deux dégradés liés : un définissant le vecteur de couleur et l'autre la position.
  • La modification d'un propriété de style provoquera la reconstruction de la totalité de l'attribut "style". Les commentaires CSS (mais pas XML) seront donc perdus et le format sera peut-être modifié.
  • Le style de mise en forme du fichier SVG sera changé pour s'accorder à celui d'Inkscape.

Nous travaillons à mieux préserver les fichiers SVG créés à la main, mais c'est une tâche très difficile nécessitant beaucoup de travail d'infrastructure. Cela se fera petit à petit, et une aide est toujours appréciée.

Inkscape et la visionneuse xxx affichent mes fichiers SVG différemment. Que faire ?

Cela dépend de xxx. Nous acceptons Batik et le plugin Adobe SVG comme références pour rendre le SVG car ils sont soutenus par certains des auteurs du standard SVG et font vraiment attention à être conformes. Ceci n'est pas toujours vrai pour les autres visionneuses. Donc si vous avez un problème avec une visionneuse, essayez le même fichier avec Batik ou Adobe, ou mieux encore, avec les deux (ils sont tous les deux gratuits et multi-plateformes). Si le problème persiste, nous voulons l'investiguer. Merci de soumettre un bug, sans oublier d'attacher un fichier d'exemple, et idéalement des captures d'écran aussi.

Inkscape et les autres programmes

Pourquoi s'être séparé de Sodipodi ?

Inkscape a démarré lors d'une séparation de Sodipodi. Les principales raisons étaient des différences d'objectif et d'approche de développement. L'objectif d'Inkscape était d'être un éditeur SVG valide et complet, alors que pour Sodipodi, SVG est plus moyen de devenir un logiciel de dessin vectoriel. Le développement d'Inkscape repose sur un accès au code source, ainsi que sur l'utilisation de librairies tierce-parties et de standards tels que HIG, CSS, etc., plutôt que des solutions personnalisées. Réutiliser et partager des solutions existantes aide les développeurs à se concentrer uniquement sur le noyau dur de Inkscape.

A titre culturel, il peut être intéressant de lire le post de Lauris d'octobre 2003 : Sodipodi direction. Il y décrit son avis sur SVG, la licence de publication, et l'intérêt de séparer le projet en deux branches indépendantes.

Quelle est la différence entre Inkscape et Dia ?

DIA est spécialisé pour création de diagrammes techniques, telles que les schémas de base de données, les diagrammes de classe, etc., tandis que Inskscape lui, est conçu pour la cration d'illustrations vectorielles, comme les logos, les posters, les icônes, etc.

Cependant, le format SVG est aussi utile pour créer des diagrammes, nous espérons donc qu'en implémentant petit à petit toutes les fonctionnalités du SVG, Inkscape deviendra aussi un outil intéressant pour la réalisation de diagrammes. Plusieurs d'entre nous espèrent que Inkscape pourra servir au dessin technique et travaillent dans ce sens. Mais Dia propose plusieurs fonctionnalités, telles que le support d'UML ou l'autogénération de diagrammes, qui sortent des limites d'un éditeur SVG standard. Dans l'idéal, Inkscape et Dia peuvent partager des morceaux de code et des librairies.

Le projet a-t-il l'intention de remplacer Flash ?

Bien que SVG est souvent décrit comme un "remplacement de Flash", SVG a un grand nombre d'autres utilités. Remplacer Flash ne fait pas partie des principaux buts de Inkscape. Si SVG peut remplacer Flash et que Inkscape peut aider, très bien, mais il y a bien plus que SVG qui vaut le coup pour les animations Web (Voir aussi SMIL).

Inkscape est-il un remplacement de The GIMP ou Photoshop ?

Dans la plupart des cas, non. Ils sont utilisés différemment. Inkscape est utilisé pour créer des illustrations vectorielles, comme mettre en page un poster ou dessiner un logo fantaisiste, tandis que les éditeurs bitmap sont utilisés pour travailler sur des images matricielles, comme retoucher une photo. Dans beaucoup de projets, vous aurez besoin des deux, par exemple pour ajouter des effets bitmap sur une image exportée par Inkscape.

Cependant, les éditeurs bitmap sont souvent utilisés à des fins pour lesquelles ils ne sont pas très bien équipés, comme mettre en page une page web, créer des logos, ou du dessin technique. Dans la plupart des cas, c'est parce que les utiliateurs ne sont pas au courant de la puissance (ou même de l'existence) des éditeurs vectoriels modernes. Inkscape veut mettre fin à cette situation, et faire de l'éditeur vectoriel un outil de bureau essentiel pour tout le monde, plutôt qu'un outil exotique et spécialisé pour des tâches professionnelles.

Inkscape fera-t-il partie de la suite Gnome-Office ?

Inkscape a besoin de mûrir encore un peu pour cela. En particulier, une meilleure implémentation de Bonobo est nécessaire, et le système d'impression de Gnome doit être testé de manière plus approfondie (de l'aide serait grandement appréciée). Si vous pouvez compiler une version récente d'Inkscape et nous aider à le tester, cela serait très utile.

Quels formats Inkscape peut-il importer/exporter ?

Inkscape supporte nativement l'ouverture des fomats SVG et SVGZ (SVG gzippé) uniquement, et la sauvegarde des formats SVG, SVGZ, Postscript/EPS/EPSi, Adobe Illustrator (*.ai), LaTeX (*.tex) et POVRay (*.pov).

Avec l'aide d'extensions, Inkscape peut lire et sauvegarder en PDF, EPS, AI, Dia, Sketch et quelques autres formats. La plupart des formats bitmaps (JPG, PNG, GIF, etc.) peuvent être importés nativement en tant qu'images bitmap, mais ne peut exporter qu'au format PNG.

Veuillez vous référer à FileTypes pour une discussion à propos des formats de fichiers que les utilisateurs aimeraient voir supportés, et des outils externes qui peuvent être utilisés pour convertir des fichiers vers et depuis le format SVG.

Comment puis-je utiliser des fichiers CDR (fichiers Corel Draw) avec Inskcape ?

  1. Ouvrez le fichier CDR avec Corel Draw et sauvegardez le au format CGM. Seuls les dessins vectoriels seront conservés, aucune image matricielle.
  2. Ouvrez le fichier CGM dans OpenOffice Impress. Copiez le contenu dans OpenOffice Draw et insérez les images matricielles manquantes. (Sauvegardez au format ODG et vous pouvez continuer à utiliser OpenOffice Draw)
  3. Sélectionnez tout (Ctrl+A).
  4. Exportez au format SVG.
  5. Ouvrez le SVG dans Inkscape et corrigez les erreurs éventuelles.

J'ai exporté au format SVG avec Adobe Illustrator, édité celui-ci dans Inkscape, et l'ai importé dans AI, mais toutes mes modifications sont perdues !

C'est parce que Adobe triche. Un fichier SVG valide est créé, mais le contenu est aussi sauvegardé au format binaire natif de AI dans le fichier. Bien entendu, Inkscape édite la partie SVG et ignore la partie binaire. Mais quand vous importez le fichier SVG dans AI, il ignore complètement le code SVG et lit directement la partie binaire. Les changements SVG sont donc perdus. Pour contourner ce problème, ouvrez l'éditeur XML dans Inkscape et supprimez les éléments non-SVG (tout ce qui ne commence pas par svg:).

Development topics

Quels sont les objectifs du développement d'Inkscape ?

Inkscape se veut un éditeur de dessin vectoriel complètement compatible SVG. A part la conformité au standard, nos principaux buts sont la stabilité, la performance, l'état de l'art en matière d'outils vectoriels, ainsi qu'une interface efficace et innovante.

A partir de quel langage et librairie graphique Inkscape est-il construit ?

Les sources héritées de Sodipodi étaient écrites en C/Gtk. Mais nous essayons actuellement de tout convertir en C++/Gtkmm. Le but final est de simplifier le code et de le rendre plus facile à maintenir. Nous vous invitons à nous y aider, évitez simplement de mentionner Qt. :)

Quelle est votre position vis-à-vis du partage de code avec d'autres projets ?

Nous sommes tout à fait pour, à quelques conditions. Une bonne librairie candidate doit être mature, répandue, bien documentée, et activement maintenue. Elle ne doit pas introduire d'importants problèmes de dépendances pour l'utilisateur final et doit être stable, puissance et légère. Il est préférable qu'elle se contente de ne faire qu'un truc, mais qu'elle le fasse bien. Les librairies qui ne respectent pas tous les critères seront considérées au cas par cas.

Comment créer une extension pour Inkscape ?

Il n'est pas utile de connaître le fonctionnement interne de Inkscape pour créer une extension utile. Aaron Spike, auteur de la plupart des extensions en Python, a écrit une page web bien pratique (incluant une série de didacticiels) sur la création d'extensions en Python (Perl et Ruby sont aussi possibles).

Comment se familiariser avec le code ?

Un bon point de départ est la documentation Doxygen. Vous pourrez non seulement y trouver les éléments Doxygen habituels, mais aussi des vues catégorisées du code d'Inkscape.

Dans la partie Documentation du site d'Inkscape, vous pourrez trouver quelques diagrammes haut-niveau et des liens vers de la documentation supplémentaire telle que la page de manuel. Depuis toujours, le code source n'a jamais été très bien documenté, attendez-vous donc a trouvé de nombreux endroits où votre seule ressource sera de lire le code. Cependant, nous nous efforçons de changer cela, en complétant la documentation au fur et à mesure.

Certains développeurs ont trouvé que tester des patches est un bonne façon de rentrer rapidement dans le code, car cela permet de voir l'approche utilisée par les développeurs pour modifier le code. D'autres aiment choisir une demande de fonctionnalité intéressante (ou éventuellement une fonctionnalité qu'ils aimeraient) et essaient de l'implémenter. Occasionnellement, nous avons de besoin de faire de larges refactorisations du code, c'est une façon simple de contribuer grandement avec peu d'expérience.

Après une première étape, accéder à la suivante en rentrant dans le détail n'est pas toujours facile à cause du manque de documentation, mais cela est possible avec un peu de détermination. Certains développeurs trouvent que corriger un plantage de l'application en traçant les appels de fonction donne un bon aperçu du déroulement du programme. Il est parfois très pédagogique de partir d'un boîte de dialogue bien choisie et de suivre la pile d'exécution. De même que partir du chargeur de fichiers SVG et suivre les entrées/sorties du parseur. D'autres développeurs enfin estiment que de commenter le code permet de comprendre le fonctionnement de certaines parties tout en étant utile aux autres développeurs.

Une fois que vous vous sentez suffisamment avancé, implémenter de nouvelles fonctionnalités consolidera votre expérience et votre compréhension du code source. N'oubliez pas non plus d'écrire des cas de tests et de la documentation, ce sera utile aux développeurs qui vous suivront et assurera la pérennité du code.

Quel est le moteur de rendu utilisé ?

Actuellement nous utilisons notre propre moteur de rendu. Nous prévoyons de migrer vers Cairo lorsqu'il sera suffisamment mature.

Quelle est la plateforme de développement ?

La plupart des développeurs travaillent sous Linux. Il est cependant possible de compiler Inkscape sur Windows. Cette page fournit les instructions détaillées pour y parvenir, ainsi que pour compiler des binaires Windows depuis Linux.

Quelle commande linux permet de télécharger le code avec Subversion ?

Des instructions générales se trouve sur le lien Subversion de la page sourceforge d'inkscape. Notez cependant que la commande donnée sur la page de sourceforge vont tester tous les modules du projet Inkscape et toutes les branches de ces modules.

  • pour ne tester que la dernière copie de la branche principale (le "trunk") du programme Inkscape, utilisez :
    <pre>svn checkout https://svn.sourceforge.net/svnroot/inkscape/inkscape/trunk/
  • To only check out the trunk of another Inkscape module, do:
    svn checkout https://svn.sourceforge.net/svnroot/inkscape/MODULE_NAME/trunk/
    where MODULE_NAME is the name of the module you want to check out. Other modules you can check out include: experimental, our development "scratchpad" for working up prototypes; inkscape_web, which holds our website files; and inkscape_project, which holds config files and other project-level things. You can use our Subversion viewer to get the names of available modules.
  • To only check out a branch of some Inkscape module, do:
    svn checkout https://svn.sourceforge.net/svnroot/inkscape/MODULE_NAME/branches/BRANCH_NAME/ 
    where MODULE_NAME is the name of the module you want to check out, and BRANCH_NAME is the name of the branch that you are interested in. You can use our Subversion viewer to get the names of available modules and branches.

These commands will download the requested module into a directory named either trunk or BRANCH_NAME, depending on whether you chose to check out the trunk or a branch.

  • If you'd like to later test out a different branch of any of Inkscape's modules, you can do that by running

svn switch https://svn.sourceforge.net/svnroot/inkscape/MODULE_NAME/branches/BRANCH_NAME

in your working copy, where MODULE_NAME is the name of the module you are working in, and BRANCH_NAME is the name of the branch that you want to switch to.
  • You can do something similar for tagged branches:

svn switch https://svn.sourceforge.net/svnroot/inkscape/MODULE_NAME/tags/BRANCH_NAME

Note that Subversion supports the ability to move individual subdirectories of a working copy of a module to different branches of that module, so if you want to switch an entire working copy to a different branch, run svn switch in the root directory of the working copy.

How are feature requests selected for implementing?

Many developers become involved because they wish to "scratch an itch", so of course if they wish to work on a particular feature, then by definition that one will receive implementational attention. This is the primary mechanism by which features get implemented.

Inkscape also strives to take user requests for features seriously, especially if they're easy to do or mesh with what one of the existing developers already wants to do, or if the user has helped the project in other ways.

If you have a feature that you'd really like to see implemented, but others aren't working on, the right thing to do is delve into the code and develop it yourself. We put great importance on keeping the development process open and straightforward with exactly this in mind.

I'd prefer the interface to look like ...

Understandably, many users are accustomed to other programs (such as Illustrator, the GIMP, etc.) and would prefer Inkscape to follow them in design. Inkscape developers are constantly examining other projects and on the look for better interface ideas. A large motivation is to make the application follow the GNOME Human Interface Guidelines, which has a number of rules in how the interface is made. The Inkscape developers also seek advice and ideas from other GUI app designers, such as the GIMP crew, AbiWord, and Gnumeric; they've been at it longer and we view them as an excellent source of battle tested experience.

But please understand that the Inkscape interface will, at the end of the day, be the "Inkscape interface". We will strive to find our own balance of compatibility with common drawing programs, wishes of our userbase, good workflow, creativity of our developers, and compliance with UI guidelines. It's unlikely that this balance will meet every user's wish, or achieve 100% compliance with the various platform specific Interface Guidelines, or include every developer's idea, and if it did it probably wouldn't be as good.  ;-)

Usually when we discuss interface look and feel, we arrive at the conclusion that, really, it should be configurable so that each user can flip a few switches and get an app that is most cozy to them. However, flexibility should not be used as an excuse not to make tough decisions when they are called for.

Aspects juridiques

Sous quelle licence Inkscape est-il publié ?

GNU GENERAL PUBLIC LICENSE Version 2, Juin 1991 [1]. En bref, cela signifie que vous êtes libre d'utiliser et distribuer Inkscape à des fins commerciales ou non, sans restrictions. Vous êtes aussi libres de modifier le programme comme bon vous semble, avec la seule restriction que si vous distribuez la version modifiée, vous devenir fournir un accès au code source de la version modifiée.