Dependencies

From Inkscape Wiki
Jump to: navigation, search

Overview

What versions do which distros have, which do versions of Inkscape require, etc.

Distro Details

Look to Tracking Dependencies for details on which distros come with which libraries.

Chart

http://distrowatch.com/ should help in getting info on what versions of libraries were available in what versions of distributions, at least for fairly current distro versions.

lib/tool V 0.45 V 0.46 V 0.47-dev Ubuntu Fedora OpenSUSE MacPorts
gcc 3.x
glib
gtk+
glibmm
gtkmm 2.10.0
lcms 1.13 1.13 1.13
libpng 1.2
libgc 6.4+
libxml 2.6.11
libxslt 1.0.15
poppler 0.5.9
sigc++ 2.0.11/2.0.12