0.91-tutorial-review

From Inkscape Wiki
Jump to: navigation, search

This is a page to track the reviews of the official tutorials for the 0.91 release:

Contents

Basic tutorial [OK]

  • Status -- Ready - All changes committed in inkscape-docs, revision 493.
  • Reviewer -- ryanlerch
  • Notes -- tutorial good
  • Reviewer -- jazzynico
  • Notes --
    • Uses old label for the menu item formerly called 'File > New' -> in trunk now called 'File > New > Default'
    • Should we add something on document templates?
    • Should we add something on the new Select Same feature?
    • All shortcuts should show the same modifiers older (Shift+Ctrl+Alt+Key). One inverts Shift and Ctrl : Ctrl+Shift+A.

Advanced tutorial [WIP]

  • Reviewer -- Ryanlerch
  • Notes
    • this section on nodes doesnt mention auto-smooth. (do we want to add it here?)

A node can be made cusp (Shift+C), which means its two handles can move independently at any angle to each other; smooth (Shift+S), which means its handles are always on the same straight line (collinear); and symmetric (Shift+Y), which is the same as smooth, but the handles also have the same length. When you switch the type of node, you can preserve the position of one of the two handles by hovering your mouse over it, so that only the other handle is rotated/scaled to match.

  • Reviewer -- jazzynico
  • Notes --
    • Sometimes Click is capitalized, sometimes not. To be consistent with the other tutorials, it should not be capitalized.

Shapes tutorial [OK]

  • Status -- Ready - All changes committed in inkscape-docs, revision 494.
  • Reviewer -- Ryanlerch
  • Notes
    • "The snap angle can be changed in Inkscape Preferences (the Steps tab)." --> in the Prefs Dialog, this is now in Behaviour > Steps
  • Reviewer -- jazzynico
  • Notes --
    • All shortcuts should show the same modifiers older (Shift+Ctrl+Alt+Key). One inverts Shift and Ctrl : Ctrl+Shift+C.
    • Sometimes Click is capitalized, sometimes not. To be consistent with the other tutorials, it should not be capitalized.

Bitmap tracing tutorial [WIP]

  • Reviewer -- jazzynico
  • Notes --
    • The English Trace dialog's screenshot is a bit old (older than 0.46 it seems...).
    • 'Optimal Edge Detection' parameter is now called 'Edge Detection'

Calligraphy tutorial [WIP]

  • Reviewer -- jazzynico
  • Notes --
    • Uses old label for the menu item formerly called 'File > Input Devices' -> in trunk now called 'Edit > Input Devices'
    • There are also two buttons to toggle tablet Pressure and Tilt sensitivity on and off (for drawing tablets). We also have another button (Trace the lightness of the background...).
    • Tremor is adjustable in the Controls bar with values ranging from 0.0 to 1.0. Should be from 0 to 100.
    • No details or examples on the Caps parameter.

Elements of Design tutorial [OK]

  • Status -- Ready - All changes committed in inkscape-docs, revision 495.

Tips and tricks [WIP]

  • Reviewer -- su_v
  • Notes --
    • Uses old label for the menu item formerly called 'Vaccum Defs' -> in trunk now called 'Clean up Document'.
    • Uses old label for the menu item formerly called 'File > Export Bitmap' -> in trunk now called 'File > Export PNG Image'
  • Reviewer -- jazzynico
  • Notes --
    • The dialog's name should be 'Create Tiled Clones', not 'Tile Clones'.
    • SVG slice extension link invalid (digitalunleach doesn't seem to provide the extension anymore). New possible link: https://launchpad.net/svgslice. Note that the extension is quite old and may not work with 0.91 (not tested yet). Also note that we now provide a Web>Slicer extension menu and an Export>Guillotine extension that could replace it.
    • All shortcuts should show the same modifiers older (Shift+Ctrl+Alt+Key). Some invert Shift and Ctrl : Ctrl+Shift+A, Ctrl+Shift+D.
    • In the Pen (Bezier) tool, you have the following options to finish the current line:... Select the Pen tool again. Doesn't work if one tries to select the Pen tool with its shortcut (but works with the toolbar icon).
    • Entering Unicode values. Should we mention the new Glyphs dialog?
    • Drop shadows. Inkscape also provides a custom predefined Drop shadows filter.
    • Uses old label for the preferences item formerly called 'Windows' -> in trunk now called 'Interface > Windows'.
    • PostScript or EPS formats do not support transparency. They do, but transparency is rasterized.
    • Exporting gradients to PS or EPS does not work for text (unless text is converted to path) or for stroke paint. Seems to work now.

Interpolate [OK]

  • Status -- Ready - Nothing to do.
  • Reviewer -- ryanlerch
  • Notes -- tutorial good.
Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox